You are not logged in.

#5451 2013-07-27 07:03:09

PhotonX
Member
From: Munich
Registered: 2008-08-10
Posts: 429

Re: The AMD/ATI Bar & Grill

After yesterday's update to 13.7 cairo-dock with OpenGL backend crashes with following output:

warning :  (/build/src/cairo-dock-3.2.1/src/gldit/cairo-dock-opengl.c:cairo_dock_initialize_opengl_backend:202)  
  couldn't find an appropriate visual, trying to get one without Stencil buffer
(it may cause some little deterioration in the rendering) ...

Desktop: http://www.sysprofile.de/id15562, Arch Linux    |    Notebook: Thinkpad X200 Tablet, Manjaro

The very worst thing you can do with free software is to download it, see that it doesn't work for some reason, leave it, and tell your friends that it doesn't work.  -  Tuomas Lukka

Offline

#5452 2013-07-27 07:58:33

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: The AMD/ATI Bar & Grill

I haven't tested catalyst in a while, so just two quick questions for pxp/enduro (muxless):

* When using the intel gpu by default, can you use the amd one without restarting X?
* Can catalyst completely power off the discrete gpu when it's not used? Last time I tried it, it was very spotty, especially after suspend.


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#5453 2013-07-27 08:55:55

savalaserg1
Member
Registered: 2013-06-27
Posts: 21

Re: The AMD/ATI Bar & Grill

I am having the same problem with 13.7 I am able to boot to GDM but once I launch my gnome session the whole computer freezes ...... The screen stays black and the cursor does not even move ...

Offline

#5454 2013-07-27 11:36:20

Shinto
Member
Registered: 2012-07-27
Posts: 67

Re: The AMD/ATI Bar & Grill

savalaserg1 wrote:

I am having the same problem with 13.7 I am able to boot to GDM but once I launch my gnome session the whole computer freezes ...... The screen stays black and the cursor does not even move ...

I downgraded back to 13.6. I think that's the best solution atm.

Offline

#5455 2013-07-27 14:54:41

bvad
Member
Registered: 2013-07-27
Posts: 1

Re: The AMD/ATI Bar & Grill

I got 13.7 to not crash by disabling "tear-free" in amdcccle..

From the wiki:
#run as root
aticonfig --del-pcs-key=DDX,EnableTearFreeDesktop

Offline

#5456 2013-07-28 04:33:07

savalaserg1
Member
Registered: 2013-06-27
Posts: 21

Re: The AMD/ATI Bar & Grill

Thing is I cant even get to the desktop before it locks up I can move around and get to GDM fine after I type in my username/password screen goes black I can see the cursor after that it freezes up. I also noticed that my laptop specifically on the GPU side begins to dramatically heat up very fast........

Offline

#5457 2013-07-28 07:27:34

JoKo
Member
Registered: 2010-04-09
Posts: 37

Re: The AMD/ATI Bar & Grill

Hello,

I am using catalyst-total 13.4-5 and trying to compile it against the 3.10.3-zen+ kernel. Here's the output of catalyst.log:

--------
2013-07-27 22:57:40
Building fglrx module for 3.10.3-zen+ kernel ...
--------
OsVersion says: SMP=1
file /proc/kallsyms says: SMP=1
file /usr/lib/modules/3.10.3-zen+/build/include/generated/autoconf.h says: SMP=1
file /usr/lib/modules/3.10.3-zen+/build/include/generated/autoconf.h says: MODVERSIONS=
file /usr/lib/modules/3.10.3-zen+/build/arch/x86/include/asm/compat.h says: COMPAT_ALLOC_USER_SPACE=arch_compat_alloc_user_space
make: Entering directory `/usr/src/linux-zen'
  CC [M]  /tmp/catalyst.Npk9R8/firegl_public.o
/tmp/catalyst.Npk9R8/firegl_public.c: In function ‘firegl_debug_proc_read_wrap’:
/tmp/catalyst.Npk9R8/firegl_public.c:536:33: error: dereferencing pointer to incomplete type
  return firegl_debug_proc_read(m->buf, m->from, m->index, m->size, m->size - m->count, data);
                                 ^
/tmp/catalyst.Npk9R8/firegl_public.c:536:41: error: dereferencing pointer to incomplete type
  return firegl_debug_proc_read(m->buf, m->from, m->index, m->size, m->size - m->count, data);
                                         ^
/tmp/catalyst.Npk9R8/firegl_public.c:536:50: error: dereferencing pointer to incomplete type
  return firegl_debug_proc_read(m->buf, m->from, m->index, m->size, m->size - m->count, data);
                                                  ^
/tmp/catalyst.Npk9R8/firegl_public.c:536:60: error: dereferencing pointer to incomplete type
  return firegl_debug_proc_read(m->buf, m->from, m->index, m->size, m->size - m->count, data);
                                                            ^
/tmp/catalyst.Npk9R8/firegl_public.c:536:69: error: dereferencing pointer to incomplete type
  return firegl_debug_proc_read(m->buf, m->from, m->index, m->size, m->size - m->count, data);
                                                                     ^
/tmp/catalyst.Npk9R8/firegl_public.c:536:79: error: dereferencing pointer to incomplete type
  return firegl_debug_proc_read(m->buf, m->from, m->index, m->size, m->size - m->count, data);
                                                                               ^
/tmp/catalyst.Npk9R8/firegl_public.c: In function ‘firegl_major_proc_read’:
/tmp/catalyst.Npk9R8/firegl_public.c:583:5: error: implicit declaration of function ‘seq_printf’ [-Werror=implicit-function-declaration]
     int len = seq_printf(m, "%d\n", major);
     ^
/tmp/catalyst.Npk9R8/firegl_public.c: In function ‘firegl_major_proc_open’:
/tmp/catalyst.Npk9R8/firegl_public.c:608:9: error: implicit declaration of function ‘single_open’ [-Werror=implicit-function-declaration]
         return single_open(file, firegl_major_proc_read, NULL);
         ^
/tmp/catalyst.Npk9R8/firegl_public.c: At top level:
/tmp/catalyst.Npk9R8/firegl_public.c:613:17: error: ‘seq_read’ undeclared here (not in a function)
         .read = seq_read,
                 ^
/tmp/catalyst.Npk9R8/firegl_public.c:614:19: error: ‘seq_lseek’ undeclared here (not in a function)
         .llseek = seq_lseek,
                   ^
/tmp/catalyst.Npk9R8/firegl_public.c:623:9: warning: initialization from incompatible pointer type [enabled by default]
         .write = firegl_debug_proc_write_wrap,
         ^
/tmp/catalyst.Npk9R8/firegl_public.c:623:9: warning: (near initialization for ‘firegl_debug_fops.write’) [enabled by default]
cc1: some warnings being treated as errors
make[1]: *** [/tmp/catalyst.Npk9R8/firegl_public.o] Error 1
make: *** [_module_/tmp/catalyst.Npk9R8] Error 2
make: Leaving directory `/usr/src/linux-zen'

Is there any version of Catalyst which works with Linux 3.10?

Offline

#5458 2013-07-28 13:28:49

clfarron4
Member
From: London, UK
Registered: 2013-06-28
Posts: 2,162
Website

Re: The AMD/ATI Bar & Grill

JoKo wrote:

Hello,

I am using catalyst-total 13.4-5 and trying to compile it against the 3.10.3-zen+ kernel...

Is there any version of Catalyst which works with Linux 3.10?

I take it your using the linux-zen kernel right? That might be why you are having problems.

I'm using the standard 3.10.3-1 kernel and it's working fine with Catalyst 13.7 from Vi0L0's repository (on a 6480G card).


Claire is fine.
Problems? I have dysgraphia, so clear and concise please.
My public GPG key for package signing
My x86_64 package repository

Offline

#5459 2013-07-29 07:56:19

savalaserg1
Member
Registered: 2013-06-27
Posts: 21

Re: The AMD/ATI Bar & Grill

Still having that same problem I have downgraded to 13.6 hopefully a fix arises ? I would sure like to try out the new 13.7 to see if there any performance improvements......

Offline

#5460 2013-07-29 16:00:10

dffx
Member
Registered: 2011-05-02
Posts: 15

Re: The AMD/ATI Bar & Grill

Has anyone had any luck with 13.7 on Enduro/PXP? I'm trying to get it to work, but whenever I try to startx with the AMD card enabled (fglrx in xorg.conf) I get a hard lock on my system (X doesn't even load up, locks up on the TTY with the initial X messages printed to stdout) and an empty Xorg log when I restart. sad

EDIT: It looks like I had, at one point or another, added fglrx to the modprobe blacklist. it still crashed after removing it and rebooting, but then, somehow, I managed to actually get it to work? I removed all the old Xorg.X.log files in /var/log, but I'm not sure if that actually had anything to do with it. Frankly, I blame wizards.

That said, is there any solution to high fan usage? This laptop is running like a jet engine half the time.

Last edited by dffx (2013-07-29 16:54:07)

Offline

#5461 2013-07-29 20:51:51

IVIonty
Member
Registered: 2013-02-19
Posts: 23

Re: The AMD/ATI Bar & Grill

Hi again guys,
I had a quite stable state with kernel 3.9.x and Catalyst-hook 13.4.5 from Vi0l0 stable repo. After 3.10.x mainstream upgrade the fglrx module seems to build correctly but x.org fails to start and if I try to rmmod or insmod fgrlx I obtain a kernel panic.

I think something in module building gone wrong and there is a "bad" version of fglrx loaded.

Very similar behaviour described here:

1. OpenSuse

2. Ubuntu 13.04

I tried Catalyst-hook 13.7 but nothing changes.

Perhaps I missed something... some hints? tongue

Last edited by IVIonty (2013-07-29 21:40:47)


_______________________________________________________________________
- One may not reach the dawn save by the path of the night -
Kahlil Gibran

Offline

#5462 2013-07-30 05:03:45

Anon11
Member
Registered: 2012-05-20
Posts: 33

Re: The AMD/ATI Bar & Grill

IVIonty wrote:

Hi again guys,
I had a quite stable state with kernel 3.9.x and Catalyst-hook 13.4.5 from Vi0l0 stable repo. After 3.10.x mainstream upgrade the fglrx module seems to build correctly but x.org fails to start and if I try to rmmod or insmod fgrlx I obtain a kernel panic.

I think something in module building gone wrong and there is a "bad" version of fglrx loaded.

Very similar behaviour described here:

1. OpenSuse

2. Ubuntu 13.04

I tried Catalyst-hook 13.7 but nothing changes.

Perhaps I missed something... some hints? tongue

I had similar problem with 3.10 + 13.7 too , downgrade to 3.9 worked
But now i just removed catalyst and using 3.11rc3 ,temperature with dpm is as good as catalyst smile

Offline

#5463 2013-07-30 05:43:19

IVIonty
Member
Registered: 2013-02-19
Posts: 23

Re: The AMD/ATI Bar & Grill

Anon11 wrote:
IVIonty wrote:

Hi again guys,
I had a quite stable state with kernel 3.9.x and Catalyst-hook 13.4.5 from Vi0l0 stable repo. After 3.10.x mainstream upgrade the fglrx module seems to build correctly but x.org fails to start and if I try to rmmod or insmod fgrlx I obtain a kernel panic.

I think something in module building gone wrong and there is a "bad" version of fglrx loaded.

Very similar behaviour described here:

1. OpenSuse

2. Ubuntu 13.04

I tried Catalyst-hook 13.7 but nothing changes.

Perhaps I missed something... some hints? tongue

I had similar problem with 3.10 + 13.7 too , downgrade to 3.9 worked
But now i just removed catalyst and using 3.11rc3 ,temperature with dpm is as good as catalyst smile

Good!

'll try asap

Thanks for the hint smile


_______________________________________________________________________
- One may not reach the dawn save by the path of the night -
Kahlil Gibran

Offline

#5464 2013-07-30 09:26:33

punkeroso
Member
From: Rome, Italy
Registered: 2007-01-19
Posts: 104

Re: The AMD/ATI Bar & Grill

Anon11 wrote:

I had similar problem with 3.10 + 13.7 too , downgrade to 3.9 worked
But now i just removed catalyst and using 3.11rc3 ,temperature with dpm is as good as catalyst smile

Really good to hear!
Which GPU?
I planned to do that since 2 week but I haven't had time sad

Offline

#5465 2013-07-30 09:38:00

Anon11
Member
Registered: 2012-05-20
Posts: 33

Re: The AMD/ATI Bar & Grill

I have 6520g and 6750m (shut off), did not test 6750m yet but i barely use it in linux.
Tested some games in wine, they all work fine on 6520g with radeon drivers.

I will not use catalyst anymore now.

@Violo : Thanks for maintaining catalyst.

Offline

#5466 2013-07-31 14:28:47

Aldur
Member
Registered: 2013-06-19
Posts: 15

Re: The AMD/ATI Bar & Grill

Catalyst 13.7 limits my fps in 3D applications to 30 and ignores when I turn off vsync and tear-free via the AMD Control Center.
I'm just curious if other people have the same issue or if it's isolated to my setup.

Radeon HD 6870
Kernel 3.10.4-1
KDE/Xfce (doesn't matter which one)

I used webGL applications, glxgears and TF2 to see if it happens in all 3D applications.

Offline

#5467 2013-08-01 01:33:30

marcio
Member
Registered: 2010-10-08
Posts: 30

Re: The AMD/ATI Bar & Grill

I am using Catlyst 13.7 with linux 3.9.xx and it is working fine. When i use with linux-ck 3.10.3 at first boot xorg don't start wherever when i reset my pc that works.

So, i still using linux-3.9.xx

Offline

#5468 2013-08-01 03:33:23

zoqaeski
Member
From: /earth/australia/.
Registered: 2009-09-30
Posts: 124

Re: The AMD/ATI Bar & Grill

I can’t upgrade from 12.8. Every single version higher than that has issues with the backlight, and none of the supposed fixes seems to work. Has anyone else had issues similar to mine?

Offline

#5469 2013-08-01 11:27:35

Fregtux
Member
From: Italy
Registered: 2013-08-01
Posts: 55

Re: The AMD/ATI Bar & Grill

marcio wrote:

I am using Catlyst 13.7 with linux 3.9.xx and it is working fine. When i use with linux-ck 3.10.3 at first boot xorg don't start wherever when i reset my pc that works.

So, i still using linux-3.9.xx

Have you compile fglrx module for custom kernel, for example with catalyst-generator?


ASUS P8P67 EVO | i7-2600k |RAM 16GB DDR 3 Vengeance@1600MHz | AMD 7950 Sapphire Dual-X | SSD: Samsung 830 250GB | HD: Western Digital Caviar Blue 1TB

Offline

#5470 2013-08-01 11:28:50

Fregtux
Member
From: Italy
Registered: 2013-08-01
Posts: 55

Re: The AMD/ATI Bar & Grill

zoqaeski wrote:

I can’t upgrade from 12.8. Every single version higher than that has issues with the backlight, and none of the supposed fixes seems to work. Has anyone else had issues similar to mine?

What are your Xorg and kernel versions?

I'm with catalyst 13.7 and kernel stock 3.10 and catalyst work with no problem.


ASUS P8P67 EVO | i7-2600k |RAM 16GB DDR 3 Vengeance@1600MHz | AMD 7950 Sapphire Dual-X | SSD: Samsung 830 250GB | HD: Western Digital Caviar Blue 1TB

Offline

#5471 2013-08-01 19:28:03

snowblind
Member
Registered: 2013-07-18
Posts: 34

Re: The AMD/ATI Bar & Grill

13.8 beta 1 is available

Anxious to see what this brings.

Additionally, I've got a question: Does anyone have any issues with their GPU periodically flipping between minimum and maximum clockspeeds with no apparent reason? My card seems to randomly hop between the two, which results in my fans going from idle to SUPER JET SPEED on a pretty regular basis, and it's actually pretty disconcerting (since I can hear the laptop fans going from across the apartment).

Offline

#5472 2013-08-01 20:30:30

clfarron4
Member
From: London, UK
Registered: 2013-06-28
Posts: 2,162
Website

Re: The AMD/ATI Bar & Grill

marcio wrote:

I am using Catlyst 13.7 with linux 3.9.xx and it is working fine. When i use with linux-ck 3.10.3 at first boot xorg don't start wherever when i reset my pc that works.

Using Catalyst 13.7 with linux-ck-k10 3.10.4 (previously 3.10.3 when I started with linux-ck-k10) and it works like a charm. I did have to manually build the modules, but I do that anyways after every kernel upgrade.

EDIT:

snowblind wrote:

Does anyone have any issues with their GPU periodically flipping between minimum and maximum clockspeeds with no apparent reason?

I've had no such problems with my AMD Radeon 6480G.

zoqaeski wrote:

I can’t upgrade from 12.8. Every single version higher than that has issues with the backlight, and none of the supposed fixes seems to work. Has anyone else had issues similar to mine?

I've gone latest with everything from Vi0l0's repository and the latest version of X that will work with it and this little script seems to work for me for setting the brightness (though I have to run it a couple of times before anything happens). That said, knowing the version of X and kernel as well would help.

Last edited by clfarron4 (2013-08-01 20:36:30)


Claire is fine.
Problems? I have dysgraphia, so clear and concise please.
My public GPG key for package signing
My x86_64 package repository

Offline

#5473 2013-08-01 21:50:21

brittyazel
Member
From: Davis, CA
Registered: 2013-05-11
Posts: 144

Re: The AMD/ATI Bar & Grill

Today catalyst 13.8 beta for linux was released:

http://www.phoronix.com/scan.php?page=n … px=MTQyNjQ

http://support.amd.com/us/kbarticles/Pa … river.aspx

Seems like they fully added OpenGL 4.3 and Linux 3.10 support.


I don't really know what I'm doing.

Offline

#5474 2013-08-02 06:29:01

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

snowblind wrote:
brittyazel wrote:

Today catalyst 13.8 beta for linux was released:

http://www.phoronix.com/scan.php?page=n … px=MTQyNjQ

http://support.amd.com/us/kbarticles/Pa … river.aspx

Seems like they fully added OpenGL 4.3 and Linux 3.10 support.

Very good, I will test it and update later after getting back from work.
I'm surprised especially with 3.10 kernel support - it came pretty fast (as for the catalyst). Hope it will fix some things, because the patch we've been using was only a workaround and could actually generate some issues.

Offline

#5475 2013-08-02 17:37:32

jfernyhough
Member
Registered: 2012-09-26
Posts: 5

Re: The AMD/ATI Bar & Grill

As a heads-up, I'm running 13.8b1 on Saucy (xserver 1.14 & kernel 3.10) and while kernel modules etc. build and load correctly there's an issue somewhere. This is the first time I've seen this particular error. big_smile

$ LIBGL_DEBUG=verbose fglrxinfo
libGL: AtiGetClientDriverName: 13.20.4 fglrx (screen 0)
libGL: OpenDriver: trying /usr/lib/fglrx/dri/fglrx_dri.so
ukiDynamicMajor: failed to open /proc/ati/major
Setting of real/effective user Id to 0/0 failed
ukiDynamicMajor: failed to open /proc/ati/major
ukiDynamicMajor: failed to open /proc/ati/major
ukiDynamicMajor: failed to open /proc/ati/major
libGL error: open uki failed (Operation not permitted)
libGL error: reverting to (slow) indirect rendering
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: AMD Radeon HD 6500M/5600/5700 Series
OpenGL version string: 2.1 (4.3.12438 Compatibility Profile Context 9.01)

I'm not sure if this is may be due to control or amdpcsdb; any number of other fixes I've tried (including, e.g., a DRI section in xorg.conf, adding my user to 'video' group) haven't made any difference.


1) Dell Studio 1749: i5 540 (2.5GHz), 8GB, ATi 5650, Intel 5300AGN, XFCE@U13.10x64
2) IBM X61: C2D T7200, 2GB, Intel Centrino, XFCE@U13.10x64
3) Compaq Mini 311c: Atom N270 (OC@2.0GHz), 3GB, Nvidia ION, Broadcom G+BT, KDE@U13.10x32
Comms: HTC Desire Z@JB4.2 (Flinny Andromadus CM10.1)

Offline

Board footer

Powered by FluxBB