You are not logged in.

#5526 2013-08-15 20:10:43

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,320
Website

Re: The AMD/ATI Bar & Grill

Cdh wrote:
clfarron4 wrote:
Lord Aro wrote:

Hi, i think there might be a problem in the catalyst-hook service

When I installed the new kernel (via pacman) the build script kicks in automagically as it should, but fails, with this error:

--------
2013-08-14 13:04:51
Building fglrx module for 3.10.6-2-ARCH kernel ...
--------
Kernel header files are absent: directory /usr/lib/modules/3.10.6-2-ARCH/build doesn't exist! 
Game over

However, if i run the build script manually ("sudo catalyst_build_module all") it works fine


I've never had the "Game Over" bit, but I've had the message above it everytime I've updated the kernel. I read something about Vi0L0 only compiling the module against one kernel somewhere, but I can't remember where. Either way, I build the modules manually anyways just for the sake of inner peace.

@clfarron4
Maybe the package linux-headers was updated after linux was updated and the hook run? Just a guess...

Yeah, that's the exact reason of why the error occurs, also the reason of why the systemd's catalyst-hook.service arrived (just to remind it was after pacman's option called SyncFirst was removed, with SyncFirst we were forcing linux-headers to be installed in 1st place).
When installing catalyst-hook there's still a big banner saying:

----------------------------------------------------------------
        ATTENTION!
----------------------------------------------------------------
To enable 'automatic re-compilation while system shutdown/reboot'
testing feature run these commands as root:
systemctl enable catalyst-hook
systemctl start catalyst-hook

If you will enable this service you won't have to update modules manually.
BTW: I'm unable to even start properly catalyst_build_module script as the unprivileged user, such user don't have permission to write anything to /var/log - but it's expected and that's the way how catalyst-hook works - its script has to be run by root.

@Cdh:
i'm unable to reproduce 13.8 clock bug, but nice find. I don't see similar behavior @ bugzilla - maybe it's worth to report.



lib32-glibc-2.18-1 bug?
Probably related with the errors reported by Cdh at the prev page, glibc 2.18 just landed in [core] with lib32-glibc 2.18, braking steam skype and other 32 bit software here.
For me downgrading just one package lib32-glibc to 2.17-5 did the trick

Last edited by Vi0L0 (2013-08-15 21:11:30)

Offline

#5527 2013-08-15 21:48:05

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: The AMD/ATI Bar & Grill

Hm, the performance in wine is still more than abysmal. I tried borderlands 1 and the fps go from okay when looking at nothing to ~1 fps when looking in a direction where there is some distance. Comparing it to the ivy bridge graphics, with them it runs at perfectly playable fps all the time.

With fglrx I get much more fps in unigine valley on ultra than on borderlands in wine!

Unigine Valley Benchmark 1.0

FPS:	
21.1
Score:	
881
Min FPS:	
13.2
Max FPS:	
28.0

Feels like a software renderer but LIBGL_DEBUG=verbose says it opens the fglrx driver.

Are there any tips for improving the wine fglrx situation?

Last edited by Cdh (2013-08-15 21:50:37)


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#5528 2013-08-15 22:15:29

Jannis
Member
Registered: 2013-06-03
Posts: 32

Re: The AMD/ATI Bar & Grill

clfarron4 wrote:

I've never had the "Game Over" bit, but I've had the message above it everytime I've updated the kernel. I read something about Vi0L0 only compiling the module against one kernel somewhere, but I can't remember where. Either way, I build the modules manually anyways just for the sake of inner peace.

If you're using catalyst-hook, the problem is pacman always updates the kernel package before updating the kernel-headers package. The hook runs on mkinitcpio which is called when updating the kernel package, so the new kernel headers aren't installed when the hook tries to build the catalyst module.

Edit: Yeah, somehow I didn't refresh the page before posting, so this post is actually kinda redundant.

Last edited by Jannis (2013-08-16 01:36:05)

Offline

#5529 2013-08-16 02:28:14

Cerbereus
Member
Registered: 2008-10-06
Posts: 24

Re: The AMD/ATI Bar & Grill

Hello everyone i m having to problem to login at kde using startx, well i m good starting xfce but kde that i installed seem to ask for some files that event i don't have on my xorg, the message i recive is
[   251.970] (EE) AIGLX error: failed to open /usr/X11R6/lib64/modules/dri/fglrx_dri.so, error[/usr/X11R6/lib64/modules/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]
How i can fix these and the weird i think it only happen to kde, with Xfce everything going good i have from the repo of Vi0l0 the last one, and a Radeon 7770 any help will be nice, oh i forgot to said  i m archlinux x64.
Cheers.

Offline

#5530 2013-08-16 10:16:07

blackbirdrozd
Member
Registered: 2013-08-16
Posts: 2

Re: The AMD/ATI Bar & Grill

Hello,
after my today's Arch update (to catalyst 13.8-3) steam stopped working (steam.sh failed on line 704 which according to github issue tracker means problem with GPU driver).
So I tried to revert (pacman -U /var/cache/pacman/pkg/...) to 13.8-2 however after that I was not able to even start X correctly.

Can someone help me with this?

My specs:
kernel 3.10.6-2-ARCH 64bit
Ati Radeon HD 6870
using http://catalyst.wirephire.com/repo/catalyst/ repo

$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6800 Series
OpenGL version string: 4.3.12438 Compatibility Profile Context 13.101

Offline

#5531 2013-08-16 10:47:31

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 673

Re: The AMD/ATI Bar & Grill

blackbirdrozd wrote:

Hello,
after my today's Arch update (to catalyst 13.8-3) steam stopped working (steam.sh failed on line 704 which according to github issue tracker means problem with GPU driver).
So I tried to revert (pacman -U /var/cache/pacman/pkg/...) to 13.8-2 however after that I was not able to even start X correctly.

Can someone help me with this?

My specs:
kernel 3.10.6-2-ARCH 64bit
Ati Radeon HD 6870
using http://catalyst.wirephire.com/repo/catalyst/ repo

$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6800 Series
OpenGL version string: 4.3.12438 Compatibility Profile Context 13.101

Vi0l0 reported a breakage of steam by the new glibc just a few posts above:

Vi0l0 wrote:

lib32-glibc-2.18-1 bug?
Probably related with the errors reported by Cdh at the prev page, glibc 2.18 just landed in [core] with lib32-glibc 2.18, braking steam skype and other 32 bit software here.
For me downgrading just one package lib32-glibc to 2.17-5 did the trick

Offline

#5532 2013-08-16 11:04:50

psychoticmeow
Member
Registered: 2013-05-01
Posts: 20

Re: The AMD/ATI Bar & Grill

This just started happening today...

$ sudo pacman -Syu
:: Synchronizing package databases...
 catalyst is up to date
 infinality-bundle is up to date
 infinality-bundle-multilib is up to date
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 heftig is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: mesa-libgl and catalyst-utils are in conflict (libgl). Remove catalyst-utils? [y/N] 

However mesa-libgl isn't installed, so... why?

Last edited by psychoticmeow (2013-08-16 11:05:23)

Offline

#5533 2013-08-16 11:09:41

JaniAL
Member
Registered: 2013-08-16
Posts: 2

Re: The AMD/ATI Bar & Grill

Vi0l0 wrote:

lib32-glibc-2.18-1 bug?
Probably related with the errors reported by Cdh at the prev page, glibc 2.18 just landed in [core] with lib32-glibc 2.18, braking steam skype and other 32 bit software here.
For me downgrading just one package lib32-glibc to 2.17-5 did the trick

Hey, just registered to confirm this indeed solves the Steam problems. Been searching half a day after reinstalling/downgrading to every catalyst version tongue
Thanks for the quick fix!

Offline

#5534 2013-08-16 11:36:03

blackbirdrozd
Member
Registered: 2013-08-16
Posts: 2

Re: The AMD/ATI Bar & Grill

snack wrote:
blackbirdrozd wrote:

Hello,
after my today's Arch update (to catalyst 13.8-3) steam stopped working (steam.sh failed on line 704 which according to github issue tracker means problem with GPU driver).
So I tried to revert (pacman -U /var/cache/pacman/pkg/...) to 13.8-2 however after that I was not able to even start X correctly.

Can someone help me with this?

My specs:
kernel 3.10.6-2-ARCH 64bit
Ati Radeon HD 6870
using http://catalyst.wirephire.com/repo/catalyst/ repo

$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6800 Series
OpenGL version string: 4.3.12438 Compatibility Profile Context 13.101

Vi0l0 reported a breakage of steam by the new glibc just a few posts above:

Vi0l0 wrote:

lib32-glibc-2.18-1 bug?
Probably related with the errors reported by Cdh at the prev page, glibc 2.18 just landed in [core] with lib32-glibc 2.18, braking steam skype and other 32 bit software here.
For me downgrading just one package lib32-glibc to 2.17-5 did the trick

I checked previous posts but missed this. Thank you.

EDIT: downgrade to lib32-glibc-2.17-5 also worked for me.

Last edited by blackbirdrozd (2013-08-16 11:49:34)

Offline

#5535 2013-08-16 11:57:39

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: The AMD/ATI Bar & Grill

psychoticmeow wrote:

This just started happening today...

$ sudo pacman -Syu
:: Synchronizing package databases...
 catalyst is up to date
 infinality-bundle is up to date
 infinality-bundle-multilib is up to date
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 heftig is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
:: mesa-libgl and catalyst-utils are in conflict (libgl). Remove catalyst-utils? [y/N] 

However mesa-libgl isn't installed, so... why?

Something wants to install mesa and pacman is still too stupid to display  what or why.
Run pacman -Syu --debug, it will show a little bit more information.

Last edited by Cdh (2013-08-16 11:57:52)


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#5536 2013-08-16 12:48:04

ghostwolf
Member
Registered: 2013-07-19
Posts: 5

Re: The AMD/ATI Bar & Grill

Don't know why, but this happens since yesterday update:

$ fglrxinfo 
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  155 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  13
  Current serial number in output stream:  13

Tried to downgrade lib32-glibc - didn't help.

Offline

#5537 2013-08-16 14:37:29

savalaserg1
Member
Registered: 2013-06-27
Posts: 21

Re: The AMD/ATI Bar & Grill

I dont have the previous lib32-glibc package in my /var/cache anymore since I regular wipe that directory.... How would I install via pacman ?
I tried using downgrade but it does not have the older lib32-glibc 17 version ....

Last edited by savalaserg1 (2013-08-16 15:22:38)

Offline

#5538 2013-08-16 15:22:26

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 673

Re: The AMD/ATI Bar & Grill

savalaserg1 wrote:

I dont have the previous lib32-glibc package in my /var/cache anymore since I regular wipe that directory.... How would I install via pacman ?

https://wiki.archlinux.org/index.php/Do … ck_Machine

Offline

#5539 2013-08-16 15:33:02

savalaserg1
Member
Registered: 2013-06-27
Posts: 21

Re: The AMD/ATI Bar & Grill

Problem with that is they do not have the latest version of lib32-glibc before the push to new lib32-glibc ...
The latest version on arm is lib32-glibc-2.12-5-x86_64.pkg.tar.xz ........

Last edited by savalaserg1 (2013-08-16 15:35:15)

Offline

#5540 2013-08-16 15:35:24

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 673

Re: The AMD/ATI Bar & Grill

savalaserg1 wrote:

Problem with that is they do not have the latest version of lib32-glibc before the push to new lib32-glibc ...

Are you sure? http://arm.konnichi.com/2013/08/14/mult … pkg.tar.xz

Offline

#5541 2013-08-16 16:10:44

savalaserg1
Member
Registered: 2013-06-27
Posts: 21

Re: The AMD/ATI Bar & Grill

That is very odd I can only see the version I posted above when searching the ARM repository ..... anyway thanks for the link man....

Offline

#5542 2013-08-16 16:25:36

causa-prima
Member
Registered: 2013-07-21
Posts: 21

Re: The AMD/ATI Bar & Grill

I'm still new to the catalyst drivers, I'm using the catalyst-hook packages from Vi0L0s repos (tanks!).

Recently there was a kernel update (3.10.5-1 => 3.10.6-2), but there are no updates for the catalyst packages. Am I supposed to install the recent minor kernel update and build the modules or should I wait for new catalyst packages?

Which brings me to another question: when should I wait for new catalyst packages, and when am I supposed to just rebuild the modules?

Last edited by causa-prima (2013-08-16 16:28:21)

Offline

#5543 2013-08-16 18:12:30

Roken
Member
From: UK
Registered: 2012-01-16
Posts: 681

Re: The AMD/ATI Bar & Grill

I tend to find that minor kernel updates don't break catalyst. Incremental version jumps (3.10.5 - 3.10.6 for example) may need a kernel module rebuild. Full version jumps (3.9 - 3.10) will almost certainly need a rebuild.

Last edited by Roken (2013-08-16 21:32:22)


[img=Speedtest]http://www.speedtest.net/my-result/5145583518[/img]

Nvidia GTX 670 2Gb, AMD Phenom II X4 (965BE) @ 3.6 Ghz (Overclocked) 8GB RAM
Linux user #545703

Offline

#5544 2013-08-16 20:17:24

Jannis
Member
Registered: 2013-06-03
Posts: 32

Re: The AMD/ATI Bar & Grill

causa-prima wrote:

I'm still new to the catalyst drivers, I'm using the catalyst-hook packages from Vi0L0s repos (tanks!).

Recently there was a kernel update (3.10.5-1 => 3.10.6-2), but there are no updates for the catalyst packages. Am I supposed to install the recent minor kernel update and build the modules or should I wait for new catalyst packages?

Which brings me to another question: when should I wait for new catalyst packages, and when am I supposed to just rebuild the modules?

I use the catalyst-hook package and install all kernel updates. I just do a "sudo mkinitcpio -p linux" afterwards. (Actually linux-ck as I'm not using the repo kernel).

Last edited by Jannis (2013-08-16 20:17:50)

Offline

#5545 2013-08-16 22:25:38

clfarron4
Member
From: London, UK
Registered: 2013-06-28
Posts: 2,162
Website

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

lib32-glibc-2.18-1 bug?
Probably related with the errors reported by Cdh at the prev page, glibc 2.18 just landed in [core] with lib32-glibc 2.18, braking steam skype and other 32 bit software here.
For me downgrading just one package lib32-glibc to 2.17-5 did the trick

Just to add to this discussion about this package, I am running Catalyst 13.6-3, with the 3.10.7-2 linux-ck-k10 kernel (with the elevator=bfq option) and I am having no problems with 32bit programs.

I would like to ask how is 13.8 performance now compared to when it was first released?


Claire is fine.
Problems? I have dysgraphia, so clear and concise please.
My public GPG key for package signing
My x86_64 package repository

Offline

#5546 2013-08-16 22:27:32

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: The AMD/ATI Bar & Grill

multilib/lib32-glibc 2.18-2 should solve it anyway.


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#5547 2013-08-17 06:14:56

JaniAL
Member
Registered: 2013-08-16
Posts: 2

Re: The AMD/ATI Bar & Grill

Cdh wrote:

multilib/lib32-glibc 2.18-2 should solve it anyway.

Yeah 2.18-2 seems to work with Steam at least.

Offline

#5548 2013-08-18 00:34:54

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 137

Re: The AMD/ATI Bar & Grill

I've been working on trying to get an install of Arch up and running over the last couple of days- I'm trying to install the Catalyst drivers on my system during the install by editing /etc/pacman.conf and putting in the [catalyst] repo (my card is an HD Radeon 6400/7400m series). I have installed catalyst-hook, catalyst-utils-pxp, and linux-headers in that order, after installing X. I run the aticonfig --initial -f command, and everything looks good:

       Found fglrx primary device section
       PowerXpress info: Diagnostic output from /usr/lib/fglrx/switchlibglx:
       Switch to AMD

       Using /etc/X11/xorg.conf
       Saving back-up to /etc/X11/xorg.conf.fglrx4

I check to see which card I'm using with the aticonfig --pxl command:

       PowerXpress: Discrete GPU is active (High-Performance mode).

Everything looks good... until I try fglrxinfo:

       Error: unable to open display (null)

As you can imagine, startx doesn't work either. Output is good until:

       Loading extension GLX,

then I get:

       Server terminated with error (1).

I then take a look at the log file. Everything looks good until I see the first (WW)

       [1352.558] (WW) Falling back to old probe method for fglrx

I get more information, and everything looks good until I see:

       [1352.581] ukiDynamicMajor: failed to open /proc/ati/major (twice)

Then I get this:

       [1352.584] (II) fglrx(0): Invalid ATI BIOS from int10, the adapter is not VGA-enabled
       [1352.585] (EE) fglrx(0): Invalid video BIOS signature!
       [1352.585] (EE) fglrx(0): GetBIOSParameter failed
       [1352.585] (EE) fglrx(0): PreInitAdapter failed
       [1352.585] (EE) fglrx(0): PreInit failed

Then it unloads modules and gives me other errors:

       [1352.588] (EE) Screen(s) found, but none have a usable configuration.
       [1352.588] (EE)
       Fatal server error:
       [1352.588] (EE) no screens found(EE)

And then it's the error disclaimer. I tried loading the Catalyst drivers on my system two nights ago, and it crashed my system. On boot, all I got was a black screen, and I couldn't even open a tty. This is a fresh install that I'm trying to get up and running. I can't get X to start... Any help would be GREATLY appreciated.
Please forgive that I did not highlight the screen output that I typed in. I don't know how to do so!!

Offline

#5549 2013-08-18 20:30:13

Jannis
Member
Registered: 2013-06-03
Posts: 32

Re: The AMD/ATI Bar & Grill

horsemanoffaith wrote:

I have installed catalyst-hook, catalyst-utils-pxp, and linux-headers in that order, after installing X.

I think you're supposed to install linux-headers before catalyst. Maybe try to rebuild initramfs so fglrx module gets rebuild: sudo mkinitcpio -p linux

Other than that, I can't help. Good luck!

Offline

#5550 2013-08-18 21:55:36

Fregtux
Member
From: Italy
Registered: 2013-08-01
Posts: 55

Re: The AMD/ATI Bar & Grill

Exactly, if it is the installation order, you have to build fglrx kernel module with mkinitcpio command.


ASUS P8P67 EVO | i7-2600k |RAM 16GB DDR 3 Vengeance@1600MHz | AMD 7950 Sapphire Dual-X | SSD: Samsung 830 250GB | HD: Western Digital Caviar Blue 1TB

Offline

Board footer

Powered by FluxBB