You are not logged in.

#5726 2013-09-18 22:16:00

Ztjuh
Member
Registered: 2011-05-30
Posts: 40

Re: The AMD/ATI Bar & Grill

Hi Vi0L0,

Thanks for all your work!
I updated my system but now Xorg doesn't start anymore, here are my logs.

Xorg.0.log: http://pastebin.com/4CvsY4gg
catalyst-install.log: http://pastebin.com/jsxEH7Ct
xorg.conf: http://pastebin.com/B4Q0dNBr

Using
[catalyst-hd234k]
[xorg112]
3.11.1-1-ARCH kernel

Last edited by Ztjuh (2013-09-18 22:27:02)

Offline

#5727 2013-09-19 06:44:33

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,305
Website

Re: The AMD/ATI Bar & Grill

Ztjuh wrote:

Hi Vi0L0,

Thanks for all your work!
I updated my system but now Xorg doesn't start anymore, here are my logs.

Xorg.0.log: http://pastebin.com/4CvsY4gg
catalyst-install.log: http://pastebin.com/jsxEH7Ct
xorg.conf: http://pastebin.com/B4Q0dNBr

Using
[catalyst-hd234k]
[xorg112]
3.11.1-1-ARCH kernel

Any other legacy user is experiencing same behaviour? / Or could tell it's working fine?
I was able to run this driver, but on hd 7850

Last edited by Vi0L0 (2013-09-19 06:45:13)

Offline

#5728 2013-09-19 08:11:20

ilusi0n
Member
Registered: 2010-06-09
Posts: 187

Re: The AMD/ATI Bar & Grill

I'm using legacy driver as well. Using the same repositories and kernel as @Ztjuh. And everything is running fine

Offline

#5729 2013-09-19 18:16:27

WiteHaze
Member
Registered: 2013-09-19
Posts: 3

Re: The AMD/ATI Bar & Grill

I have not been able to get the Catalyst drivers to work for the longest time.  I think it's time for me to ask for help.

I am using the Catalyst-13.8-5 driver, and xorg-server 1.14.3-1.  I have "nomodeset" in my kernel parameters.  fglrxinfo returns "Error: unable to open display (null)".  startx is stuck at "Loading extension GLX".

Xorg.0.log - http://codepad.org/rVPWyeBG
xorg.conf - http://codepad.org/3oMnQxVS

I will be forever in your debt if you could help me out.

Offline

#5730 2013-09-19 19:02:05

stundrum
Member
Registered: 2013-09-17
Posts: 8

Re: The AMD/ATI Bar & Grill

ilusi0n wrote:

I'm using legacy driver as well. Using the same repositories and kernel as @Ztjuh. And everything is running fine

Same here.

Offline

#5731 2013-09-19 21:42:11

snowblind
Member
Registered: 2013-07-18
Posts: 36

Re: The AMD/ATI Bar & Grill

WiteHaze wrote:

I have not been able to get the Catalyst drivers to work for the longest time.  I think it's time for me to ask for help.

I am using the Catalyst-13.8-5 driver, and xorg-server 1.14.3-1.  I have "nomodeset" in my kernel parameters.  fglrxinfo returns "Error: unable to open display (null)".  startx is stuck at "Loading extension GLX".

What happens without nomodeset?

Offline

#5732 2013-09-19 22:19:02

WiteHaze
Member
Registered: 2013-09-19
Posts: 3

Re: The AMD/ATI Bar & Grill

snowblind wrote:
WiteHaze wrote:

I have not been able to get the Catalyst drivers to work for the longest time.  I think it's time for me to ask for help.

I am using the Catalyst-13.8-5 driver, and xorg-server 1.14.3-1.  I have "nomodeset" in my kernel parameters.  fglrxinfo returns "Error: unable to open display (null)".  startx is stuck at "Loading extension GLX".

What happens without nomodeset?

Nothing.  There is no change.

Offline

#5733 2013-09-20 07:11:49

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,305
Website

Re: The AMD/ATI Bar & Grill

@Ztjuh:
so it does look like it could be not catalyst fault, check system's logs and dmesg

@WiteHaze:
was your xorg.conf generated by aticonfig? You have 2 monitors, right? Screen is trying to reach aticonfig-Device[0]-0, but it doesn't exist, device "ATI radeon 7970" was added manually or, more probably, modified manually, also
Option        "KeyNotFound" "KeyNotFound"
looks strange
I would start with backup/remove xorg.conf and `aticonfig --inital`

BTW: 13.9 is no longer stable and was posted by a mistake

Offline

#5734 2013-09-20 15:43:37

omeringen
Member
Registered: 2012-05-28
Posts: 109

Re: The AMD/ATI Bar & Grill

sudo pacman -Syu
error: xorg112: signature from "Vi0L0 <vi0l093@gmail.com>" is invalid
:: Synchronizing package databases...
 xorg112 is up to date
 catalyst-hd234k is up to date
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
error: database 'xorg112' is not valid (invalid or corrupted database (PGP signature))

I have already added Vi0L0's GPG key.

Offline

#5735 2013-09-20 18:42:52

Ztjuh
Member
Registered: 2011-05-30
Posts: 40

Re: The AMD/ATI Bar & Grill

I will check it later smile I did check it already, but maybe I missed something.. Can't check it right now.. Will come back when I have some more info!

Nothing wrong in dmesg or my journal... I made a new xorg.conf and now the tty displays this text which isn't in the xorg.0.log.

(WW) No matching Device section for instance (BusID PCI:0@2:0:0) found
(WW) No matching Device section for instance (BusID PCI:0@1:0:1) found
(WW) No matching Device section for instance (BusID PCI:0@2:0:1) found

I don't have any screens attached to these, so why would it crash on it?

Last edited by Ztjuh (2013-09-20 20:01:05)

Offline

#5736 2013-09-21 02:08:24

WiteHaze
Member
Registered: 2013-09-19
Posts: 3

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

@WiteHaze:
was your xorg.conf generated by aticonfig? You have 2 monitors, right? Screen is trying to reach aticonfig-Device[0]-0, but it doesn't exist, device "ATI radeon 7970" was added manually or, more probably, modified manually, also
Option        "KeyNotFound" "KeyNotFound"
looks strange
I would start with backup/remove xorg.conf and `aticonfig --inital`

Deleting xorg.conf and regenerating it with 'aticonfig --initial' worked.  Thanks!

Edit:  Spoke far too soon.  After changing the settings with amdcccle to work with my dual screen set up, I was not able to load my DE again.

Xorg.0.log - http://codepad.org/tvxXms28
xorg.conf - http://codepad.org/w8MB2JWk

Edit2:  The lastest update to the Catalyst driver seems to have solved my problem completely.

Last edited by WiteHaze (2013-09-30 01:46:20)

Offline

#5737 2013-09-23 15:08:05

clfarron4
Member
From: London, UK
Registered: 2013-06-28
Posts: 2,162
Website

Re: The AMD/ATI Bar & Grill

Hey, so this is probably nothing, but I have the catalyst-hook package installed at version 13.6 and with the latest kernel 3.11 I am getting the following message:

 [drm:radeon_init] *ERROR* No UMS support in radeon module! 

Im not too worried about it because everything is still working fine, but I thought I should mention it.


Claire is fine.
Problems? I have dysgraphia, so clear and concise please.
My public GPG key for package signing
My x86_64 package repository

Offline

#5738 2013-09-24 08:45:41

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,305
Website

Re: The AMD/ATI Bar & Grill

Guys, i'm at work and it's very possible that I will be away from my pc for another like 30 hours, and there's something important and worth to check...

A fix for the big memory leak bug for catalyst 13.8 beta 2 smile
jacob from amd just sent it to bugzilla, he also find out that the leak was actually caused by this tiny community patch which was fixing non-root access and which we (and probably all linux community) were using, lol

Anyhow if you will find some free time feel free to take catalyst-test from AUR, remove flim_fglrx_13.8_proc_perm.patch from it and add jacob's patch which is available right here: http://ati.cchtml.com/show_bug.cgi?id=866#c14
and test it on l4d 2 or (better, cuz easier to notice) on xbmc

Edit: ok, i found some time and tested jacob's patch, it worked well with xbmc so i've updated catalyst-test and catalyst-test-pxp for now. I will update catalyst repo tomorrow smile

Last edited by Vi0L0 (2013-09-24 15:20:19)

Offline

#5739 2013-09-24 17:34:03

ivdok
Member
From: Nizhniy Novgorod (ru)
Registered: 2013-07-17
Posts: 56
Website

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

Guys, i'm at work and it's very possible that I will be away from my pc for another like 30 hours, and there's something important and worth to check...

A fix for the big memory leak bug for catalyst 13.8 beta 2 smile
jacob from amd just sent it to bugzilla, he also find out that the leak was actually caused by this tiny community patch which was fixing non-root access and which we (and probably all linux community) were using, lol

Anyhow if you will find some free time feel free to take catalyst-test from AUR, remove flim_fglrx_13.8_proc_perm.patch from it and add jacob's patch which is available right here: http://ati.cchtml.com/show_bug.cgi?id=866#c14
and test it on l4d 2 or (better, cuz easier to notice) on xbmc

Edit: ok, i found some time and tested jacob's patch, it worked well with xbmc so i've updated catalyst-test and catalyst-test-pxp for now. I will update catalyst repo tomorrow smile

Uhm...

> patching file etc/ati/authatieventsd.sh
> patching file etc/ati/authatieventsd.sh
> patch unexpectedly ends in middle of line
> Hunk #1 succeeded at 71 with fuzz 1 (offset 10 lines).
> patching file common/lib/modules/fglrx/build_mod/2.6.x/Makefile
> Hunk #1 succeeded at 68 (offset 2 lines).
> patching file common/lib/modules/fglrx/build_mod/firegl_public.c
> Hunk #1 succeeded at 93 with fuzz 2.
> patching file common/lib/modules/fglrx/build_mod/kcl_agp.c
> patching file common/lib/modules/fglrx/build_mod/firegl_public.c

Is this okay?


I use Arch Linux since 14/07/2013. Not that long, I agree, but I don't think what I will change it in near time - extensive wiki, obvious package manager and big, built-up community makes its job. I use Xfce4 as DE, Xfwm4 + Compton as WM, and for DM... "exec startxfce4" and "compton -b" inside .bash_profile big_smile
[ASUS P5QSE2, Pentium dual-core E5300, HD5770, 2GB RAM, 120G ext4 sda, 320G ntfs sdb]

Offline

#5740 2013-09-24 18:44:35

ivdok
Member
From: Nizhniy Novgorod (ru)
Registered: 2013-07-17
Posts: 56
Website

Re: The AMD/ATI Bar & Grill

Well, seems like OK:

$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 5700 Series
OpenGL version string: 4.3.12441 Compatibility Profile Context 13.20.11

lsmod | grep fglrx
fglrx                6445581  155
button                  3685  1 fglrx
agpgart                22047  5 drm,ttm,fglrx,intel_agp,intel_gtt

glxinfo | grep "direct rendering"
direct rendering: Yes

Xorg -version

X.Org X Server 1.14.3
Release Date: 2013-09-12
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.11.0-1-ARCH i686
Current Operating System: Linux localhost 3.11.1-1-ARCH #1 SMP PREEMPT Sat Sep 14 20:31:35 CEST 2013 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=691f4e0c-c7fc-40c5-bf00-e8ed2f0e4392 rw nomodeset quiet
Build Date: 13 September 2013  01:31:03PM

Current version of pixman: 0.30.2
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.

Brilliant! Beta drivees work once again OK. Thanks, Vi0L0! But even still, I'll switch back to 13.6, since xvba-video (Hello once again!) still doesn't work with catalyst newer than 13.6/13.7 (latter questionable).

Last edited by ivdok (2013-09-24 19:33:27)


I use Arch Linux since 14/07/2013. Not that long, I agree, but I don't think what I will change it in near time - extensive wiki, obvious package manager and big, built-up community makes its job. I use Xfce4 as DE, Xfwm4 + Compton as WM, and for DM... "exec startxfce4" and "compton -b" inside .bash_profile big_smile
[ASUS P5QSE2, Pentium dual-core E5300, HD5770, 2GB RAM, 120G ext4 sda, 320G ntfs sdb]

Offline

#5741 2013-09-24 19:37:24

chessmaster
Member
From: Dover,DE
Registered: 2011-12-10
Posts: 30

Re: The AMD/ATI Bar & Grill

where exactly is this patch applied to the fglrx.ko modules?


When you see a good move, wait — look for a better one.

Offline

#5742 2013-09-24 20:16:09

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,305
Website

Re: The AMD/ATI Bar & Grill

it's applied before module compilation, before putting files into ${pkgdir}/usr/share/ati/build_mod directory, look at catalyst-test's PKGBUILD and you will find line:

      patch -Np1 -i ../jacob_access_right.patch

Offline

#5743 2013-09-24 20:38:05

chessmaster
Member
From: Dover,DE
Registered: 2011-12-10
Posts: 30

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

it's applied before module compilation, before putting files into ${pkgdir}/usr/share/ati/build_mod directory, look at catalyst-test's PKGBUILD and you will find line:

      patch -Np1 -i ../jacob_access_right.patch

Trying to do this on a diffrent distro. Gentoo...
never mind I posted over on the gentoo forums.

Last edited by chessmaster (2013-09-24 21:02:07)


When you see a good move, wait — look for a better one.

Offline

#5744 2013-09-25 11:27:58

stevenandree
Member
Registered: 2013-09-16
Posts: 6

Re: The AMD/ATI Bar & Grill

I continually have this problem and others seem to have a similar issue, however can't for the life of me find a fix. I continue to revert to the open source drivers on my arch install but want to make use of my card for gaming. Don't want to have to bomb another install so would appreciate some help. Running a fairly new system with eufi boot.

To date i have followed the wiki and have installed catalyst and utils 13.6, running xorg 1.14.3. After doing aticonfig etc and nomodeset grubconfig etc,

lsmod | grep fglrx returns

fglrx                                6583658  0
amd_iommu_v2                  7188  1 fglrx
button                                   4669  1 fglrx

fglrxinfo returns
Error: unable to open display (null)

How can I fix this crucial step and get the card working?

Offline

#5745 2013-09-25 12:38:03

ivdok
Member
From: Nizhniy Novgorod (ru)
Registered: 2013-07-17
Posts: 56
Website

Re: The AMD/ATI Bar & Grill

stevenandree wrote:

I continually have this problem and others seem to have a similar issue, however can't for the life of me find a fix. I continue to revert to the open source drivers on my arch install but want to make use of my card for gaming. Don't want to have to bomb another install so would appreciate some help. Running a fairly new system with eufi boot.

To date i have followed the wiki and have installed catalyst and utils 13.6, running xorg 1.14.3. After doing aticonfig etc and nomodeset grubconfig etc,

lsmod | grep fglrx returns

fglrx                                6583658  0
amd_iommu_v2                  7188  1 fglrx
button                                   4669  1 fglrx

fglrxinfo returns
Error: unable to open display (null)

How can I fix this crucial step and get the card working?

Use old Xorg. Wonder how to switch?
1. Open another teletype with Ctrl-Alt-F2
2. Login as root
3. Edit /etc/pacman.conf as you need.
4. Update your repo cache:

pacman -Syy

5. Force remove your new Xorg:

pacman -Sdd xorg-server xorg-server-common xf86-input-evdev

Why not perform an "downgrading of old version with pacman -Suu"? Because it's not a stable operation IMO, since I frequently failed to load Xorg properly after it. Don't worry, it won't hurt, since we'll do this:
6. ...Reinstall old version -

pacman -Syu xorg-server xorg-server-common xf86-input-evdev catalyst-utils catalyst-hook

Second two packages are added by me to fix probable errors of fglrx.so compilation - sometimes it won't recompile itself correctly and from the first time. Permissions elevation problem? Don't know. But you can feel free to not to install them once again - it's just a conter-measure for sudden fails.
7. Just for a sane load, you probably won't need this:

pacman -Syy && pacman -Syu catalyst_build_module all && reboot

8. Reboot and start X. Easy!

If you don't know, how to reuse old versions' repo, read this.


I use Arch Linux since 14/07/2013. Not that long, I agree, but I don't think what I will change it in near time - extensive wiki, obvious package manager and big, built-up community makes its job. I use Xfce4 as DE, Xfwm4 + Compton as WM, and for DM... "exec startxfce4" and "compton -b" inside .bash_profile big_smile
[ASUS P5QSE2, Pentium dual-core E5300, HD5770, 2GB RAM, 120G ext4 sda, 320G ntfs sdb]

Offline

#5746 2013-09-25 12:42:51

stevenandree
Member
Registered: 2013-09-16
Posts: 6

Re: The AMD/ATI Bar & Grill

Thanks for the feedback, will give it a run

Offline

#5747 2013-09-25 13:14:06

stevenandree
Member
Registered: 2013-09-16
Posts: 6

Re: The AMD/ATI Bar & Grill

Still running the same error, any idea where this problem might be stemming from?

Offline

#5748 2013-09-25 13:18:54

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 672

Re: The AMD/ATI Bar & Grill

@stevenadree: can you start the desktop environment? I can get your same error if I switch to a tty and laung fglrxinfo, while from a konsole session in KDE I get the correct informations. Are you issuing fglrx from a tty or from a desktop environment?

Offline

#5749 2013-09-25 13:22:02

stevenandree
Member
Registered: 2013-09-16
Posts: 6

Re: The AMD/ATI Bar & Grill

Currently in tty. When I issue the command to load gdm I get a persistent black screen and are unable to so anything further

Offline

#5750 2013-09-25 13:25:28

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 672

Re: The AMD/ATI Bar & Grill

@stevenandree: then I think that it's better that you post /var/log/Xorg.0.log and /etc/X11/xorg.conf. Output of fglrxinfo from a tty is pretty useless.

Offline

Board footer

Powered by FluxBB