You are not logged in.

#6026 2013-12-28 10:34:46

scjet
Banned
Registered: 2011-07-23
Posts: 172

Re: The AMD/ATI Bar & Grill

although this question is no surprise, but, with respect to the "newer" amd-HD-5/6/7/... gpu's,
any news when Arch goes to xorg 1.15, that latest amd/ati catalyst drivers will be ready for it ?

Last edited by scjet (2013-12-28 10:59:42)


The "BSD" things in life are "Free", and "Open", and so is "Arch"

Offline

#6027 2013-12-28 18:02:04

ivdok
Member
From: Nizhniy Novgorod (ru)
Registered: 2013-07-17
Posts: 56
Website

Re: The AMD/ATI Bar & Grill

scjet wrote:

although this question is no surprise, but, with respect to the "newer" amd-HD-5/6/7/... gpu's,
any news when Arch goes to xorg 1.15, that latest amd/ati catalyst drivers will be ready for it ?

Hell, we don't even have .14 support in [stable], so don't even start to think about .15. New software versions drop from [testing] rather frequently, most of it - under a month or 3 weeks. Typically from 3 days to a week.


I use Arch Linux since 14/07/2013. Not that long, I agree, but I don't think what I will change it in near time - extensive wiki, obvious package manager and big, built-up community makes its job. I use Xfce4 as DE, Xfwm4 + Compton as WM, and for DM... "exec startxfce4" and "compton -b" inside .bash_profile big_smile
[ASUS P5QSE2, Pentium dual-core E5300, HD5770, 2GB RAM, 120G ext4 sda, 320G ntfs sdb]

Offline

#6028 2013-12-28 22:52:32

JoshQuake
Member
Registered: 2013-12-28
Posts: 8

Re: The AMD/ATI Bar & Grill

Hi, I just installed catalyst following the guide on arch wiki, but it seems X isn't starting now. When I try to do fglrxinfo I get "Error: Unable to open display (null)" and when I try to do aticonfig --adapter=all --odgt I get "ERROR - X needs to be running to perform AMD Overdrive(TM) commands"

Offline

#6029 2013-12-29 12:05:35

rulex
Member
From: Finland
Registered: 2009-05-20
Posts: 55

Re: The AMD/ATI Bar & Grill

Hi, the catalyst.wirephire.com domain seems to no longer be active. Is there a new domain?

Offline

#6030 2013-12-29 15:34:06

tehgeek
Member
Registered: 2013-02-24
Posts: 11

Re: The AMD/ATI Bar & Grill

rulex wrote:

Hi, the catalyst.wirephire.com domain seems to no longer be active. Is there a new domain?

Going to the site in a browser you get "This Domain Name Has Expired". =/

Offline

#6031 2013-12-29 16:35:50

Steef435
Member
From: age
Registered: 2013-08-29
Posts: 374
Website

Re: The AMD/ATI Bar & Grill

Tip: Because catalyst.wirephire.com will go down if a certain bandwidth limit is exceeded (this happened in the past) or may be too slow at your location, repository mirrors are provided by yanom at [1] (USA) and rtsinformatique at [2] (France). These mirrors however come with no warranty and are not guaranteed to always be operational:

I find this in the wiki.

Offline

#6032 2013-12-29 22:23:25

s0l1dsnak3123
Member
From: Scotland
Registered: 2008-06-26
Posts: 62
Website

Re: The AMD/ATI Bar & Grill

I can confirm that rts-informatique.fr mirrors correctly, but that wirephire repo being down has broken the xorg113 repository too

Last edited by s0l1dsnak3123 (2013-12-29 22:23:48)

Offline

#6033 2013-12-29 22:30:01

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,305
Website

Re: The AMD/ATI Bar & Grill

s0l1dsnak3123 wrote:

I can confirm that rts-informatique.fr mirrors correctly, but that wirephire repo being down has broken the xorg113 repository too

Mirrors are also serving xorg repos. While waiting for Apocalypsus' answer I've created [xorg114] repo, you can find out all repos ie. here:
rtsinformatique, France: http://mirror.rts-informatique.fr/archl … lyst/repo/
yanom, USA: http://70.239.162.206/catalyst-mirror/repo/

Last edited by Vi0L0 (2013-12-30 08:41:15)

Offline

#6034 2013-12-29 22:32:50

s0l1dsnak3123
Member
From: Scotland
Registered: 2008-06-26
Posts: 62
Website

Re: The AMD/ATI Bar & Grill

Beautiful, thanks Vi0l0 smile

Offline

#6035 2013-12-30 16:40:45

scjet
Banned
Registered: 2011-07-23
Posts: 172

Re: The AMD/ATI Bar & Grill

ivdok wrote:
scjet wrote:

although this question is no surprise, but, with respect to the "newer" amd-HD-5/6/7/... gpu's,
any news when Arch goes to xorg 1.15, that latest amd/ati catalyst drivers will be ready for it ?

Hell, we don't even have .14 support in [stable], so don't even start to think about .15. New software versions drop from [testing] rather frequently, most of it - under a month or 3 weeks. Typically from 3 days to a week.

smile,  yes I agree regarding [stable] possibly?, ,.., sry, I should have specified I'm using (AUR)catalyst-test 13.12-1, with "X.Org X Server 1.14.5", and have no problems so far,
on my Laptop -> AMD/A10-APU/GPU/7600M.

-just wondered about Xorg 1.15 eventually comin down the pipe.
but OK thx, I guess it is what it is, when it is, with regards to AMD/ATI, still.

Last edited by scjet (2013-12-30 16:47:50)


The "BSD" things in life are "Free", and "Open", and so is "Arch"

Offline

#6036 2013-12-30 19:11:20

brittyazel
Member
From: Davis, CA
Registered: 2013-05-11
Posts: 145

Re: The AMD/ATI Bar & Grill

I am getting an error message this morning saying that your have an invalid or corrupted PGP signature.

"error: database 'catalyst' is not valid (invalid or corrupted database (PGP signature))"

I have tried clearing my pgp keys and repulling yours down, but it is still broken. Any thoughts?


I don't really know what I'm doing.

Offline

#6037 2013-12-30 19:29:14

ilusi0n
Member
Registered: 2010-06-09
Posts: 187

Re: The AMD/ATI Bar & Grill

brittyazel wrote:

I am getting an error message this morning saying that your have an invalid or corrupted PGP signature.

"error: database 'catalyst' is not valid (invalid or corrupted database (PGP signature))"

I have tried clearing my pgp keys and repulling yours down, but it is still broken. Any thoughts?

use the servers provide by Violo 2 posts above

Offline

#6038 2013-12-30 21:58:16

clfarron4
Member
From: London, UK
Registered: 2013-06-28
Posts: 2,162
Website

Re: The AMD/ATI Bar & Grill

Any reference to Catalyst is the catalyst-hook package from Vi0L0's repository.

i'm trying to build the kernel modules for the 3.12.4 and 3.12.6 linux-lqx kernels from the AUR, and it will quite happily do with Catalyst 13.11-10 but not with Catalyst 13.12.

Here is the output from /var/log/catalyst-install.log when I try to build the modules for the 3.12.6 linux-lqx kernel with Catalyst 13.12 (for two separate runs). A reinstall yesterday means I can't create logs for 3.12.4 lqx with Catalyst 13.12 without compiling it again:

 --------
2013-12-30 21:34:20
Building fglrx module for 3.12.6-1-lqx kernel ...
--------
OsVersion says: SMP=1
file /proc/kallsyms says: SMP=1
file /usr/lib/modules/3.12.6-1-lqx/build/include/generated/autoconf.h says: SMP=1
file /usr/lib/modules/3.12.6-1-lqx/build/include/generated/autoconf.h says: MODVERSIONS=1
file /usr/lib/modules/3.12.6-1-lqx/build/arch/x86/include/asm/compat.h says: COMPAT_ALLOC_USER_SPACE=arch_compat_alloc_user_space
make: Entering directory '/usr/src/linux-3.12.6-1-lqx'
  CC [M]  /tmp/catalyst.fdSBSk/firegl_public.o
/tmp/catalyst.fdSBSk/firegl_public.c: In function ‘KCL_GetEffectiveUid’:
/tmp/catalyst.fdSBSk/firegl_public.c:1759:5: error: incompatible types when returning type ‘kuid_t’ but ‘KCL_TYPE_Uid’ was expected
     return current_euid();
     ^
/tmp/catalyst.fdSBSk/firegl_public.c:1763:1: warning: control reaches end of non-void function [-Wreturn-type]
 }
 ^
scripts/Makefile.build:308: recipe for target '/tmp/catalyst.fdSBSk/firegl_public.o' failed
make[1]: *** [/tmp/catalyst.fdSBSk/firegl_public.o] Error 1
Makefile:1228: recipe for target '_module_/tmp/catalyst.fdSBSk' failed
make: *** [_module_/tmp/catalyst.fdSBSk] Error 2
make: Leaving directory '/usr/src/linux-3.12.6-1-lqx'

--------
2013-12-30 21:35:34
Building fglrx module for 3.12.6-1-lqx kernel ...
--------
OsVersion says: SMP=1
file /proc/kallsyms says: SMP=1
file /usr/lib/modules/3.12.6-1-lqx/build/include/generated/autoconf.h says: SMP=1
file /usr/lib/modules/3.12.6-1-lqx/build/include/generated/autoconf.h says: MODVERSIONS=1
file /usr/lib/modules/3.12.6-1-lqx/build/arch/x86/include/asm/compat.h says: COMPAT_ALLOC_USER_SPACE=arch_compat_alloc_user_space
make: Entering directory '/usr/src/linux-3.12.6-1-lqx'
  CC [M]  /tmp/catalyst.zoJyx0/firegl_public.o
/tmp/catalyst.zoJyx0/firegl_public.c: In function ‘KCL_GetEffectiveUid’:
/tmp/catalyst.zoJyx0/firegl_public.c:1759:5: error: incompatible types when returning type ‘kuid_t’ but ‘KCL_TYPE_Uid’ was expected
     return current_euid();
     ^
/tmp/catalyst.zoJyx0/firegl_public.c:1763:1: warning: control reaches end of non-void function [-Wreturn-type]
 }
 ^
scripts/Makefile.build:308: recipe for target '/tmp/catalyst.zoJyx0/firegl_public.o' failed
make[1]: *** [/tmp/catalyst.zoJyx0/firegl_public.o] Error 1
Makefile:1228: recipe for target '_module_/tmp/catalyst.zoJyx0' failed
make: *** [_module_/tmp/catalyst.zoJyx0] Error 2
make: Leaving directory '/usr/src/linux-3.12.6-1-lqx' 

Note that Catalyst 13.12 is working fine with my CK-K10 and stock ARCH kernels.

Last edited by clfarron4 (2013-12-30 22:32:30)


Claire is fine.
Problems? I have dysgraphia, so clear and concise please.
My public GPG key for package signing
My x86_64 package repository

Offline

#6039 2013-12-31 07:22:04

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,305
Website

Re: The AMD/ATI Bar & Grill

@clfarron4:
have you tried applying the patch provided by Cold @ https://aur.archlinux.org/packages/catalyst-test/ ?

Offline

#6040 2013-12-31 11:13:26

clfarron4
Member
From: London, UK
Registered: 2013-06-28
Posts: 2,162
Website

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

@clfarron4:
have you tried applying the patch provided by Cold @ https://aur.archlinux.org/packages/catalyst-test/ ?

I will try it and report back, but it reads like it fixes the problem for lqx 3.12.4.

EDIT: It works, and all the other kernel modules seem to work work too big_smile

Last edited by clfarron4 (2013-12-31 12:06:26)


Claire is fine.
Problems? I have dysgraphia, so clear and concise please.
My public GPG key for package signing
My x86_64 package repository

Offline

#6041 2013-12-31 21:57:54

l0vot
Member
Registered: 2011-08-26
Posts: 117

Re: The AMD/ATI Bar & Grill

I am using the latest Arch, catalyst-total from the AUR, and the xorg packaged from xorg114.
I have a problem, when I try to start x using "startx", I get an error that is similar to this (not exactly cuz i have no screenshots to copy from):

Error: failed to load shared object file: libgcrypt.so.11, No such file or directory.

Due to this error, X refuses to start.


I used locate to find libgcrypt.so, and I found libgcrypt.so, and libgcrypt.so.20 inside of /usr/lib
I also found libgcrypt.so.11 inside lib32, but that doesn't count

I symlinked libgcrypt.so.20 to libgcrypt.so.11, but that did not work (I didn't expect it to, but it was worth a shot).

I am using my backup install until the problem is resolved.(it uses the FOSS drivers to avoide any problems encountered while using the proprietary ones).

Thank you for your time.

EDIT: Why does xorg need what appears to be a cryptography library in order to start anyways?

Last edited by l0vot (2014-01-02 20:57:39)

Offline

#6042 2014-01-01 11:29:05

PhotonX
Member
From: Munich
Registered: 2008-08-10
Posts: 431

Re: The AMD/ATI Bar & Grill

The server seems to be up again, but something is not working. Doing " pacman -Syu" I get

error: GPGME error: No data
error: failed to update catalyst (invalid or corrupted database (PGP signature))
error: database 'catalyst' is not valid (invalid or corrupted database (PGP signature))

So I disabled the signature check with "SigLevel = Never" in /etc/pacman.conf. After "pacman -Syy" there are no errors, but when "pacman -Su" I get many of

error: could not open file /var/lib/pacman/sync/catalyst.db: Unrecognized archive format

Desktop: http://www.sysprofile.de/id15562, Arch Linux    |    Notebook: Thinkpad X200 Tablet, Manjaro

The very worst thing you can do with free software is to download it, see that it doesn't work for some reason, leave it, and tell your friends that it doesn't work.  -  Tuomas Lukka

Offline

#6043 2014-01-01 18:04:59

l0vot
Member
Registered: 2011-08-26
Posts: 117

Re: The AMD/ATI Bar & Grill

@PhotonX: I have the same problem, but I use the AUR insead of the catalyst repo, so I left that out of my post.

Last edited by l0vot (2014-01-01 18:08:01)

Offline

#6044 2014-01-02 12:10:30

acgtyrant
Member
From: Hangzhou, China
Registered: 2013-04-09
Posts: 54
Website

Re: The AMD/ATI Bar & Grill

I find a strange phenomenon, it may be a big bug.

I have a ThinkPad and a DELL monitor, and I installed catalyst-utils-pxp and catalyst-hook while I use i3 as my windows manager.

When I use Intel driver, xrandr works very well with the dual screen.

However, when I use AMD driver and xrandr to implement dual screen, the strange phenomenon will happens.

If I am active at the laptop's window, or take a screenshot, it looks very normal, here is the screenshot: https://lh6.googleusercontent.com/-AWKs … enShot.png

But if I am active at the DELL screen, <b>the second screen will be copied at the laptop screen and cover it!</b>, here is the image: https://lh4.googleusercontent.com/-0lpP … 214911.jpg. However the screenshot is still normal, or I active or fresh the laptop screen again then the strange phenomenon will disappears.

I think there must be something copy the second screen to the laptop screen and cover it when the second screen is active. Do you have any idea? Thank you!

Forgive my poor English please.


I am Chinese! I love Arch Linux!

Offline

#6045 2014-01-02 20:53:52

l0vot
Member
Registered: 2011-08-26
Posts: 117

Re: The AMD/ATI Bar & Grill

@acgtyrant: protip, HTML tags have no power here, you would use

[b][/b]

in order to get bold text.
Have you tried using the AMD control center* to set up dual screens?

*it should be in your main menue somewhere, if that fails, the ArchWiki page is here: https://wiki.archlinux.org/index.php/AM … figuring_X

Offline

#6046 2014-01-03 11:39:08

clfarron4
Member
From: London, UK
Registered: 2013-06-28
Posts: 2,162
Website

Re: The AMD/ATI Bar & Grill

So, I'm in the middle of re-doing the dual-boot setup on one of my rigs, when I went to the AMD site to get the stable AMD Catalyst drivers for Windows when I was greeted by this. That is, it appears that 13.12 is the latest stable driver and 13.11.9-6 is the latest beta driver. Here is the corresponding Linux page.

Does anyone know what version is the latest stable version of Catalyst?


Claire is fine.
Problems? I have dysgraphia, so clear and concise please.
My public GPG key for package signing
My x86_64 package repository

Offline

#6047 2014-01-03 12:40:38

ChemBro
Member
Registered: 2008-10-22
Posts: 678

Re: The AMD/ATI Bar & Grill

clfarron4 wrote:

Does anyone know what version is the latest stable version of Catalyst?

13.12., as you mentioned.

Offline

#6048 2014-01-03 13:47:17

acgtyrant
Member
From: Hangzhou, China
Registered: 2013-04-09
Posts: 54
Website

Re: The AMD/ATI Bar & Grill

@l0vot Thank you. But I think you misunderstand my problem, I said,I have set the dual screen successfully, but there are something always copy the second screen to the laptop screen when it is active.


I am Chinese! I love Arch Linux!

Offline

#6049 2014-01-03 16:16:34

snowblind
Member
Registered: 2013-07-18
Posts: 36

Re: The AMD/ATI Bar & Grill

acgtyrant wrote:

@l0vot Thank you. But I think you misunderstand my problem, I said,I have set the dual screen successfully, but there are something always copy the second screen to the laptop screen when it is active.

This is a known issue with the Catalyst drivers on laptops with PowerXpress graphics -- when using the AMD card, if you use xrandr to expand the desktop to an external monitor, you get strange corruption. AMD has yet to fix this.

In order to deal with this, you have a few options:

1. You can scale your laptop monitor, as such:

xrandr --output HDMI1 --left-of LVDS1 --primary --scale 1x1 --output LVDS1 --scale 1.0001x1.0001

This should make the artifacting go away, with little noticeable difference to the screen output

2. You can use Bumblebee, specifically with YoRyan's AMD hacks: https://github.com/YoRyan/bumblebee-amd-hacks (note: some games don't really like this, and the performance is not as high as just using the AMD driver directly, mostly because Primus still doesn't work with AMD+Bumblebee)

3. You can ditch the Catalyst driver and use the Mesa driver -- from git -- which has PRIME offloading. Performance is not as good on Mesa (I'd peg it around 60-70% of Catalyst for radeonsi, 80% or higher for r600g) and Mesa doesn't have the OpenGL compliance that Catalyst does, but overall it presents a higher quality of life, especially on PowerXpress laptops.

Last edited by snowblind (2014-01-03 16:17:37)

Offline

#6050 2014-01-03 21:23:01

zyth88
Member
Registered: 2012-12-21
Posts: 14

Re: The AMD/ATI Bar & Grill

Is it recommended to use CLUTTER_VBLANK=none in Gnome if Tear Free is enabled in the catalyst options?

Offline

Board footer

Powered by FluxBB