You are not logged in.

#6276 2014-02-11 10:35:25

joanmanel
Member
Registered: 2012-11-06
Posts: 112

Re: The AMD/ATI Bar & Grill

Fresh install, my steam won't work. It fails loading with a seg fault

pacman -Q xorg-server catalyst-utils linux
xorg-server 1.15.0-5
catalyst-utils 14.1-1
linux 3.12.9-2

steam
Running Steam on arch  64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0_client)
Uploading dump (out-of-process) [proxy '']
/tmp/dumps/crash_20140211091421_1.dmp
/home/juanma/.local/share/Steam/steam.sh: line 755:  1599 Segmentation fault      (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
mv: cannot stat ‘/home/juanma/.steam/registry.vdf’: No such file or directory
Installing bootstrap /home/juanma/.local/share/Steam/bootstrap.tar.xz
Reset complete!
Restarting Steam by request...
Running Steam on arch  64-bit
STEAM_RUNTIME has been set by the user to: /home/juanma/.local/share/Steam/ubuntu12_32/steam-runtime
Installing breakpad exception handler for appid(steam)/version(0_client)
Uploading dump (out-of-process) [proxy '']
/tmp/dumps/crash_20140211091422_1.dmp
/home/juanma/.local/share/Steam/steam.sh: line 755:  1695 Segmentation fault      (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
Finished uploading minidump (out-of-process): success = yes
response: CrashID=bp-cff2a058-de9f-4237-95ae-661ed2140211
Finished uploading minidump (out-of-process): success = yes
response: CrashID=bp-e2185ff9-2605-4f1b-8df9-328c62140211

It was giving the same error with xorg-server 1.14

Offline

#6277 2014-02-11 21:13:32

joanmanel
Member
Registered: 2012-11-06
Posts: 112

Re: The AMD/ATI Bar & Grill

I have realized than although I have installed lib32-catalyst-utils, it gives me a seg fault when I try to glxinfo32:

glxinfo32
name of display: :0
Segmentation fault (core dumped

if I try glxinfo, it gives me the right stuff, with direct rendering YES

so although I have the 32 bits driver installed, something is missing

Offline

#6278 2014-02-11 23:16:36

okubax
Member
From: London
Registered: 2010-04-24
Posts: 186
Website

Re: The AMD/ATI Bar & Grill

joanmanel wrote:

I have realized than although I have installed lib32-catalyst-utils, it gives me a seg fault when I try to glxinfo32:

glxinfo32
name of display: :0
Segmentation fault (core dumped

if I try glxinfo, it gives me the right stuff, with direct rendering YES

so although I have the 32 bits driver installed, something is missing

Try installing lib32-libxinerama

Offline

#6279 2014-02-12 00:00:01

joanmanel
Member
Registered: 2012-11-06
Posts: 112

Re: The AMD/ATI Bar & Grill

okubax wrote:
joanmanel wrote:

I have realized than although I have installed lib32-catalyst-utils, it gives me a seg fault when I try to glxinfo32:

glxinfo32
name of display: :0
Segmentation fault (core dumped

if I try glxinfo, it gives me the right stuff, with direct rendering YES

so although I have the 32 bits driver installed, something is missing

Try installing lib32-libxinerama

It is working! Well at least I have a window now saying that Steam is updated

thank you

big_smile

I don't know why I needed libxinerama, because I only use 1 screen

Offline

#6280 2014-02-12 09:04:10

episyron
Member
Registered: 2010-07-21
Posts: 17

Re: The AMD/ATI Bar & Grill

Removed.

Last edited by episyron (2014-02-12 09:53:36)

Offline

#6281 2014-02-13 09:29:33

fc
Member
Registered: 2013-11-21
Posts: 5

Re: The AMD/ATI Bar & Grill

okubax wrote:
joanmanel wrote:

I have realized than although I have installed lib32-catalyst-utils, it gives me a seg fault when I try to glxinfo32:

glxinfo32
name of display: :0
Segmentation fault (core dumped

if I try glxinfo, it gives me the right stuff, with direct rendering YES

so although I have the 32 bits driver installed, something is missing

Try installing lib32-libxinerama

That fixed the problem for me too. How did you find out that solution ?

Offline

#6282 2014-02-14 17:44:10

joanmanel
Member
Registered: 2012-11-06
Posts: 112

Re: The AMD/ATI Bar & Grill

Now with Steam and Dota2 working, my performance seems to degrade a lot over time.

It started being nice, all max, all fast. After 15 minutes more or less, FPS dropped and I had to set all to mid, and again after one hour FPS dropped and I had to set all to low.

This looks more like a driver problem than application problem.

Anyone has similar experiences?

Offline

#6283 2014-02-14 20:19:08

hippieben
Member
Registered: 2013-10-27
Posts: 197

Re: The AMD/ATI Bar & Grill

Every now and then my screens will go black for a split second and then come back.  Running catalyst-hook 14.1-1

Xorg log Doesn't seem to be anything relevant in here, but though I'd post it anyway just in case.

EDIT: I suspect it has to do with flash.  I followed these instructions and will report back the results.

Last edited by hippieben (2014-02-14 20:42:08)

Offline

#6284 2014-02-14 20:57:03

LucetLux
Member
Registered: 2013-08-16
Posts: 136

Re: The AMD/ATI Bar & Grill

hippieben wrote:

Every now and then my screens will go black for a split second and then come back.  Running catalyst-hook 14.1-1

Xorg log Doesn't seem to be anything relevant in here, but though I'd post it anyway just in case.

EDIT: I suspect it has to do with flash.  I followed these instructions and will report back the results.


Same thing here, it happened to me when I was watching some youtube videos, yet I only use the html5 player, I don't think this is flash related.
It is like the screen goes black after some idle time, I don't know what's going on with that.

Last edited by LucetLux (2014-02-14 20:57:55)

Offline

#6285 2014-02-14 21:40:26

LucetLux
Member
Registered: 2013-08-16
Posts: 136

Re: The AMD/ATI Bar & Grill

I'm having some problems with wine, some 3d applications that worked fine when I used xf86-video-ati don't work if I use fglrx, these are mostly more recent applications, older ones, 2d applications or those which use less 3d features work just fine, like Devil May Cry 3 , Skullgirls or Hearthstone, yet games like Devil May Cry 4, Dark Souls or Metal Gear Rising Revengeance fail to load or freeze at some point, DMC4 loads up to the title screen, which has a moving 3d background, but if I try to get to the actual game it takes forever to load and then freezes, a similar thing happens with Dark Souls, which loads up to the main menu and then hangs as soon as I try to load a saved game, Metal Gear Rising just isn't working.
Native modern 3D applications work fine, like Dota 2 or Team Fortress 2.

I'm not sure if this is caused because I missed something when installing the driver or if this is expected from fglrx for wine applications, as always I appreciate any help you can provide.

I installed fglrx from the unofficial repo provided in the wiki, I installed catalyst-hook and lib32-catalyst-utils




fglrxinfo

display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 6700 Series  
OpenGL version string: 4.3.12780 Compatibility Profile Context 13.20.5

glxinfo | grep direct

 direct rendering: Yes
    GL_AMD_multi_draw_indirect, GL_AMD_name_gen_delete, 
    GL_ARB_draw_elements_base_vertex, GL_ARB_draw_indirect, 
    GL_ARB_multi_draw_indirect, GL_ARB_multisample, GL_ARB_multitexture, 
    GL_EXT_copy_buffer, GL_EXT_copy_texture, GL_EXT_direct_state_access, 
    GL_AMD_multi_draw_indirect, GL_AMD_name_gen_delete, 
    GL_ARB_draw_elements_base_vertex, GL_ARB_draw_indirect, 
    GL_ARB_multi_draw_indirect, GL_ARB_multisample, GL_ARB_multitexture, 
    GL_EXT_copy_buffer, GL_EXT_copy_texture, GL_EXT_direct_state_access,

glxinfo | grep render

direct rendering: Yes
OpenGL renderer string: AMD Radeon HD 6700 Series  
    GL_KTX_buffer_region, GL_NV_blend_square, GL_NV_conditional_render, 
    GL_KTX_buffer_region, GL_NV_blend_square, GL_NV_conditional_render,

lsmod | grep fglrx

fglrx                7940427  99 
amd_iommu_v2            7196  1 fglrx
button                  4677  1 fglrx

Last edited by LucetLux (2014-02-14 22:43:32)

Offline

#6286 2014-02-15 13:33:31

solar
Member
Registered: 2011-03-01
Posts: 77

Re: The AMD/ATI Bar & Grill

Hi Vi0l0..  I see you have a comment about xz being slow in the PKGBUILD... maybe try something like

yaourt pxz (multi-threaded xz)
echo alias xz='pxz' >> ~/.bashrc

and see if you find that helpful.


I am hilariously insane. yup. you won't notice though.. I promise...I think.

Offline

#6287 2014-02-16 20:25:43

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,336
Website

Re: The AMD/ATI Bar & Grill

sas wrote:

Installing lib32-libxinerama fixed it. This should probably be made a dependency of the lib32-catalyst-utils package.

For future reference, the way I found this solution was by installing strace, and then running:

strace glxdemo32

...which showed that the last thing it tried to do before segfaulting was to load "/usr/lib32/libXinerama.so.1".

Done, lib32-catalyst-utils(-pxp) dependencies were updated on AUR and repos: [catalyst], [catalyst-stable], [catalyst-hd234k]
Thanks cool

solar wrote:

Hi Vi0l0..  I see you have a comment about xz being slow in the PKGBUILD... maybe try something like

yaourt pxz (multi-threaded xz)
echo alias xz='pxz' >> ~/.bashrc

and see if you find that helpful.

pxz works flawlessly! Nice find, thanks :-)

Offline

#6288 2014-02-18 03:32:55

LucetLux
Member
Registered: 2013-08-16
Posts: 136

Re: The AMD/ATI Bar & Grill

Should I make a new thread for my issue or is it okay to post it here ?

Offline

#6289 2014-02-18 09:53:13

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,336
Website

Re: The AMD/ATI Bar & Grill

You mean problems with wine apps?
Unfortunatelly it's pretty normal that some titles are working well and some are not.
Firstly I would go to http://appdb.winehq.org and check some tips mentioned there.
If this won't help I would post a bug report at unofficial bugzilla, with a screenshot(s) if possible.

Offline

#6290 2014-02-18 11:52:08

LucetLux
Member
Registered: 2013-08-16
Posts: 136

Re: The AMD/ATI Bar & Grill

As I said, I'm having problems specifically with the fglrx driver, everything I mentioned works flawlessly with the opensource driver.
I tried looking for some older threads about running wine apps with fglrx but I couldn't find anything recent.
I didn't go straight to fill a bug report as it wouldn't have been the first time I missed something obvious, or maybe not that obvious, I've switched from the opensource driver to the proprietary one like 10 times now.

edit: Well this looks oddly similar http://ati.cchtml.com/show_bug.cgi?id=1011 , I'll look into that.

Last edited by LucetLux (2014-02-18 12:15:50)

Offline

#6291 2014-02-18 15:50:48

hippieben
Member
Registered: 2013-10-27
Posts: 197

Re: The AMD/ATI Bar & Grill

I'm still getting the intermittent flash. 

I'm running catalyst-stable and xorg114.

Is there anything in the wiki that is out of date?

Offline

#6292 2014-02-19 05:09:08

hippieben
Member
Registered: 2013-10-27
Posts: 197

Re: The AMD/ATI Bar & Grill

Any info on the 13.12-2 update?

Offline

#6293 2014-02-19 08:59:46

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,336
Website

Re: The AMD/ATI Bar & Grill

Only a little changes, as wrote on AUR:
catalyst-utils:
- added 'lib32-catalyst-utils' to the optdeps
- authatieventsd' patch by solar (patch s/-1/255)
- amd has updated its /etc/ati/ files

lib32-catalyst-utils:
- added 'lib32-libxinerama' to the deps (thanks sas)

Offline

#6294 2014-02-19 13:57:59

hippieben
Member
Registered: 2013-10-27
Posts: 197

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

Only a little changes, as wrote on AUR:
catalyst-utils:
- added 'lib32-catalyst-utils' to the optdeps
- authatieventsd' patch by solar (patch s/-1/255)
- amd has updated its /etc/ati/ files

lib32-catalyst-utils:
- added 'lib32-libxinerama' to the deps (thanks sas)

Thanks!

Offline

#6295 2014-02-20 10:29:06

joanmanel
Member
Registered: 2012-11-06
Posts: 112

Re: The AMD/ATI Bar & Grill

after some time using xorg114 repo, I decided to uncomment it, because in another computer everything runs fine with the last xorg

In this computer, I have an intel integrated, and an Ati 7700 series. after trying to update it gives me

debug: package xorg-server conflicts with glamor-egl (by X-ABI-VIDEODRV_VERSION>=15)
debug: package 'xorg-server' conflicts with 'glamor-egl'
:: xorg-server and glamor-egl are in conflict (X-ABI-VIDEODRV_VERSION). Remove glamor-egl? [y/N]

and then if I press yes

error: failed to prepare transaction (could not satisfy dependencies)
:: xf86-video-intel: requires glamor-egl

so basically I cannot update it

Offline

#6296 2014-02-20 11:16:00

desaparecido
Member
From: Liège, Belgium
Registered: 2010-03-14
Posts: 141

Re: The AMD/ATI Bar & Grill

joanmanel wrote:

after some time using xorg114 repo, I decided to uncomment it, because in another computer everything runs fine with the last xorg

In this computer, I have an intel integrated, and an Ati 7700 series. after trying to update it gives me

debug: package xorg-server conflicts with glamor-egl (by X-ABI-VIDEODRV_VERSION>=15)
debug: package 'xorg-server' conflicts with 'glamor-egl'
:: xorg-server and glamor-egl are in conflict (X-ABI-VIDEODRV_VERSION). Remove glamor-egl? [y/N]

and then if I press yes

error: failed to prepare transaction (could not satisfy dependencies)
:: xf86-video-intel: requires glamor-egl

so basically I cannot update it

hi, if you will install catalyst drivers you'll not need anymore xf86-video-intel (and glamor-egl) so you can make

# pacman -Rdd xf86-video-intel glamor-egl

without problem, but before logout your session or restart your X server you need to install completly the news catalyst drivers following the wiki.


KF5 & Plasma5 (git versions) - Awesome WM
ASUS Sabertooth 990FX - AMD FX8350 - ATI Radeon HD 7970
[testing] repo

Offline

#6297 2014-02-20 13:58:34

joanmanel
Member
Registered: 2012-11-06
Posts: 112

Re: The AMD/ATI Bar & Grill

I have total-catalyst-pxp installed which allows me to swap from intel to amd. That's why I think I need xf86-video-intel.

It's actually working with xorg114 (as suggested in the wiki) but I want to update it

Offline

#6298 2014-02-20 14:08:07

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,336
Website

Re: The AMD/ATI Bar & Grill

total doesn't support xorg-server 1.15. Use catalyst-test-pxp.

Offline

#6299 2014-02-20 16:30:42

karkhaz
Member
Registered: 2014-01-25
Posts: 77

Re: The AMD/ATI Bar & Grill

Hi all,
does anybody have any experience using a Rx-series AMD card (I'm using R9) with >4 outputs? I'll start a thread about this if I can't figure it out, but my new card has one of its DVI outputs disabled for some reason. xrandr can see all 5 outputs, and can even enable the DVI output: when I move the cursor to the edge of the screen, it dissapears as if it were moving on to the DVI monitor, but the monitor is getting no signal. Sound familiar to anybody?

Offline

#6300 2014-02-22 07:26:34

hippieben
Member
Registered: 2013-10-27
Posts: 197

Re: The AMD/ATI Bar & Grill

Hardware acceleration seems to be broken with kdenlive.  Whenever I try to play a clip X crashes.  I'm running 14.1-2.  Works fine with 13.12, but then I have to deal with X crashing every time I resize konsole sad

Offline

Board footer

Powered by FluxBB