You are not logged in.

#6401 2014-03-20 05:23:32

episyron
Member
Registered: 2010-07-21
Posts: 15

Re: The AMD/ATI Bar & Grill

sajuuk wrote:

Thanks for the help. I checked, KMS is disabled and the fglrx module is loaded. But when I run "fglrxinfo" I get "Error: unable to open display (null)".

What is in your /etc/X11/xorg.conf?

Offline

#6402 2014-03-20 17:36:03

sajuuk
Member
Registered: 2011-05-11
Posts: 8

Re: The AMD/ATI Bar & Grill

Here it is :

Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:0:0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Offline

#6403 2014-03-22 19:07:14

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

What a sad thing. I just found that clinfo isn't able to see my 290x, every opencl sample isn't able to use it... what a ... Soon I will wrote bug report.
Edit: btw there's no problem with hd 7850 in opencl case
Edit2: report is here: http://ati.cchtml.com/show_bug.cgi?id=1044

Meanwhile i'm updating [catalyst] repo. Edit2: updated, archive repo is called [catalyst-14.2]

I've added expoerimental powerXpress support to catalyt-test@AUR. Feel free to test wink. As said in comments:
Idea is descibed here [1]. I decided to add check_switch into .install file. Before extracting files it's checking if your pxp is set to intel, and if so it's switching to intel after extraction. check_switch implementation is n00bish (because Im creating file to store data) and I don't like it, maybe someone knows some hack-trick which will allow to transfer data from pre_upgrade to post_upgrade?

[1] https://bbs.archlinux.org/viewtopic.php … 9#p1391639

Last edited by Vi0L0 (2014-03-22 20:47:25)

Offline

#6404 2014-03-23 09:00:45

captainmrgn
Member
Registered: 2014-03-23
Posts: 1

Re: The AMD/ATI Bar & Grill

Why does the catalyst-utils package in the catalyst-hd234k repository say "Radeons HD 2 3 4 xxx ARE NOT SUPPORTED"?

  catalyst-hd234k/catalyst-utils 13.1-7
      AMD/ATI Catalyst legacy drivers. Utilities and libraries. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED

I using a Radeon HD 4200 series card and I have tried every package/build I could find but continue to get a black screen that doesnt allow me to switch TTYs when starting Xorg. I can power off nicely by hitting the power button, ACPI shutdown, but CTRL-ALT-DELETE or switching to another TTY doesn't work.

I'm downloading the 12.6 hd234k total source now to see if that works. I've used 13.1 in Ubuntu without any issues but can' get this to work in Arch. Ive tried linux, linux-lts and linux-lts34 kernels with a known "good" xorg.conf, freshly initiated xorg.conf(s) after removing amdpcsdb each time. The acpi-services=off doesn't help and even the desperate option of removing nomodeset from the kernel line. Even tried just running the amd installer myself but with the same result.

Any ideas? Thanks and sorry for any typos... the past couple nights have been long. :)

# lspci
01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250]

Xorg.0.log with strange warnings...

[    72.533] (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
[    72.533]    compiled for 1.4.99.906, module version = 8.97.2
[    72.533] (II) ATI Proprietary Linux Driver Version Identifier:8.97.2
[    72.533] (II) ATI Proprietary Linux Driver Release Identifier: 8.97.100.7                           
[    72.533] (II) ATI Proprietary Linux Driver Build Date: Nov 16 2012 14:45:00
[    72.534] (--) using VT number 3

[    72.651] (WW) Falling back to old probe method for fglrx
[    72.678] (II) Loading PCS database from /etc/ati/amdpcsdb
[    72.681] (--) Chipset Supported AMD Graphics Processor (0x9712) found
[    72.681] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:17:0) found
[    72.681] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:0) found
[    72.681] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:2) found
[    72.681] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:0) found
[    72.681] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:2) found
[    72.681] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:0) found
[    72.681] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:2) found
[    72.681] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:3) found
[    72.681] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:4) found
[    72.681] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:5) found
[    72.681] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:22:0) found
[    72.681] (WW) fglrx: No matching Device section for instance (BusID PCI:0@0:22:2) found
[    72.681] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:5:1) found
[    72.682] (II) AMD Video driver is running on a device belonging to a group targeted for this release
[    72.692] (II) AMD Video driver is signed

Offline

#6405 2014-03-23 09:47:25

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

I will fix this "simple typo" wink with next update.
Since you have Mobility Radeon, do you also have some intel gpu? If so then maybe it would be good to check catalyst-utils-pxp package.
Please paste full xorg log, maybe theres something interesting out there.

Offline

#6406 2014-03-23 20:22:40

tomsloan
Member
Registered: 2013-09-30
Posts: 22

Re: The AMD/ATI Bar & Grill

I'm trying to switch back to Catalyst after a short stint with RadeonSI and I'm running into some weirdness on xinit. Short story: xorg hangs on startup. When I check the log, I see no EE lines, but pretty consistently it ends with the following lines:

FBADPhys: 0xf400000000 FBMappedSize: 0x01040000

Should I try downgrading to 14.2? I've tried both xorg 1.14 a d 1.15. Suggestions would be greatly appreciated.

Offline

#6407 2014-03-25 20:15:18

bricem13
Member
Registered: 2011-02-02
Posts: 5

Re: The AMD/ATI Bar & Grill

Hi


I'm trying to install catalyst on my intel/radeon laptop. So far I experience some issues... I had no screens previously, what solved with last catalyst pkg but now here is the log:


[    28.817] 
X.Org X Server 1.15.0
Release Date: 2013-12-27
[    28.818] X Protocol Version 11, Revision 0
[    28.818] Build Operating System: Linux 3.12.5-1-ARCH x86_64 
[    28.818] Current Operating System: Linux TuxBox 3.13.7-1-ARCH #1 SMP PREEMPT Mon Mar 24 20:06:08 CET 2014 x86_64
[    28.818] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=/dev/sda5 ro quiet
[    28.818] Build Date: 09 January 2014  08:47:24AM
[    28.818]  
[    28.818] Current version of pixman: 0.32.4
[    28.818] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    28.818] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    28.818] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Mar 25 21:04:04 2014
[    28.872] (==) Using config file: "/etc/X11/xorg.conf"
[    28.872] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    28.872] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    28.928] (==) ServerLayout "ServerLayout0"
[    28.928] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[    28.928] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[    28.928] (**) |   |-->Device "aticonfig-Device[0]-0"
[    28.928] (**) Option "BlankTime" "3"
[    28.928] (**) Option "StandbyTime" "10"
[    28.928] (**) Option "SuspendTime" "20"
[    28.928] (**) Option "OffTime" "30"
[    28.928] (==) Automatically adding devices
[    28.928] (==) Automatically enabling devices
[    28.928] (==) Automatically adding GPU devices
[    28.965] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    28.965] 	Entry deleted from font path.
[    28.969] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    28.969] 	Entry deleted from font path.
[    28.969] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    28.969] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    28.969] 	Entry deleted from font path.
[    28.969] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    28.969] (==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/Type1/
[    28.969] (**) ModulePath set to "/usr/lib/xorg/modules/updates,/usr/lib/xorg/modules"
[    28.969] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    28.969] (II) Loader magic: 0x804c80
[    28.969] (II) Module ABI versions:
[    28.969] 	X.Org ANSI C Emulation: 0.4
[    28.969] 	X.Org Video Driver: 15.0
[    28.969] 	X.Org XInput driver : 20.0
[    28.969] 	X.Org Server Extension : 8.0
[    28.970] (II) xfree86: Adding drm device (/dev/dri/card0)
[    28.972] (--) PCI:*(0:0:2:0) 8086:0046:103c:144a rev 2, Mem @ 0xc0000000/4194304, 0xb0000000/268435456, I/O @ 0x00005050/8
[    28.972] (--) PCI: (0:1:0:0) 1002:68e0:103c:144a rev 0, Mem @ 0xa0000000/268435456, 0xc4400000/131072, I/O @ 0x00004000/256, BIOS @ 0x????????/131072
[    28.972] (II) Open ACPI successful (/var/run/acpid.socket)
[    28.972] Initializing built-in extension Generic Event Extension
[    28.972] Initializing built-in extension SHAPE
[    28.972] Initializing built-in extension MIT-SHM
[    28.972] Initializing built-in extension XInputExtension
[    28.972] Initializing built-in extension XTEST
[    28.972] Initializing built-in extension BIG-REQUESTS
[    28.972] Initializing built-in extension SYNC
[    28.972] Initializing built-in extension XKEYBOARD
[    28.972] Initializing built-in extension XC-MISC
[    28.972] Initializing built-in extension SECURITY
[    28.972] Initializing built-in extension XINERAMA
[    28.972] Initializing built-in extension XFIXES
[    28.972] Initializing built-in extension RENDER
[    28.972] Initializing built-in extension RANDR
[    28.972] Initializing built-in extension COMPOSITE
[    28.972] Initializing built-in extension DAMAGE
[    28.972] Initializing built-in extension MIT-SCREEN-SAVER
[    28.972] Initializing built-in extension DOUBLE-BUFFER
[    28.972] Initializing built-in extension RECORD
[    28.973] Initializing built-in extension DPMS
[    28.974] Initializing built-in extension Present
[    28.975] Initializing built-in extension DRI3
[    28.976] Initializing built-in extension X-Resource
[    28.976] Initializing built-in extension XVideo
[    28.977] Initializing built-in extension XVideo-MotionCompensation
[    28.978] Initializing built-in extension XFree86-VidModeExtension
[    28.979] Initializing built-in extension XFree86-DGA
[    28.979] Initializing built-in extension XFree86-DRI
[    28.980] Initializing built-in extension DRI2
[    28.980] (II) "glx" will be loaded by default.
[    28.980] (II) LoadModule: "glx"
[    29.019] (II) Loading /usr/lib/xorg/modules/updates/extensions/libglx.so
[    29.034] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[    29.034] 	compiled for 6.9.0, module version = 1.0.0
[    29.036] Loading extension GLX
[    29.036] (II) LoadModule: "fglrx"
[    29.040] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
[    29.247] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[    29.247] 	compiled for 1.4.99.906, module version = 13.35.5
[    29.247] 	Module class: X.Org Video Driver
[    29.247] (II) Loading sub module "fglrxdrm"
[    29.247] (II) LoadModule: "fglrxdrm"
[    29.247] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[    29.407] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    29.407] 	compiled for 1.4.99.906, module version = 13.35.5
[    29.407] (II) AMD Proprietary Linux Driver Version Identifier:13.35.5
[    29.407] (II) AMD Proprietary Linux Driver Release Identifier: UNSUPPORTED-13.35.1005               
[    29.407] (II) AMD Proprietary Linux Driver Build Date: Mar 12 2014 10:32:23
[    29.407] (++) using VT number 1

[    29.408] (WW) Falling back to old probe method for fglrx
[    29.488] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[    29.490] ukiDynamicMajor: found major device number 250
[    29.490] ukiDynamicMajor: found major device number 250
[    29.490] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[    29.490] ukiOpenDevice: node name is /dev/ati/card0
[    29.490] ukiOpenDevice: open result is 10, (OK)
[    33.924] ukiOpenByBusid: ukiOpenMinor returns 10
[    33.925] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[    34.031] (--) Chipset Supported AMD Graphics Processor (0x68E0) found
[    34.031] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
[    34.031] (II) fglrx: intel VGA device detected, load intel driver.
[    34.031] (II) LoadModule: "intel"
[    34.045] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[    34.181] (II) Module intel: vendor="X.Org Foundation"
[    34.181] 	compiled for 1.15.0, module version = 2.99.911
[    34.181] 	Module class: X.Org Video Driver
[    34.181] 	ABI class: X.Org Video Driver, version 15.0
[    34.181] (WW) PowerXpress feature is not supported on A+I Mux platform. Please uninstall fglrx driver.
[    34.181] (EE) this is a Muxless PX A+I platform, we doesn't supported it
[    34.181] (EE) No devices detected.
[    34.181] (EE) 
Fatal server error:
[    34.181] (EE) no screens found(EE) 
[    34.181] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    34.181] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    34.181] (EE) 

last warning is quite suspicious: PowerXpress feature is not supported on A+I Mux platform. Please uninstall fglrx driver ==> what can I do? I had previously the intel driver installed but laptop was always running too hot under arch, as root cause seems to be the graphics card I decided to use catalyst.

best regards
Brice

Offline

#6408 2014-03-25 21:54:01

clfarron4
Member
From: London, UK
Registered: 2013-06-28
Posts: 2,147
Website

Re: The AMD/ATI Bar & Grill

bricem13 wrote:

intel/radeon laptop.

Just what card models do you have? The outputs of lspci | grep VGA and lspci | grep 3D will help if you don't know the exact models.


Claire is fine.
Problems? I have dysgraphia, so clear and concise please.
My public GPG key for package signing
My x86_64 package repository

Offline

#6409 2014-03-26 19:06:12

hippieben
Member
Registered: 2013-10-27
Posts: 194

Re: The AMD/ATI Bar & Grill

Every time I restart my system my tear free setting gets reset to disabled.  Any idea why this might be?  Didn't always do it.

EDIT:  This seems to have started after I switched to radeon, then back to catalyst.  It may have also started after updating to 14.3-1.

Last edited by hippieben (2014-03-27 02:44:28)

Offline

#6410 2014-03-26 19:30:47

bricem13
Member
Registered: 2011-02-02
Posts: 5

Re: The AMD/ATI Bar & Grill

here it is

[brice@TuxBox:~]$  lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470]
[brice@TuxBox:~]$  lspci | grep 3D
[brice@TuxBox:~]$ 

best regards

Offline

#6411 2014-03-26 20:44:55

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

BTW from catalyst-test-pxp:
Comment by vantu5z
X don't start with xf86-video-intel-2.99.911-1-x86_64.
with xf86-video-intel-2.99.910-1-x86_64 is ok.

Offline

#6412 2014-03-26 22:17:20

clfarron4
Member
From: London, UK
Registered: 2013-06-28
Posts: 2,147
Website

Re: The AMD/ATI Bar & Grill

bricem13 wrote:

here it is

[brice@TuxBox:~]$  lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470]
[brice@TuxBox:~]$  lspci | grep 3D
[brice@TuxBox:~]$ 

best regards

I think you'd be looking to use the Catalyst with PowerXpress instead of straight Catalyst


Claire is fine.
Problems? I have dysgraphia, so clear and concise please.
My public GPG key for package signing
My x86_64 package repository

Offline

#6413 2014-03-27 20:25:18

bricem13
Member
Registered: 2011-02-02
Posts: 5

Re: The AMD/ATI Bar & Grill

clfarron4 wrote:
bricem13 wrote:

here it is

[brice@TuxBox:~]$  lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470]
[brice@TuxBox:~]$  lspci | grep 3D
[brice@TuxBox:~]$ 

best regards

I think you'd be looking to use the Catalyst with PowerXpress instead of straight Catalyst

I installed catalyst-utils-pxp from the repo as indicated on the wiki. What make catalyst-total-pxp better?

Offline

#6414 2014-03-27 21:59:26

clfarron4
Member
From: London, UK
Registered: 2013-06-28
Posts: 2,147
Website

Re: The AMD/ATI Bar & Grill

bricem13 wrote:

I installed catalyst-utils-pxp from the repo as indicated on the wiki. What make catalyst-total-pxp better?

The link I quoted at you states

ArchWiki wrote:

PowerXpress technology allows switching notebooks with dual-graphic capability from integrated graphics (IGP) to discrete graphics either to increase battery life or to achieve better 3D rendering capabilities.

That is, it's designed to work with the Intel/Radeon setup in your laptop.


Claire is fine.
Problems? I have dysgraphia, so clear and concise please.
My public GPG key for package signing
My x86_64 package repository

Offline

#6415 2014-03-27 22:03:43

hippieben
Member
Registered: 2013-10-27
Posts: 194

Re: The AMD/ATI Bar & Grill

clfarron4 wrote:
bricem13 wrote:

I installed catalyst-utils-pxp from the repo as indicated on the wiki. What make catalyst-total-pxp better?

The link I quoted at you states

ArchWiki wrote:

PowerXpress technology allows switching notebooks with dual-graphic capability from integrated graphics (IGP) to discrete graphics either to increase battery life or to achieve better 3D rendering capabilities.

That is, it's designed to work with the Intel/Radeon setup in your laptop.

Wish I could get that working on Apple hardware

Offline

#6416 2014-03-27 22:07:20

clfarron4
Member
From: London, UK
Registered: 2013-06-28
Posts: 2,147
Website

Re: The AMD/ATI Bar & Grill

hippieben wrote:

Wish I could get that working on Apple hardware

Don't tell me Apple have done something weird with their setup?


Claire is fine.
Problems? I have dysgraphia, so clear and concise please.
My public GPG key for package signing
My x86_64 package repository

Offline

#6417 2014-03-27 22:12:44

hippieben
Member
Registered: 2013-10-27
Posts: 194

Re: The AMD/ATI Bar & Grill

clfarron4 wrote:
hippieben wrote:

Wish I could get that working on Apple hardware

Don't tell me Apple have done something weird with their setup?

ati card only accessible with BIOS boot and intel accessible only with EFI boot.  Some people have had success with some hackery, but I've never had luck any time I've tried.

Offline

#6418 2014-03-29 02:37:43

wmcinnis
Member
From: Houston, TX
Registered: 2011-08-31
Posts: 2

Re: The AMD/ATI Bar & Grill

So I have gotten pxp to work just fine, the main issue is that now when i move a window i have mad tearing, on my desktop with the only ati card i have a tearfree option in my settings with pxp i do not, is there a trick to this?

Offline

#6419 2014-03-30 22:42:57

hippieben
Member
Registered: 2013-10-27
Posts: 194

Re: The AMD/ATI Bar & Grill

wmcinnis wrote:

So I have gotten pxp to work just fine, the main issue is that now when i move a window i have mad tearing, on my desktop with the only ati card i have a tearfree option in my settings with pxp i do not, is there a trick to this?

What settings are you looking at?  Catalyst control center (should be under display settings)? You can also try enabling it through command line as stated in the wiki (https://wiki.archlinux.org/index.php/Ca … _Rendering). Finally, your DE software may have a tear free option in its own settings you may want to try.  Also, you can try toggling "wait for vertical refresh"

Offline

#6420 2014-03-31 20:54:03

clfarron4
Member
From: London, UK
Registered: 2013-06-28
Posts: 2,147
Website

Re: The AMD/ATI Bar & Grill

Oooh, it looks like catalyst-test can build modules for 3.14-mainline as provided in the [miffe] repository by miffe. I'm going to reboot and test it out and let you know how it runs for me.

EDIT: I would test it if it would boot. I'm not getting any useful messages and I can wait for 3.14 to hit [testing].

Last edited by clfarron4 (2014-03-31 21:04:05)


Claire is fine.
Problems? I have dysgraphia, so clear and concise please.
My public GPG key for package signing
My x86_64 package repository

Offline

#6421 2014-04-01 04:33:15

tjamir
Member
Registered: 2014-04-01
Posts: 3

Re: The AMD/ATI Bar & Grill

Hello everyone,

After two nights of work, I am not still able to make my Intel / 8970M work properly. So any help would be appreciated.

I followed all procedures for PowerXpress systems, including blacklisting radeon module.

This is my lscpi output:

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Neptune [Radeon HD 8970M]

These are the currently installed drivers:

catalyst-hook 14.3-1
catalyst-utils-pxp 14.3-1
lib32-catalyst-utils-pxp 14.3-1
intel-dri 10.1.0-4
xf86-video-intel 2.99.911-1
lib32-mesa 10.1.0-4
lib32-mesa-libgl 10.1.0-4
mesa 10.1.0-4
mesa-libgl 10.1.0-4

Here is my generated xorg.conf =

Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:0:0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

And finally here, the output I got in Xorg.0.log file:

(.....)
   109.200] (--) Chipset Supported AMD Graphics Processor (0x6801) found
[   109.201] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
[   109.201] (II) fglrx: intel VGA device detected, load intel driver.
[   109.201] (II) LoadModule: "intel"
[   109.202] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[   109.239] (II) Module intel: vendor="X.Org Foundation"
[   109.239] 	compiled for 1.15.0, module version = 2.99.911
[   109.239] 	Module class: X.Org Video Driver
[   109.239] 	ABI class: X.Org Video Driver, version 15.0
[   109.239] (II) fglrx(0): pEnt->device->identifier=0x2112160
[   109.243] (II) intel(1): pEnt->device->identifier=(nil)
[   109.243] (EE) Screen 1 deleted because of no matching config section.
[   109.243] (II) UnloadModule: "intel"
[   109.243] (II) fglrx(0): === [xdl_xs115_atiddxPreInit] === begin
[   109.243] (II) fglrx(0): PowerXpress: Discrete GPU is selected.
[   109.435] (II) fglrx(0): PowerXpress: Diagnostic output from /usr/lib64/fglrx/switchlibGL: Switch to AMD
(.....)
   109.689] (==) fglrx(0): hotplug detection: "enabled"
[   109.690] (EE) 
[   109.690] (EE) Backtrace:
[   109.697] (EE) 0: X (xorg_backtrace+0x48) [0x584ae8]
[   109.697] (EE) 1: X (0x400000+0x1887c9) [0x5887c9]
[   109.697] (EE) 2: /usr/lib/libpthread.so.0 (0x7fc323366000+0xf880) [0x7fc323375880]
[   109.697] (EE) 3: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7fc31ce25000+0x15c80) [0x7fc31ce3ac80]
[   109.697] (EE) 4: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7fc31ce25000+0x10d7e9) [0x7fc31cf327e9]
[   109.697] (EE) 5: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7fc31ce25000+0x10dd4d) [0x7fc31cf32d4d]
[   109.697] (EE) 6: /usr/lib/xorg/modules/drivers/fglrx_drv.so (xdl_xs115_atiddxPxScreenInit+0x72) [0x7fc31d87e502]
[   109.697] (EE) 7: /usr/lib/xorg/modules/drivers/fglrx_drv.so (xdl_xs115_atiddxScreenInit+0x1108) [0x7fc31d85add8]
[   109.697] (EE) 8: X (AddScreen+0x71) [0x435fa1]
[   109.697] (EE) 9: X (InitOutput+0x3df) [0x476cef]
[   109.697] (EE) 10: X (0x400000+0x3993b) [0x43993b]
[   109.697] (EE) 11: /usr/lib/libc.so.6 (__libc_start_main+0xf5) [0x7fc321fddb05]
[   109.697] (EE) 12: X (0x400000+0x250ce) [0x4250ce]
[   109.697] (EE) 
[   109.698] (EE) Segmentation fault at address 0x18
[   109.698] (EE) 
Fatal server error:
[   109.698] (EE) Caught signal 11 (Segmentation fault). Server aborting
[   109.698] (EE) 
[   109.698] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[   109.698] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   109.698] (EE) 

All I got is a black screen when I startx, any help is welcome.

Cheers,
T. Jamir

P.S: Sorry the long post, I tried to gather all information I could.

Last edited by tjamir (2014-04-01 04:35:22)

Offline

#6422 2014-04-01 07:19:06

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,299
Website

Re: The AMD/ATI Bar & Grill

clfarron4 wrote:

Oooh, it looks like catalyst-test can build modules for 3.14-mainline as provided in the [miffe] repository by miffe. I'm going to reboot and test it out and let you know how it runs for me.

EDIT: I would test it if it would boot. I'm not getting any useful messages and I can wait for 3.14 to hit [testing].

Last mainline I checked was 3.14 rc8, had no problems. I will be away from my pc for another 4 days and I'm unable to check 3.14 final, but it should work fine.
Edit: OT about 3.14 kernel, if you have problems with sound on intel/realtek add this line to your alsa/sound conf file from /etc/modprobe.d
options snd-hda-intel model=auto
OR:
options snd-hda-intel model=generic

tjamir wrote:

These are the currently installed drivers:

xf86-video-intel 2.99.911-1

You missed this post:

Vi0L0 wrote:

BTW from catalyst-test-pxp:
Comment by vantu5z
X don't start with xf86-video-intel-2.99.911-1-x86_64.
with xf86-video-intel-2.99.910-1-x86_64 is ok.

you can get xf86-video-intel-2.99.910-1 package from ARM, ie here:
i686: http://seblu.net/a/arm/2014/03/03/extra … pkg.tar.xz
x86_64: http://seblu.net/a/arm/2014/03/03/extra … pkg.tar.xz

BTW:

Vi0L0 wrote:

What a sad thing. I just found that clinfo isn't able to see my 290x, every opencl sample isn't able to use it... what a ... Soon I will wrote bug report.
Edit: btw there's no problem with hd 7850 in opencl case
Edit2: report is here: http://ati.cchtml.com/show_bug.cgi?id=1044

Fixed. Turned out that libOpenCL of amdapp-sdk 2.9 was causing the problem. It simply doesn't suport R9 290X. Removing sdk file from profile.d solved the clinfo problem. Removing /etc/OpenCL/vendors/amd.icd (iirc the path correctly) let me run sdk's samples.

Last edited by Vi0L0 (2014-04-01 07:43:17)

Offline

#6423 2014-04-01 14:43:36

tjamir
Member
Registered: 2014-04-01
Posts: 3

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:
Vi0L0 wrote:

BTW from catalyst-test-pxp:
Comment by vantu5z
X don't start with xf86-video-intel-2.99.911-1-x86_64.
with xf86-video-intel-2.99.910-1-x86_64 is ok.

you can get xf86-video-intel-2.99.910-1 package from ARM, ie here:
i686: http://seblu.net/a/arm/2014/03/03/extra … pkg.tar.xz
x86_64: http://seblu.net/a/arm/2014/03/03/extra … pkg.tar.xz

Thank you, man, that solved my problem!

Offline

#6424 2014-04-03 21:46:18

hippieben
Member
Registered: 2013-10-27
Posts: 194

Re: The AMD/ATI Bar & Grill

hippieben wrote:

Every time I restart my system my tear free setting gets reset to disabled.  Any idea why this might be?  Didn't always do it.

EDIT:  This seems to have started after I switched to radeon, then back to catalyst.  It may have also started after updating to 14.3-1.

Anybody? sad

Offline

#6425 2014-04-04 03:18:44

DarksideEE7
Member
From: Arkansas, United States
Registered: 2009-06-06
Posts: 356

Re: The AMD/ATI Bar & Grill

Does anyone know why I get an error when I try to get the temperatures and/or clocks of all my cards using aticonfig?  Command and output:

sudo aticonfig --odgt --adapter=all
[sudo] password for USER: 
ERROR - Get temperature failed for Adapter 0 - Supported device 67B0

Adapter 1 - Supported device 67B0
            Sensor 0: Temperature - 42.00 C
ERROR - Get temperature failed for Adapter 2 - Supported device 67B0

Offline

Board footer

Powered by FluxBB