You are not logged in.

#6926 2015-03-13 20:52:03

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,349
Website

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:
ChemBro wrote:

Catalyst, um, 15.04? The version for Ubuntu 15.04: http://archive.ubuntu.com/ubuntu/pool/r … rig.tar.gz

Gogogo, you can do it! :-D

Aaaaaaah!
Should be easy to convert ubuntu driver, but im afk and have lot of work these times, maybe I will be able to update on Friday, maybe on Sunday, dunno.
Please be patient :>

This ubuntu driver is nothing good, it does support xserver 1.17, but xv video output is broken as well as switching to tty terminal sad  it get back to work after switching to xserver 1.16, though.
Brrr...
Stil testing...
Edit: oh what the hell... I decided to update catalyst-test, im not so sure about [catalyst] repo, don't have time either way atm, but i really need to think about it, because not having tty terminal kinda sucks tongue...
Forgot to add - GDM still segfaults.

Last edited by Vi0L0 (2015-03-13 21:27:04)

Offline

#6927 2015-03-13 21:39:42

Xabre
Member
From: Serbia
Registered: 2009-03-19
Posts: 725

Re: The AMD/ATI Bar & Grill

Thanks for updating catalyst-test, makes it a lot easier for me to test it. Will report my experiences. Will have to tweak catalyst-test-pxp, but that should be a fairly easy task.

Offline

#6928 2015-03-13 21:59:42

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,349
Website

Re: The AMD/ATI Bar & Grill

catalyst-test also implements pxp functionality, it provides mesa-libgl (which is in fact a package of symlinks) on its own.

Last edited by Vi0L0 (2015-03-13 22:02:25)

Offline

#6929 2015-03-13 22:42:24

Xabre
Member
From: Serbia
Registered: 2009-03-19
Posts: 725

Re: The AMD/ATI Bar & Grill

Oh, thanks for the info, will remember that.

Anyhow, here are the results.

X.org 1.17 and 1.16:

...
[  1274.177] (EE) fglrx(0): failed to map MMIO register space!(EE) fglrx(0): MapMMIO failed
[  1274.177] (EE) fglrx(0): PreInitAdapter failed
[  1274.177] (EE) fglrx(0): PreInit failed
...

Xorg 1.15: works, no problems detected so far.

It's a PowerXpress laptop (HD4600+Radeon 8750M).

Am not even surprised.

Ok, tried again with Xorg 1.17 set to run in root mode and got a different error:

[   435.685] 
X.Org X Server 1.17.1
Release Date: 2015-02-10
[   435.687] X Protocol Version 11, Revision 0
[   435.688] Build Operating System: Linux 3.18.6-1-ARCH x86_64 
[   435.688] Current Operating System: Linux Megatherion 3.19.1-1-ck #1 SMP PREEMPT Sat Mar 7 10:46:26 EST 2015 x86_64
[   435.689] Kernel command line: initrd=\intel-ucode.img initrd=\initramfs-linux-ck.img root=/dev/sda2 rw quiet resume=/dev/sda5 elevator=bfq
[   435.690] Build Date: 22 February 2015  12:50:32PM
[   435.691]  
[   435.692] Current version of pixman: 0.32.6
[   435.693]     Before reporting problems, check [url]http://wiki.x.org[/url]
    to make sure that you have the latest version.
[   435.693] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   435.697] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Mar 14 00:10:36 2015
[   435.698] (==) Using config file: "/etc/X11/xorg.conf"
[   435.699] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   435.699] (==) ServerLayout "aticonfig Layout"
[   435.699] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[   435.699] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[   435.699] (**) |   |-->Device "aticonfig-Device[0]-0"
[   435.699] (==) Automatically adding devices
[   435.699] (==) Automatically enabling devices
[   435.699] (==) Automatically adding GPU devices
[   435.699] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/OTF/".
[   435.699]     Entry deleted from font path.
[   435.699]     (Run 'mkfontdir' on "/usr/share/fonts/OTF/").
[   435.699] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[   435.699]     Entry deleted from font path.
[   435.699]     (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[   435.699] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[   435.699]     Entry deleted from font path.
[   435.699]     (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[   435.699] (==) FontPath set to:
    /usr/share/fonts/misc/,
    /usr/share/fonts/TTF/,
    /usr/share/fonts/Type1/
[   435.699] (==) ModulePath set to "/usr/lib/xorg/modules"
[   435.699] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[   435.699] (II) Loader magic: 0x815d80
[   435.699] (II) Module ABI versions:
[   435.699]     X.Org ANSI C Emulation: 0.4
[   435.699]     X.Org Video Driver: 19.0
[   435.699]     X.Org XInput driver : 21.0
[   435.699]     X.Org Server Extension : 9.0
[   435.700] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c1
[   435.701] (II) xfree86: Adding drm device (/dev/dri/card0)
[   435.701] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 0
[   435.702] (--) PCI:*(0:0:2:0) 8086:0416:103c:1942 rev 6, Mem @ 0xb0000000/4194304, 0xa0000000/268435456, I/O @ 0x00005000/64
[   435.702] (--) PCI: (0:1:0:0) 1002:6600:103c:1947 rev 0, Mem @ 0x90000000/268435456, 0xb0900000/262144, I/O @ 0x00004000/256, BIOS @ 0x????????/131072
[   435.702] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   435.702] (II) "glx" will be loaded by default.
[   435.702] (II) LoadModule: "glx"
[   435.702] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   435.702] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[   435.702]     compiled for 6.9.0, module version = 1.0.0
[   435.702] (II) LoadModule: "fglrx"
[   435.702] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
[   435.721] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[   435.721]     compiled for 1.4.99.906, module version = 15.20.2
[   435.721]     Module class: X.Org Video Driver
[   435.721] (II) Loading sub module "fglrxdrm"
[   435.721] (II) LoadModule: "fglrxdrm"
[   435.721] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[   435.721] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[   435.721]     compiled for 1.4.99.906, module version = 15.20.2
[   435.721] (II) AMD Proprietary Linux Driver Version Identifier:15.20.2
[   435.721] (II) AMD Proprietary Linux Driver Release Identifier: UNSUPPORTED-15.20.1013               
[   435.721] (II) AMD Proprietary Linux Driver Build Date: Feb 27 2015 03:27:32
[   435.721] (++) using VT number 1

[   435.721] (--) controlling tty is VT number 1, auto-enabling KeepTty
[   435.721] (WW) Falling back to old probe method for fglrx
[   435.744] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[   435.745] ukiDynamicMajor: found major device number 250
[   435.745] ukiDynamicMajor: found major device number 250
[   435.745] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[   435.745] ukiOpenDevice: node name is /dev/ati/card0
[   435.745] ukiOpenDevice: open result is 11, (OK)
[   435.745] ukiOpenByBusid: ukiOpenMinor returns 11
[   435.745] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[   435.746] (--) Chipset Supported AMD Graphics Processor (0x6600) found
[   435.747] (II) fglrx: intel VGA device detected, load intel driver.
[   435.747] (II) LoadModule: "intel"
[   435.747] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[   435.747] (II) Module intel: vendor="X.Org Foundation"
[   435.747]     compiled for 1.17.1, module version = 2.99.917
[   435.747]     Module class: X.Org Video Driver
[   435.747]     ABI class: X.Org Video Driver, version 19.0
[   435.747] (II) fglrx(0): pEnt->device->identifier=0x226d800
[   435.747] (II) intel(1): pEnt->device->identifier=(nil)
[   435.747] (EE) Screen 1 deleted because of no matching config section.
[   435.747] (II) UnloadModule: "intel"
[   435.747] (II) fglrx(0): === [xdl_xs117_atiddxPreInit] === begin
[   435.747] (II) fglrx(0): FB driver is enabled
[   435.747] (II) fglrx(0): PowerXpress: Discrete GPU is selected.
[   435.918] (II) fglrx(0): PowerXpress: Diagnostic output from /usr/lib64/fglrx/switchlibGL:
Switch to AMD

[   438.172] (EE) fglrx(0): [drm] failed to set drm interface version: Permission denied [13].
[   438.172] (II) fglrx(0): [drm] Contents of '/sys/kernel/debug/dri/0/clients':
[   438.172] (II) fglrx(0): [drm]              command   pid dev master a   uid      magic
[   438.172] (II) fglrx(0): [drm]       systemd-logind   544   0   y    y     0          0
[   438.172] (II) fglrx(0): [drm]                 Xorg  2609   0   n    y     0          0
[   438.172] (EE) fglrx(0): Failed to become DRM master.
[   438.172] (WW) fglrx(0): Quitting screen -- PreInit PowerXpress failed.
[   438.172] (II) fglrx(0): === [xdl_xs117_atiddxPreInit] === end
[   438.172] (EE) 
[   438.172] (EE) Backtrace:
[   438.172] (EE) 0: /usr/lib/xorg-server/Xorg (OsLookupColor+0x119) [0x5949c9]
[   438.172] (EE) 1: /usr/lib/libc.so.6 (__restore_rt+0x0) [0x7f6a62a2553f]
[   438.172] (EE) 2: /usr/lib/xorg/modules/drivers/intel_drv.so (_init+0x49d0) [0x7f6a5e8245f0]
[   438.173] (EE) 3: /usr/lib/xorg/modules/drivers/intel_drv.so (ignore+0x4cc0) [0x7f6a5e93faf0]
[   438.174] (EE) 4: /usr/lib/xorg/modules/drivers/fglrx_drv.so (xdl_xs117_atiddxPxFreeScreen+0x2e) [0x7f6a5f4da44e]
[   438.176] (EE) 5: /usr/lib/xorg/modules/drivers/fglrx_drv.so (xdl_xs117_atiddxFreeScreen+0x64) [0x7f6a5f4b8924]
[   438.176] (EE) 6: /usr/lib/xorg-server/Xorg (xf86DeleteScreen+0x5a) [0x481e9a]
[   438.176] (EE) 7: /usr/lib/xorg-server/Xorg (InitOutput+0xaf7) [0x47b567]
[   438.177] (EE) 8: /usr/lib/xorg-server/Xorg (remove_fs_handlers+0x22a) [0x43c9da]
[   438.177] (EE) 9: /usr/lib/libc.so.6 (__libc_start_main+0xf0) [0x7f6a62a12800]
[   438.177] (EE) 10: /usr/lib/xorg-server/Xorg (_start+0x29) [0x427039]
[   438.178] (EE) 11: ? (?+0x29) [0x29]
[   438.178] (EE) 
[   438.178] (EE) Segmentation fault at address 0x20
[   438.178] (EE) 
Fatal server error:
[   438.178] (EE) Caught signal 11 (Segmentation fault). Server aborting
[   438.178] (EE) 
[   438.178] (EE) 
Please consult the The X.Org Foundation support 
     at [url]http://wiki.x.org[/url]
 for help. 
[   438.178] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   438.178] (EE) 
[   438.184] (EE) Server terminated with error (1). Closing log file.

Apparently this time it complains about permissions and segfaults.

Last edited by Xabre (2015-03-13 23:16:45)

Offline

#6930 2015-03-14 11:59:55

ChemBro
Member
Registered: 2008-10-22
Posts: 703

Re: The AMD/ATI Bar & Grill

https://manjaro.github.io/Update-2015-0 … stable%29/

Manjaro is shipping with the new beta driver from AMD... Bold move...

Edit: Tested Metro Last Light with Catalyst 15.3, at least that one works now.

Last edited by ChemBro (2015-03-15 13:42:45)

Offline

#6931 2015-03-25 15:33:56

herOldMan
Member
Registered: 2013-10-11
Posts: 110

Re: The AMD/ATI Bar & Grill

I am having a problem with the catalyst-hook package. In my case, this is a year-old, regularly updated machine that uses the legacy drivers. (catalyst-hd234k)

I am using the unofficial repository and not AUR. The error I see at pacman Syu is:
error: failed to prepare transaction (could not satisfy dependencies)
:: catalyst-hook: requires linux<3.19

Here are the relevant mirrors (I have also tried the other mirror choices in the wiki):
[xorg112]
Server = http://catalyst.wirephire.com/repo/xorg112/$arch
[catalyst-hd234k]
Server = http://catalyst.wirephire.com/repo/cata … 234k/$arch

The open-source driver is not an option (an hdmi artifact). My instinct is to be patient and allow the unofficial repository to catch up. Is this the right approach or should I begin exploring a work-around.

(My original post of this problem was accidently piggybacked on a related, solved post.)

Offline

#6932 2015-04-01 10:32:04

Elemento Cero
Member
From: Spain
Registered: 2011-12-09
Posts: 17

Re: The AMD/ATI Bar & Grill

It is safe to use Catalyst 14.12 with a dual-monitor setup now, via HDMI? It's been a long time since the blank screen problem was detected (almost 3 months), but I don't know if it was fixed already.

Offline

#6933 2015-04-01 12:03:20

ChemBro
Member
Registered: 2008-10-22
Posts: 703

Re: The AMD/ATI Bar & Grill

Elemento Cero wrote:

It is safe to use Catalyst 14.12 with a dual-monitor setup now, via HDMI? It's been a long time since the blank screen problem was detected (almost 3 months), but I don't know if it was fixed already.

Can't say, if it was fixed, because I use dual-monitor (with one monitor using HDMI) and never had a black screen. Or do both monitors need to be plugged via HDMI?

Offline

#6934 2015-04-01 15:40:12

Elemento Cero
Member
From: Spain
Registered: 2011-12-09
Posts: 17

Re: The AMD/ATI Bar & Grill

ChemBro wrote:
Elemento Cero wrote:

It is safe to use Catalyst 14.12 with a dual-monitor setup now, via HDMI? It's been a long time since the blank screen problem was detected (almost 3 months), but I don't know if it was fixed already.

Can't say, if it was fixed, because I use dual-monitor (with one monitor using HDMI) and never had a black screen. Or do both monitors need to be plugged via HDMI?

I have one monitor via DVI-HDMI and the other via HDMI-HDMI, with an ATI HD 7850. If I have both monitors plugged, they remain with the "No Signal" message (using Catalyst driver +14.12). Unplugging one serves as a temporary fix, but I need both monitors operational. Reverting to 14.9 solves the problem. I don't know why this is happening.

Offline

#6935 2015-04-01 21:08:42

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,349
Website

Re: The AMD/ATI Bar & Grill

herOldMan wrote:

I am having a problem with the catalyst-hook package. In my case, this is a year-old, regularly updated machine that uses the legacy drivers. (catalyst-hd234k)

I am using the unofficial repository and not AUR. The error I see at pacman Syu is:
error: failed to prepare transaction (could not satisfy dependencies)
:: catalyst-hook: requires linux<3.19

Here are the relevant mirrors (I have also tried the other mirror choices in the wiki):
[xorg112]
Server = http://catalyst.wirephire.com/repo/xorg112/$arch
[catalyst-hd234k]
Server = http://catalyst.wirephire.com/repo/cata … 234k/$arch

The open-source driver is not an option (an hdmi artifact). My instinct is to be patient and allow the unofficial repository to catch up. Is this the right approach or should I begin exploring a work-around.

(My original post of this problem was accidently piggybacked on a related, solved post.)

Sorry for the delay mate, been busy working also on weekends... Anyhow hd234k should be updated, it supports also 4.0 kernel.

Offline

#6936 2015-04-03 02:54:54

Wolf0
Member
Registered: 2013-01-29
Posts: 16

Re: The AMD/ATI Bar & Grill

I am loving Catalyst 15.3... it's like they're slowly removing the stupid from their OpenCL compiler, bit by bit!

Offline

#6937 2015-04-03 09:20:08

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,349
Website

Offline

#6938 2015-04-04 16:10:16

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 181

Re: The AMD/ATI Bar & Grill

I decided to try Catalyst 15.3, and to my surprise, it works on my laptop... until I upgraded. It does NOT work on my machine with xorg-server 1.17. I'm getting different errors than Xabre, so I'm going to post my Xorg.log.

[    55.287] 
X.Org X Server 1.17.1
Release Date: 2015-02-10
[    55.287] X Protocol Version 11, Revision 0
[    55.287] Build Operating System: Linux 3.18.6-1-ARCH x86_64 
[    55.287] Current Operating System: Linux mikearchlaptop 3.19.2-1-ARCH #1 SMP PREEMPT Wed Mar 18 16:21:02 CET 2015 x86_64
[    55.287] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=5abf4bb4-163e-40fa-bb0b-fb9f757d47e9 rw quiet
[    55.287] Build Date: 14 March 2015  06:45:50PM
[    55.287]  
[    55.287] Current version of pixman: 0.32.6
[    55.287] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    55.287] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    55.288] (==) Log file: "/home/mikearch/.local/share/xorg/Xorg.0.log", Time: Sat Apr  4 08:52:53 2015
[    55.288] (==) Using config file: "/etc/X11/xorg.conf"
[    55.288] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    55.289] (==) ServerLayout "aticonfig Layout"
[    55.289] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[    55.289] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[    55.289] (**) |   |-->Device "aticonfig-Device[0]-0"
[    55.289] (==) Automatically adding devices
[    55.289] (==) Automatically enabling devices
[    55.289] (==) Automatically adding GPU devices
[    55.289] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/OTF/".
[    55.289] 	Entry deleted from font path.
[    55.289] 	(Run 'mkfontdir' on "/usr/share/fonts/OTF/").
[    55.289] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    55.289] 	Entry deleted from font path.
[    55.289] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    55.289] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    55.289] 	Entry deleted from font path.
[    55.289] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    55.289] (==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/Type1/
[    55.289] (==) ModulePath set to "/usr/lib/xorg/modules"
[    55.289] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    55.289] (II) Loader magic: 0x815d80
[    55.289] (II) Module ABI versions:
[    55.289] 	X.Org ANSI C Emulation: 0.4
[    55.289] 	X.Org Video Driver: 19.0
[    55.289] 	X.Org XInput driver : 21.0
[    55.289] 	X.Org Server Extension : 9.0
[    55.293] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c1
[    55.294] (II) xfree86: Adding drm device (/dev/dri/card0)
[    55.295] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 0
[    55.297] (--) PCI:*(0:0:2:0) 8086:0116:1028:04ca rev 9, Mem @ 0xf6400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[    55.297] (--) PCI: (0:1:0:0) 1002:6760:1028:04ca rev 0, Mem @ 0xe0000000/268435456, 0xf7b20000/131072, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
[    55.297] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    55.297] (II) "glx" will be loaded by default.
[    55.297] (II) LoadModule: "glx"
[    55.298] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    55.298] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[    55.298] 	compiled for 6.9.0, module version = 1.0.0
[    55.298] (II) LoadModule: "fglrx"
[    55.299] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
[    55.335] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[    55.335] 	compiled for 1.4.99.906, module version = 15.20.2
[    55.335] 	Module class: X.Org Video Driver
[    55.336] (II) Loading sub module "fglrxdrm"
[    55.336] (II) LoadModule: "fglrxdrm"
[    55.336] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[    55.336] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    55.336] 	compiled for 1.4.99.906, module version = 15.20.2
[    55.336] (II) AMD Proprietary Linux Driver Version Identifier:15.20.2
[    55.336] (II) AMD Proprietary Linux Driver Release Identifier: UNSUPPORTED-15.20.1013               
[    55.336] (II) AMD Proprietary Linux Driver Build Date: Feb 27 2015 03:27:32
[    55.336] (++) using VT number 1

[    55.336] (--) controlling tty is VT number 1, auto-enabling KeepTty
[    55.336] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
[    55.336] (WW) Falling back to old probe method for fglrx
[    55.378] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[    55.378] (WW) LoadKernelModule: Setting of real/effective user Id to 0/0 failed[    55.381] ukiDynamicMajor: found major device number 250
[    55.381] ukiDynamicMajor: found major device number 250
[    55.381] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[    55.381] ukiOpenDevice: node name is /dev/ati/card0
[    55.381] ukiOpenDevice: open result is 9, (OK)
[    55.381] ukiOpenByBusid: ukiOpenMinor returns 9
[    55.381] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[    55.383] (--) Chipset Supported AMD Graphics Processor (0x6760) found
[    55.383] (II) fglrx(0): pEnt->device->identifier=0x1043820
[    55.383] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    55.383] (II) fglrx(0): === [xdl_xs117_atiddxPreInit] === begin
[    55.383] (II) fglrx(0): FB driver is not enabled
[    55.383] (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
[    55.383] (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[    55.383] (==) fglrx(0): Default visual is TrueColor
[    55.383] (**) fglrx(0): Option "DPMS" "true"
[    55.384] (==) fglrx(0): RGB weight 888
[    55.384] (II) fglrx(0): Using 8 bits per RGB 
[    55.384] (==) fglrx(0): Buffer Tiling is ON
[    55.384] (II) Loading sub module "fglrxdrm"
[    55.384] (II) LoadModule: "fglrxdrm"
[    55.384] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[    55.384] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    55.384] 	compiled for 1.4.99.906, module version = 15.20.2
[    55.384] (WW) LoadKernelModule: Setting of real/effective user Id to 0/0 failed[    55.387] ukiDynamicMajor: found major device number 250
[    55.387] ukiDynamicMajor: found major device number 250
[    55.387] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[    55.387] ukiOpenDevice: node name is /dev/ati/card0
[    55.387] ukiOpenDevice: open result is 10, (OK)
[    55.387] ukiOpenByBusid: ukiOpenMinor returns 10
[    55.387] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[    55.387] (EE) fglrx(0): The graphics processor is already set to console mode, set X mode fail. Cannot start X.
[    55.387] (EE) fglrx(0): PreInit failed
[    55.387] (II) fglrx(0): === [xdl_xs117_atiddxPreInit] === end
[    55.387] (II) UnloadModule: "fglrx"
[    55.387] (II) UnloadSubModule: "fglrxdrm"
[    55.387] (II) Unloading fglrxdrm
[    55.387] (II) UnloadSubModule: "fglrxdrm"
[    55.387] (EE) Screen(s) found, but none have a usable configuration.
[    55.387] (EE) 
Fatal server error:
[    55.387] (EE) no screens found(EE) 
[    55.387] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    55.387] (EE) Please also check the log file at "/home/mikearch/.local/share/xorg/Xorg.0.log" for additional information.
[    55.387] (EE) 
[    55.392] (EE) Server terminated with error (1). Closing log file.

Any help would be appreciated!

Offline

#6939 2015-04-04 16:22:54

desaparecido
Member
From: Liège, Belgium
Registered: 2010-03-14
Posts: 151

Re: The AMD/ATI Bar & Grill

horsemanoffaith wrote:

I decided to try Catalyst 15.3, and to my surprise, it works on my laptop... until I upgraded. It does NOT work on my machine with xorg-server 1.17. I'm getting different errors than Xabre, so I'm going to post my Xorg.log.

[    55.287] 
X.Org X Server 1.17.1
Release Date: 2015-02-10
[    55.287] X Protocol Version 11, Revision 0
[    55.287] Build Operating System: Linux 3.18.6-1-ARCH x86_64 
[    55.287] Current Operating System: Linux mikearchlaptop 3.19.2-1-ARCH #1 SMP PREEMPT Wed Mar 18 16:21:02 CET 2015 x86_64
[    55.287] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=5abf4bb4-163e-40fa-bb0b-fb9f757d47e9 rw quiet
[    55.287] Build Date: 14 March 2015  06:45:50PM
[    55.287]  
[    55.287] Current version of pixman: 0.32.6
[    55.287] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    55.287] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    55.288] (==) Log file: "/home/mikearch/.local/share/xorg/Xorg.0.log", Time: Sat Apr  4 08:52:53 2015
[    55.288] (==) Using config file: "/etc/X11/xorg.conf"
[    55.288] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    55.289] (==) ServerLayout "aticonfig Layout"
[    55.289] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[    55.289] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[    55.289] (**) |   |-->Device "aticonfig-Device[0]-0"
[    55.289] (==) Automatically adding devices
[    55.289] (==) Automatically enabling devices
[    55.289] (==) Automatically adding GPU devices
[    55.289] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/OTF/".
[    55.289] 	Entry deleted from font path.
[    55.289] 	(Run 'mkfontdir' on "/usr/share/fonts/OTF/").
[    55.289] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    55.289] 	Entry deleted from font path.
[    55.289] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    55.289] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    55.289] 	Entry deleted from font path.
[    55.289] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    55.289] (==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/Type1/
[    55.289] (==) ModulePath set to "/usr/lib/xorg/modules"
[    55.289] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    55.289] (II) Loader magic: 0x815d80
[    55.289] (II) Module ABI versions:
[    55.289] 	X.Org ANSI C Emulation: 0.4
[    55.289] 	X.Org Video Driver: 19.0
[    55.289] 	X.Org XInput driver : 21.0
[    55.289] 	X.Org Server Extension : 9.0
[    55.293] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c1
[    55.294] (II) xfree86: Adding drm device (/dev/dri/card0)
[    55.295] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 0
[    55.297] (--) PCI:*(0:0:2:0) 8086:0116:1028:04ca rev 9, Mem @ 0xf6400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[    55.297] (--) PCI: (0:1:0:0) 1002:6760:1028:04ca rev 0, Mem @ 0xe0000000/268435456, 0xf7b20000/131072, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
[    55.297] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    55.297] (II) "glx" will be loaded by default.
[    55.297] (II) LoadModule: "glx"
[    55.298] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    55.298] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[    55.298] 	compiled for 6.9.0, module version = 1.0.0
[    55.298] (II) LoadModule: "fglrx"
[    55.299] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
[    55.335] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[    55.335] 	compiled for 1.4.99.906, module version = 15.20.2
[    55.335] 	Module class: X.Org Video Driver
[    55.336] (II) Loading sub module "fglrxdrm"
[    55.336] (II) LoadModule: "fglrxdrm"
[    55.336] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[    55.336] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    55.336] 	compiled for 1.4.99.906, module version = 15.20.2
[    55.336] (II) AMD Proprietary Linux Driver Version Identifier:15.20.2
[    55.336] (II) AMD Proprietary Linux Driver Release Identifier: UNSUPPORTED-15.20.1013               
[    55.336] (II) AMD Proprietary Linux Driver Build Date: Feb 27 2015 03:27:32
[    55.336] (++) using VT number 1

[    55.336] (--) controlling tty is VT number 1, auto-enabling KeepTty
[    55.336] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
[    55.336] (WW) Falling back to old probe method for fglrx
[    55.378] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[    55.378] (WW) LoadKernelModule: Setting of real/effective user Id to 0/0 failed[    55.381] ukiDynamicMajor: found major device number 250
[    55.381] ukiDynamicMajor: found major device number 250
[    55.381] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[    55.381] ukiOpenDevice: node name is /dev/ati/card0
[    55.381] ukiOpenDevice: open result is 9, (OK)
[    55.381] ukiOpenByBusid: ukiOpenMinor returns 9
[    55.381] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[    55.383] (--) Chipset Supported AMD Graphics Processor (0x6760) found
[    55.383] (II) fglrx(0): pEnt->device->identifier=0x1043820
[    55.383] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    55.383] (II) fglrx(0): === [xdl_xs117_atiddxPreInit] === begin
[    55.383] (II) fglrx(0): FB driver is not enabled
[    55.383] (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
[    55.383] (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[    55.383] (==) fglrx(0): Default visual is TrueColor
[    55.383] (**) fglrx(0): Option "DPMS" "true"
[    55.384] (==) fglrx(0): RGB weight 888
[    55.384] (II) fglrx(0): Using 8 bits per RGB 
[    55.384] (==) fglrx(0): Buffer Tiling is ON
[    55.384] (II) Loading sub module "fglrxdrm"
[    55.384] (II) LoadModule: "fglrxdrm"
[    55.384] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[    55.384] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    55.384] 	compiled for 1.4.99.906, module version = 15.20.2
[    55.384] (WW) LoadKernelModule: Setting of real/effective user Id to 0/0 failed[    55.387] ukiDynamicMajor: found major device number 250
[    55.387] ukiDynamicMajor: found major device number 250
[    55.387] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[    55.387] ukiOpenDevice: node name is /dev/ati/card0
[    55.387] ukiOpenDevice: open result is 10, (OK)
[    55.387] ukiOpenByBusid: ukiOpenMinor returns 10
[    55.387] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[    55.387] (EE) fglrx(0): The graphics processor is already set to console mode, set X mode fail. Cannot start X.
[    55.387] (EE) fglrx(0): PreInit failed
[    55.387] (II) fglrx(0): === [xdl_xs117_atiddxPreInit] === end
[    55.387] (II) UnloadModule: "fglrx"
[    55.387] (II) UnloadSubModule: "fglrxdrm"
[    55.387] (II) Unloading fglrxdrm
[    55.387] (II) UnloadSubModule: "fglrxdrm"
[    55.387] (EE) Screen(s) found, but none have a usable configuration.
[    55.387] (EE) 
Fatal server error:
[    55.387] (EE) no screens found(EE) 
[    55.387] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    55.387] (EE) Please also check the log file at "/home/mikearch/.local/share/xorg/Xorg.0.log" for additional information.
[    55.387] (EE) 
[    55.392] (EE) Server terminated with error (1). Closing log file.

Any help would be appreciated!

Hi, I use HD 7970 and all works fine (VT sad saddly not) with xorg 1.17, but I don't know if is needed to re-build against xorg 1.17 ? did you tried ?


KF5 & Plasma5 (git versions) - Awesome WM
ASUS Sabertooth 990FX - AMD FX8350 - ATI Radeon HD 7970
[testing] repo

Offline

#6940 2015-04-04 16:37:56

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 181

Re: The AMD/ATI Bar & Grill

desaparecido wrote:
horsemanoffaith wrote:

I decided to try Catalyst 15.3, and to my surprise, it works on my laptop... until I upgraded. It does NOT work on my machine with xorg-server 1.17. I'm getting different errors than Xabre, so I'm going to post my Xorg.log.

[    55.287] 
X.Org X Server 1.17.1
Release Date: 2015-02-10
[    55.287] X Protocol Version 11, Revision 0
[    55.287] Build Operating System: Linux 3.18.6-1-ARCH x86_64 
[    55.287] Current Operating System: Linux mikearchlaptop 3.19.2-1-ARCH #1 SMP PREEMPT Wed Mar 18 16:21:02 CET 2015 x86_64
[    55.287] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=5abf4bb4-163e-40fa-bb0b-fb9f757d47e9 rw quiet
[    55.287] Build Date: 14 March 2015  06:45:50PM
[    55.287]  
[    55.287] Current version of pixman: 0.32.6
[    55.287] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    55.287] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    55.288] (==) Log file: "/home/mikearch/.local/share/xorg/Xorg.0.log", Time: Sat Apr  4 08:52:53 2015
[    55.288] (==) Using config file: "/etc/X11/xorg.conf"
[    55.288] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    55.289] (==) ServerLayout "aticonfig Layout"
[    55.289] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[    55.289] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[    55.289] (**) |   |-->Device "aticonfig-Device[0]-0"
[    55.289] (==) Automatically adding devices
[    55.289] (==) Automatically enabling devices
[    55.289] (==) Automatically adding GPU devices
[    55.289] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/OTF/".
[    55.289] 	Entry deleted from font path.
[    55.289] 	(Run 'mkfontdir' on "/usr/share/fonts/OTF/").
[    55.289] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    55.289] 	Entry deleted from font path.
[    55.289] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    55.289] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    55.289] 	Entry deleted from font path.
[    55.289] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    55.289] (==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/Type1/
[    55.289] (==) ModulePath set to "/usr/lib/xorg/modules"
[    55.289] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    55.289] (II) Loader magic: 0x815d80
[    55.289] (II) Module ABI versions:
[    55.289] 	X.Org ANSI C Emulation: 0.4
[    55.289] 	X.Org Video Driver: 19.0
[    55.289] 	X.Org XInput driver : 21.0
[    55.289] 	X.Org Server Extension : 9.0
[    55.293] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c1
[    55.294] (II) xfree86: Adding drm device (/dev/dri/card0)
[    55.295] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 0
[    55.297] (--) PCI:*(0:0:2:0) 8086:0116:1028:04ca rev 9, Mem @ 0xf6400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[    55.297] (--) PCI: (0:1:0:0) 1002:6760:1028:04ca rev 0, Mem @ 0xe0000000/268435456, 0xf7b20000/131072, I/O @ 0x0000e000/256, BIOS @ 0x????????/131072
[    55.297] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    55.297] (II) "glx" will be loaded by default.
[    55.297] (II) LoadModule: "glx"
[    55.298] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    55.298] (II) Module glx: vendor="Advanced Micro Devices, Inc."
[    55.298] 	compiled for 6.9.0, module version = 1.0.0
[    55.298] (II) LoadModule: "fglrx"
[    55.299] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
[    55.335] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
[    55.335] 	compiled for 1.4.99.906, module version = 15.20.2
[    55.335] 	Module class: X.Org Video Driver
[    55.336] (II) Loading sub module "fglrxdrm"
[    55.336] (II) LoadModule: "fglrxdrm"
[    55.336] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[    55.336] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    55.336] 	compiled for 1.4.99.906, module version = 15.20.2
[    55.336] (II) AMD Proprietary Linux Driver Version Identifier:15.20.2
[    55.336] (II) AMD Proprietary Linux Driver Release Identifier: UNSUPPORTED-15.20.1013               
[    55.336] (II) AMD Proprietary Linux Driver Build Date: Feb 27 2015 03:27:32
[    55.336] (++) using VT number 1

[    55.336] (--) controlling tty is VT number 1, auto-enabling KeepTty
[    55.336] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
[    55.336] (WW) Falling back to old probe method for fglrx
[    55.378] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
[    55.378] (WW) LoadKernelModule: Setting of real/effective user Id to 0/0 failed[    55.381] ukiDynamicMajor: found major device number 250
[    55.381] ukiDynamicMajor: found major device number 250
[    55.381] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[    55.381] ukiOpenDevice: node name is /dev/ati/card0
[    55.381] ukiOpenDevice: open result is 9, (OK)
[    55.381] ukiOpenByBusid: ukiOpenMinor returns 9
[    55.381] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[    55.383] (--) Chipset Supported AMD Graphics Processor (0x6760) found
[    55.383] (II) fglrx(0): pEnt->device->identifier=0x1043820
[    55.383] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[    55.383] (II) fglrx(0): === [xdl_xs117_atiddxPreInit] === begin
[    55.383] (II) fglrx(0): FB driver is not enabled
[    55.383] (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
[    55.383] (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[    55.383] (==) fglrx(0): Default visual is TrueColor
[    55.383] (**) fglrx(0): Option "DPMS" "true"
[    55.384] (==) fglrx(0): RGB weight 888
[    55.384] (II) fglrx(0): Using 8 bits per RGB 
[    55.384] (==) fglrx(0): Buffer Tiling is ON
[    55.384] (II) Loading sub module "fglrxdrm"
[    55.384] (II) LoadModule: "fglrxdrm"
[    55.384] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[    55.384] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
[    55.384] 	compiled for 1.4.99.906, module version = 15.20.2
[    55.384] (WW) LoadKernelModule: Setting of real/effective user Id to 0/0 failed[    55.387] ukiDynamicMajor: found major device number 250
[    55.387] ukiDynamicMajor: found major device number 250
[    55.387] ukiOpenByBusid: Searching for BusID PCI:1:0:0
[    55.387] ukiOpenDevice: node name is /dev/ati/card0
[    55.387] ukiOpenDevice: open result is 10, (OK)
[    55.387] ukiOpenByBusid: ukiOpenMinor returns 10
[    55.387] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
[    55.387] (EE) fglrx(0): The graphics processor is already set to console mode, set X mode fail. Cannot start X.
[    55.387] (EE) fglrx(0): PreInit failed
[    55.387] (II) fglrx(0): === [xdl_xs117_atiddxPreInit] === end
[    55.387] (II) UnloadModule: "fglrx"
[    55.387] (II) UnloadSubModule: "fglrxdrm"
[    55.387] (II) Unloading fglrxdrm
[    55.387] (II) UnloadSubModule: "fglrxdrm"
[    55.387] (EE) Screen(s) found, but none have a usable configuration.
[    55.387] (EE) 
Fatal server error:
[    55.387] (EE) no screens found(EE) 
[    55.387] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    55.387] (EE) Please also check the log file at "/home/mikearch/.local/share/xorg/Xorg.0.log" for additional information.
[    55.387] (EE) 
[    55.392] (EE) Server terminated with error (1). Closing log file.

Any help would be appreciated!

Hi, I use HD 7970 and all works fine (VT sad saddly not) with xorg 1.17, but I don't know if is needed to re-build against xorg 1.17 ? did you tried ?

I used yaourt and pulled Catalyst-test from the AUR. Keep in mind that I did NOT have xorg-server 1.17 on my machine because I'm using Catalyst-total-pxp and pacman won't let me upgrade to xorg-server 1.17 with that version. I will delete both versions, upgrade to xorg-server 1.17 and try pulling Catalyst-test from the AUR again.

Edit: didn't work. Still having the same trouble with xorg 1.17. I'm not sure how I would re-build it against xorg 1.17. How would I do so?

Last edited by horsemanoffaith (2015-04-04 16:55:05)

Offline

#6941 2015-04-04 23:22:09

desaparecido
Member
From: Liège, Belgium
Registered: 2010-03-14
Posts: 151

Re: The AMD/ATI Bar & Grill

horsemanoffaith wrote:

I used yaourt and pulled Catalyst-test from the AUR. Keep in mind that I did NOT have xorg-server 1.17 on my machine because I'm using Catalyst-total-pxp and pacman won't let me upgrade to xorg-server 1.17 with that version. I will delete both versions, upgrade to xorg-server 1.17 and try pulling Catalyst-test from the AUR again.

Edit: didn't work. Still having the same trouble with xorg 1.17. I'm not sure how I would re-build it against xorg 1.17. How would I do so?

usually is like you did to re-build it, with new xorg version, and then re-install catalyst-test (with yaourt or makepkg -si) .  I have "simple" card so "pxp" flavor ... I don't know about it hmm .  When I have problems like that I test usually with different kernels (LTS, stable and mainline), I don't know what other test you would try... sorry.

Last edited by desaparecido (2015-04-04 23:22:59)


KF5 & Plasma5 (git versions) - Awesome WM
ASUS Sabertooth 990FX - AMD FX8350 - ATI Radeon HD 7970
[testing] repo

Offline

#6942 2015-04-05 00:11:52

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 181

Re: The AMD/ATI Bar & Grill

desaparecido wrote:
horsemanoffaith wrote:

I used yaourt and pulled Catalyst-test from the AUR. Keep in mind that I did NOT have xorg-server 1.17 on my machine because I'm using Catalyst-total-pxp and pacman won't let me upgrade to xorg-server 1.17 with that version. I will delete both versions, upgrade to xorg-server 1.17 and try pulling Catalyst-test from the AUR again.

Edit: didn't work. Still having the same trouble with xorg 1.17. I'm not sure how I would re-build it against xorg 1.17. How would I do so?

usually is like you did to re-build it, with new xorg version, and then re-install catalyst-test (with yaourt or makepkg -si) .  I have "simple" card so "pxp" flavor ... I don't know about it hmm .  When I have problems like that I test usually with different kernels (LTS, stable and mainline), I don't know what other test you would try... sorry.

Thanks for letting me know... I guess I will just have to wait until 15.3 comes out via ATI. ATI takes FOREVER to update their drivers... Xorg has been at 1.17 for quite some time now. I'll just have to stay at 1.16 for the time being... it's working on 1.16.

Offline

#6943 2015-04-05 10:02:12

ChemBro
Member
Registered: 2008-10-22
Posts: 703

Re: The AMD/ATI Bar & Grill

horsemanoffaith wrote:
desaparecido wrote:
horsemanoffaith wrote:

I used yaourt and pulled Catalyst-test from the AUR. Keep in mind that I did NOT have xorg-server 1.17 on my machine because I'm using Catalyst-total-pxp and pacman won't let me upgrade to xorg-server 1.17 with that version. I will delete both versions, upgrade to xorg-server 1.17 and try pulling Catalyst-test from the AUR again.

Edit: didn't work. Still having the same trouble with xorg 1.17. I'm not sure how I would re-build it against xorg 1.17. How would I do so?

usually is like you did to re-build it, with new xorg version, and then re-install catalyst-test (with yaourt or makepkg -si) .  I have "simple" card so "pxp" flavor ... I don't know about it hmm .  When I have problems like that I test usually with different kernels (LTS, stable and mainline), I don't know what other test you would try... sorry.

Thanks for letting me know... I guess I will just have to wait until 15.3 comes out via ATI. ATI takes FOREVER to update their drivers... Xorg has been at 1.17 for quite some time now. I'll just have to stay at 1.16 for the time being... it's working on 1.16.

Of course ATI takes forever to update their drivers, because ATI does not exist anymore. Also the focus for AMD is the open-source driver. And yes, we all know, their closed-source driver is... not so great.

Offline

#6944 2015-04-05 21:33:12

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 181

Re: The AMD/ATI Bar & Grill

ChemBro wrote:
horsemanoffaith wrote:
desaparecido wrote:

usually is like you did to re-build it, with new xorg version, and then re-install catalyst-test (with yaourt or makepkg -si) .  I have "simple" card so "pxp" flavor ... I don't know about it hmm .  When I have problems like that I test usually with different kernels (LTS, stable and mainline), I don't know what other test you would try... sorry.

Thanks for letting me know... I guess I will just have to wait until 15.3 comes out via ATI. ATI takes FOREVER to update their drivers... Xorg has been at 1.17 for quite some time now. I'll just have to stay at 1.16 for the time being... it's working on 1.16.

Of course ATI takes forever to update their drivers, because ATI does not exist anymore. Also the focus for AMD is the open-source driver. And yes, we all know, their closed-source driver is... not so great.

Believe me, I know. I have a Dell laptop with hybrid graphics setup, and for a while I just had to use the Intel chip, because there was no way to successfully switch between the Intel chip and the AMD chip. I had to learn how to use vga_switcheroo just to turn off the discrete GPU, because if I didn't my gpu fan would run incessantly. (I did this on an Ubuntu system.) Ever since Steam for Linux came out, AMD's drivers have steadily improved, even though it's been slow. I have noticed a great improvement over the past couple of years- I am now able to run most of my games on my laptop, both Linux native and WINE games. The one that gave me the biggest amount of trouble was Bioshock- it was so bad it was virtually unplayable due to graphical issues and freezing. The last time I played it on my laptop, it seemed to work just fine. I haven't played it for a while, so I'm not sure if it still works. Using the 15.3 drivers yesterday with xorg-server 1.17, Half-life 2 had the same type of graphical glitches, so I downgraded to xorg-server 1.16 (still using the 15.3 drivers), and it works just fine. I know a lot of Arch users are anti-Ubuntu, but I'm thankful to the Ubuntu/Steam partnership and Steam's development of the SteamOS, because it's caused AMD to get off their collective duffs and try to develop better drivers for Linux.

nVidia does a great job on their Linux drivers. I have a nVidia card on my desktop, and I've had absolutely NO issues with it. I will certainly be paying attention to any future laptop purchases and staying away from any laptops with AMD cards in them... and if I can help it, I will NOT be buying a hybrid graphics setup, from ANY manufacturer!

Offline

#6945 2015-04-11 18:51:02

calle116
Member
Registered: 2015-02-03
Posts: 3

Re: The AMD/ATI Bar & Grill

Hey there,

please excuse my bad english, my german is much better.

i have a short question for better understanding the driver and the system.
i installed catalyst on my hp pavilion g6-2009sg from vi0l0s repo, works absolutely fine. no trouble, no errors. everything fine.

after the install, ich look at the drivers gui an found a point called: switchable graphics (in german: Umschaltbare Grafiken) where i can choose the ATI or the Intel GPU.

My core-question is: when i use the INTEL for desktop, does the pc switch automatic to ATI if i start a game or something else? or should i switch manual?

please give answer if anybody knows about my question.

have a nice evening!

calle

Offline

#6946 2015-04-11 20:11:43

Xabre
Member
From: Serbia
Registered: 2009-03-19
Posts: 725

Re: The AMD/ATI Bar & Grill

Brief answer: you need an appropriate driver that can use both cards. This thread focuses on AMD proprietary driver. Other solution is the free driver via PRIME.
Depending on luck and nerves, you may get one or the other to work.

EDIT: Ugh, sorry, I kinda didn't read that post well.

No, on Linux, it won't use discrete card automatically when you start some 3D game and such, switching is strictly manual.

Last edited by Xabre (2015-04-11 20:17:27)

Offline

#6947 2015-04-12 11:32:17

calle116
Member
Registered: 2015-02-03
Posts: 3

Re: The AMD/ATI Bar & Grill

Thank you Xabre for answer.

Both cards a running well. there is no problem.
my whish was only to safe energy in laptopmode by activate the intel for desktop.
and if i plugged on AC to use the ati for games or whatever....

i hope they'll find a solution. :-)

nice weekend and thank you

Offline

#6948 2015-04-13 18:57:40

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,349
Website

Re: The AMD/ATI Bar & Grill

There was no official catalyst 15.3 beta, and i don't see any signs of 15.4, and i had some "free"  time so I decided to update [catalyst] repo with fglrx prepared for ubuntu 15.04 - yes, the one with tty bug ;P...

It does support also 4.0 kernel so it should work fine with one that just landed in [testing] repo.

Because months ago I get some good feedback about pxp support of standard packages I decided to remove dedicated -pxp packages (-pxp should be replaced with catalyst-libgl automatically). I doubt that catalyst with initial xserver support will work fine with pxp hardware/switching anyhow (iirc it never happened), pxp users should rather check it with [xorg116] or [xorg115] repos.
Bad thing about pxp support of standard package is that its switching to fglrx after every catalyst-libgl package, so keep it in mind - post_install should remind you about this.

I also removed catalyst-daemon package as I doubt that anybody is using it now. But if there is such a person just let me know, i will re-up it.

Last edited by Vi0L0 (2015-04-13 18:59:26)

Offline

#6949 2015-04-14 09:05:11

calle116
Member
Registered: 2015-02-03
Posts: 3

Re: The AMD/ATI Bar & Grill

Little trouble after update: no screens found (unable to open display 0)

SOLVED by:

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.BAK
sudo pacman -S linux-headers
sudo catalyst_build_module
sudo aticonfig --adapter=ALL --initial

tested on HP G6-2009sg INTEL 4000HD/ATI Radeon M7670HD

greets calle

Last edited by calle116 (2015-04-14 09:05:52)

Offline

#6950 2015-04-15 18:21:08

Elemento Cero
Member
From: Spain
Registered: 2011-12-09
Posts: 17

Re: The AMD/ATI Bar & Grill

Today I updated to 15.3 and everything works surprisingly fine, for now. My problem with the dual-monitor setup and Catalyst 14.12 is gone... However, something in the updating process went amok (not sure if it was Catalyst or a random package of GNOME/KDE/Etc). Upon a reboot, I encountered an unbootable system and I had to chroot from the install CD; xorg.conf was plain empty, systemd couldn't load the proper fglrx module... Just a pleasure when everything fails and you have to invest a couple of hours trying to find the problem and a proper workaround. But, ey, that's the reason we are in Arch, right? wink.

Last edited by Elemento Cero (2015-04-15 18:22:44)

Offline

Board footer

Powered by FluxBB