You are not logged in.

#6976 2015-06-04 15:26:36

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,349
Website

Re: The AMD/ATI Bar & Grill

I've updated [catalyst-stable] repo and AUR's stable catalyst packages to fresh catalyst 15.5.
What's new in 15.5 i don't know... it's like freshened 14.12. It's doesn't even support xserver 1.17 sad
I've added initial support for 4.1 kernel (using kolasa's patch, tested on 4.1rc5) - this patch will soon also hit other packages/repos.
Rel notes is here: http://support.amd.com/en-us/kb-article … Notes.aspx
Chrome glitches when working on plasma are still here.

I've removed catalyst-daemon and -pxp specific packages also from [catalyst-stable] repo. Probably noone is using daemon, pxp functinality is served by regular catalyst-utils package.

Archive 14.12 repo is called [catalyst-stable-14.12].

I will leave [catalyst] repo and catalyt-test@AUR in ubuntu vivid catalyst version.

Repo has almost hit the space limit so I'm planning to remove catalyst repos and packages older than 14.6 (except hd234k ofcourse) within a week, lets say till 12 june. If someone is still using any of those archive repos - feel free to mail me, and I will leave it.


@Xacky
You don't have to install -pxp packages cuz regular catalyst packages are also serving pxp functinality. Most probably castalyst will need xf86-video-intel driver so you may leave it, if you will encounter problems with fresh xorg-server use archive [xorg116] repo (and xf86-video-intel from there, ie. add repo on top of pacman.conf's repo list and perform pacman -Syuu).
BTW: to install whole catalyst pack on x86_84 from the catalyst repo use:

pacman -S catalyst-hook catalyst-utils catalyst-libgl opencl-catalyst lib32-catalyst-utils lib32-catalyst-libgl lib32-opencl-catalyst

Last edited by Vi0L0 (2015-06-04 16:01:34)

Offline

#6977 2015-06-04 18:50:20

Xacky
Member
Registered: 2011-08-26
Posts: 26

Re: The AMD/ATI Bar & Grill

Dear vi0l0,

Thnx for your fast response. I'm still troubleshooting at this moment. After 13.1 there was a bug for many users that the backlight didn't work. I tried most stuf I found in this or other forums. Butt stil no luck for me.

Things I tried:
-Several kernel parameters non of them worked (have to find my file which exact but a lot).
-xrandr
-setpci
-If the service still fails to start, edit /usr/lib/systemd/system/atieventsd.service and change acpid.socket to acpid.service (from the wiki).
-aticonfig --acpi-services=off

Non of them seem to work do have any pointers, suggestions or things to search?

-Edit-
Important detail, external screens does work en laptop screen works but is really really dark but I can see lightDM login when I use a flashlight. So I know that fglrx drivers are working smile. Also before login everything is fine. When LightDM is starting backlight turns off.

Last edited by Xacky (2015-06-04 18:58:23)

Offline

#6978 2015-06-04 19:43:52

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,349
Website

Re: The AMD/ATI Bar & Grill

quick searching showed this: https://askubuntu.com/questions/459930/ … 0-is-there
Did you also checked acpi_backlight=legacy or acpi_backlight=vendor kernel options?
Also I understand that everything is fine when using intel or radeon?

Offline

#6979 2015-06-05 12:57:53

Xacky
Member
Registered: 2011-08-26
Posts: 26

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

quick searching showed this: https://askubuntu.com/questions/459930/ … 0-is-there
Did you also checked acpi_backlight=legacy or acpi_backlight=vendor kernel options?
Also I understand that everything is fine when using intel or radeon?

I did also found this website and tried all suggestions that were given there including the acpi_backlight=legaly, acpi_backlight_vendor I tried almost all kernel parameters I could find in simalar threads. None of them seems to work.

xf86-video-ati and xf86-video-intel work just fine butt are not suffisant for 3D-games.

I did found simalar trouble's for the 5470 in combination with fglrx in all distro's Ubuntu users are also complaining that after 13.1 backlight stops working.

Last edited by Xacky (2015-06-05 13:12:21)

Offline

#6980 2015-06-06 12:04:08

nous
Member
From: Across the Universe
Registered: 2006-08-18
Posts: 323
Website

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

I've updated [catalyst-stable] repo and AUR's stable catalyst packages to fresh catalyst 15.5.
What's new in 15.5 i don't know... it's like freshened 14.12. It's doesn't even support xserver 1.17 sad
I've added initial support for 4.1 kernel (using kolasa's patch, tested on 4.1rc5) - this patch will soon also hit other packages/repos.
Rel notes is here: http://support.amd.com/en-us/kb-article … Notes.aspx

The repo's database still points to 15.3 packages, perhaps you forgot to update catalyst.db?

[EDIT] And catalyst-stable points to 15.5 :-)

[EDIT 2] Upgrading to 15.5 (and downgrading xorg-server to 1.16) fixed hardware accelerated playback with mpv, which broke with xorg-server-1.17.

Last edited by nous (2015-06-06 16:58:38)

Offline

#6981 2015-06-07 04:58:17

Xanomead
Member
Registered: 2015-05-31
Posts: 29

Re: The AMD/ATI Bar & Grill

I have changed to the stable version to install 15.5, but amdcccle says that my "Driver Packaging Version" is 15.20, this doesn't seem correct to me, but pacman indicates that I have 15.5 installed. Could anyone who has installed 15.5 check which version is reported to them?

I previously had the ubuntu beta 15.2(?) installed.

Offline

#6982 2015-06-07 09:35:45

ChemBro
Member
Registered: 2008-10-22
Posts: 703

Re: The AMD/ATI Bar & Grill

Xanomead wrote:

I have changed to the stable version to install 15.5, but amdcccle says that my "Driver Packaging Version" is 15.20, this doesn't seem correct to me, but pacman indicates that I have 15.5 installed. Could anyone who has installed 15.5 check which version is reported to them?

I previously had the ubuntu beta 15.2(?) installed.

This is a known problem, I just forgot how to "fix" it.

Offline

#6983 2015-06-07 16:32:49

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,349
Website

Re: The AMD/ATI Bar & Grill

IIRC solution is to stop X, remove /etc/ati/amdpcsdb and start X again

Offline

#6984 2015-06-13 05:32:30

Xanomead
Member
Registered: 2015-05-31
Posts: 29

Re: The AMD/ATI Bar & Grill

I often get crashes if I leave my machine to idle, I suspect it's to do with fglrx.

I get an error message saying 'asic hang happened'.

The full crash log is here. http://pastebin.com/b8jwX9Mw

Any chance there is a known fix for this?

Offline

#6985 2015-06-13 06:13:26

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,349
Website

Re: The AMD/ATI Bar & Grill

wow, there's a lot posts about this problem on the net, looks like it's known problem. Quick search return no fixes except from one guy who found out that he's gpu is overheating and so lowered the voltage of he's gfx. Do you think that the heat could be an issue?

Offline

#6986 2015-06-13 07:46:50

Xanomead
Member
Registered: 2015-05-31
Posts: 29

Re: The AMD/ATI Bar & Grill

It seems unlikely to be a heat issue as this only happens when the system is idle and the screen turns off. If I set the power settings so the screen never turns off then I don't have the problem.

From what I could find it sounds like it's a hardware issue, but in Windows apparently the driver just resets itself and doesn't lock up the system, so I can't really take it back as the store would test it on a Windows machine and likely not find problems, unless a stress-test was likely to also trigger the problem forcing them to admit there is a hardware issue.

For me though my system locks up badly, I can't even ssh in and most of the sysrq keys don't work, the one to dump those error logs work but I can't even reboot with the sysrq keys.

Offline

#6987 2015-06-14 21:13:53

Xanomead
Member
Registered: 2015-05-31
Posts: 29

Re: The AMD/ATI Bar & Grill

Well a few days ago I tried pulling out my card and reseating it, so far I've been unable to get my machine to lock up.

I do notice that occasionally the backlight on my keyboard (set with xset led 3) turns off when my system goes idle, previously when that happened it was always a sign that my machine had hard locked, it doesn't seem to be doing that now. I did also install xf86-input-evdev which seems to have not been installed when I switched to the xorg 1.16 repo from previously using 1.17, but is seems unlikely that has been what fixed my problem.

Offline

#6988 2015-06-15 10:34:48

Xanomead
Member
Registered: 2015-05-31
Posts: 29

Re: The AMD/ATI Bar & Grill

Okay, so I haven't been able to get my machine to lock up, but I suspect that the driver is still crashing. If I let the screen sleep by going idle and then wake up, if I try to start a 3D application the frame-rate is severely crippled, and if I log out of my desktop session the screen will turn off and not come back on. I seemed to then be unable to switch to another tty and blindly log in and reboot. I can instead of logging out just choose to reboot which works fine.

But as my system seems to no longer be locking up it should be possible for me to start trouble shooting this, I'm just not sure where to start looking, any tips? Perhaps I should just do a clean install as I've changed and then reverted quite a few things.

Offline

#6989 2015-06-16 19:41:29

PhotonX
Member
From: Munich
Registered: 2008-08-10
Posts: 508

Re: The AMD/ATI Bar & Grill

I have a small problem, not sure if it is related to Catalyst: It appears on two machines (HD6410D and HD6770), both using Catalyst (catalyst-hook), Compiz and Cairo Dock. If Cairo Dock's OpenGL effects are switched on, it sometimes lags very strongly (e.g. doesn't move at all). The behaviour appears sporadically and isn't purposefully reproducible. Cairo Dock's output gives nothing related to graphics, unfortunately... I cannot tell exactly, when the problem started appearing, but I would guess it to be 1-3 months ago. Is there any way to diagnose the problem, any helpful logs or debug options? Thanks for any hints!

Last edited by PhotonX (2015-06-16 19:42:16)


Desktop: http://www.sysprofile.de/id15562, Arch Linux    |    Notebook: Thinkpad X200 Tablet, Manjaro

The very worst thing you can do with free software is to download it, see that it doesn't work for some reason, leave it, and tell your friends that it doesn't work.  -  Tuomas Lukka

Offline

#6990 2015-06-18 10:52:14

Tromzy
Member
Registered: 2015-02-15
Posts: 163

Re: The AMD/ATI Bar & Grill

Hi,

My laptop has an intel Core i7 with integrated GPU, and also an AMD graphics chip called "Topaz XT [Radeon R7 M260/M265]" in kinfocenter. I can't figure out how to make the AMD chip work. I tried the free radeon driver, and also catalyst-test from AUR, nothing worked. Is this chip even supported ? Is it planned to be ? Thanks for any answer.

Offline

#6991 2015-06-18 14:44:44

revberaldo
Member
From: Campinas, Brazil
Registered: 2009-09-18
Posts: 45
Website

Re: The AMD/ATI Bar & Grill

Tromzy wrote:

Hi,

My laptop has an intel Core i7 with integrated GPU, and also an AMD graphics chip called "Topaz XT [Radeon R7 M260/M265]" in kinfocenter. I can't figure out how to make the AMD chip work. I tried the free radeon driver, and also catalyst-test from AUR, nothing worked. Is this chip even supported ? Is it planned to be ? Thanks for any answer.

Hi Tromzy, I have the same configuration and I haven't been able to make it work properly. I tried every combination of driver version and X server version etc. and nothing worked. I can actually start X with the proprietary drivers, but the performance is terrible and quite glitchy. I tried running Dota, for instance, which ran very nicely under Windows, but it just wasn't playable. I guess we're out of luck sad

What laptop do you have? Mine is a Dell Inspirion 15 5547.

Offline

#6992 2015-06-18 16:03:31

Tromzy
Member
Registered: 2015-02-15
Posts: 163

Re: The AMD/ATI Bar & Grill

Thank you for your answer. I guess our best bet is just to wait for a proper free driver now...

Offline

#6993 2015-06-18 19:02:35

revberaldo
Member
From: Campinas, Brazil
Registered: 2009-09-18
Posts: 45
Website

Re: The AMD/ATI Bar & Grill

@Tromzy No problem. In fact, every post that I see where the AMD cards actually work are about desktop computers. I think AMD doesn't support their mobile chips very well on Linux.

Offline

#6994 2015-06-22 04:33:59

HanFox
Member
Registered: 2015-06-09
Posts: 9

Re: The AMD/ATI Bar & Grill

For some reason my Memory clock won't automatically adjust as needed for 3D applications. The Core clock quite happily jumps around, but the Memory is stuck at 150MHz.

I have an R9 290X and have installed xorg116 and from catalyst-stable: catalyst-hook catalyst-utils catalyst-libgl opencl-catalyst lib32-catalyst-utils lib32-catalyst-libgl lib32-opencl-catalyst

If I manually force the clock to be 1350, which is its intended peak, it will change.

Obviously I don't really want to have to have the clock constantly set at peak.

My xorg.conf (I don't really know what else to provide):

Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Monitor"
	Identifier   "0-DFP7"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
	Option	    "PreferredMode" "1920x1200"
	Option	    "TargetRefresh" "60"
	Option	    "Position" "0 0"
	Option	    "Rotate" "normal"
	Option	    "Disable" "false"
	Option	    "Primary" "true"
EndSection

Section "Monitor"
	Identifier   "0-DFP5"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
	Option	    "PreferredMode" "1280x1024"
	Option	    "TargetRefresh" "75"
	Option	    "Position" "1920 176"
	Option	    "Rotate" "normal"
	Option	    "Disable" "false"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	Option	    "Monitor-DFP7" "0-DFP7"
	Option	    "Monitor-DFP5" "0-DFP5"
	BusID       "PCI:1:0:0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Last edited by HanFox (2015-06-22 07:07:17)

Offline

#6995 2015-06-23 14:15:53

parazyd
Member
From: Amsterdam
Registered: 2012-10-14
Posts: 259
Website

Re: The AMD/ATI Bar & Grill

revberaldo wrote:

@Tromzy No problem. In fact, every post that I see where the AMD cards actually work are about desktop computers. I think AMD doesn't support their mobile chips very well on Linux.


The APU in my laptop works quite nicely smile
With Vi0L0's Catalyst.

Last edited by parazyd (2015-06-23 14:16:19)

Offline

#6996 2015-06-28 20:17:43

Holzhaus
Member
Registered: 2013-10-25
Posts: 11

Re: The AMD/ATI Bar & Grill

Anyone knows when the next catalyst version will be released?

I'm asking, because it looks like that will finally fix the "White/Missing Textures" bug in Bioshock Infinite.

Thanks for reporting this issue

we have fixed this issue in latest Staging Drivers, Next Catalyst will have this fix.

-- Source: http://ati.cchtml.com/show_bug.cgi?id=1158#c3

Offline

#6997 2015-07-05 09:05:05

ms
Member
From: Bandung, Indonesia
Registered: 2010-07-28
Posts: 74
Website

Re: The AMD/ATI Bar & Grill

@all: I run Catalyst driver from Vi0L0 catalyst repository with Xorg server 1.17.

ms 0 % pacman -Qs xorg-server
local/xorg-server 1.17.2-2 (xorg)
    Xorg X server
local/xorg-server-common 1.17.2-2
    Xorg server common files

ms 0 % pacman -Qs catalyst   
local/amdtfset-git v1.0-1
    Small command-line utility to set and query the tear free desktop option present in the AMD Catalyst. Uses AMD ADL
local/catalyst-hook 15.3-2
    AMD/ATI drivers for Ubuntu 15.04, AMD's version is 15.200. Auto re-compile fglrx module while shutdown/reboot.
local/catalyst-libgl 15.3-1
    AMD/ATI drivers for Ubuntu 15.04, AMD's version is 15.200. Catalyst drivers libraries symlinks + experimental powerXpress support.
local/catalyst-utils 15.3-1
    AMD/ATI drivers for Ubuntu 15.04, AMD's version is 15.200. Utilities and libraries. Radeons HD 2 3 4 xxx ARE NOT SUPPORTED
local/opencl-catalyst 15.3-1
    AMD/ATI drivers for Ubuntu 15.04, AMD's version is 15.200. OpenCL implemention for AMD Catalyst

Why did catalyst package in AUR said it can't build without Xorg server 1.17? Is it compilation error or else?

Offline

#6998 2015-07-07 17:56:03

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,349
Website

Re: The AMD/ATI Bar & Grill

[catalyst] repo serves testing catalyst packages, just like catalyst-test@AUR, which atm is ubuntu catalyst versioned as 15.3 because it was released in march (borrowed from ubuntu 15.4) which does support xorg-server 1.17
[catalyst-stable] serves stable packages, just like catalyst-utils@AUR, atm catalyst 15.5, which in fact doesn't support xorg-server 1.17

Offline

#6999 2015-07-08 19:50:12

babel
Member
From: Mexico City
Registered: 2012-05-21
Posts: 47
Website

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

[catalyst] repo serves testing catalyst packages, just like catalyst-test@AUR, which atm is ubuntu catalyst versioned as 15.3 because it was released in march (borrowed from ubuntu 15.4) which does support xorg-server 1.17
[catalyst-stable] serves stable packages, just like catalyst-utils@AUR, atm catalyst 15.5, which in fact doesn't support xorg-server 1.17

Hello to everyonw. Vi0L0, thank you for doing the work amd should be doing XD.
Just like @ms, I use Catalyst with xorg-server 1.17 and everything worked fine until the last update (I think it was xorg-server 1.17.2.-2). Right now I have a working lightDM screen but when I login I just see the mouse cursor moving around in a black screen. The worst part is that if I click ctrl+alt+2, 3 or whatever to use a terminal without a graphical environment I don't see a damn think either! So I can't do anything because I don't know what I'm typing.

I'm sure the terminal is there because I've managed to login, update, and reboot like a blind guy, but I can't uninstall nor downgrade anything because I don't know what the terminal will tell me. Does anyone have a thought? I can wait patiently for a xorg-server update, wait even more for a catalyst update, or just regret my whole life for buying an AMD card and install arch all over again and use the open source drivers.

Thank you.

Offline

#7000 2015-07-08 19:58:26

Holzhaus
Member
Registered: 2013-10-25
Posts: 11

Re: The AMD/ATI Bar & Grill

The new Catalyst 15.7 drivers have been released!

Linux x86: http://support.amd.com/en-us/download/d … =Linux+x86
Ubuntu x86 32 Bit: http://support.amd.com/en-us/download/d … ntu+x86+32
Ubuntu x86 64 Bit: http://support.amd.com/en-us/download/d … ntu+x86+64

New Features:
AMD PowerXpress support for laptops equipped with Intel 6th generation (Skylake) CPUs
Linux Platform Atomics & SVM Fine Grain Buffer support for Carrizo APUs
Multi-Device support for OpenCL 2.0

Vi0L0, can you update your repo?

Offline

Board footer

Powered by FluxBB