You are not logged in.

#7101 2015-09-21 10:42:46

aslmaswd
Member
Registered: 2014-07-01
Posts: 4

Re: The AMD/ATI Bar & Grill

Please update atieventsd.service

[Unit]
Description=Catalyst event Daemon
Requires=acpid.socket

[Service]
ExecStart=/usr/bin/atieventsd --nodaemon

[Install]
WantedBy=multi-user.target

acpid.socket should be acpid.service

And script /etc/acpi/ati-powermode.sh is buggy

line 30:

grep -q off-line /proc/acpi/ac_adapter/*/state 

It doesn't work since /proc/acpi interface is deprecated.

Offline

#7102 2015-09-21 18:23:16

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,349
Website

Re: The AMD/ATI Bar & Grill

Yep, you are right. ati-powermode.sh is even more buggy, it needs to be rewritten. I will try to do this in free time and update when it's all finished.

Offline

#7103 2015-09-21 20:52:30

bouloumag
Member
Registered: 2009-12-24
Posts: 8

Re: The AMD/ATI Bar & Grill

@Vi0L0:

Thank you for your very good work.
Does Catalyst now support xorg-server 1.17 or we still need to use the xorg116 repository ?

Offline

#7104 2015-09-21 21:00:39

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,349
Website

Re: The AMD/ATI Bar & Grill

catalyst-test@AUR and packages from [catalyst] and [catalyst-stable] repos do support xorg-server 1.17

Offline

#7105 2015-09-24 16:26:06

an0nymity
Member
Registered: 2015-09-24
Posts: 14

Re: The AMD/ATI Bar & Grill

Vi0L0, maybe you might have an idea of what I am having issues with lighting up/detecting my heads:

https://bbs.archlinux.org/viewtopic.php?id=202846

Offline

#7106 2015-09-26 09:38:18

ChemBro
Member
Registered: 2008-10-22
Posts: 703

Re: The AMD/ATI Bar & Grill

So first of all, Vi0L0, I want to thank you for your hard work (I guess again, but last time should be year(s) ago). Your repo did help a lot. Though now that the radeonsi driver and Mesa 11 are good enough to play even AAA games, I will switch to the open-source side indefinitely. I also made a video so you (meaning all of you) can see how games perform with my setup.

https://www.youtube.com/watch?v=FLesgKSatQ4

Again thank you.

Offline

#7107 2015-09-26 10:26:46

Ambrevar
Member
Registered: 2011-08-14
Posts: 212
Website

Re: The AMD/ATI Bar & Grill

@ChemBro: great video! I am amazed by the radeonsi performance increase made in the last few years.
Brütal Legend looks much more like 60 fps though. What did you use to measure fps?

I tested a GeForce 960 last July: Metro Last Light did not look great, but performance was good, Unigine was buggy (tesselation missing), Wine performance was catastrophic (could not run smoothly anything past 2003-2004 games). That was way below what could be expected from such a graphic card, the nvidia blob is not supposed to be that bad. Not sure what happened, I might have got an outsider card sad

I'm curious about the evolution of the radeonsi driver, I can't wait to try it out!

In any case, it's fantastic news for the computer graphics world to finally have powerful open-source 3D drivers! Not forgetting it alleviates part of the burden of incompatible hardware.

Offline

#7108 2015-09-26 11:36:43

ChemBro
Member
Registered: 2008-10-22
Posts: 703

Re: The AMD/ATI Bar & Grill

Steam has a fps-counter in the "Steam Overlay". And yes, Brütal Legend does look smooth, but 60 fps is just a little bit smoother. :-)

Offline

#7109 2015-09-28 07:34:07

headkase
Member
Registered: 2011-12-06
Posts: 1,873

Re: The AMD/ATI Bar & Grill

Hey,

I'm new to using the proprietary AMD driver so I don't know how the update cycle works yet.  I just synced pacman's databases and Linux 4.2 was noted.  As Catalyst-Hook depends on Linux < 4.2 I am unable to upgrade, satisfy dependencies.  Does it take long for Hook to be updated?  Now that I've synced pacman's databases I can't install any new software until I complete the upgrade - partial upgrades are not supported.

Offline

#7110 2015-09-28 12:44:59

ChemBro
Member
Registered: 2008-10-22
Posts: 703

Re: The AMD/ATI Bar & Grill

You have to wait until Catalyst supports Kernel 4.2 (atm they only support -officially- up to 3.19). And because they don't even support 4.0 (officially), which was released 5 month ago...

And yes, you can update your system. That's what pacman.conf is for. And partial upgrades are supported. Look it up on the wiki page.

Offline

#7111 2015-09-28 18:05:20

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,349
Website

Re: The AMD/ATI Bar & Grill

ChemBro it was always good to have you here but I understand your decision and I support it :>. Especially now when we are out of the mainline kernel xD!
I was always trying to promote oss drivers, using it for years etc. As for now I'm jumping between catalyst and oss mainly because performance (and bags/glitches) of radeonsi on 290x is not stable, sometimes -git is great, sometimes not that much.

Hope you will visit us sometimes, not to install catalyst lol, but to say hi or something ;-)

Last edited by Vi0L0 (2015-09-28 20:00:35)

Offline

#7112 2015-09-28 22:57:55

headkase
Member
Registered: 2011-12-06
Posts: 1,873

Re: The AMD/ATI Bar & Grill

Ok, have to wait for kernel support and X.Org support with 15.9 only goes up to server 1.17.x

So, I did this in pacman.conf:

IgnorePkg   = linux linux-headers
IgnoreGroup = xorg-server xorg-server-utils xorg-apps

Is that what I should do?

Also, I do require the proprietary driver.  I switched to xf86-video-ati this morning and this evening I bought SOMA off of Steam.  SOMA just isn't working with xf86-video-ati so I reinstalled Catalyst and it now works perfect.

Last edited by headkase (2015-09-28 22:59:00)

Offline

#7113 2015-09-28 23:49:45

Palmitoxico
Member
From: Brazil
Registered: 2015-09-24
Posts: 14

Re: The AMD/ATI Bar & Grill

headkase wrote:

Also, I do require the proprietary driver.  I switched to xf86-video-ati this morning and this evening I bought SOMA off of Steam.  SOMA just isn't working with xf86-video-ati so I reinstalled Catalyst and it now works perfect.

What's the error message? I really want to buy this game, but I'll not change from radeonsi to Catalyst.

Offline

#7114 2015-09-28 23:55:04

headkase
Member
Registered: 2011-12-06
Posts: 1,873

Re: The AMD/ATI Bar & Grill

Palmitoxico wrote:

What's the error message? I really want to buy this game, but I'll not change from radeonsi to Catalyst.

Your luck might be better with RadeonSI.  I'm plain old Radeon, a 6870 1GB, the generation just before Southern Islands.  With xf86-video-ati the program didn't crash or produce a segfault or anything.  The 2D menus in the game worked perfect but the instant you entered the 3D game parts the rendering was so screwed that you couldn't make anything out.  Because I'm not Southern Islands my OpenGL version with xf86-video-ati is 3.3.  Since you are Southern Islands you should be sitting at 4.1.  So, I'd try it.  You have nothing to lose.  And SOMA is an awesome game from what I've played so far. wink

Edit: Well, you have $30 to lose but as I read on the Frictional Forums: Amnesia didn't work either with xf86-video-ati when it first came out.  But eventually xf86-video-ati improved enough that Amnesia now works fine with it.  So if you buy it now and it doesn't work it likely will eventually work as the driver matures.

Last edited by headkase (2015-09-28 23:58:44)

Offline

#7115 2015-09-29 00:04:07

Palmitoxico
Member
From: Brazil
Registered: 2015-09-24
Posts: 14

Re: The AMD/ATI Bar & Grill

headkase wrote:

Your luck might be better with RadeonSI.  I'm plain old Radeon, a 6870 1GB, the generation just before Southern Islands.  With xf86-video-ati the program didn't crash or produce a segfault or anything.  The 2D menus in the game worked perfect but the instant you entered the 3D game parts the rendering was so screwed that you couldn't make anything out.  Because I'm not Southern Islands my OpenGL version with xf86-video-ati is 3.3.  Since you are Southern Islands you should be sitting at 4.1.  So, I'd try it.  You have nothing to lose.  And SOMA is an awesome game from what I've played so far. wink

Ha! I meant xf86-video-ati by radeonsi (sorry for the typo). I have a HD6850 1GB sad

I use gnome-shell and last 2 times I've tried to install Catalyst it fucked my system soo badly... And Catalyst doesn't support KMS.

Offline

#7116 2015-09-29 00:08:45

headkase
Member
Registered: 2011-12-06
Posts: 1,873

Re: The AMD/ATI Bar & Grill

Palmitoxico wrote:

Ha! I meant xf86-video-ati by radeonsi (sorry for the typo). I have a HD6850 1GB sad

I use gnome-shell and last 2 times I've tried to install Catalyst it fucked my system soo badly... And Catalyst doesn't support KMS.

Well if you have a 6850 you'd likely be in the same boat as my 6870.  sad  Sorry man, did you at least see my edit about eventual support being likely?

Offline

#7117 2015-09-29 00:19:39

Palmitoxico
Member
From: Brazil
Registered: 2015-09-24
Posts: 14

Re: The AMD/ATI Bar & Grill

headkase wrote:

Well if you have a 6850 you'd likely be in the same boat as my 6870.  sad  Sorry man, did you at least see my edit about eventual support being likely?

I didn't, where is it?

Offline

#7118 2015-09-29 00:22:44

headkase
Member
Registered: 2011-12-06
Posts: 1,873

Re: The AMD/ATI Bar & Grill

Palmitoxico wrote:

I didn't, where is it?

A few posts up, I edited my post.  I'm referencing: This post on the Frictional Forums too, the author is a Frictional employee.

Offline

#7119 2015-09-29 01:38:08

Palmitoxico
Member
From: Brazil
Registered: 2015-09-24
Posts: 14

Re: The AMD/ATI Bar & Grill

headkase wrote:

A few posts up, I edited my post.  I'm referencing: This post on the Frictional Forums too, the author is a Frictional employee.

Well, I think I'll buy, wait, it costs 56,00 BRL here in Brazil, 1$ = 4 BRL so 56/4 = 15,80$ yeah!

Offline

#7120 2015-09-29 13:37:13

headkase
Member
Registered: 2011-12-06
Posts: 1,873

Re: The AMD/ATI Bar & Grill

headkase wrote:

So, I did this in pacman.conf:

IgnorePkg   = linux linux-headers
IgnoreGroup = xorg-server xorg-server-utils xorg-apps

Is that what I should do?

First of all, a proper thank you Vi0L0 for providing the repo.  Is what I did above correct?  Should I install linux-lts and use the custom kernel building as described in the wiki?  I'm pretty sure that I can't hold back these packages indefinitely so I'm seeking some advice here.

Offline

#7121 2015-09-29 17:44:16

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,349
Website

Re: The AMD/ATI Bar & Grill

catalyst won't let you update xorg-server so you don't need to add it to ignore, maybe there will be some update in 1.17 line and then you will miss it with this ignore entry. I will create [xorg117] repo when time for this will come so you could add it to repos.

ATM i'm modifying packages and removing linux dependency from them (and adding linux-lts), so you won't have to ignore linux package also. In fact if you switched to linux-lts and its booting correctly you can remove linux and its headers completelly (or you can leave it, after catalyst update it should not bother you again)



Edit: @all be aware that I'm gonna remove linux from dependency array and so it will let linux to update (while it's not supported tongue), if you will not configure bootloader to use kernel older than 4.2, like linux-lts, it will probably boot linux and you will probably gonna see a freeze or blank screen. System should work though, you can ssh to it and config bootloader from here, or use single mode if you can't ssh, or well there's possibility that linux-lts was added before, boot it and config as default kernel to boot.

Last edited by Vi0L0 (2015-09-29 18:54:23)

Offline

#7122 2015-09-29 21:23:55

headkase
Member
Registered: 2011-12-06
Posts: 1,873

Re: The AMD/ATI Bar & Grill

Thank you Vi0L0, on the LTS kernel now and once you get the Xorg 117 repo going will do that too.  Thank you very much for your effort.

Offline

#7123 2015-10-01 01:16:47

Palmitoxico
Member
From: Brazil
Registered: 2015-09-24
Posts: 14

Re: The AMD/ATI Bar & Grill

Well, I've downloaded SOMA and tried with the open source AMD drivers (HD6850), everything works ok until the 3D stuff. Here some screenshots:

SOMA3.jpg
SOMA1.jpg
SOMA2.jpg

I'll wait until they fix that, in the worst case I'll make a dual boot with some ubuntu derivative and install the crappy Catalyst.

Offline

#7124 2015-10-01 03:09:51

turtlepleasure
Member
Registered: 2015-10-01
Posts: 5

Re: The AMD/ATI Bar & Grill

I upgraded catalyst to 15.9 (conveniently I use linux-lts anyway). Then tried upgrading to xorg-server 1.17 from 1.16 and got a bunch of messages like this:

:: xorg-server and xf86-video-ast are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-ast? [y/N]
:: xorg-server and xf86-video-cirrus are in conflict (X-ABI-VIDEODRV_VERSION). Remove xf86-video-cirrus? [y/N]

Is it safe to remove these? Or should I just wait until the new repo is set up for 1.17?

Offline

#7125 2015-10-01 11:07:26

headkase
Member
Registered: 2011-12-06
Posts: 1,873

Re: The AMD/ATI Bar & Grill

Palmitoxico wrote:

Well, I've downloaded SOMA and tried with the open source AMD drivers (HD6850), everything works ok until the 3D stuff. Here some screenshots:

http://s7.postimg.org/dfbc59q5z/SOMA3.jpg
http://s7.postimg.org/x8nfxz3jr/SOMA1.jpg
http://s7.postimg.org/bxpvtplfb/SOMA2.jpg

I'll wait until they fix that, in the worst case I'll make a dual boot with some ubuntu derivative and install the crappy Catalyst.

That's the exact same issue I had.  Catalyst fixed it though, the game works with it.  Too bad it's not an option for you.  sad

Offline

Board footer

Powered by FluxBB