You are not logged in.

#1401 2010-02-23 10:39:08

timong
Member
From: Budapest, HU
Registered: 2007-02-20
Posts: 91
Website

Re: The AMD/ATI Bar & Grill

Yeah, amd under linux is infamous...but  no idea how, the fun factor on my notebook is that with the 5650 (evergreen) i havent experienced any kind of system freeze that are reported to happen with the previous generations. I guess the part of catalyst blob that was introduced for the 5xxx series lacks something that causes freeze on older cards. Hopefully AMD wont introduce it later on... mad big_smile


2x arch amd64, one with Intel GP GMA965, one with ATi Mobility HD 5650

Offline

#1402 2010-02-23 10:43:10

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 677

Re: The AMD/ATI Bar & Grill

timong wrote:

Yeah, amd under linux is infamous...but  no idea how, the fun factor on my notebook is that with the 5650 (evergreen) i havent experienced any kind of system freeze that are reported to happen with the previous generations. I guess the part of catalyst blob that was introduced for the 5xxx series lacks something that causes freeze on older cards. Hopefully AMD wont introduce it later on... mad big_smile

I have no freezes on my laptop (Mobility HD 3470), at least, no frequent freezes. I can say that it's rock solid (but I don't use 3D, except for kwin).

Offline

#1403 2010-02-23 10:44:55

agapito
Member
From: Spain
Registered: 2008-11-13
Posts: 498

Re: The AMD/ATI Bar & Grill

timong wrote:

Yeah, amd under linux is infamous...but  no idea how, the fun factor on my notebook is that with the 5650 (evergreen) i havent experienced any kind of system freeze that are reported to happen with the previous generations. I guess the part of catalyst blob that was introduced for the 5xxx series lacks something that causes freeze on older cards. Hopefully AMD wont introduce it later on... mad big_smile

+1

I have 5770 and i have to admit, with catalyst i never had a system freeze. I hope with 10.3 composite works again and 1.7 support.


Excuse my poor English.

Offline

#1404 2010-02-23 11:30:03

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,335
Website

Re: The AMD/ATI Bar & Grill

I'd like to remid you that this forum is to critic ati, not glorify it ;P

Is it really such hard to freeze catalyst on your systems? I remember that this wasn't so hard on my 4850 - changing kde effects and applying different effects many times or switching to VT when something was going on sometimes(/often) causes freezes...
Generally system was stable, but now with oss driver i have no freezes/crashes, and it feels almost as stable as Windows wink tongue

Last edited by Vi0L0 (2010-02-23 11:32:22)

Offline

#1405 2010-02-23 11:34:42

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 677

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

I'd like to remid you that this forum is to critic ati, not glorify it ;P

Is it really such hard to freeze catalyst on your systems? I remember that this wasn't so hard on my 4850 - changing kde effects and applying different effects many times or switching to VT when something was going on sometimes(/often) causes freezes...
Generally system was stable, but now with oss driver i have no freezes/crashes, and it feels almost as stable as Windows wink tongue

I almost never noticed the things you are mentioning. Changing effects and switching to VT work flawlessly. I had some problems but they went away many months ago, I think with 9.6. Maybe the 4xxx series has some driver problems wrt 3xxx/5xxx.

Offline

#1406 2010-02-23 11:42:04

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,335
Website

Re: The AMD/ATI Bar & Grill

snack wrote:
Vi0L0 wrote:

I'd like to remid you that this forum is to critic ati, not glorify it ;P

Is it really such hard to freeze catalyst on your systems? I remember that this wasn't so hard on my 4850 - changing kde effects and applying different effects many times or switching to VT when something was going on sometimes(/often) causes freezes...
Generally system was stable, but now with oss driver i have no freezes/crashes, and it feels almost as stable as Windows wink tongue

I almost never noticed the things you are mentioning. Changing effects and switching to VT work flawlessly. I had some problems but they went away many months ago, I think with 9.6. Maybe the 4xxx series has some driver problems wrt 3xxx/5xxx.

Maybe... My last X's crash was after installing 10.2... no kwin at all wink
Naah - i have those problems with effects even on 10.1

Offline

#1407 2010-02-23 12:06:28

timong
Member
From: Budapest, HU
Registered: 2007-02-20
Posts: 91
Website

Re: The AMD/ATI Bar & Grill

snack wrote:
Vi0L0 wrote:

I'd like to remid you that this forum is to critic ati, not glorify it ;P

Is it really such hard to freeze catalyst on your systems? I remember that this wasn't so hard on my 4850 - changing kde effects and applying different effects many times or switching to VT when something was going on sometimes(/often) causes freezes...
Generally system was stable, but now with oss driver i have no freezes/crashes, and it feels almost as stable as Windows wink tongue

I almost never noticed the things you are mentioning. Changing effects and switching to VT work flawlessly. I had some problems but they went away many months ago, I think with 9.6. Maybe the 4xxx series has some driver problems wrt 3xxx/5xxx.

Yeah, i'm actively changing VTs and it works without any problem, also suspend/resume doesnt effect the further functioning of the system. These things were working very ugly when I was owning an ati 9600xt. Back then I had to use the opensource driver to prevent Neverwinter from freezing. Since I have this new notebook only two ways i can freeze it: one is to go back to 9.10 - always freeze upon starting X if DRI enabled (drmOpen fails and that makes it freeze, i guess some part doesnt support my exact model even if it runs okay with other 5xxx). With 10.1+ the only way i can make it freeze is to shutdown GDM and restart it, and switch to the X instance. If i dont shut it down, but instead use killall -9 Xorg it restarts nicely. Also it's working quite nice to switch users, so multiple X instances is working too so far.

Last edited by timong (2010-02-23 12:14:04)


2x arch amd64, one with Intel GP GMA965, one with ATi Mobility HD 5650

Offline

#1408 2010-02-23 12:30:26

LukynZ
Member
From: Ostrava, Czech Republic
Registered: 2008-11-13
Posts: 122

Re: The AMD/ATI Bar & Grill

Well catalyst driver is ok until u:

1] don't want to switch user
2] don't want to play game and then go back to compositing desktop
3] don't want to play game through wine
4] dont want to kill X server

then say hello to reset button

Last edited by LukynZ (2010-02-23 12:30:40)

Offline

#1409 2010-02-23 12:35:39

timong
Member
From: Budapest, HU
Registered: 2007-02-20
Posts: 91
Website

Re: The AMD/ATI Bar & Grill

LukynZ wrote:

Well catalyst driver is ok until u:

1] don't want to switch user
2] don't want to play game and then go back to compositing desktop
3] don't want to play game through wine
4] dont want to kill X server

then say hello to reset button

Thats quite sad. I read you have an 3xxx series card. 

Out of these I can do 1,2,4 without freeze on my hd5650 with catalyst 10.1+. I haven't tried point 3 yet.

ATi guys are splitting the driver code in a way that seems to do different things on different cards?

Last edited by timong (2010-02-23 12:36:00)


2x arch amd64, one with Intel GP GMA965, one with ATi Mobility HD 5650

Offline

#1410 2010-02-23 12:43:52

LukynZ
Member
From: Ostrava, Czech Republic
Registered: 2008-11-13
Posts: 122

Re: The AMD/ATI Bar & Grill

dunno, but I am hardly thinking about 5450...this card is just amazing

Offline

#1411 2010-02-23 12:47:08

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,335
Website

Re: The AMD/ATI Bar & Grill

LukynZ wrote:

Well catalyst driver is ok until u:

1] don't want to switch user
2] don't want to play game and then go back to compositing desktop
3] don't want to play game through wine
4] dont want to kill X server

then say hello to reset button

I also didn't have problems with those points, except maybe 1] which i don't even tried.  Some wine games works very well for me, some not. And like i wrote earlier - running Witcher on medium details was kinda surprise.

Offline

#1412 2010-02-23 12:53:08

timong
Member
From: Budapest, HU
Registered: 2007-02-20
Posts: 91
Website

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

Some wine games works very well for me, some not. And like i wrote earlier - running Witcher on medium details was kinda surprise.

Fun!  I dualboot win7 for Witcher (too), i'm just playing, chapter III big_smile
I prefer to run games in their native OS since i was left with no choice to buy or not a win7 with the notebook.
Luckily Linux native games run fine for me. NWN1, Eschalon Book I, Penumbra Series, Quake4, Warzone 2100 works really nice. I can't guess why is it working not with some of the ati cards we are talking about here..

Last edited by timong (2010-02-23 12:55:22)


2x arch amd64, one with Intel GP GMA965, one with ATi Mobility HD 5650

Offline

#1413 2010-02-23 12:55:04

LukynZ
Member
From: Ostrava, Czech Republic
Registered: 2008-11-13
Posts: 122

Re: The AMD/ATI Bar & Grill

well problem 1 means switch user and first one is still running - so creating another new session - this alwasy freeze graphics and restart was only choice
problem 2 I had yesterday when I play openarena and then quit the game - black screen with cursor...so ctrl+alt+f1...kill X server and then total break of graphic and restart (viz point 4)
problem 3 depend on game, but if there is a problem, no chance to return back unless u haven't wine in window...

Offline

#1414 2010-02-23 12:57:16

timong
Member
From: Budapest, HU
Registered: 2007-02-20
Posts: 91
Website

Re: The AMD/ATI Bar & Grill

LukynZ wrote:

well problem 1 means switch user and first one is still running - so creating another new session - this alwasy freeze graphics and restart was only choice
problem 2 I had yesterday when I play openarena and then quit the game - black screen with cursor...so ctrl+alt+f1...kill X server and then total break of graphic and restart (viz point 4)
problem 3 depend on game, but if there is a problem, no chance to return back unless u haven't wine in window...

I will try to check these. Havent checked these exactly like that. Havent played openarena either. Is it easily reproducible?


2x arch amd64, one with Intel GP GMA965, one with ATi Mobility HD 5650

Offline

#1415 2010-02-23 13:01:07

LukynZ
Member
From: Ostrava, Czech Republic
Registered: 2008-11-13
Posts: 122

Re: The AMD/ATI Bar & Grill

timong wrote:
LukynZ wrote:

well problem 1 means switch user and first one is still running - so creating another new session - this alwasy freeze graphics and restart was only choice
problem 2 I had yesterday when I play openarena and then quit the game - black screen with cursor...so ctrl+alt+f1...kill X server and then total break of graphic and restart (viz point 4)
problem 3 depend on game, but if there is a problem, no chance to return back unless u haven't wine in window...

I will try to check these. Havent checked these exactly like that. Havent played openarena either. Is it easily reproducible?

point 1 always, openarena I triend only one times with catalyst, I dont want to restart smile point 3 ... try CS, there it is standard....point 4 ... I am killing server only when there is any problem, so I don't know how it works normally

Offline

#1416 2010-02-23 13:01:35

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,335
Website

Re: The AMD/ATI Bar & Grill

LukynZ wrote:

problem 2 I had yesterday when I play openarena and then quit the game - black screen with cursor...so ctrl+alt+f1...kill X server and then total break of graphic and restart (viz point 4)

Did you try to kill DM and start it again after X kill?

LukynZ wrote:

problem 3 depend on game, but if there is a problem, no chance to return back unless u haven't wine in window...

For me that's also usually true.

Offline

#1417 2010-02-23 13:14:06

timong
Member
From: Budapest, HU
Registered: 2007-02-20
Posts: 91
Website

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:
LukynZ wrote:

problem 3 depend on game, but if there is a problem, no chance to return back unless u haven't wine in window...

For me that's also usually true.

That's usually the same with nvidia and intel for me. So I guess it's more related to how wine and X works. Isn't switch to VT working then? Well, that will be a catalyst related thing then... I usually use a remote ssh connection to kill X if nothing else helps...

Last edited by timong (2010-02-23 13:15:06)


2x arch amd64, one with Intel GP GMA965, one with ATi Mobility HD 5650

Offline

#1418 2010-02-23 13:17:57

LukynZ
Member
From: Ostrava, Czech Republic
Registered: 2008-11-13
Posts: 122

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:
LukynZ wrote:

problem 2 I had yesterday when I play openarena and then quit the game - black screen with cursor...so ctrl+alt+f1...kill X server and then total break of graphic and restart (viz point 4)

Did you try to kill DM and start it again after X kill?

Ok maybe I write it a little bit wrong....I am stopping KDM. I have KDM start in inittab, so when I stop KDM daemon, it automatically starts again, but at this point I see totaly broken screen and graphics freeze

With OSS drivers there is no problem doing this

Last edited by LukynZ (2010-02-23 13:18:56)

Offline

#1419 2010-02-23 19:39:44

*vitali*
Member
Registered: 2009-12-20
Posts: 83

Re: The AMD/ATI Bar & Grill

Offline

#1420 2010-02-24 20:39:57

kronsi
Member
Registered: 2010-02-24
Posts: 5

Re: The AMD/ATI Bar & Grill

Hey Guys,

I don't know what I'm doing wrong....
I have installed  catalyst 10.1
bevore i've downgraded xorg-server an theese keyboard, endev and mouse packages
I've got a a ATI Mobility Radeon 4650 HD

Now the XServer didn't want to start....
Here is my xorg.conf

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

and here is my Xorg.log, i hope you can help me.... thanks a lot

X.Org X Server 1.6.3
Release Date: 2009-7-31
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.30-ARCH x86_64 
Current Operating System: Linux kronsi-notebook 2.6.32-ARCH #1 SMP PREEMPT Tue Feb 9 15:12:10 CET 2010 x86_64
Build Date: 25 August 2009  09:11:18PM
 
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Feb 24 22:23:21 2010
(II) Loader magic: 0x15c0
(II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 5.0
    X.Org XInput driver : 4.0
    X.Org Server Extension : 2.0
(II) Loader running on linux
(--) using VT number 7

(--) PCI:*(0:1:0:0) 1002:9480:144d:c050 ATI Technologies Inc M96 [Mobility Radeon HD 4650] rev 0, Mem @ 0xd0000000/268435456, 0xcfef0000/65536, I/O @ 0x00002000/256, BIOS @ 0x????????/131072
List of video drivers:
    fglrx
(II) LoadModule: "fglrx"
(II) Loading /usr/lib/xorg/modules/drivers//fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
    compiled for 1.4.99.906, module version = 8.69.4
    Module class: X.Org Video Driver
(II) Loading sub module "fglrxdrm"
(II) LoadModule: "fglrxdrm"
(II) Loading /usr/lib/xorg/modules/linux//libfglrxdrm.so
(II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
    compiled for 1.4.99.906, module version = 8.69.4
(II) System resource ranges:
    [0] -1    0    0xffffffff - 0xffffffff (0x1) MX[b]
    [1] -1    0    0x000f0000 - 0x000fffff (0x10000) MX[b]
    [2] -1    0    0x000c0000 - 0x000effff (0x30000) MX[b]
    [3] -1    0    0x00000000 - 0x0009ffff (0xa0000) MX[b]
    [4] -1    0    0x0000ffff - 0x0000ffff (0x1) IX[b]
    [5] -1    0    0x00000000 - 0x00000000 (0x1) IX[b]
(II) Primary Device is: PCI 01@00:00:0
(WW) Falling back to old probe method for fglrx
(II) Loading PCS database from /etc/ati/amdpcsdb
(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
(**) ChipID override: 0x9480
(**) Chipset Supported AMD Graphics Processor (0x9480) found

Backtrace:
0: Xorg(xorg_backtrace+0x26) [0x4e9186]
1: Xorg(xf86SigHandler+0x6f) [0x47612f]
2: /lib/libc.so.6(+0x320b0) [0x7fe1e93300b0]
3: /usr/lib/xorg/modules/drivers//fglrx_drv.so(atiddxProbeMain+0x98a) [0x7fe1e85137ca]
4: Xorg(xf86CallDriverProbe+0xd9) [0x4685b9]
5: Xorg(DoConfigure+0x1a3) [0x485ea3]
6: Xorg(InitOutput+0x159) [0x468a79]
7: Xorg(main+0x1fe) [0x42e5be]
8: /lib/libc.so.6(__libc_start_main+0xfd) [0x7fe1e931cb6d]
9: Xorg() [0x42dbf9]

Fatal server error:
Caught signal 11.  Server aborting


Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Last edited by kronsi (2010-02-24 21:30:39)

Offline

#1421 2010-02-24 21:09:47

LukynZ
Member
From: Ostrava, Czech Republic
Registered: 2008-11-13
Posts: 122

Re: The AMD/ATI Bar & Grill

What type of ATI card do you have?

Offline

#1422 2010-02-24 21:17:57

LukynZ
Member
From: Ostrava, Czech Republic
Registered: 2008-11-13
Posts: 122

Re: The AMD/ATI Bar & Grill

Today I tried catalyst 10.2. again. I uninstalled xorg and all drivers I had, installed xorg with fix and catalyst, restart kdm, let xorg load fglrx module and now openarena works fine, switch user works fine. CS through wine still freeze, but I try go to tty, kill wine and hl.exe...after this my screen break...but with alt+f7 I can go back to KDE and everything is fine. Weird...but working smile However kwin composition isnt so smooth like OSS drivers and this wine-thing is really sad for me..

Last edited by LukynZ (2010-02-24 21:18:52)

Offline

#1423 2010-02-24 21:29:38

kronsi
Member
Registered: 2010-02-24
Posts: 5

Re: The AMD/ATI Bar & Grill

I'm sorry it's a ATI Mobility Radeon 4650

I think the problem is near here

(II) Primary Device is: PCI 01@00:00:0
(WW) Falling back to old probe method for fglrx
(II) Loading PCS database from /etc/ati/amdpcsdb
(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found

But I dont know what i have to do

Last edited by kronsi (2010-02-24 21:33:36)

Offline

#1424 2010-02-24 21:50:02

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 677

Re: The AMD/ATI Bar & Grill

Did you try Vi0l0's repository? Try to uninstall everything (xorg and catalyst) and follow the instructions posted by Vi0l0 up in this thread.

@Vi0l0: this thread is overflowing. If you are planning to maintain your catalyst repo for some time, then why don't you write a brief wiki page with installation instructions? It should be very useful for those like kronsi who are experiencing some problems.

Offline

#1425 2010-02-24 22:01:14

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: The AMD/ATI Bar & Grill

kronsi wrote:

I'm sorry it's a ATI Mobility Radeon 4650

I think the problem is near here

(II) Primary Device is: PCI 01@00:00:0
(WW) Falling back to old probe method for fglrx
(II) Loading PCS database from /etc/ati/amdpcsdb
(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found

But I dont know what i have to do

Delete /etc/ati folder and retry.

Offline

Board footer

Powered by FluxBB