You are not logged in.

#1576 2010-03-28 13:44:03

vitaliyy
Member
Registered: 2010-03-28
Posts: 1

Re: The AMD/ATI Bar & Grill

I've tried fglrx-8.721-1.x86_64.rpm (converted by "alien" from https://launchpad.net/ubuntu/+source/fg … amd64.deb) on MSI EX400X under Fedora 12 (2.6.31.9-174.fc12.x86_64; Xorg 7.5), and, failed ... with black screen and next in Xorg.0.log:

-- BEGIN --
(**) ModulePath set to "/usr/lib/fglrx/xorg/modules"                                                                                                         
(II) Cannot locate a core pointer device.                                                                                                                   
(II) The server relies on HAL to provide the list of input devices.                                                                                         
        If no devices become available, reconfigure HAL or disable AutoAddDevices.                                                                           
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.                                                             
(WW) Disabling Keyboard0                                                                                                                                     
(II) Loader magic: 0x7c9800                                                                                                                                 
(II) Module ABI versions:                                                                                                                                   
        X.Org ANSI C Emulation: 0.4                                                                                                                         
        X.Org Video Driver: 6.0                                                                                                                             
        X.Org XInput driver : 7.0                                                                                                                           
        X.Org Server Extension : 2.0                                                                                                                         
(--) using VT number 2                                                                                                                                       

(--) PCI:*(0:1:0:0) 1002:95c4:1462:4330 ATI Technologies Inc Mobility Radeon HD 3400 Series rev 0, Mem @ 0xd0000000/268435456, 0xfdef0000/65536, I/O @ 0x0000d800/256, BIOS @ 0x????????/131072                                                                                                                           
(II) "extmod" will be loaded by default.                                                                                                                     
(II) "dbe" will be loaded by default.                                                                                                                       
(II) "glx" will be loaded by default.                                                                                                                       
(II) "record" will be loaded by default.                                                                                                                     
(II) "dri" will be loaded by default.                                                                                                                       
(II) "dri2" will be loaded by default.                                                                                                                       
(II) LoadModule: "extmod"                                                                                                                                   
(WW) Warning, couldn't open module extmod                                                                                                                   
(II) UnloadModule: "extmod"                                                                                                                                 
(EE) Failed to load module "extmod" (module does not exist, 0)                                                                                               
(II) LoadModule: "dbe"                                                                                                                                       
(WW) Warning, couldn't open module dbe                                                                                                                       
(II) UnloadModule: "dbe"                                                                                                                                     
(EE) Failed to load module "dbe" (module does not exist, 0)                                                                                                 
(II) LoadModule: "glx"                                                                                                                                       
(II) Loading /usr/lib/fglrx/xorg/modules/extensions/libglx.so                                                                                               
(II) Module glx: vendor="FireGL - ATI Technologies Inc."                                                                                                     
        compiled for 7.5.0, module version = 1.0.0                                                                                                           
(II) Loading extension GLX                                                                                                                                   
(II) LoadModule: "record"                                                                                                                                   
(WW) Warning, couldn't open module record                                                                                                                   
(II) UnloadModule: "record"                                                                                                                                 
(EE) Failed to load module "record" (module does not exist, 0)                                                                                               
(II) LoadModule: "dri"                                                                                                                                       
(WW) Warning, couldn't open module dri                                                                                                                       
(II) UnloadModule: "dri"                                                                                                                                     
(EE) Failed to load module "dri" (module does not exist, 0)                                                                                                 
(II) LoadModule: "dri2"                                                                                                                                     
(WW) Warning, couldn't open module dri2                                                                                                                     
(II) UnloadModule: "dri2"
(EE) Failed to load module "dri2" (module does not exist, 0)
(II) LoadModule: "fglrx"
(II) Loading /usr/lib/fglrx/xorg/modules/drivers/fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
        compiled for 1.7.1, module version = 8.72.10
        Module class: X.Org Video Driver
(II) Loading sub module "fglrxdrm"
(II) LoadModule: "fglrxdrm"
(II) Loading /usr/lib/fglrx/xorg/modules/linux/libfglrxdrm.so
(II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
        compiled for 1.7.1, module version = 8.72.10
(II) ATI Proprietary Linux Driver Version Identifier:8.72.10
(II) ATI Proprietary Linux Driver Release Identifier: 8.72.1
(II) ATI Proprietary Linux Driver Build Date: Mar 10 2010 23:41:33
(II) Primary Device is: PCI 01@00:00:0
(WW) Falling back to old probe method for fglrx
(II) Loading PCS database from /etc/ati/amdpcsdb
(--) Chipset Supported AMD Graphics Processor (0x95C4) found
(II) AMD Video driver is running on a device belonging to a group targeted for this release
(II) AMD Video driver is signed
(II) fglrx(0): pEnt->device->identifier=0x2381e00
(II) fglrx(0): === [atiddxPreInit] === begin
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(WW) Warning, couldn't open module vgahw
(II) UnloadModule: "vgahw"
(EE) fglrx: Failed to load module "vgahw" (module does not exist, 0)
(II) fglrx(0): Error === [atiddxPreInit] === end
(II) UnloadModule: "fglrx"
(II) UnloadModule: "fglrxdrm"
(EE) Screen(s) found, but none have a usable configuration.
--- END ---

P. S. On the file-system I have /usr/lib64/xorg/modules/libvgahw.so and correspondent 'ModulePath "/usr/lib64/xorg/modules"' inside "Files" section of /etc/X11/xorg.conf.


From another hand, ATI Catalyst OpenGL 4.0 preview driver from http://support.amd.com/us/kbarticles/Pa … river.aspx was started up, but failed as well, because of ... hm-m-m, "DRI initialization failed" issue:

-- BEGIN --
(II) fglrx(0): [uki] DRM interface version 1.0                                                                                                               
(II) fglrx(0): [uki] created "fglrx" driver at busid "PCI:1:0:0"                                                                                             
(II) fglrx(0): [uki] added 8192 byte SAREA at 0x2000                                                                                                         
(II) fglrx(0): [uki] mapped SAREA 0x2000 to 0x7f485abeb000                                                                                                   
(II) fglrx(0): [uki] framebuffer handle = 0x3000                                                                                                             
(II) fglrx(0): [uki] added 1 reserved context for kernel                                                                                                     
(II) fglrx(0): swlDriScreenInit done                                                                                                                         
(II) fglrx(0): Kernel Module Version Information:                                                                                                           
(II) fglrx(0):     Name: fglrx                                                                                                                               
(II) fglrx(0):     Version: 8.71.4                                                                                                                           
(II) fglrx(0):     Date: Mar 23 2010                                                                                                                         
(II) fglrx(0):     Desc: ATI FireGL DRM kernel module                                                                                                       
(WW) fglrx(0): Kernel Module version does *not* match driver.                                                                                               
(EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work                                                                     
(II) fglrx(0): [uki] removed 1 reserved context for kernel                                                                                                   
(II) fglrx(0): [uki] unmapping 8192 bytes of SAREA 0x2000 at 0x7f485abeb000                                                                                 
(WW) fglrx(0): ***********************************************                                                                                               
(WW) fglrx(0): * DRI initialization failed!                  *                                                                                               
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *                                                                                               
(WW) fglrx(0): * 2D acceleraton available (MMIO)             *                                                                                               
(WW) fglrx(0): * no 3D acceleration available                *                                                                                               
(WW) fglrx(0): ********************************************* *                                                                                               
(II) fglrx(0): FBADPhys: 0xc0000000 FBMappedSize: 0x10000000                                                                                                 
(II) fglrx(0): FBMM initialized for area (0,0)-(1280,8191)                                                                                                   
(II) fglrx(0): FBMM auto alloc for area (0,0)-(1280,1280) (front color buffer - assumption)                                                                 
(II) fglrx(0): Largest offscreen area available: 1280 x 6911                                                                                                 
(==) fglrx(0): Backing store disabled                                                                                                                       
(II) Loading extension FGLRXEXTENSION                                                                                                                       
(**) fglrx(0): DPMS enabled                                                                                                                                 
(II) fglrx(0): Initialized in-driver Xinerama extension                                                                                                     
(WW) fglrx(0): Textured Video not supported without DRI enabled.                                                                                             
--- END ---

Offline

#1577 2010-03-28 17:44:42

yimm
Member
From: France
Registered: 2009-10-16
Posts: 106

Re: The AMD/ATI Bar & Grill

agapito wrote:
yimm wrote:

catalyst-test works well too for me, with Direct2D too. It's fast on KDE 4 yikes
Now, I am trying UVD2

Direct2d works fine? Are you sure is really activated?

It seems, because now it's very very fluid/fast after I have activated it (and restarted X server wink )

cat /var/log/Xorg.0.log | grep -i direct
(**) fglrx(0): 2D Acceleration through direct hook is enabled

Hm... UVD2 doesn't work fine. It's fast, but videos are a little blur and sometimes there are artifacts.

And lib32-catalyst-utils (for catalyst-test) doesn't work at all with wine.

Last edited by yimm (2010-03-28 21:21:38)

Offline

#1578 2010-03-29 02:31:22

doorknob60
Member
From: Oregon
Registered: 2008-09-29
Posts: 401

Re: The AMD/ATI Bar & Grill

yimm wrote:
agapito wrote:
yimm wrote:

catalyst-test works well too for me, with Direct2D too. It's fast on KDE 4 yikes
Now, I am trying UVD2

Direct2d works fine? Are you sure is really activated?

It seems, because now it's very very fluid/fast after I have activated it (and restarted X server wink )

cat /var/log/Xorg.0.log | grep -i direct
(**) fglrx(0): 2D Acceleration through direct hook is enabled

Hm... UVD2 doesn't work fine. It's fast, but videos are a little blur and sometimes there are artifacts.

And lib32-catalyst-utils (for catalyst-test) doesn't work at all with wine.

You'd need a lib32-catalyst-test if it exists (or something like that, it needs to be the same version). I use a chroot and Wine works fine, just installed catalyst-test in the chroot smile

Offline

#1579 2010-03-29 03:21:38

martin77
Member
Registered: 2010-03-14
Posts: 111

Re: The AMD/ATI Bar & Grill

hi guys,

is anyone having trouble with sound in flash? Before updating KDE4 few days ago everything was cool and smooth, now I have no sound in any flash movie, locally play or website embedded - Youtube, Dailymotion, etc.
I'm running a x86_64 Arch + KDE4 + ATI's HD5750

Offline

#1580 2010-03-29 06:17:23

agapito
Member
From: Spain
Registered: 2008-11-13
Posts: 495

Re: The AMD/ATI Bar & Grill

martin77 wrote:

hi guys,

is anyone having trouble with sound in flash? Before updating KDE4 few days ago everything was cool and smooth, now I have no sound in any flash movie, locally play or website embedded - Youtube, Dailymotion, etc.
I'm running a x86_64 Arch + KDE4 + ATI's HD5750

Works fine here. Maybe you have to blacklist your hdmi output modules if you don't use it.

This is my MODULES line

MODULES=(fglrx vboxdrv fuse !snd_hda_codec_atihdmi !snd_hda_intel !snd_hda_codec)


Excuse my poor English.

Offline

#1581 2010-03-29 07:15:35

Perry3D
Member
Registered: 2008-03-20
Posts: 542

Offline

#1582 2010-03-29 07:40:20

yimm
Member
From: France
Registered: 2009-10-16
Posts: 106

Re: The AMD/ATI Bar & Grill

@ doorknob60
yes, I use this package here from Violo.
I will try within a chroot wink

Hm... within a chroot, or with bin32-wine doesn't work lol I will wait

Last edited by yimm (2010-03-29 10:22:04)

Offline

#1583 2010-03-29 20:55:45

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: The AMD/ATI Bar & Grill

I activated direct2d.
I noticed that the maximize problem with enabled compositing went completely away (without patched xorg). It is fast as it should be.
On the other hand vsync makes the glxgear window completely black with compositing enabled and without compositing it is terribly laggy (but warcraft III in wine without compositing runs good).
Without vsync it looks better.
But without vsync in hd videos (with mplayer-vaapi) there is tearing...

But still the problem that the whole screen flickers when putting a window over the full screen warcraft3. And warcraft3 is still on all workspaces (it flickers when you change workspace and then the game is there)
It's in other 3d games too.

Last edited by Cdh (2010-03-29 20:59:37)


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#1584 2010-03-30 13:55:46

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

I decided to give direct2d another chance, the only difference is now im not killing xserver with a kill cmd, but i am simply restarting my dm (/etc/rc.d/kdm restart) to turn changes in amdpcsdb on. And its working really good now, the performance impact is mostly seen while scrolling pages - even with much flash content sites (such as myspace profiles) are scrolling fast, nice and smoothly, much better than without d2d, and also faster than with oss driver.
Still its better to use xorg-server-catalyst-maximize-fix cuz its much faster than unpatched xserver - at least with kwin.

yimm wrote:

yes, I use this package here from Violo.

strange... im also using this package + bin32-wine 1.1.41 and i can still play on witcher @ medium details

Offline

#1585 2010-03-30 16:24:25

rulex
Member
From: Finland
Registered: 2009-05-20
Posts: 55

Re: The AMD/ATI Bar & Grill

I just noticed
aticonfig --od-gettemperature
stopped working for me after i updated to catalyst 10.3
it doesnt output anything, aticonfig just sits taking 100% cpu. The other --od-* seemst to be working fine though.
Any ideas?
I got a hd5770

Offline

#1586 2010-03-30 16:31:53

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: The AMD/ATI Bar & Grill

Is 10.4 an alternative for you?

chris@chrispc ~ % aticonfig --od-gettemperature 

Default Adapter - ATI Radeon HD 4600 Series 
                  Sensor 0: Temperature - 35.50 C
chris@chrispc ~ % pacman -Q catalyst-test
catalyst-test 10.4-444

฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#1587 2010-03-30 16:54:37

rulex
Member
From: Finland
Registered: 2009-05-20
Posts: 55

Re: The AMD/ATI Bar & Grill

i guess its an alternative but you know what, it started working after I played a litte ioquake big_smile

Offline

#1588 2010-03-30 18:00:12

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

10.4 beta is not alternative - its the future! smile
xserver 1.8 will arrive in a days, and catalyst 10.4 should work with it. Ofcourse not on clean 1.8 - it need a version change before compiling.

Like i wrote on phoronix forum:
(you actually should read this cuz of incoming new config order)
"I would like to confirm that this catalyst 10.4 beta works fine on xserver 1.8 - at least on yesterday's git build. The final version shall arrive soon, so i dont expect much changes here.
I have succesfuly ran it basing on krionius (aka timong) research posted mostly here: http://bbs.archlinux.org/viewtopic.php? … 71#p728571
As you can see you must cheat catalyst by compiling xserver 1.8 as xserver 1.7.5.1, otherwise catalyst wont work with it cuz of xserver version mismatch.
Also with xserver 1.8 comes some changes cuz of switching to udev instead of hal - you need to create /etc/xorg.conf.d directory with additional files in it for every input device you have (otherwise your mouse/keybrd wont start).
More here: http://forums.gentoo.org/viewtopic-p-62 … df57f66731 and here: http://who-t.blogspot.com/2010/01/new-c … order.html
Plus dont add any new xserver Section into your /etc/X11/xorg.conf - this file is still used by catalyst - i mean ie dont add any Section "InputClass" into xorg.conf cuz when you do this both aticonfig and amdcccle wont start cuz of parsing xorg.conf error (just use /etc/xorg.conf.d directory for it)."

Sooo - we all own timong a beer for hes research!
Ofcourse i will prepare repo with needed files (mean patched xserver 1.8 + catalyst) as soon as 1.8 appear on arch repos.
I will repeat this message when time will come...

Last edited by Vi0L0 (2010-03-30 18:00:37)

Offline

#1589 2010-03-30 23:59:54

silenc3r
Member
From: Poland
Registered: 2009-08-29
Posts: 149

Re: The AMD/ATI Bar & Grill

Good job with updating catalyst!

It is slightly better than open source drivers for my HD3470:
- gnome menus and such work faster
- screen doesn't freeze with gnome mplayer when it's hiding progress bar at fullscreen mode
- osd notices such as volume level doesn't force to close fullscreen youtube videos any more

There are only 2 bad things for me:
- fullscreen videos on youtube feeze when I move the mouse cursor
- the fan is as loud as it was with open source drivers, when I try to change it's speed I got this

> aticonfig --pplib-cmd "set fanspeed 0 50"
PPLIB command execution has failed!
ati_pplib_cmd: execute "set" failed!

same with temperature checking.
Anyone know what may be causing that? I'm using kernel 2.6.33.

Offline

#1590 2010-03-31 07:22:15

agapito
Member
From: Spain
Registered: 2008-11-13
Posts: 495

Re: The AMD/ATI Bar & Grill

New Opengl4 driver preview

http://support.amd.com/us/kbarticles/Pa … river.aspx

Last edited by agapito (2010-03-31 07:58:05)


Excuse my poor English.

Offline

#1591 2010-03-31 10:38:49

Mikko777
Member
From: Suomi, Finland
Registered: 2006-10-30
Posts: 837

Re: The AMD/ATI Bar & Grill

Catalyst 10.4 test would be awesome except I can no longer enable s-video TV out...

Anyone else experiencing this problem?

Atm I'm using opensource radeon driver and it seems to be inferior on every department.
(picture quality, speed, horrible tv-out and so on)

Offline

#1592 2010-03-31 14:43:10

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

agapito wrote:

I bet its not supporting xserver 1.7 - but for all gamers its good to have it : there was a nice performance impact in all opengl apps with first ogl4.0 preview driver, so its gotta be similar with this hotfix

Offline

#1593 2010-04-04 17:19:20

REN
Member
From: Porto Alegre
Registered: 2009-07-25
Posts: 17
Website

Re: The AMD/ATI Bar & Grill

I have a question regarding to the installation of this package.
When I try to install it I got this error from pacman:

$ sudo pacman -U catalyst-test-10.4-444-i686.pkg.tar.gz 
loading package data...
checking dependencies...
error: replacing packages with -U is not supported yet
error: you can replace packages manually using -Rd and -U
error: failed to prepare transaction (conflicting dependencies)
:: catalyst-test: conflicts with libgl
:: catalyst-test: conflicts with xf86-video-ati
:: catalyst-test: conflicts with ati-dri

Then if  try to remove libgl I got:

$ sudo pacman -R libgl
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: ati-dri: requires libgl=7.7.1
:: intel-dri: requires libgl=7.7.1
:: mach64-dri: requires libgl=7.7.1
:: mesa: requires libgl
:: mga-dri: requires libgl=7.7.1
:: mplayer: requires libgl
:: r128-dri: requires libgl=7.7.1
:: savage-dri: requires libgl=7.7.1
:: sis-dri: requires libgl=7.7.1
:: tdfx-dri: requires libgl=7.7.1
:: unichrome-dri: requires libgl=7.7.1
:: xine-lib: requires libgl
:: xorg-server: requires libgl
:: xorg-utils: requires libgl

What should I do to install it?

Renan

Offline

#1594 2010-04-04 17:57:55

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: The AMD/ATI Bar & Grill

Don't remove with -R, use -Rd


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#1595 2010-04-04 23:26:02

REN
Member
From: Porto Alegre
Registered: 2009-07-25
Posts: 17
Website

Re: The AMD/ATI Bar & Grill

Done! But I still have some problems.

$ sudo modprobe fglrx
FATAL: Error inserting fglrx (/lib/modules/2.6.32-ARCH/video/fglrx.ko): No such device

Offline

#1596 2010-04-04 23:41:26

webmasteryoda
Member
From: Serbia
Registered: 2010-03-20
Posts: 115
Website

Re: The AMD/ATI Bar & Grill

Hi ppl.

I am using catalyst-test on Acer laptop with Radeon HD 4570.

I switched to fglrx because there is no powersaving with open source drivers. Now my temperatures are normal, but I have different problems.

Windows are leaving trails while dragging. Display is flickering sometimes. Parts of inactive windows popup above active windows sometimes. There is no composition (transparency) on KDE.

Here s my xorg.conf:
http://pastebin.com/58znGeVH

Am I missing something?

PS - I posted this problem in separate topic, but that topics name is "Overheating the laptop". Now as I know that open source driver is problem I posted here hoping that someone can help me.

Offline

#1597 2010-04-05 02:47:38

handy
Member
From: Oz
Registered: 2008-03-26
Posts: 719

Re: The AMD/ATI Bar & Grill

@webmasteryoda: Had you tried using Perry3D's repo, which provides compiled open-source packages required for the ATi GPUs & kernel .34-git ?

kernel .34 introduces power management for ATi GPUs.


I used to be surprised that I was still surprised by my own stupidity, finding it strangely refreshing.
Well, now I don't find it refreshing.
I'm over it!

Offline

#1598 2010-04-05 08:37:46

Gruntz
Member
From: Haskovo, Bulgaria
Registered: 2007-08-31
Posts: 256

Re: The AMD/ATI Bar & Grill

Where can I download ati catalyst 10.4 beta driver guys?

Offline

#1599 2010-04-05 10:44:06

webmasteryoda
Member
From: Serbia
Registered: 2010-03-20
Posts: 115
Website

Re: The AMD/ATI Bar & Grill

Gruntz wrote:

Where can I download ati catalyst 10.4 beta driver guys?

Its in AUR. Try searching with yaourt or download and compile....

@Handy
I didnt tried, as it is not stable kernel version. Maybe its better to wait a bit.

Thx anyway

Last edited by webmasteryoda (2010-04-05 10:45:39)

Offline

#1600 2010-04-05 11:14:19

cebarres
Member
Registered: 2009-05-10
Posts: 7

Re: The AMD/ATI Bar & Grill

Hi !

I'm installing catalyst from the repo and I have a display problem with my Ati5770.
So I did :
pacman -Syy
pacman -Suu
pacman -Rd xorg-server
pacman -S xorg-server-catalyst-maximize-fix
pacman -Rd libgl
pacman -S catalyst
fglrx module added in the rc.conf

Now, when I launch kdm in console, I come in the login manager, no problem. But when I enter my password, kde is loading during 1 second, and the screen goes black and comes back to the kdm.
I tried to start X, the screen is black, so I go in tty1 and I can read :
(WW) fglrx: No matching Device section for instance (BusID PCI:0@3:0:1) found

This is my xorg.conf generated with aticonfig --initial :

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
    ModulePath "/usr/lib/xorg/modules"
EndSection

Section "Module"
    Load  "glx"
    Load  "dri"
    Load  "drm"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:3:0:0"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "DRI"
    Mode 0666
EndSection

Do you have some ideas ?
Thank you

Last edited by cebarres (2010-04-05 11:54:18)

Offline

Board footer

Powered by FluxBB