You are not logged in.

#1676 2010-04-11 09:40:48

Ultraman
Member
Registered: 2009-12-24
Posts: 242

Re: The AMD/ATI Bar & Grill

Your system is out-of-date. Like dcc24 says, it's probably because you are using a mirror that is out-of-sync for a while.
libcrypto.so belongs to the openssl package, which is also at version 1.0.0 now instead of 0.9.8.
So make sure you are up to date and try again.

Offline

#1677 2010-04-11 10:03:23

devadittya
Member
From: Bangalore
Registered: 2009-11-16
Posts: 127
Website

Re: The AMD/ATI Bar & Grill

Yes, the problem was the old Xorg server (1.7.6.1) with the maximize fit. I uninstalled that, and installed the latest xorg (1.7.6.3). Now X works, but I am back with the maximizing issue.

Offline

#1678 2010-04-11 10:08:17

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: The AMD/ATI Bar & Grill

You have 2 options:

- Either use Vi0L0's catalyst repo (see previous page) combined with the xorg18 repo and move to xorg-server 1.8
- Or use my xorg-server-1.7.6.3 package with the maximize fix: http://aur.archlinux.org/packages.php?ID=35686


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#1679 2010-04-11 13:47:59

webmasteryoda
Member
From: Serbia
Registered: 2010-03-20
Posts: 115
Website

Re: The AMD/ATI Bar & Grill

After yesterdays update fglrx stopped working properly.

No composite. Slow graphics... Its working just like there is no video driver.

What happened and how to solve this problem.... I think that Xorg update caused this....

Offline

#1680 2010-04-11 14:08:44

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: The AMD/ATI Bar & Grill

What are the versions of xorg-server and catalyst-test? Which kernel? Are you using the catalyst and/or xorg18 repos?


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#1681 2010-04-11 14:12:32

gtklocker
Member
Registered: 2009-09-01
Posts: 460

Re: The AMD/ATI Bar & Grill

Mine is always slow, but I stay with it for powersaving. If powersaving was implemented in a better way, I would definately use it.

Offline

#1682 2010-04-11 14:17:28

webmasteryoda
Member
From: Serbia
Registered: 2010-03-20
Posts: 115
Website

Re: The AMD/ATI Bar & Grill

dcc24 wrote:

What are the versions of xorg-server and catalyst-test? Which kernel? Are you using the catalyst and/or xorg18 repos?

I am using default Arch repos.... fglrx is 10.4.444 (catalyst-test)...... using it because of the powersaving (I am the laptop user).

Versions of Xorg and kernel I really dont know.... but I guess its default versions of Arch. How can I check these versions ?

Until yesterdays update all worked fine.... now stopped working....

Offline

#1683 2010-04-11 14:21:33

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: The AMD/ATI Bar & Grill

Post the outputs of these please:

pacman -Q xorg-server
pacman -Q catalyst-test
pacman -Q openssl
pacman -Q kernel26
cat /etc/pacman.conf

Last edited by dcc24 (2010-04-11 14:22:05)


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#1684 2010-04-11 14:27:15

webmasteryoda
Member
From: Serbia
Registered: 2010-03-20
Posts: 115
Website

Re: The AMD/ATI Bar & Grill

dcc24 wrote:

Post the outputs of these please:

pacman -Q xorg-server
pacman -Q catalyst-test
pacman -Q openssl
pacman -Q kernel26
cat /etc/pacman.conf

xorg-server 1.7.6-3
catalyst-test 10.4-444
openssl 1.0.0-2
kernel26 2.6.33.2-1

#[testing]
## Add your preferred servers here, they will be used first
#Include = /etc/pacman.d/mirrorlist

[core]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

[extra]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

#[community-testing]
## Add your preferred servers here, they will be used first
#Include = /etc/pacman.d/mirrorlist

[community]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#Server = file:///home/custompkgs

[archlinuxfr] 
Server = http://repo.archlinux.fr/i686

Offline

#1685 2010-04-11 14:31:06

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: The AMD/ATI Bar & Grill

Well, everything seems up-to-date.

Slow graphics could be caused by an fglrx issue, which should be solved by this patched xorg: http://aur.archlinux.org/packages.php?ID=35686

As for no compositing, can you post your /var/log/Xorg.0.log?


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#1686 2010-04-11 14:38:19

webmasteryoda
Member
From: Serbia
Registered: 2010-03-20
Posts: 115
Website

Re: The AMD/ATI Bar & Grill

dcc24 wrote:

Well, everything seems up-to-date.

Slow graphics could be caused by an fglrx issue, which should be solved by this patched xorg: http://aur.archlinux.org/packages.php?ID=35686

As for no compositing, can you post your /var/log/Xorg.0.log?

Yaourt installing of maximize fix:

resolving dependencies...
looking for inter-conflicts...
:: libgl conflicts with catalyst-test. Remove catalyst-test? [Y/n]

Xorg.0.log:

X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.33-ARCH i686 
Current Operating System: Linux myhost 2.6.33-ARCH #1 SMP PREEMPT Mon Apr 5 05:57:38 UTC 2010 i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz26 root=/dev/sda8 ro
Build Date: 01 April 2010  05:35:33PM
 
Current version of pixman: 0.18.0
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Apr 11 15:33:29 2010
(==) Using config file: "/etc/X11/xorg.conf"
Parse error on line 10 of section Files in file /etc/X11/xorg.conf
    Ignoring obsolete keyword "RgbPath".
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Card0"
(**) |-->Screen "aticonfig-Screen[0]-1" (1)
(**) |   |-->Monitor "aticonfig-Monitor[0]-1"
(**) |   |-->Device "aticonfig-Device[0]-1"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(==) Automatically adding devices
(==) Automatically enabling devices
(**) FontPath set to:
    /usr/share/fonts/misc,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/TTF,
    /usr/share/fonts/Type1,
    /usr/share/fonts/misc,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/TTF,
    /usr/share/fonts/Type1
(**) ModulePath set to "/usr/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(II) Loader magic: 0x81e4c60
(II) Module ABI versions:
    X.Org ANSI C Emulation: 0.4
    X.Org Video Driver: 6.0
    X.Org XInput driver : 7.0
    X.Org Server Extension : 2.0
(++) using VT number 7

(--) PCI:*(0:1:0:0) 1002:9553:1025:0212 ATI Technologies Inc M92 [Mobility Radeon HD 4500 Series] rev 0, Mem @ 0xc0000000/268435456, 0xd6200000/65536, I/O @ 0x00005000/256, BIOS @ 0x????????/131072
(II) Open ACPI successful (/var/run/acpid.socket)
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "record" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri2" will be loaded by default.
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.0.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "xtrap"
(WW) Warning, couldn't open module xtrap
(II) UnloadModule: "xtrap"
(EE) Failed to load module "xtrap" (module does not exist, 0)
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.13.0
    Module class: X.Org Server Extension
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri"
(II) Loading /usr/lib/xorg/modules/extensions/libdri.so
(II) Module dri: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.0.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension XFree86-DRI
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="FireGL - ATI Technologies Inc."
    compiled for 7.5.0, module version = 1.0.0
(II) Loading extension GLX
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.1.0
    ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "fglrx"
(II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
    compiled for 1.7.1, module version = 8.72.10
    Module class: X.Org Video Driver
(II) Loading sub module "fglrxdrm"
(II) LoadModule: "fglrxdrm"
(II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
(II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
    compiled for 1.7.1, module version = 8.72.10
(II) ATI Proprietary Linux Driver Version Identifier:8.72.10
(II) ATI Proprietary Linux Driver Release Identifier: 8.72.1                               
(II) ATI Proprietary Linux Driver Build Date: Mar 10 2010 23:41:04
(II) Primary Device is: PCI 01@00:00:0
(WW) Falling back to old probe method for fglrx
(II) Loading PCS database from /etc/ati/amdpcsdb
(--) Chipset Supported AMD Graphics Processor (0x9553) found
(--) Chipset Supported AMD Graphics Processor (0x9553) found
(II) AMD Video driver is running on a device belonging to a group targeted for this release
(II) AMD Video driver is signed
(II) fglrx(0): pEnt->device->identifier=0x9bccc38
(II) fglrx(1): pEnt->device->identifier=0x9bccc38
(II) fglrx(0): === [atiddxPreInit] === begin
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/lib/xorg/modules/libvgahw.so
(II) Module vgahw: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 0.1.0
    ABI class: X.Org Video Driver, version 6.0
(**) fglrx(0): Depth 24, (--) framebuffer bpp 32
(II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
(==) fglrx(0): Default visual is TrueColor
(==) fglrx(0): RGB weight 888
(II) fglrx(0): Using 8 bits per RGB 
(==) fglrx(0): Buffer Tiling is ON
(II) Loading sub module "fglrxdrm"
(II) LoadModule: "fglrxdrm"
(II) Reloading /usr/lib/xorg/modules/linux/libfglrxdrm.so
ukiDynamicMajor: failed to open /proc/ati/major
ukiDynamicMajor: failed to open /proc/ati/major
(--) fglrx(0): Chipset: "ATI Mobility Radeon HD 4500 Series" (Chipset = 0x9553)
(--) fglrx(0): (PciSubVendor = 0x1025, PciSubDevice = 0x0212)
(==) fglrx(0): board vendor info: third party graphics adapter - NOT original ATI
(--) fglrx(0): Linear framebuffer (phys) at 0xc0000000
(--) fglrx(0): MMIO registers at 0xd6200000
(--) fglrx(0): I/O port at 0x00005000
(==) fglrx(0): ROM-BIOS at 0x000c0000
(II) fglrx(0): Primary V_BIOS segment is: 0xc000
(EE) fglrx(0): Hasn't establisted DRM connection
(II) Loading sub module "vbe"
(II) LoadModule: "vbe"
(II) Loading /usr/lib/xorg/modules/libvbe.so
(II) Module vbe: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.1.0
    ABI class: X.Org Video Driver, version 6.0
(II) fglrx(0): VESA BIOS detected
(II) fglrx(0): VESA VBE Version 3.0
(II) fglrx(0): VESA VBE Total Mem: 16384 kB
(II) fglrx(0): VESA VBE OEM: ATI ATOMBIOS
(II) fglrx(0): VESA VBE OEM Software Rev: 11.22
(II) fglrx(0): VESA VBE OEM Vendor: (C) 1988-2005, ATI Technologies Inc. 
(II) fglrx(0): VESA VBE OEM Product: M92
(II) fglrx(0): VESA VBE OEM Product Rev: 01.00
(II) fglrx(0): ATI Video BIOS revision 9 or later detected
(--) fglrx(0): Video RAM: 524288 kByte, Type: DDR2
(II) fglrx(0): PCIE card detected
(--) fglrx(0): Using per-process page tables (PPPT) as GART.
(WW) fglrx(0): board is an unknown third party board, chipset is supported
(EE) fglrx(0): Hasn't establisted DRM connection
(WW) fglrx(0): Hasn't establisted DRM connection
(II) fglrx(0): [FB] MC range(MCFBBase = 0xf00000000, MCFBSize = 0x20000000)
(WW) fglrx(0): No DRM connection for driver fglrx.
(II) fglrx(0): RandR 1.2 support is enabled!
(II) fglrx(0): RandR 1.2 rotation support is enabled!
(==) fglrx(0): Center Mode is disabled 
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.0.0
    ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Module "ddc" already built-in
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Module "ddc" already built-in
(II) fglrx(0): Connected Display0: LCD on internal LVDS [lvds]
(II) fglrx(0): Display0 EDID data ---------------------------
(II) fglrx(0): Manufacturer: AUO  Model: 12ec  Serial#: 0
(II) fglrx(0): Year: 2008  Week: 1
(II) fglrx(0): EDID Version: 1.3
(II) fglrx(0): Digital Display Input
(II) fglrx(0): Max Image Size [cm]: horiz.: 34  vert.: 19
(II) fglrx(0): Gamma: 2.20
(II) fglrx(0): No DPMS capabilities specified
(II) fglrx(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4 
(II) fglrx(0): First detailed timing is preferred mode
(II) fglrx(0): redX: 0.640 redY: 0.342   greenX: 0.310 greenY: 0.580
(II) fglrx(0): blueX: 0.150 blueY: 0.120   whiteX: 0.313 whiteY: 0.329
(II) fglrx(0): Manufacturer's mask: 0
(II) fglrx(0): Supported detailed timing:
(II) fglrx(0): clock: 72.0 MHz   Image Size:  344 x 193 mm
(II) fglrx(0): h_active: 1366  h_sync: 1414  h_sync_end 1446 h_blank_end 1486 h_border: 0
(II) fglrx(0): v_active: 768  v_sync: 771  v_sync_end 775 v_blanking: 806 v_border: 0
(II) fglrx(0): Unknown vendor-specific block f
(II) fglrx(0):  AUO
(II) fglrx(0):  B156XW01 V2
(II) fglrx(0): EDID (in hex):
(II) fglrx(0):     00ffffffffffff0006afec1200000000
(II) fglrx(0):     01120103802213780ae6b5a3574f9426
(II) fglrx(0):     1e505400000001010101010101010101
(II) fglrx(0):     010101010101201c5678500026303020
(II) fglrx(0):     340058c1100000180000000f00000000
(II) fglrx(0):     00000000000000000020000000fe0041
(II) fglrx(0):     554f0a202020202020202020000000fe
(II) fglrx(0):     004231353658573031205632200a0026
(II) fglrx(0): End of Display0 EDID data --------------------
(II) fglrx(0): Output LVDS using monitor section Monitor0
(II) fglrx(0): Output CRT1 has no monitor section
(II) fglrx(0): Output LVDS connected
(II) fglrx(0): Output CRT1 disconnected
(II) fglrx(0): Using exact sizes for initial modes
(II) fglrx(0): Output LVDS using initial mode 1366x768
(II) fglrx(0): DPI set to (96, 96)
(II) fglrx(0): Adapter ATI Mobility Radeon HD 4500 Series has 2 configurable heads and 1 displays connected.
(==) fglrx(0): QBS disabled
(==) fglrx(0):  PseudoColor visuals disabled
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(==) fglrx(0): NoAccel = NO
(==) fglrx(0): NoDRI = NO
(==) fglrx(0): Capabilities: 0x00000000
(==) fglrx(0): CapabilitiesEx: 0x00000000
(==) fglrx(0): OpenGL ClientDriverName: "fglrx_dri.so"
(==) fglrx(0): UseFastTLS=0
(==) fglrx(0): BlockSignalsOnLock=1
(II) fglrx(1): === [atiddxPreInit] === begin
(WW) fglrx(1): Quitting screen 1 -- no monitor specified.
(II) fglrx(1): === [atiddxPreInit] === end
(II) UnloadModule: "fglrx"
(II) UnloadModule: "fglrxdrm"
(--) Depth 24 pixmap format is 32 bpp
(EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized. 
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)             *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): ********************************************* *
(II) fglrx(0): FBADPhys: 0xf00000000 FBMappedSize: 0x10000000
(II) fglrx(0): FBMM initialized for area (0,0)-(1408,8191)
(II) fglrx(0): FBMM auto alloc for area (0,0)-(1408,1366) (front color buffer - assumption)
(II) fglrx(0): Largest offscreen area available: 1408 x 6825
(==) fglrx(0): Backing store disabled
(II) Loading extension FGLRXEXTENSION
(==) fglrx(0): DPMS enabled
(II) fglrx(0): Initialized in-driver Xinerama extension
(WW) fglrx(0): Textured Video not supported without DRI enabled.
(II) LoadModule: "glesx"
(II) Loading /usr/lib/xorg/modules/glesx.so
(II) Module glesx: vendor="X.Org Foundation"
    compiled for 1.7.1, module version = 1.0.0
(II) Loading extension GLESX
(II) Loading sub module "xaa"
(II) LoadModule: "xaa"
(II) Loading /usr/lib/xorg/modules/libxaa.so
(II) Module xaa: vendor="X.Org Foundation"
    compiled for 1.7.6, module version = 1.2.1
    ABI class: X.Org Video Driver, version 6.0
(II) fglrx(0): GLESX enableFlags = 78
(II) fglrx(0): Acceleration enabled
(II) LoadModule: "amdxmm"
(II) Loading /usr/lib/xorg/modules/amdxmm.so
(II) Module amdxmm: vendor="X.Org Foundation"
    compiled for 1.7.1, module version = 1.0.0
(EE) fglrx(0): XMM failed to open CMMQS connection.
(II) fglrx(0): XMM failed to initialize!
(II) fglrx(0): Enable composite support successfully
(==) fglrx(0): Silken mouse enabled
(==) fglrx(0): Using HW cursor of display infrastructure!
(II) fglrx(0): Disabling in-server RandR and enabling in-driver RandR 1.2.
(II) fglrx(0): 'LVDS LCD' ConnectorType, abstracted as 'Panel'
(II) fglrx(0): 'eDP LCD' ConnectorType, abstracted as 'Panel'
(--) RandR disabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) AIGLX: Screen 0 is not DRI capable
[glesx] __glESXExtensionInit: No GL ES2.0 capable screen found!
(II) fglrx(0): Setting screen physical size to 361 x 203
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(II) LoadModule: "evdev"
(II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
    compiled for 1.7.3, module version = 2.3.2
    Module class: X.Org XInput Driver
    ABI class: X.Org XInput driver, version 7.0
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event1"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: Adding input device Macintosh mouse button emulation
(**) Macintosh mouse button emulation: always reports core events
(**) Macintosh mouse button emulation: Device: "/dev/input/event0"
(II) Macintosh mouse button emulation: Found 3 mouse buttons
(II) Macintosh mouse button emulation: Found relative axes
(II) Macintosh mouse button emulation: Found x and y relative axes
(II) Macintosh mouse button emulation: Configuring as mouse
(**) Macintosh mouse button emulation: YAxisMapping: buttons 4 and 5
(**) Macintosh mouse button emulation: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "Macintosh mouse button emulation" (type: MOUSE)
(**) Macintosh mouse button emulation: (accel) keeping acceleration scheme 1
(**) Macintosh mouse button emulation: (accel) acceleration profile 0
(II) Macintosh mouse button emulation: initialized for relative axes.
(II) config/hal: Adding input device SynPS/2 Synaptics TouchPad
(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
    compiled for 1.7.3, module version = 1.2.1
    Module class: X.Org XInput Driver
    ABI class: X.Org XInput driver, version 7.0
(II) Synaptics touchpad driver version 1.2.1
(**) Option "Device" "/dev/input/event8"
(II) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5472
(II) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4448
(II) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
(II) SynPS/2 Synaptics TouchPad: finger width range 0 - 0
(II) SynPS/2 Synaptics TouchPad: buttons: left right
(**) Option "TapButton1" "1"
(**) Option "TapButton2" "2"
(**) Option "TapButton3" "3"
(--) SynPS/2 Synaptics TouchPad: touchpad found
(**) SynPS/2 Synaptics TouchPad: always reports core events
(II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
(**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
(**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 0
(--) SynPS/2 Synaptics TouchPad: touchpad found
(II) config/hal: Adding input device Video WebCam
(**) Video WebCam: always reports core events
(**) Video WebCam: Device: "/dev/input/event9"
(II) Video WebCam: Found keys
(II) Video WebCam: Configuring as keyboard
(II) XINPUT: Adding extended input device "Video WebCam" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: Adding input device Sleep Button
(**) Sleep Button: always reports core events
(**) Sleep Button: Device: "/dev/input/event4"
(II) Sleep Button: Found keys
(II) Sleep Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: Adding input device Power Button
(**) Power Button: always reports core events
(**) Power Button: Device: "/dev/input/event2"
(II) Power Button: Found keys
(II) Power Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: Adding input device Video Bus
(**) Video Bus: always reports core events
(**) Video Bus: Device: "/dev/input/event7"
(II) Video Bus: Found keys
(II) Video Bus: Configuring as keyboard
(II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) config/hal: Adding input device Power Button
(**) Power Button: always reports core events
(**) Power Button: Device: "/dev/input/event5"
(II) Power Button: Found keys
(II) Power Button: Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "us"
(II) fglrx(0): Restoring Recent Mode via PCS is not supported in RANDR 1.2 capable environments

Offline

#1687 2010-04-11 14:41:24

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: The AMD/ATI Bar & Grill

First remove catalyst with "pacman -Rd catalyst-test".
Then, since you are using yaourt, do "yaourt -S xorg-server-1.7-catalyst-maximize-fix".
Then remove libgl: "pacman -Rd libgl".
Finally rebuild & install catalyst-test: "yaourt -S catalyst-test".

Also, looking at your Xorg log, fglrx fails to initialize DRI, that's why you have no 3D. Can you post /etc/X11/xorg.conf?

Last edited by dcc24 (2010-04-11 14:44:17)


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#1688 2010-04-11 15:06:54

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,320
Website

Re: The AMD/ATI Bar & Grill

@webmasteryoda:
Have you rebuilded catalyst-test after update?
Whats the output of

# modprobe fglrx

?

Offline

#1689 2010-04-11 15:21:21

webmasteryoda
Member
From: Serbia
Registered: 2010-03-20
Posts: 115
Website

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

@webmasteryoda:
Have you rebuilded catalyst-test after update?
Whats the output of

# modprobe fglrx

?

I did it now. (rebuilding the catalyst-test)

Its normal again. Didnt know that its a must after the upgrade....

thx

Offline

#1690 2010-04-11 15:23:06

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,320
Website

Re: The AMD/ATI Bar & Grill

webmasteryoda wrote:

I did it now. (rebuilding the catalyst-test)

Its normal again. Didnt know that its a must after the upgrade....

thx

Thats because of new kernel version in [core] repo 2.6.32 -> 2.6.33

Offline

#1691 2010-04-11 15:55:47

agapito
Member
From: Spain
Registered: 2008-11-13
Posts: 495

Re: The AMD/ATI Bar & Grill

NEW CATALYST 10.4 BETA

http://www.phoronix.com/scan.php?page=n … &px=ODE0MQ

This PKGBUILD worked for me

# Maintainer: Vi0L0 <vi0l093@gmail.com>
# Contributor: Eduardo "kensai" Romero
# Contributor: Anssi Hannula
# Contributor: Stefan Bühler
# Contributor: baghera
# Contributor: Arlekino

_kernver=`uname -r`

pkgname=catalyst-test
pkgver=10.4
pkgrel=555
pkgdesc="AMD/ATI drivers for Radeon brand cards (based on ubuntu's fglrx with xserver 1.7 support). Stock kernel"
arch=('i686' 'x86_64')
url="http://www.ati.amd.com"
license=('custom')
depends=('xorg-server<1.9.0' 'kernel26>=2.6.29' 'kernel26<2.6.35' 'kernel26-headers' 'netkit-bsd-finger' 'libstdc++5' 'libxrandr' 'libsm' 'fontconfig' 'libxcursor' 'libxi' 'gcc-libs')

conflicts=('catalyst' 'catalyst-utils' 'nvidia' 'libgl' 'catalyst-leaked' 'xf86-video-ati' 'xf86-video-radeonhd' 'ati-dri')
provides=('catalyst' 'libgl')
install=catalyst.install
source=(https://launchpad.net/ubuntu/lucid/+source/fglrx-installer/2:8.723.1-0ubuntu1/+files/fglrx-installer_8.723.1.orig.tar.gz
    catalyst.sh amdcccle.desktop atieventsd.sh fglrx-2.6.33.patch)
md5sums=('c5bed046747747b8f8e66f0338c81907'
         'bdafe749e046bfddee2d1c5e90eabd83'
         '4efa8414a8fe9eeb50da38b5522ef81d'
         'f729bf913613f49b0b9759c246058a87'
     'c5eb5571782fed5232461f59a789fb08')

build() {

##Preparing ubuntu's fglrx to work with old archs pkgbuild
tar zxvf fglrx-installer_8.723.1.orig.tar.gz
cd fglrx-installer-8.723.1
mkdir common
mv  etc usr lib common
cp common/usr/share/doc/fglrx/ATI_LICENSE.TXT .
cd ..


##Build kernel modules

if [ "${CARCH}" = "x86_64" ]; then
BUILDARCH=x86_64
_archdir=x86_64
fi
if [ "${CARCH}" = "i686" ]; then
BUILDARCH=i386
_archdir=x86
fi

##patching for kernel 2.6.33 or 2.6.34 support
if [ `uname -r |grep -c "2.6.33"` != 0 ] || [ `uname -r |grep -c "2.6.34"` != 0 ]; then
cd "${srcdir}/fglrx-installer-8.723.1/"
patch -Np1 -i ../fglrx-2.6.33.patch || return 1
fi


cd "${srcdir}/fglrx-installer-8.723.1/common/lib/modules/fglrx/build_mod"
cp "${srcdir}/fglrx-installer-8.723.1/arch/${_archdir}/lib/modules/fglrx/build_mod/libfglrx_ip.a.GCC4" . || return 1
cp 2.6.x/Makefile . || return 1

make -C /lib/modules/${_kernver}/build SUBDIRS="`pwd`" ARCH=${BUILDARCH} modules || return 1

install -m755 -d "${pkgdir}/lib/modules/${_kernver}/video/"
install -m644 fglrx.ko "${pkgdir}/lib/modules/${_kernver}/video/" || return 1
install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"

sed -i -e "s/KERNEL_VERSION=.*/KERNEL_VERSION=${_kernver}/" $startdir/*.install

##Install catalyst utilities

# Create directories
install -m755 -d "${pkgdir}/etc/ati"
install -m755 -d "${pkgdir}/etc/rc.d"
install -m755 -d "${pkgdir}/etc/profile.d"
install -m755 -d "${pkgdir}/etc/acpi/events"

install -m755 -d "${pkgdir}/usr/lib/xorg/modules/dri"
install -m755 -d "${pkgdir}/usr/lib/xorg/modules/drivers"
install -m755 -d "${pkgdir}/usr/lib/xorg/modules/extensions"
install -m755 -d "${pkgdir}/usr/lib/xorg/modules/linux"

install -m755 -d "${pkgdir}/usr/bin"
install -m755 -d "${pkgdir}/usr/sbin"

install -m755 -d "${pkgdir}/usr/include/X11/extensions"
install -m755 -d "${pkgdir}/usr/include/GL"

install -m755 -d "${pkgdir}/usr/share/applications"
install -m755 -d "${pkgdir}/usr/share/ati/amdcccle"
install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
install -m755 -d "${pkgdir}/usr/share/man/man8"
install -m755 -d "${pkgdir}/usr/share/pixmaps"

# X driver installation
if [ "${CARCH}" = "i686" ]; then
cd "${srcdir}/fglrx-installer-8.723.1/x750/usr/X11R6/lib/modules" || return 1
elif [ "${CARCH}" = "x86_64" ]; then
cd "${srcdir}/fglrx-installer-8.723.1/x750_64a/usr/X11R6/lib64/modules" || return 1
fi

#install -m644 *.a "${pkgdir}/usr/lib/xorg/modules/" || return 1
install -m755 *.so "${pkgdir}/usr/lib/xorg/modules/" || return 1
install -m755 drivers/*.so "${pkgdir}/usr/lib/xorg/modules/drivers/" || return 1
install -m755 linux/*.so "${pkgdir}/usr/lib/xorg/modules/linux/" || return 1
install -m755 extensions/libglx.so "${pkgdir}/usr/lib/xorg/modules/extensions/" || return 1
#install -m755 extensions/libdri.so "${pkgdir}/usr/lib/xorg/modules/extensions/libdri.ati" || return 1

# Controlcenter / library installation
if [ "${CARCH}" = "i686" ]; then
cd "${srcdir}/fglrx-installer-8.723.1/arch/x86/usr" || return 1
_lib=lib
elif [ "${CARCH}" = "x86_64" ]; then
cd "${srcdir}/fglrx-installer-8.723.1/arch/x86_64/usr" || return 1
_lib=lib64
fi

install -m755 X11R6/bin/* "${pkgdir}/usr/bin/" || return 1
install -m755 sbin/* "${pkgdir}/usr/sbin/" || return 1
install -m755 X11R6/${_lib}/*.so* "${pkgdir}/usr/lib/" || return 1
install -m644 X11R6/${_lib}/*.a "${pkgdir}/usr/lib/" || return 1 # really needed?
install -m644 X11R6/${_lib}/*.cap "${pkgdir}/usr/lib/" || return 1
install -m755 X11R6/${_lib}/modules/dri/*.so "${pkgdir}/usr/lib/xorg/modules/dri/" || return 1
install -m755 ${_lib}/*.so* "${pkgdir}/usr/lib/" || return 1

ln -sf /usr/lib/xorg/modules/dri ${pkgdir}/usr/lib/dri
ln -sf libfglrx_dm.so.1.0 "${pkgdir}/usr/lib/libfglrx_dm.so.1"
ln -sf libfglrx_pp.so.1.0 "${pkgdir}/usr/lib/libfglrx_pp.so.1"
ln -sf libfglrx_tvout.so.1.0 "${pkgdir}/usr/lib/libfglrx_tvout.so.1"
ln -sf libfglrx_gamma.so.1.0 "${pkgdir}/usr/lib/libfglrx_gamma.so.1"
ln -sf libGL.so.1.2 "${pkgdir}/usr/lib/libGL.so.1"
ln -sf libGL.so.1.2 "${pkgdir}/usr/lib/libGL.so"

cd "${srcdir}"/fglrx-installer-8.723.1/common
install -m644 etc/ati/* "${pkgdir}/etc/ati/" || return 1
chmod 755 "${pkgdir}/etc/ati/authatieventsd.sh" || return 1

install -m644 usr/X11R6/include/X11/extensions/*.h "${pkgdir}/usr/include/X11/extensions/" || return 1
install -m644 usr/X11R6/bin/amdupdaterandrconfig "${pkgdir}/usr/bin/" || return 1
install -m644 usr/include/GL/*.h "${pkgdir}/usr/include/GL/" || return 1
install -m755 usr/sbin/*.sh "${pkgdir}/usr/sbin/" || return 1
install -m644 usr/share/ati/amdcccle/* "${pkgdir}/usr/share/ati/amdcccle/" || return 1 # ? what are these files for?
# install -m644 usr/share/gnome/apps/amdcccle.desktop "${pkgdir}/usr/share/applications/" || return 1
install -m644 usr/share/icons/*.xpm "${pkgdir}/usr/share/pixmaps/" || return 1
install -m644 usr/share/man/man8/*.8 "${pkgdir}/usr/share/man/man8/" || return 1
install -m644 "${srcdir}/amdcccle.desktop" "${pkgdir}/usr/share/applications/" || return 1

# ACPI example files
install -m755 usr/share/doc/fglrx/examples/etc/acpi/*.sh "${pkgdir}/etc/acpi/" || return 1
sed -i -e 's/usr\/X11R6/usr/g' "${pkgdir}/etc/acpi/ati-powermode.sh" || return 1
install -m644 usr/share/doc/fglrx/examples/etc/acpi/events/* "${pkgdir}/etc/acpi/events/" || return 1

# Add ATI Events Daemon launcher
install -m755 "${srcdir}/atieventsd.sh" "${pkgdir}/etc/rc.d/atieventsd" || return 1

# thanks to cerebral, we dont need that damned symlink
install -m755 "${srcdir}/catalyst.sh" "${pkgdir}/etc/profile.d/" || return 1

# License
install -m644 "${srcdir}/fglrx-installer-8.723.1/ATI_LICENSE.TXT" "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
}

I had to recreate xorg.conf with aticonfig --initial to start kde.


Seems to works fine. Open GL version is 3.2.9756

Last edited by agapito (2010-04-11 16:24:14)


Excuse my poor English.

Offline

#1692 2010-04-11 17:29:43

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,320
Website

Re: The AMD/ATI Bar & Grill

Thanks agapito :*
AUR's catalyst-test has been already updated.
[catalyst-test-xorg18] repo will be updated soon.

Btw: I mustn't to recreate xorg.conf with aticonfig --initial to start kde.

Edit: [catalyst-test-xorg18] repo is updated now, if you have any problems with it - rollback to older one by changing
[catalyst-test-xorg18] to [catalyst-test-xorg18-555] in pacman.conf
and
pacman -Syy
pacman -Suu

Last edited by Vi0L0 (2010-04-11 18:29:10)

Offline

#1693 2010-04-11 18:03:52

devadittya
Member
From: Bangalore
Registered: 2009-11-16
Posts: 127
Website

Re: The AMD/ATI Bar & Grill

Yessss. Everything works. Used Vi0L0's reps and installed catalyst and xorg 1.8.
Thanks a real lot Vi0L0. You rock!
Question: So does this mean that once Xorg 1.8 is officially out, there wouldn't be any need to patch xorg-server for the maximize problem?

Offline

#1694 2010-04-11 18:27:13

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,320
Website

Re: The AMD/ATI Bar & Grill

devadittya wrote:

Question: So does this mean that once Xorg 1.8 is officially out, there wouldn't be any need to patch xorg-server for the maximize problem?

This xorg-server from [catalyst-test-xorg18] repo is already patched with backclear.patch which fix maximize problem smile.

Maybe tomorrow i will find time to add dcc24's xorg-server-maximize-fix(with fedora.patch) to this repo so anyone could choose which patched xorg-server is best for him.
@dcc24: can you post your i686 xorg-server-maximize-fix (1.8) package on some hosting portal like mediafire? It would save my time for compiling and testing

Last edited by Vi0L0 (2010-04-11 18:32:31)

Offline

#1695 2010-04-11 18:52:34

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

@dcc24: can you post your i686 xorg-server-maximize-fix (1.8) package on some hosting portal like mediafire? It would save my time for compiling and testing

I can do better, host it on my server, so it's easier for everyone smile http://durucancelasun.info/linux/xorg-s … pkg.tar.xz


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#1696 2010-04-11 19:53:40

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,320
Website

Re: The AMD/ATI Bar & Grill

@dcc24: im wondering how could your xorg-server-1.8-catalyst-maximize-fix work for you smile check comments to your package
I havent tested your i686 package yet, but its impossible to get it work with x86_64 - cuz without autogen.sh fglrx-xorg-version.patch is doing nothing smile
I mean look @ configure file - without fglrx-xorg-version.patch+autogen.sh this file is telling gcc to compile xorg-server so it may represent itself as 1.8.0 ...
Does it mean that on i686 catalyst-test can work on unpatched xserver 1.8?

Edit:

dcc24 wrote:

I can do better, host it on my server, so it's easier for everyone smile http://durucancelasun.info/linux/xorg-s … pkg.tar.xz

Tested, and like i said its not working cuz of version mismatch

Last edited by Vi0L0 (2010-04-11 20:21:34)

Offline

#1697 2010-04-11 20:18:55

delroth
Member
Registered: 2008-10-11
Posts: 8

Re: The AMD/ATI Bar & Grill

By the way, I have a small problem with catalyst since I've been using it (at least 6 months) : when I launch wine, the screen starts to flicker for 3 to 5 seconds then everything works normally. It even happens with non graphic programs : wine cmd.exe does it too. Does anyone know the cause of this flickering ?

It's really a problem for me because I'm using wine to launch a program in a script, and whenever I launch this script the screen flickers for at least 20 seconds...

Offline

#1698 2010-04-11 20:46:20

dcc24
Member
Registered: 2009-10-31
Posts: 723

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

@dcc24: im wondering how could your xorg-server-1.8-catalyst-maximize-fix work for you smile check comments to your package
I havent tested your i686 package yet, but its impossible to get it work with x86_64 - cuz without autogen.sh fglrx-xorg-version.patch is doing nothing smile
I mean look @ configure file - without fglrx-xorg-version.patch+autogen.sh this file is telling gcc to compile xorg-server so it may represent itself as 1.8.0 ...
Does it mean that on i686 catalyst-test can work on unpatched xserver 1.8?

Edit:

dcc24 wrote:

I can do better, host it on my server, so it's easier for everyone smile http://durucancelasun.info/linux/xorg-s … pkg.tar.xz

Tested, and like i said its not working cuz of version mismatch

As I said on the comments, it "works for me" smile Why, I have no idea. Still, I'm rebuilding the package and will update the binary version when it's done.

Edit: Binary updated.

Last edited by dcc24 (2010-04-11 20:52:33)


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#1699 2010-04-11 20:49:34

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,320
Website

Re: The AMD/ATI Bar & Grill

@dcc24:
so its really strange smile
But ok, i have fixed it, and added to [catalyst-test-xorg18] repo smile
Now, i will just edit [catalyst-test-xorg18] repo post with info about such fact

Offline

#1700 2010-04-11 21:04:51

Perry3D
Member
Registered: 2008-03-20
Posts: 542

Re: The AMD/ATI Bar & Grill

Offline

Board footer

Powered by FluxBB