You are not logged in.

#1726 2010-04-22 00:04:08

delcake
Member
Registered: 2008-07-28
Posts: 62

Re: The AMD/ATI Bar & Grill

I haven't played with the xorg18 repo so I don't know how things are set up in there, but are you sure the entire xorg group is installed, not just xorg-server?

Offline

#1727 2010-04-22 00:06:05

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

Skypers wrote:

Hai there. I've tried catalyst-test. Once installed, I typed "startx" -> does not exist.

startx doesnt exist? hmm...

# pacman -Qo /usr/bin/startx
/usr/bin/startx is owned by xorg-xinit 1.2.1-1

are you sure your xorg-xinit is installed?
Edit: maybe try to install all packages with pacman -S xorg

Last edited by Vi0L0 (2010-04-22 00:13:47)

Offline

#1728 2010-04-22 00:47:36

Skypers
Member
Registered: 2009-11-23
Posts: 4

Re: The AMD/ATI Bar & Grill

If I install all xorg packages, there're many conflicts with *18 version. Should I install xorg group first, then catalyst-test ?

Offline

#1729 2010-04-22 01:52:00

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

Skypers wrote:

If I install all xorg packages, there're many conflicts with *18 version. Should I install xorg group first, then catalyst-test ?

I believe most safe way is to:
- comment [catalyst-test-xorg18] and [xorg18]
- pacman -Syy
- pacman -Suu
- pacman -S xorg
- pacman -S xorg-xinit  (just in case)
- uncomment [catalyst-test-xorg18] and [xorg18]
- pacman -Syy
- pacman -Suu

and install catalyst-test package at the end

Offline

#1730 2010-04-22 05:25:39

Faxanadu
Member
Registered: 2006-07-20
Posts: 18

Re: The AMD/ATI Bar & Grill

Ok i am trying to get this working again...

Since the release of the 1.7 xorg server I have not been able to use catalyst, I have tried building from AUR, using repos and even trying installing and patching manually, but nothing works for me.

In this attempt I have a clean Archlinux install, I have used Vi0L0's repositories and did exactly what he instructs, but with no success.

For being more specific:

- Fresh Archlinux Install.

- Added nomodeset to my kernel line in /boot/grub/menu.lst

- Added to my /etc/pacman.conf above the other repositories:

[catalyst-test-xorg18]
Server = http://dl.dropbox.com/u/4321633/repo/catalyst-test/x86_64/

[xorg18]
Include = /etc/pacman.d/mirrorlist

- pacman -Syy
- pacman -Suu
- pacman -S catalyst-test

- aticonfig --initial

So reboot and startx and got the frozen black screen with the cursor at the left-upper corner like always...


So I tried again with what you mencioned your last post:

- comment [catalyst-test-xorg18] and [xorg18]
- pacman -Syy
- pacman -Suu
- pacman -S xorg
- pacman -S xorg-xinit
- uncomment [catalyst-test-xorg18] and [xorg18]
- pacman -Syy
- pacman -Suu
- pacman -S catalyst-test

So the damn same thing, and do you know what is really pissing me off?, that everybody gets this thing working except me, I have installed Linux From Scratch successfully, installed exotic drivers in linux like tablets, printers, joysticks, etc. but I can't install the damn Catalyst driver not even from repositories WTF.

Btw I have a HIS HD4850 IceQ 4 1Gb Ram, Stock Archlinux kernel.

Offline

#1731 2010-04-22 12:39:59

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

@Faxanadu: give your /var/log/Xorg.0.log (maybe also /var/log/Xorg.1.log) and /etc/X11/xorg.conf

Offline

#1732 2010-04-22 13:57:38

Skypers
Member
Registered: 2009-11-23
Posts: 4

Re: The AMD/ATI Bar & Grill

ViOlO : it works ! Thanks ! But I have still a question about xorg18 : will it be, soon or later, an [extra] package ? Also, is my netbook (a MSI Wind U210, black one but we don't care) ready to run with xorg18 ? I had to installed the `radeonhd' on it (because of xorg seemed not work ...).

Thank you for you help ! smile

EDIT : I just got a trouble right now : how configure keyboard configuration ? I wanna set mine to fr (azerty). Thanks

Last edited by Skypers (2010-04-22 14:58:54)

Offline

#1733 2010-04-22 15:19:00

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

Skypers wrote:

ViOlO : it works ! Thanks ! But I have still a question about xorg18 : will it be, soon or later, an [extra] package ?

Ofcourse.

Skypers wrote:

Also, is my netbook (a MSI Wind U210, black one but we don't care) ready to run with xorg18 ? I had to installed the `radeonhd' on it (because of xorg seemed not work ...).

I guess so, but instead of radeonhd, use ati driver, xf86-video-ati exactly, its in xorg18 repo so it should work fine.
umm... it is a notebook so maybe try to use new kernel26-pm kernel (with power management, which should work fine), check this thread:
http://bbs.archlinux.org/viewtopic.php? … 15#p746715
And try to use packages from repo builded by Perry3D - right now only for x86_64, so i dunno is this architecture you are using, if not - try to build packages on your own. About how to install and what packages to install read on first post @ first page of that thread.
About howto build and what patches to use to build kernel26-pm kernel right - read on latest pages. Yep - its lot of reading but you may be sattisfied if power management for your radeon will work.
Although im not sure does your card is supported by this pm kernel - you must to investigate it by your own...

Skypers wrote:

EDIT : I just got a trouble right now : how configure keyboard configuration ? I wanna set mine to fr (azerty). Thanks

Ive never did this, but look here:
http://wiki.archlinux.org/index.php/Xor … org_1.8.29

Last edited by Vi0L0 (2010-04-22 15:19:27)

Offline

#1734 2010-04-22 16:13:00

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

i guess its time to make some noise, rumors, and fudz here!

Valve is delivering Steam to Mac http://store.steampowered.com/news/3569/
with native opengl support for many games:
"Steam and Valve's library of games including Left 4 Dead 2, Team Fortress 2, Counter-Strike, Portal, and the Half-Life series will be available in April." (btw wheres cod mw2? hope they wouldnt deliver only valve games!)
Yeeey smile

Now the speculations on phoronix said also about linux support:
http://www.phoronix.com/scan.php?page=a … ript&num=1
http://www.phoronix.com/scan.php?page=n … &px=ODE3MQ

This is still speculation, but hell yeah its looking really good! big_smile
We gonna have native support for many fresh and new games... Yeeeeeeeey! smile

Linux will come out from the underground and finally own all continents and planets! Yeeeeeeey! xD


Edit: "We are treating the Mac as a tier-1 platform so all of our future games will release simultaneously on Windows, Mac, and the Xbox 360. Updates for the Mac will be available simultaneously with the Windows updates. Furthermore, Mac and Windows players will be part of the same multiplayer universe, sharing servers, lobbies, and so forth. We fully support a heterogeneous mix of servers and clients." - now that are big words! Im wondering about developing process - developers would have to write games for both DX and OGL - afaik theres no dx2ogl converter wink. And im surprised cuz for last thousands of years opengl seemed to be totally forsaken in games market.

Last edited by Vi0L0 (2010-04-22 16:36:44)

Offline

#1735 2010-04-22 16:20:00

Faxanadu
Member
Registered: 2006-07-20
Posts: 18

Re: The AMD/ATI Bar & Grill

Something I realised was the Xorg.0.log log says I am still using Xorg-server 1.7.5.1, but I installed xorg18 from Vi0L0 repositories with no errors, I reinstalled them but with no luck, btw there is not Xorg.1.log.

xorg.conf

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:2:0:0"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Xorg.0.log

[   225.530] 
This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.
[   225.545] 
X.Org X Server 1.7.5.1
Release Date: 2010-04-02
[   225.551] X Protocol Version 11, Revision 0
[   225.553] Build Operating System: Linux 2.6.33-ARCH x86_64 
[   225.555] Current Operating System: Linux Faxanadu 2.6.33-ARCH #1 SMP PREEMPT Sun Apr 4 10:27:30 CEST 2010 x86_64
[   225.557] Kernel command line: root=/dev/disk/by-uuid/44158374-643a-4eee-b3e3-546ba7ffd23f ro nomodeset vga=793 quiet splash
[   225.559] Build Date: 09 April 2010  03:44:51PM
[   225.561]  
[   225.563] Current version of pixman: 0.18.0
[   225.565]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[   225.569] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   225.575] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Apr 22 10:00:51 2010
[   225.601] (==) Using config file: "/etc/X11/xorg.conf"
[   225.603] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   225.627] (==) ServerLayout "aticonfig Layout"
[   225.627] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
[   225.627] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
[   225.627] (**) |   |-->Device "aticonfig-Device[0]-0"
[   225.627] (==) Automatically adding devices
[   225.627] (==) Automatically enabling devices
[   225.699] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[   225.699]     Entry deleted from font path.
[   225.700] (==) FontPath set to:
    /usr/share/fonts/misc,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/TTF
[   225.700] (==) ModulePath set to "/usr/lib/xorg/modules"
[   225.700] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[   225.700] (II) Loader magic: 0x7c5f00
[   225.700] (II) Module ABI versions:
[   225.700]     X.Org ANSI C Emulation: 0.4
[   225.700]     X.Org Video Driver: 7.0
[   225.700]     X.Org XInput driver : 9.0
[   225.700]     X.Org Server Extension : 3.0
[   225.704] (--) PCI:*(0:2:0:0) 1002:9442:1787:2003 ATI Technologies Inc RV770 [Radeon HD 4850] rev 0, Mem @ 0xe0000000/268435456, 0xfdde0000/65536, I/O @ 0x0000cc00/256, BIOS @ 0x????????/131072
[   225.704] (II) Open ACPI successful (/var/run/acpid.socket)
[   225.704] (II) "extmod" will be loaded by default.
[   225.704] (II) "dbe" will be loaded by default.
[   225.704] (II) "glx" will be loaded by default.
[   225.704] (II) "record" will be loaded by default.
[   225.704] (II) "dri" will be loaded by default.
[   225.704] (II) "dri2" will be loaded by default.
[   225.704] (II) LoadModule: "extmod"
[   225.738] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[   225.751] (II) Module extmod: vendor="X.Org Foundation"
[   225.751]     compiled for 1.7.5.1, module version = 1.0.0
[   225.751]     Module class: X.Org Server Extension
[   225.751]     ABI class: X.Org Server Extension, version 3.0
[   225.751] (II) Loading extension MIT-SCREEN-SAVER
[   225.751] (II) Loading extension XFree86-VidModeExtension
[   225.751] (II) Loading extension XFree86-DGA
[   225.751] (II) Loading extension DPMS
[   225.751] (II) Loading extension XVideo
[   225.751] (II) Loading extension XVideo-MotionCompensation
[   225.751] (II) Loading extension X-Resource
[   225.751] (II) LoadModule: "dbe"
[   225.751] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[   225.756] (II) Module dbe: vendor="X.Org Foundation"
[   225.756]     compiled for 1.7.5.1, module version = 1.0.0
[   225.756]     Module class: X.Org Server Extension
[   225.756]     ABI class: X.Org Server Extension, version 3.0
[   225.756] (II) Loading extension DOUBLE-BUFFER
[   225.756] (II) LoadModule: "glx"
[   225.756] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   225.784] (II) Module glx: vendor="FireGL - ATI Technologies Inc."
[   225.784]     compiled for 7.5.0, module version = 1.0.0
[   225.784] (II) Loading extension GLX
[   225.784] (II) LoadModule: "record"
[   225.784] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[   225.791] (II) Module record: vendor="X.Org Foundation"
[   225.791]     compiled for 1.7.5.1, module version = 1.13.0
[   225.791]     Module class: X.Org Server Extension
[   225.791]     ABI class: X.Org Server Extension, version 3.0
[   225.791] (II) Loading extension RECORD
[   225.791] (II) LoadModule: "dri"
[   225.791] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[   225.800] (II) Module dri: vendor="X.Org Foundation"
[   225.800]     compiled for 1.7.5.1, module version = 1.0.0
[   225.800]     ABI class: X.Org Server Extension, version 3.0
[   225.800] (II) Loading extension XFree86-DRI
[   225.800] (II) LoadModule: "dri2"
[   225.800] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   225.800] (II) Module dri2: vendor="X.Org Foundation"
[   225.800]     compiled for 1.7.5.1, module version = 1.2.0
[   225.800]     ABI class: X.Org Server Extension, version 3.0
[   225.800] (II) Loading extension DRI2
[   225.800] (II) LoadModule: "fglrx"
[   225.800] (II) Loading /usr/lib/xorg/modules/drivers/fglrx_drv.so
[   225.935] (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
[   225.947]     compiled for 1.7.1, module version = 8.72.11
[   225.947]     Module class: X.Org Video Driver
[   225.964] (II) Loading sub module "fglrxdrm"
[   225.964] (II) LoadModule: "fglrxdrm"
[   225.964] (II) Loading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[   225.975] (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
[   225.975]     compiled for 1.7.1, module version = 8.72.11
[   225.975] (II) ATI Proprietary Linux Driver Version Identifier:8.72.11
[   225.975] (II) ATI Proprietary Linux Driver Release Identifier: 8.723.1                              
[   225.975] (II) ATI Proprietary Linux Driver Build Date: Apr  8 2010 21:40:58
[   225.975] (--) using VT number 7

[   225.980] (II) Primary Device is: PCI 02@00:00:0
[   225.981] (WW) Falling back to old probe method for fglrx
[   226.018] (II) Loading PCS database from /etc/ati/amdpcsdb
[   226.028] (--) Chipset Supported AMD Graphics Processor (0x9442) found
[   226.028] (WW) fglrx: No matching Device section for instance (BusID PCI:0@2:0:1) found
[   226.028] (II) AMD Video driver is running on a device belonging to a group targeted for this release
[   226.038] (II) AMD Video driver is signed
[   226.038] (II) fglrx(0): pEnt->device->identifier=0x268e010
[   226.038] (II) fglrx(0): === [atiddxPreInit] === begin
[   226.039] (II) Loading sub module "vgahw"
[   226.039] (II) LoadModule: "vgahw"
[   226.039] (II) Loading /usr/lib/xorg/modules/libvgahw.so
[   226.047] (II) Module vgahw: vendor="X.Org Foundation"
[   226.047]     compiled for 1.7.5.1, module version = 0.1.0
[   226.047]     ABI class: X.Org Video Driver, version 7.0
[   226.047] (**) fglrx(0): Depth 24, (--) framebuffer bpp 32
[   226.048] (II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[   226.048] (==) fglrx(0): Default visual is TrueColor
[   226.048] (**) fglrx(0): Option "DPMS" "true"
[   226.048] (==) fglrx(0): RGB weight 888
[   226.048] (II) fglrx(0): Using 8 bits per RGB 
[   226.062] (==) fglrx(0): Buffer Tiling is ON
[   226.065] (II) Loading sub module "fglrxdrm"
[   226.065] (II) LoadModule: "fglrxdrm"
[   226.065] (II) Reloading /usr/lib/xorg/modules/linux/libfglrxdrm.so
[   226.066] ukiDynamicMajor: found major device number 251
[   226.066] ukiDynamicMajor: found major device number 251
[   226.066] ukiOpenByBusid: Searching for BusID PCI:2:0:0
[   226.066] ukiOpenDevice: node name is /dev/ati/card0
[   226.066] ukiOpenDevice: open result is 11, (OK)
[   226.066] ukiOpenByBusid: ukiOpenMinor returns 11
[   226.066] ukiOpenByBusid: ukiGetBusid reports PCI:2:0:0
[   226.066] (--) fglrx(0): Chipset: "ATI Radeon HD 4800 Series" (Chipset = 0x9442)
[   226.066] (--) fglrx(0): (PciSubVendor = 0x1787, PciSubDevice = 0x2003)
[   226.066] (==) fglrx(0): board vendor info: third party graphics adapter - NOT original ATI
[   226.066] (--) fglrx(0): Linear framebuffer (phys) at 0xe0000000
[   226.067] (--) fglrx(0): MMIO registers at 0xfdde0000
[   226.067] (--) fglrx(0): I/O port at 0x0000cc00
[   226.067] (==) fglrx(0): ROM-BIOS at 0x000c0000
[   226.078] (II) fglrx(0): AC Adapter is used
[   226.112] (II) fglrx(0): Primary V_BIOS segment is: 0xc000
[   226.113] (II) Loading sub module "vbe"
[   226.113] (II) LoadModule: "vbe"
[   226.113] (II) Loading /usr/lib/xorg/modules/libvbe.so
[   226.123] (II) Module vbe: vendor="X.Org Foundation"
[   226.123]     compiled for 1.7.5.1, module version = 1.1.0
[   226.123]     ABI class: X.Org Video Driver, version 7.0

Offline

#1736 2010-04-22 16:54:22

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

Faxanadu wrote:

Something I realised was the Xorg.0.log log says I am still using Xorg-server 1.7.5.1, but I installed xorg18 from Vi0L0 repositories with no errors, I reinstalled them but with no luck, btw there is not Xorg.1.log.

Xorg-server 1.7.5.1 - it's good, cuz we need to compile xorg-server 1.8 so it may present to catalyst as the older one. Although its still xserver 1.8

Both xorg.conf and Xorg.0.log looks rather good, but is that all that your Xorg.0.log contains? It should be much longer - with VESA BIOS, RandR, some modules, display, and input devices infos...

Offline

#1737 2010-04-22 16:56:38

yimm
Member
From: France
Registered: 2009-10-16
Posts: 106

Re: The AMD/ATI Bar & Grill

@ Vi0L0 : http://www.phoronix.com/forums/showthre … post123496

Last edited by yimm (2010-04-23 11:03:39)

Offline

#1738 2010-04-22 19:55:40

Faxanadu
Member
Registered: 2006-07-20
Posts: 18

Re: The AMD/ATI Bar & Grill

Vi0L0 wrote:

but is that all that your Xorg.0.log contains?

Yes man, in fact in order to get Xorg.0.log I had to make possible to reset using the power button, because when I launched startx all the interfaces became block, the only way was pushing reset button in the computer case or turning off the computer, and the Xorg.0.log was always empty, so I used acpid to software reboot with the powerbutton, so now I could get the Xorg.0.log I post you.

Man since Xorg 1.7 I have had exactly the same problem in x86_64, another weir thing is in 686 this driver works perfect, the problem has always been with the x86_64 version, I have no clue what is happening.


P.D. Sorry for my bad english.

Offline

#1739 2010-04-22 21:26:39

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

Faxanadu wrote:
Vi0L0 wrote:

but is that all that your Xorg.0.log contains?

Yes man, in fact in order to get Xorg.0.log I had to make possible to reset using the power button, because when I launched startx all the interfaces became block, the only way was pushing reset button in the computer case or turning off the computer, and the Xorg.0.log was always empty, so I used acpid to software reboot with the powerbutton, so now I could get the Xorg.0.log I post you.

Man since Xorg 1.7 I have had exactly the same problem in x86_64, another weir thing is in 686 this driver works perfect, the problem has always been with the x86_64 version, I have no clue what is happening.


P.D. Sorry for my bad english.

Its not looking good... Actually i dont know how can i help you here. I have seen similar to your posts on phoronix forum and the only answer was always the same that this is still beta driver. Although this answer isnt helpful at all. Especially cuz its working fine at your i686, and hd4850 is supported...
I assume you have putted nomodeset to kernel line, try also to add nopat - heh just shooting in the dark.
Try maybe to use some dm instead of startx. For example kdm isnt using startx script to work - still its just desperation...
Anybody have any idea here?

Its now almost sure that Steam is coming to linux: http://www.phoronix.com/scan.php?page=n … &px=ODE3Mw

Last edited by Vi0L0 (2010-04-22 21:31:28)

Offline

#1740 2010-04-23 05:14:09

Faxanadu
Member
Registered: 2006-07-20
Posts: 18

Re: The AMD/ATI Bar & Grill

Well man I followed your suggestions but with not luck (nopat and kdm), well finally I got officially owned by this driver, I still don't understand why it's works with i686 but not x86_64, and I don't want to go back to i686, so I suppose I will continue using windows for gaming sad

Offline

#1741 2010-04-23 11:02:56

yimm
Member
From: France
Registered: 2009-10-16
Posts: 106

Re: The AMD/ATI Bar & Grill

yimm wrote:

Hm... UVD2 doesn't work fine. It's fast, but videos are a little blur and sometimes there are artifacts.

snapshot1v.th.png
Someone have this with UVD2 ?

Last edited by yimm (2010-04-23 11:03:06)

Offline

#1742 2010-04-24 06:19:24

REN
Member
From: Porto Alegre
Registered: 2009-07-25
Posts: 17
Website

Re: The AMD/ATI Bar & Grill

I have this card:

01:05.0 VGA compatible controller: ATI Technologies Inc RS482 [Radeon Xpress 200M]

From what I have read in this thread and others, catalyst-10.4 won't work in this case, right?

Renan

Offline

#1743 2010-04-24 12:07:31

Vi0L0
Member
From: Poland
Registered: 2009-06-24
Posts: 1,301
Website

Re: The AMD/ATI Bar & Grill

@REN: yes, quoting Archlinux Ati Catalyst wiki:

Since v. 9.4, the proprietary ATI driver supports only R600 and newer devices (that means, HD2xxx and newer). For older cards, you can only use xf86-video-ati.

Offline

#1744 2010-04-24 17:29:34

REN
Member
From: Porto Alegre
Registered: 2009-07-25
Posts: 17
Website

Re: The AMD/ATI Bar & Grill

So, is it possible to get 3D with xf86-video-ati?
What about VAAPI? If that's possible with my card.

Renan

Offline

#1745 2010-04-24 17:51:26

Ultraman
Member
Registered: 2009-12-24
Posts: 242

Re: The AMD/ATI Bar & Grill

Yes, but by traying it you can get a better answer to your question.
No VAAPI yet tho

Offline

#1746 2010-04-24 18:01:55

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: The AMD/ATI Bar & Grill

yimm, can you test other files? I have had some artifacts with one video file encoded with x264, but others worked very well.


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#1747 2010-04-24 18:03:02

REN
Member
From: Porto Alegre
Registered: 2009-07-25
Posts: 17
Website

Re: The AMD/ATI Bar & Grill

Ok.

Renan

Offline

#1748 2010-04-24 18:42:14

yimm
Member
From: France
Registered: 2009-10-16
Posts: 106

Re: The AMD/ATI Bar & Grill

@ Cdh
Yes I have tested other files, I have this problem only with 2 videos. (x264) but others files encoded with x264 no problem except some colors problems

Last edited by yimm (2010-04-24 18:42:37)

Offline

#1749 2010-04-25 08:48:35

mDuo13
Member
Registered: 2010-04-25
Posts: 90

Re: The AMD/ATI Bar & Grill

*sigh*
I installed Arch for the first time today. So far I'm really liking it except that of course, once again, I've been going through "ATI Hell" trying to get my graphics to work...

The Hardware: ATI HD5770 (Evergreen chipset), Intel Core i7, 6gb RAM, LG 1920x1080p monitor, Samsung 1280x1024 monitor, etc.
The System: Arch x86_64 on a 2.6.33-arch kernel, X.org X Server 1.7.6 (installed by pacman -Syu today)
The Goal: Openbox desktop spanning both monitors running at their native resolutions, smooth & no-tearing 1080p h.264 video playback

Backstory: I had this working fairly well back on Ubuntu Jaunty (technically Linux Mint 7) using the Catalyst 9.11 driver, ATI's "Big Desktop" feature, and a whole lot of mplayer tweaking. When I upgraded to Karmic I discovered that (among many other things which broke), my monitors had swapped places and with the Catalyst 10.3 driver amdcccle segfaulted when I tried to use the Displays Manager to do anything. Reverting back to Catalyst 9.11 fixed that but not the other things wrong with Karmic. After a bunch more headaches I decided to try out a different Linux where I had more control, thus why I'm now on Arch.

The Current Situation: I may or may not have mucked up my system in my initial attempts to get this working; I tried to follow the instructions on the wiki as much as I could. Currently I think I have the catalyst-test AUR package installed and amdcccle runs (which tells me it actually is using fglrx) but dies with a segmentation fault when I try to apply any changes in the Display Manager page. I thought I might try using "aticonfig --dtop=horizontal" but that was a no-go:

sudo aticonfig --dtop=horizontal
Error: Options, e.g. --dtop and --desktop-setup, are not supported when RandR 1.2 is enabled!
Using /etc/X11/xorg.conf
Saved back-up to /etc/X11/xorg.conf.fglrx-7

Some research tells me that it might have to do with a conflict between xrandr and fglrx, but I couldn't turn up a solution there. Various other attempts at things like wiping xorg.conf and rebooting have gotten me not far. I somehow got it to put my second monitor on the left as it should be, though it's still giving me a blank display with the generic X cursor rather than treating it like part of my Openbox desktop... The "awesome" windowmanager appears to be able to utilize both screens but so far I haven't been able to figure out if/how I can move windows across screens, or any number of other things that were trivial and well-documented for Openbox...

So finally I ask: any idea what I might be able to do to get my dual monitors working in their native resolutions again, with me able to span or move windows across them and all that? I haven't tried the xf86-video-ati driver, but from what I hear it does not yet have good support for the 5000-series cards. Is there a way I could disable xrandr and let fglrx handle it this thread implies so that I can use BigDesktop again? Maybe there's a way I can install the Catalyst 9.11 driver again? Maybe there's some other way to get nice dual-monitor support? I never managed to get Xinerama working on Ubuntu but with ATI Big Desktop I didn't really need to. I'm open to suggestions, and thanks in advance to anyone who offers help.

Last edited by mDuo13 (2010-04-25 08:56:12)

Offline

#1750 2010-04-25 11:14:55

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 672

Re: The AMD/ATI Bar & Grill

@mDuo: I currently have a working dual monitor setup on my laptop (Mobility HD3470). I'm using the [catalyst] repo from Vi0l0 (not [catalyst-test]), I have kernel 2.6.33 from [core] and xorg-server-catalyst-maximize-fix from [catalyst]. This is my xorg.conf (I think you can skip aticonfig if you configure xorg.conf manually):

Section "ServerLayout":
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
EndSection

Section "Monitor"
        Identifier      "LAPTOP"
        Option          "PreferredMode" "1280x800"
        #Option          "DPMS" "true"
EndSection

Section "Monitor"
        Identifier      "VGA"
        Option          "PreferredMode" "1280x1024"
        Option          "RightOf"  "LAPTOP"
EndSection

Section "Device"
        Identifier      "HD3470"
        Driver          "fglrx"
        BusID           "PCI:1:0:0"
        # Monitor options:   radeon    radeonhd    catalyst
        #          laptop     LVDS      PANEL        LVDS
        #         external    VGA-0     VGA_1        CRT1
        Option         "monitor-CRT1" "VGA"  
        Option         "monitor-LVDS" "LAPTOP"
EndSection

Section "DRI"
        Mode 0666
        EndSection

Section "Screen"
        Identifier     "Screen0"
        Device         "HD3470"
        Monitor        "LAPTOP"
        DefaultDepth 24
        SubSection     "Display"
                Modes          "1280x800"
                Depth          24
                Virtual         2560 1024
        EndSubSection
EndSection

Maybe you can find some hint in there to fix your setup...

Offline

Board footer

Powered by FluxBB