You are not logged in.

#126 2009-02-14 09:18:12

TheGrudge
Member
Registered: 2006-06-15
Posts: 206
Website

Re: Getting ready for ext4

http://lwn.net/Articles/283161/

I would not turn it off per default, I just did so to test my speed issues while debugging digiKam.
I don't really understand why barriers is so damn slow on extX systems. The speed loss is really significant sometimes.

Last edited by TheGrudge (2009-02-14 09:20:04)


digiKam developer - www.digikam.org

Offline

#127 2009-02-14 09:19:49

TheGrudge
Member
Registered: 2006-06-15
Posts: 206
Website

Re: Getting ready for ext4

TheGrudge wrote:

I don't really understand why it is so damn slow on extX systems.

I mean "I don't really understand why barriers is so damn slow on extX systems."

Sorry for the double post. Didn't know you can't delete posts again...

Last edited by TheGrudge (2009-02-14 09:22:13)


digiKam developer - www.digikam.org

Offline

#128 2009-02-14 10:41:09

Bogart
Member
From: Madrid, Spain
Registered: 2005-06-22
Posts: 263

Re: Getting ready for ext4

TheGrudge wrote:

I would not turn it off per default, I just did so to test my speed issues while debugging digiKam.
I don't really understand why barriers is so damn slow on extX systems. The speed loss is really significant sometimes.

Well, ext3 has always had them off by default and no one has ever had problems about it. So I do think that any "normal" user should disable them in ext4.

The speed penalty is not just in extX filesystems. I tested XFS too (which has barriers on by default) and got 197 kb/s (same as ext4's 195 kb/s with barriers).

Offline

#129 2009-02-14 13:37:19

nowahn
Member
From: elsewhere
Registered: 2008-12-05
Posts: 75

Re: Getting ready for ext4

Bogart wrote:

Now, the problem I have is that I can't boot my / filesystem with barriers disabled.

I think you have to rebuild your boot images with mkinitcpio after editing your fstab (the root partition is mounted while in the initramfs, which didn't know about that option at build time)


take time to daydream, inspiration comes ...

Offline

#130 2009-02-14 14:29:49

Bogart
Member
From: Madrid, Spain
Registered: 2005-06-22
Posts: 263

Re: Getting ready for ext4

nowahn wrote:
Bogart wrote:

Now, the problem I have is that I can't boot my / filesystem with barriers disabled.

I think you have to rebuild your boot images with mkinitcpio after editing your fstab (the root partition is mounted while in the initramfs, which didn't know about that option at build time)

Well, it turned out that barriers are in fact disabled, so I don't know why dmesg is saying barriers enabled. I benchmarked the root filesystem and it certainly has no barriers, so I'll ignore the message.

Thanks for reply.

Offline

#131 2009-02-14 14:35:06

dhave
Arch Linux f@h Team Member
From: Outside the matrix.
Registered: 2005-05-15
Posts: 1,110

Re: Getting ready for ext4

For those interested in the ext4 barriers enable-or-disable question, there's another thread running now. You might want to contribute there.


Donate to Arch!

Tired? There's a nap for that. --anonymous

Offline

#132 2009-03-09 03:02:47

kringel
Member
Registered: 2009-03-09
Posts: 2

Re: Getting ready for ext4

Hi everbody,

just googled for (dis)advantages and speed measurement concerning barriers on ext4. Thanks so far.

I read several times, people wondering how to disable barriers at boot time. You must set "barrier=0" in your /etc/fstab entry and also in rootflags= in your /boot/grub/menu.lst This concerns the kernel command line.

Mine is a little freaky, but you see the barriers option there:

$ cat /proc/cmdline
root=UUID=dff349a5-284e-4bbf-a4a6-6d08fb7aa1d2 ro rootflags=data=writeback,commit=90,nobh,orlov,extents,barrier=0,async quiet splash

In /boot/menu.lst you can set the rootflags-options either in the # kopt- line  or at # defoptions - line. Than run update-grub.

menu.lst:
http://services.neakro.net/noPaste.html?paste=954&text

for instance adittionally my complete fstab-options for the ext4-filesystems are (caution! could cause data loss with sudden power off or system crash):

relatime,errors=remount-ro,user_xattr,extents,async,data=writeback,journal_async_commit,barrier=0,noreservation,delalloc,commit=90,nobh        0

commit=, data=, and barrier= options must be additional added in the kernel command line in menu.lst

Last edited by kringel (2009-03-09 03:08:28)

Offline

Board footer

Powered by FluxBB