You are not logged in.

#26 2009-04-02 13:04:07

Lifty
Member
Registered: 2006-11-05
Posts: 62

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Great thanks smile

Edit: have some kmix problems myself:

 kmix: error while loading shared libraries: libcap.so.1: cannot open shared object file: No such file or directory

Last edited by Lifty (2009-04-02 17:26:03)

Offline

#27 2009-04-02 18:04:06

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

So, the problem with kmix seems to be caused by package libcap. I'm building in chroot against libs from [extra], where libcap is in version 1.10 (out-of-date). On my standard root I have [testing] enabled (and probably so you do) and there is libcap-2.16 (providing libcap.so.2)
The standard dirty (but working!) solution is to link /lib/libcap.so.2 to /lib/libcap.so.1.

Plasma-crash solution is near, but I need some more time :-)

Offline

#28 2009-04-02 20:37:33

b9anders
Member
Registered: 2007-11-07
Posts: 691

Re: [Closed] KDE 4.3 beta (4.2.63) repo

ProgDan wrote:

Well I use this "beta" since 4.2.63 every day and I never had any big problems with stability. Sometimes krunner crashes (but I met this on 4.2.1 too, so...). I have noticed mostly improvements in smaller features like Tray Notify, App launcher, since .67 the krunner has also some smart modifications....I recommend to try - you can alway revert to 4.2 wink

Have you downgraded without problems with the config files?

Offline

#29 2009-04-02 20:52:46

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

From 4.2.64 to 4.2.1 (I think) with no problem. I believe there are no major changes in the config files. But backups are of course recommended - still it is unstable branch.

Offline

#30 2009-04-07 16:21:31

Schorfi
Member
Registered: 2008-10-14
Posts: 8

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Thank you so far, ProgDan!

Offline

#31 2009-04-07 17:29:44

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

You are welcome guys. I'm happy I can contribute to the Arch community.

I'm building 4.2.69 now so expect it in few days wink

Offline

#32 2009-04-08 22:17:42

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Updated to 4.2.69-svn949727

I haven't noticed any visible new features (but I didn't have enought time to do it yet), so I suppose it will be especially about bug fixes.

So sync your repos, update your packages and enjoy KDE :-)

PS: I'll be off for the next 5 days (till monday) so please be patient with your requests/reports.

Last edited by ProgDan (2009-04-08 22:19:38)

Offline

#33 2009-04-09 22:17:58

windu.2b
Member
Registered: 2008-12-05
Posts: 1

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Hi,
I have a problem : when I want to update my system (because I want to install KDE 4.3), I have this error message :

root@windu-laptop:/home/windu# yaourt -Syu
:: Synchronizing package databases...
 testing                   26,3K  179,9K/s 00:00:00 [###########################################################################################] 100%
 core is up to date
 extra is up to date
 community is up to date
 kdemod-unstable is up to date
 kdemod-core is up to date
 kdemod-extragear is up to date
 kdemod-playground is up to date
 archlinuxfr is up to date
:: Replace akonadi with kdemod-unstable/kdemod-akonadi? [Y/n] y
:: Replace soprano with kdemod-unstable/kdemod-soprano? [Y/n] y
:: Replace kdemod-kdebase-runtime-icons with kdemod-unstable/oxygen-icons? [Y/n] y
error: failed to prepare transaction (could not satisfy dependencies)
:: Starting full system upgrade...
resolving dependencies...
error: cannot resolve "decibel", a dependency of "kdemod-kdenetwork-kopete"
:: kdemod-kdenetwork-kopete: requires decibel

Where is the package "decibel" ?
Thanks.

Last edited by windu.2b (2009-04-09 22:19:06)

Offline

#34 2009-04-09 22:22:03

Solid1986Snake
Member
Registered: 2007-06-18
Posts: 258

Re: [Closed] KDE 4.3 beta (4.2.63) repo

@windu

you do not upgrade to kde beta, you are upgrading to latest kdemod-unstable! Its not the same! please uninstall first and then install packages from this repo here....

Offline

#35 2009-04-11 12:07:05

EvilSide
Member
Registered: 2008-04-09
Posts: 79

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Adding new panel is not working for me. (i686 and x86_64 builds).
Someone to confirm?

Offline

#36 2009-04-11 14:34:10

Spy
Member
Registered: 2009-02-26
Posts: 78

Re: [Closed] KDE 4.3 beta (4.2.63) repo

nope dude ,  only I get plasma crash when I minimalising Konqueror with open proxy options.... strange.

Offline

#37 2009-04-12 16:37:16

b9anders
Member
Registered: 2007-11-07
Posts: 691

Re: [Closed] KDE 4.3 beta (4.2.63) repo

I am using it now. feels solid and neat.

can't find the new air theme though. sad

Offline

#38 2009-04-13 10:50:38

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

I'm finally back so lets take a look on it:

windu2b: as  solidSnake said, you need to remove kdemod packages and then install kde-4.3-beta (just put my repo first in pacman.conf and run pacman -Sy kde).
EvilSide: don't worry, it doesn't work for me neither
Spy: works here
b9ander: maybe it was not yet comitted into the SVN. Honestly, I didn't even know about it but it looks wonderful!!! I'll keep watching for it

That's all? Wow it seems to be really stable :-)

Offline

#39 2009-04-13 19:16:01

flamelab
Member
From: Athens, Hellas (Greece)
Registered: 2007-12-26
Posts: 2,160

Re: [Closed] KDE 4.3 beta (4.2.63) repo

b9anders wrote:

I am using it now. feels solid and neat.

can't find the new air theme though. sad

It's on AUR !

Offline

#40 2009-04-14 05:00:27

nfm
Member
Registered: 2008-06-13
Posts: 66

Re: [Closed] KDE 4.3 beta (4.2.63) repo

How do you install this? 'pacman -S kde' tries to install 4.2.2 version for me.
Edit: Ooops, I had to move the repo above the others in the pacman.conf smile

Last edited by nfm (2009-04-14 05:07:47)

Offline

#41 2009-04-19 15:16:23

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Hi there,
I just want to announce, that I won't probably provide version 4.2.70. The reason is that there are big problems with compilation (kdepimlibs,kdebindings etc.) and I don't have enough informations (there's nothing on google) and time to sort them out.
Sorry guys. I hope .71 will work better.

Have a nice day.

Offline

#42 2009-04-22 08:18:57

Spy
Member
Registered: 2009-02-26
Posts: 78

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Wait for .71 , hope you find all informations...

Offline

#43 2009-04-30 10:40:37

Spy
Member
Registered: 2009-02-26
Posts: 78

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Something new ?

Offline

#44 2009-05-02 12:39:46

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Hi,
at this time I'm fighting damned Akonadi in KDE 4.2.71. There are some difficulties that force me to use some specific source revisions from SVN to build it. I hope I'll be able to provide update soon.

Edit: Damned Akonadi mad!!!! Who on Earth uses that crap? If there were no miracle in following hours I'm afraid .71 will be declared as another useless snapshot...

Last edited by ProgDan (2009-05-02 22:56:26)

Offline

#45 2009-05-03 13:26:00

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Guess what my friends....yes - I've done it. 4.2.71.svn961800 is here for you cool smile It was tought fight with many causalities on both sides, but I have won and Akonadi can...you know what :-)

But - there are few important things.
First: there are no kdebindings. Not because they were removed from KDE but because they simply can't be compiled. I'll try later to build them again using some new svn revisions, but I seriously doubt it would work. Uninstall current kdebindings before updating (it's not safe :-) ) It is very probable that some parts of KDE (especially those written in Python) will not work.
Second: I had to compile kdeedu without Kalzium. I hope there are no chemists between you...:-)
And third: I also had to make some modifications in the sources and header files and I'm really not sure if it won't have some negative consequences on stability and functionality, so if you find something please leave me a message, I'll try to fix it.

Thanks for you patience and stay tuned wink

Last edited by ProgDan (2009-05-03 15:17:00)

Offline

#46 2009-05-03 15:22:10

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

I just found there are some conflicting files between some of the packages. You can safely overwrite them using pacman's -f switch.
Developers probably can't agree which package will provide the icons...:-)

Offline

#47 2009-05-12 06:02:51

Lifty
Member
Registered: 2006-11-05
Posts: 62

Re: [Closed] KDE 4.3 beta (4.2.63) repo

4.2.85 has appeared. Are you going to build that too?

Offline

#48 2009-05-12 15:00:32

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Don't worry, I'm already building :-)

Offline

#49 2009-05-12 15:07:06

Pierre
Developer
From: Bonn
Registered: 2004-07-05
Posts: 1,956
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Let me know if you got it running. Some modules don't build at all for me and kdebindings is broken, too. That's also the reason why beta 1 is not released yet.

Offline

#50 2009-05-12 15:12:16

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: [Closed] KDE 4.3 beta (4.2.63) repo

I'm using the svn stuff from markc's daily svn snapshots, it says 4.2.85 and works. Just a heads up.

Last edited by lucke (2009-05-12 15:13:21)

Offline

Board footer

Powered by FluxBB