You are not logged in.

#76 2009-05-21 20:25:49

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

kensai wrote:
ProgDan wrote:

You are welcome :-)
I'm already working on 4.2.87...

You tell me if that is more stable and I'll upgrade. wink

Well there are some problems with building kdebindings (again!!!!) so it will take me some time...By the way I believe that 4.2.85 is already stable enought for everyday use as I use it every day smile

Offline

#77 2009-05-22 12:49:48

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Updated to 4.2.87! I just was not able to build kdebindings (Python -> PyKDE -> kio -> kssl) but I believe it is safe to stay with current kdebindings from 4.2.85.

Update it, use it and report bugs please :-)

Offline

#78 2009-05-23 13:56:57

benji
Member
Registered: 2009-05-23
Posts: 5

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Hi
In 4.2.87 gwenview back to work tongue but this time I've got problem with Ark.  Couldn't open rar files

 Failed to locate program 'rar' in PATH

console:

Fatal Error: Accessed global static 'KCatalogStaticData *catalogStaticData()' after destruction. Defined at /home/progdan/PKGBUILDs/kde-4.3-beta-i686/build/kdelibs/src/kdelibs-4.2.87svn969966/kdecore/localization/kcatalog.cpp:69
KCrash: Application 'ark' crashing...

Offline

#79 2009-05-23 14:06:08

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Ark works good for me. Try to check if you have "rar" program installed and it's in your $PATH (which rar) .

Offline

#80 2009-05-23 22:18:11

benji
Member
Registered: 2009-05-23
Posts: 5

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Strange :] In build before 4.2.85 was ok

which: no rar in (/bin:/usr/bin:/sbin:/usr/sbin:/opt/java/jre/bin:/opt/kde/bin:/usr/bin/perlbin/site:/usr/bin/perlbin/vendor:/usr/bin/perlbin/core:/opt/qt/bin)
sudo pacman -Qe | grep rar
unrar 3.9.3-1

Cheers

Offline

#81 2009-05-23 23:13:23

jwcxz
Member
Registered: 2008-09-23
Posts: 239
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

benji: urnar does not provide rar.  You need:
http://aur.archlinux.org/packages.php?ID=20760

Edit: also there's a pkgbuild for a beta version:
http://aur.archlinux.org/packages.php?ID=17443

Last edited by jwcxz (2009-05-23 23:14:39)


-- jwc
http://jwcxz.com/ | blog
dotman - manage your dotfiles across multiple environments
icsy - an alarm for powernappers

Offline

#82 2009-05-24 07:25:20

benji
Member
Registered: 2009-05-23
Posts: 5

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Wow I didn't now. Now it works thanks smile

Last edited by benji (2009-05-24 11:09:55)

Offline

#83 2009-05-24 10:10:58

EvilSide
Member
Registered: 2008-04-09
Posts: 79

Re: [Closed] KDE 4.3 beta (4.2.63) repo

@ProgDan, could you please share your PKGBUILDS of 4.2.87?
I wanna make some modifications and compile kde4svn-minimal for best performance. smile

P.S. 4.2.87 works awesome. And gwenview works tongue

Offline

#84 2009-05-24 13:39:51

dan.boff
Member
Registered: 2009-04-07
Posts: 42

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Fehler: Konnte Datei 'kdebindings-4.2.85-1-i686.pkg.tar.gz' nicht von repo.progdansoft.com übertragen : Not Found

I'm using x86_64 though. is there an error in the package, linking to -i686? it should link to x86-64, which is indeed on the server

Offline

#85 2009-05-24 16:07:05

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

EvilSide:
Sure, PKBUILDs together with Pierre's build scripts are here: http://repo.progdansoft.com/kde-4.3-bet … ds.tar.bz2

dan.boff:
Fixed.

I'll be off from Monday to Friday and I will not have access to the internet ( hmm ) so please be patient with more request. Thanks.

Last edited by ProgDan (2009-05-24 16:10:55)

Offline

#86 2009-05-24 19:12:43

dan.boff
Member
Registered: 2009-04-07
Posts: 42

Re: [Closed] KDE 4.3 beta (4.2.63) repo

kdebindings is still broken:
:: Die Datei kdebindings-4.2.85-1-x86_64.pkg.tar.gz ist beschädigt. Möchten Sie sie löschen? [J/n]

(kdebindings-4.2.85-1-x86_64.pkg.tar.gz is broken, do you want to remove it? [y/n]

Offline

#87 2009-05-24 19:34:47

ProgDan
Member
From: Teplice, Czech Republic
Registered: 2007-10-04
Posts: 441
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Omg, I forgot to update md5sum...sorry, I'll fix it later tonight. Check it tomorrow or just manually download the package and install it via pacman -U.

Offline

#88 2009-05-24 20:26:11

dan.boff
Member
Registered: 2009-04-07
Posts: 42

Re: [Closed] KDE 4.3 beta (4.2.63) repo

kk, thanks

Offline

#89 2009-05-26 08:59:54

utak3r
Member
From: Szczecin, Poland
Registered: 2009-03-09
Posts: 11
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Hello there smile
First: thanks for your time to build all of this smile I'm just installing a whole thing to test-drive it...

There's one confilict: icons are both in kde-base-runtime and oxygen-icons, so I need to use -f option to let it go.

Offline

#90 2009-05-26 10:39:43

titoum
Member
Registered: 2009-04-06
Posts: 8

Re: [Closed] KDE 4.3 beta (4.2.63) repo

Hi,

i am experimenting memory issue with the current kde 4.2

i added your repo into the pacman.conf as mentionned in the first reply, but how do i switch to use those package instead of the current one?
do i have to remove kde first?

thank you in advance for your help!

:-)

Offline

#91 2009-05-26 12:17:27

kensai
Member
From: Puerto Rico
Registered: 2005-06-03
Posts: 2,479
Website

Re: [Closed] KDE 4.3 beta (4.2.63) repo

titoum wrote:

i added your repo into the pacman.conf as mentionned in the first reply, but how do i switch to use those package instead of the current one?
do i have to remove kde first?
:-)

Make sure you add progdan's repo right before all the others in pacman.conf


Follow me in: Identi.ca, Twitter, Google+

Offline

#92 2009-05-26 13:18:20

titoum
Member
Registered: 2009-04-06
Posts: 8

Re: [Closed] KDE 4.3 beta (4.2.63) repo

thank that seems to do the trick.

now i have this

titoum@titoum-laptop bin]$ sudo pacman -S kde
kde package not found, searching for group...
:: group kde (including ignored packages):
    kdeaccessibility  kdeadmin  kdeartwork  kdebase  kdebase-runtime  kdebase-workspace  kdebindings  kdeedu
    kdegames  kdegraphics  kdelibs  kdemultimedia  kdenetwork  kdepim  kdepimlibs  kdeplasma-addons  kdesdk
    kdetoys  kdeutils  kdewebdev  oxygen-icons
:: Install whole content? [Y/n]
:: group kde (including ignored packages):
    kdeaccessibility  kdeadmin  kdeartwork  kdebase  kdebase-runtime  kdebase-workspace  kdeedu  kdegames
    kdegraphics  kdelibs  kdemultimedia  kdenetwork  kdepim  kdepimlibs  kdeplasma-addons  kdesdk  kdetoys
    kdeutils  kdewebdev
:: Install whole content? [Y/n]
resolving dependencies...
looking for inter-conflicts...
:: pyqt-dev conflicts with pyqt. Remove pyqt? [Y/n]
:: sip-dev conflicts with sip. Remove sip? [Y/n] ^C
Interrupt signal received

can i safely say yes? i mean, is this normal behavior?

Offline

#93 2009-05-26 13:42:50

countercraft
Member
From: Aracaju, SE - Brazil
Registered: 2008-03-30
Posts: 31

Re: [Closed] KDE 4.3 beta (4.2.63) repo

This conflict is because KDE needes the newest snapshot of PyQt. It's safe to say yes.

Offline

#94 2009-05-28 09:04:56

titoum
Member
Registered: 2009-04-06
Posts: 8

Re: [Closed] KDE 4.3 beta (4.2.63) repo

one step further:

looking for inter-conflicts...

Targets (28): kdelibs-4.2.87svn969966-1  kdeaccessibility-4.2.87svn969966-1  oxygen-icons-4.2.87svn969966-1  libasyncns-0.7-1  liboil-0.3.16-1  pulseaudio-0.9.15-1
              kdebase-runtime-4.2.87svn969966-1  kdegraphics-4.2.87svn969966-1  akonadi-1.1.85-1  kdepimlibs-4.2.87svn969966-1  sip-dev-4.8-6  qscintilla-dev-2.4-2
              pyqt-dev-4.5-6  kdebindings-4.2.85-1  kdeadmin-4.2.87svn969966-1  kdebase-workspace-4.2.87svn969966-1  kdeartwork-4.2.87svn969966-1  kdebase-4.2.87svn969966-1
              kdeedu-4.2.87svn969966-1  kdegames-4.2.87svn969966-1  kdemultimedia-4.2.87svn969966-1  libgadu-1.8.2-2  kdenetwork-4.2.87svn969966-2
              kdeplasma-addons-4.2.87svn969966-1  kdesdk-4.2.87svn969966-1  kdetoys-4.2.87svn969966-1  kdeutils-4.2.87svn969966-1  kdewebdev-4.2.87svn969966-1

Total Download Size:    0.00 MB
Total Installed Size:   748.32 MB

Proceed with installation? [Y/n]
checking package integrity...
(28/28) checking for file conflicts                 [######################################################################################################################] 100%
error: could not prepare transaction
error: failed to commit transaction (conflicting files)
/usr/share/icons/oxygen/scalable/apps/accessories-dictionary.svgz exists in both 'oxygen-icons' and 'kdeplasma-addons'
Errors occurred, no packages were upgraded.

i had the same problem with kdepim and i just removed it, but plasma-addons ? :s

Offline

#95 2009-05-28 09:08:55

Solid1986Snake
Member
Registered: 2007-06-18
Posts: 258

Re: [Closed] KDE 4.3 beta (4.2.63) repo

titoum wrote:

one step further:

looking for inter-conflicts...

Targets (28): kdelibs-4.2.87svn969966-1  kdeaccessibility-4.2.87svn969966-1  oxygen-icons-4.2.87svn969966-1  libasyncns-0.7-1  liboil-0.3.16-1  pulseaudio-0.9.15-1
              kdebase-runtime-4.2.87svn969966-1  kdegraphics-4.2.87svn969966-1  akonadi-1.1.85-1  kdepimlibs-4.2.87svn969966-1  sip-dev-4.8-6  qscintilla-dev-2.4-2
              pyqt-dev-4.5-6  kdebindings-4.2.85-1  kdeadmin-4.2.87svn969966-1  kdebase-workspace-4.2.87svn969966-1  kdeartwork-4.2.87svn969966-1  kdebase-4.2.87svn969966-1
              kdeedu-4.2.87svn969966-1  kdegames-4.2.87svn969966-1  kdemultimedia-4.2.87svn969966-1  libgadu-1.8.2-2  kdenetwork-4.2.87svn969966-2
              kdeplasma-addons-4.2.87svn969966-1  kdesdk-4.2.87svn969966-1  kdetoys-4.2.87svn969966-1  kdeutils-4.2.87svn969966-1  kdewebdev-4.2.87svn969966-1

Total Download Size:    0.00 MB
Total Installed Size:   748.32 MB

Proceed with installation? [Y/n]
checking package integrity...
(28/28) checking for file conflicts                 [######################################################################################################################] 100%
error: could not prepare transaction
error: failed to commit transaction (conflicting files)
/usr/share/icons/oxygen/scalable/apps/accessories-dictionary.svgz exists in both 'oxygen-icons' and 'kdeplasma-addons'
Errors occurred, no packages were upgraded.

i had the same problem with kdepim and i just removed it, but plasma-addons ? :s

pacman -Sf it...

there just some redundant icons.... no bigger prolems so far I think...

Offline

#96 2009-05-28 09:52:38

titoum
Member
Registered: 2009-04-06
Posts: 8

Re: [Closed] KDE 4.3 beta (4.2.63) repo

i just removed the plasma-addons and it ran fine.

i will try to install them again

Offline

#97 2009-05-28 10:00:22

Solid1986Snake
Member
Registered: 2007-06-18
Posts: 258

Re: [Closed] KDE 4.3 beta (4.2.63) repo

pacman -Sf kdeplasma-addons kdepim

like I said! There are just some redundant icons in the packages.... you cannot expect from upstream work in progress beta packages that they work perfectly integrated....

Offline

#98 2009-05-28 13:18:38

titoum
Member
Registered: 2009-04-06
Posts: 8

Re: [Closed] KDE 4.3 beta (4.2.63) repo

yup works great :-)

did you try the printing config? for me it crashes :-/

Offline

#99 2009-05-28 15:21:45

deadspider187
Member
Registered: 2008-02-04
Posts: 35

Re: [Closed] KDE 4.3 beta (4.2.63) repo

I can't seem to find a knetworkmanager applet with this repo.  What have you guys been using for a networkmanager applet?


1090T|HD4250|2GB|500GB|Arch x64
Ci7 2.66GHZ|HD5850|6GB|4x500GB|Win 7

Offline

#100 2009-05-28 16:02:19

EvilSide
Member
Registered: 2008-04-09
Posts: 79

Re: [Closed] KDE 4.3 beta (4.2.63) repo

@deadspider187, this wink

Last edited by EvilSide (2009-05-28 16:02:27)

Offline

Board footer

Powered by FluxBB