You are not logged in.

#2926 2016-04-24 07:30:26

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 291

Re: Discussion: the ati/radeon open source drivers & radeon repository

gee wrote:

@lordheavy: I'm not sure why, but I don't get compute shaders in glxinfo even with your latest builds.
Do I need to install something on top of opencl-mesa for it to show or a newer kernel than in testing? or maybe is there a new setting for the autogen step?


Thanks!

Probably it depends on your video card?

Here:

$ glxinfo | grep compute
    GL_ARB_compute_shader, GL_ARB_conditional_render_inverted, 
    GL_ARB_compute_shader, GL_ARB_conditional_render_inverted, 

Offline

#2927 2016-04-24 08:54:48

gee
Member
Registered: 2006-11-29
Posts: 310

Re: Discussion: the ati/radeon open source drivers & radeon repository

It's a 280x/7970HD it should support it I believe. Am I wrong?

glxinfo: Device: AMD TAHITI (DRM 2.43.0, LLVM 3.9.0) (0x6798).
lspci: 01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X] (prog-if 00 [VGA controller])

Last edited by gee (2016-04-24 09:13:28)

Offline

#2928 2016-04-24 09:23:29

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 291

Re: Discussion: the ati/radeon open source drivers & radeon repository

gee wrote:

It's a 280x/7970HD it should support it I believe. Am I wrong?

glxinfo: Device: AMD TAHITI (DRM 2.43.0, LLVM 3.9.0) (0x6798).
lspci: 01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X] (prog-if 00 [VGA controller])

For this card you need kernel from Alexander Deucher (the future kernel 4.7), because current kernels are missing bits to expose compute shaders
See https://cgit.freedesktop.org/~agd5f/lin … xt-4.7-wip (this patch https://cgit.freedesktop.org/~agd5f/lin … d53afab21)

Offline

#2929 2016-04-24 09:24:38

gee
Member
Registered: 2006-11-29
Posts: 310

Re: Discussion: the ati/radeon open source drivers & radeon repository

Ooooh I see, thank you so much!
I was going crazy not understanding this!

I am building the wip kernel and will report.

Last edited by gee (2016-04-24 09:57:21)

Offline

#2930 2016-04-24 10:07:20

gee
Member
Registered: 2006-11-29
Posts: 310

Re: Discussion: the ati/radeon open source drivers & radeon repository

That worked thank you!
Now I need to find something that can use this new extension smile

I'll try patching 4.5.2 and see if it works as well. I applied the patch you linked, and the previous one that changed the drm version.

edit: Well that seems to work as well!

Last edited by gee (2016-04-24 10:34:36)

Offline

#2931 2016-04-28 13:01:51

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,455

Re: Discussion: the ati/radeon open source drivers & radeon repository

a new build fail with intel-vulkan : https://bugs.freedesktop.org/show_bug.cgi?id=95182

I commented vulkan support out for Aur mesa-git & lib32-mesa-git .

EDIT : solved by upstream

Last edited by Lone_Wolf (2016-04-29 12:22:39)


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#2932 2016-05-18 22:27:56

haagch
Member
Registered: 2013-08-17
Posts: 209

Re: Discussion: the ati/radeon open source drivers & radeon repository

Anyone else getting
LLVM ERROR: branch size exceeds simm16
with the last one or two updates?

Downgraded from 269966 to 269746 and it works again.

Whatever exactly this does... http://reviews.llvm.org/D20227

Offline

#2933 2016-05-19 06:17:37

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 291

Re: Discussion: the ati/radeon open source drivers & radeon repository

haagch wrote:

Anyone else getting
LLVM ERROR: branch size exceeds simm16
with the last one or two updates?

Downgraded from 269966 to 269746 and it works again.

Whatever exactly this does... http://reviews.llvm.org/D20227

Yes, i get this with Tomb Raider.

Offline

#2934 2016-05-20 15:12:00

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 9,455

Re: Discussion: the ati/radeon open source drivers & radeon repository

For mesa-git related posts,please use https://bbs.archlinux.org/viewtopic.php?id=212819 from now on.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.
Did you use the guided installer ? If yes, I can't help you.

(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#2935 2016-05-22 20:45:48

haagch
Member
Registered: 2013-08-17
Posts: 209

Re: Discussion: the ati/radeon open source drivers & radeon repository

Can anyone actually use VCE encoding? I'm trying a simple pipeline like
gst-launch-1.0 videotestsrc ! omxh264enc ! "video/x-h264,profile=high" ! h264parse ! matroskamux ! filesink location=output.avi
and get this puzzling message:
OMX-could not load /usr/lib/bellagio/libomxvideosched.so ==> OMX.st.video.scheduler ==> OMX.st.video.scheduler: ==> 2 1,456192 1,304128: /usr/lib/bellagio/libomxvideosched.so ==> OMX.st.video.scheduler ==> OMX.st.video.scheduler: ==> 2 1,456192 1,304128: cannot open shared object file: No such file or directory

It's confusing until you try to run it with strace:
open("/usr/lib/bellagio/libomxvideosched.so ==> OMX.st.video.scheduler ==> OMX.st.video.scheduler: ==> 2 1,456192 1,304128", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)

Yes, it tries to open the whole thing as a filename.
In ~/.omxregister I have

/usr/lib/bellagio/libomxvideosched.so ==> OMX.st.video.scheduler ==> OMX.st.video.scheduler: ==> 2 1,456192 1,304128
/usr/lib/bellagio/libomx_mesa.so
BELLAGIO_SEARCH_PATHOMX-Failed to write %zu bytes to fd %d
OMX-Component % ==> OMX.mesa.video_decoder ==> OMX.mesa.video_decoder.mpeg2:OMX.mesa.video_decoder.avc:
 ==> OMX.mesa.video_encoder ==> OMX.mesa.video_encoder.avc:
/usr/lib/bellagio/libomxaudio_effects.so
BELLAGIO_SEARCH_PATHOMX-Failed to write %zu bytes to fd ==> OMX.st.volume.component ==> OMX.st.volume.component: ==> 2 1,65536 1,32768
 ==> OMX.st.audio.mixer ==> OMX.st.audio.mixer: ==> 1 50,60000
/usr/lib/bellagio/libomxclocksrc.so
BELLAGIO_SEARCH_PATHOMX-Failed to write %zu bytes to fd %d ==> OMX.st.clocksrc ==> OMX.st.clocksrc:

so I think that omxregister-bellagio screws up. But why? And how? When I remove the thing starting with ==> from the first line so only /usr/lib/bellagio/libomxvideosched.so remains and then try to run the gstreamer pipeline again I get

OMX-Component not found with current ST static component loader.
OMX-Component not found with current ST static component loader.

But... What does that mean? Does VCE encoding work for *anyone*? If yes, can someone with it working post ~/.omxregister to compare how a working one looks like?

Edit:
https://sourceforge.net/p/omxil/omxil/c … ter.c#l187
template.jpg

Last edited by haagch (2016-05-22 20:57:39)

Offline

#2936 2016-05-26 22:53:30

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,627
Website

Re: Discussion: the ati/radeon open source drivers & radeon repository

This has now been superseded. Relevant thread here: https://bbs.archlinux.org/viewtopic.php?id=212819



Closing


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB