You are not logged in.

#2226 2012-02-23 11:43:32

dekomote
Member
Registered: 2011-03-14
Posts: 6

Re: Discussion: the ati/radeon open source drivers & radeon repository

Using the perry3d repo on Juniper hardware, with KDE 4.8, there's a weird issue involving xrender. If you have dual head setup side by side, the desktop looks scrambled and skewed. It works good if the monitors are positioned one on top of another. Also, this doesn't appear to mess the cursor. The cursor looks as it should, but the whole desktop is a mess. No errors in Xorg/dmesg whatsoever.

Offline

#2227 2012-02-25 14:46:58

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: Discussion: the ati/radeon open source drivers & radeon repository

Am I really the only one where lib32 mesa + wine doesn't work when lib32 mesa is compiled with -O2?

With -O1 compiled mesa is 0,83 MiB smaller than with -O2...

Native 64 bit mesa works fine...

Since this has been the case for quite some time now I consider actually opening a bug report... But how would I get more information on the issue? wine programs just refuse to start with various errors like "Couldn't load game.dll" in case of warcraft 3 for example...


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#2228 2012-02-27 20:04:44

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,240

Re: Discussion: the ati/radeon open source drivers & radeon repository

Cdh, can you give some freely available programs/games where you have these issues ?

then it would be easier/possible for others to test.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#2229 2012-02-27 21:23:46

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: Discussion: the ati/radeon open source drivers & radeon repository

I had posted earlier:
https://bbs.archlinux.org/viewtopic.php … 1#p1030571
There's the demo of warcraft 3 that has the same issue, trackmania nations wouldn't run, furmark also crashes on startup...

However, there seem to be zero other persons having that problem...?

Since furmark has the most verbose crash output:

Unhandled exception: page fault on read access to 0xffffffff in 32-bit code (0x7d5bf47d).
Register dump:
 CS:0023 SS:002b DS:002b ES:002b FS:0063 GS:006b
 EIP:7d5bf47d ESP:0033e964 EBP:00000000 EFLAGS:00210242(  R- --  I  Z- - - )
 EAX:7ca4bb60 EBX:7d9cbff4 ECX:00000001 EDX:00000000
 ESI:0033eb00 EDI:7ca4bb60
Stack dump:
0x0033e964:  7ca4bb60 0003c000 00008092 00000000
0x0033e974:  00000000 7cb5f128 f762d400 00000a14
0x0033e984:  00000000 7c9e6190 7c9dfc00 00000000
0x0033e994:  7cab98b8 7ca4b148 0033eb40 7d5bff52
0x0033e9a4:  7c9dfc00 7ca4b148 00028000 00000000
0x0033e9b4:  00000040 00000000 00008092 00000002
000c: sel=0067 base=00000000 limit=00000000 32-bit r-x
Backtrace:
=>0 0x7d5bf47d in r600_dri.so (+0x2647d) (0x00000000)
  1 0x7d7e1426 in r600_dri.so (+0x248425) (0x7c9dfc00)
  2 0x7d5b3139 in r600_dri.so (+0x1a138) (0x7c9dfc00)
  3 0x7d5f60e8 in r600_dri.so (+0x5d0e7) (0x00000001)
  4 0x7d5e1595 in r600_dri.so (+0x48594) (0x7cb5eab8)
  5 0x7d5af6e9 in r600_dri.so (+0x166e8) (0x00000000)
  6 0x7d5af847 in r600_dri.so (+0x16846) (0x7c9cdeb0)
  7 0x7d5af87f in r600_dri.so (+0x1687e) (0x7c9cdeb0)
  8 0x7e915396 in libgl.so.1 (+0x41395) (0x7c9cdeb0)
  9 0x7e8ec151 in libgl.so.1 (+0x18150) (0x00000000)
  10 0x7e8eca75 glXCreateContext+0x84() in libgl.so.1 (0x0033eefc)
  11 0x7de49d02 in winex11 (+0x29d01) (0x0033eefc)
  12 0x7de4e4fa in winex11 (+0x2e4f9) (0x0033ef5c)
  13 0x7ea796a2 wglCreateContext+0x61() in gdi32 (0x0033ef9c)
  14 0x7e5bd97e in opengl32 (+0x6d97d) (0x0033efbc)
  15 0x00442088 in furmark (+0x42087) (0x0033f030)
  16 0x00423e2d in furmark (+0x23e2c) (0x0033f040)
  17 0x0041dcc5 in furmark (+0x1dcc4) (0x0033f2c4)
  18 0x0041df4a in furmark (+0x1df49) (0x0033f2e8)
  19 0x00410522 in furmark (+0x10521) (0x0033fde0)
  20 0x00457ca3 in furmark (+0x57ca2) (0x0033fe70)
  21 0x7b85a4bc call_process_entry+0xb() in kernel32 (0x0033fe88)
  22 0x7b85b72f in kernel32 (+0x4b72e) (0x0033fec8)
  23 0x7bc75850 call_thread_func_wrapper+0xb() in ntdll (0x0033fed8)
  24 0x7bc77dbd call_thread_func+0x7c() in ntdll (0x0033ffa8)
  25 0x7bc7582e RtlRaiseException+0x21() in ntdll (0x0033ffc8)
  26 0x7bc4c92e call_dll_entry_point+0x33d() in ntdll (0x0033ffe8)
  27 0xf76558bd wine_call_on_stack+0x1c() in libwine.so.1 (0x00000000)
  28 0xf765597b wine_switch_to_stack+0x2a() in libwine.so.1 (0xff9f2948)
  29 0x7bc525f6 LdrInitializeThunk+0x3b5() in ntdll (0xff9f29b8)
  30 0x7b86184a __wine_kernel_init+0xa19() in kernel32 (0xff9f3b58)
  31 0x7bc52d4b __wine_process_init+0x25a() in ntdll (0xff9f3bd8)
  32 0xf7652dfc wine_init+0x28b() in libwine.so.1 (0xff9f3c38)
  33 0x7bf00d6b main+0x8a() in <wine-loader> (0xff9f4088)
  34 0xf74a8483 __libc_start_main+0xf2() in libc.so.6 (0x00000000)
0x7d5bf47d: 	
Modules:
Module	Address			Debug info	Name (87 modules)
PE	  400000-  7db000	Export          furmark
PE	  7e0000-  9c5000	Deferred        freeimage
PE	10000000-1022e000	Deferred        core3d
ELF	7b800000-7b9f6000	Dwarf           kernel32<elf>
  \-PE	7b810000-7b9f6000	\               kernel32
ELF	7bc00000-7bcd2000	Dwarf           ntdll<elf>
  \-PE	7bc10000-7bcd2000	\               ntdll
ELF	7bf00000-7bf04000	Dwarf           <wine-loader>
ELF	7d53c000-7d547000	Deferred        libdrm_radeon.so.1
ELF	7d599000-7dbaf000	Dwarf           r600_dri.so
ELF	7dbaf000-7dbba000	Deferred        libxcursor.so.1
ELF	7dbd4000-7dc0a000	Deferred        uxtheme<elf>
  \-PE	7dbe0000-7dc0a000	\               uxtheme
ELF	7dd5a000-7dd84000	Deferred        libexpat.so.1
ELF	7dd84000-7ddb9000	Deferred        libfontconfig.so.1
ELF	7ddbb000-7ddc1000	Deferred        libtxc_dxtn.so
ELF	7de0b000-7dea7000	Dwarf           winex11<elf>
  \-PE	7de20000-7dea7000	\               winex11
ELF	7dea7000-7deb7000	Deferred        libbz2.so.1.0
ELF	7deb7000-7dece000	Deferred        libz.so.1
ELF	7dece000-7df6a000	Deferred        libfreetype.so.6
ELF	7df70000-7df80000	Deferred        libxi.so.6
ELF	7df80000-7df84000	Deferred        libxcomposite.so.1
ELF	7df84000-7df8d000	Deferred        libxrandr.so.2
ELF	7df8d000-7df98000	Deferred        libxrender.so.1
ELF	7df98000-7dfbc000	Deferred        imm32<elf>
  \-PE	7dfa0000-7dfbc000	\               imm32
ELF	7dfbc000-7dff0000	Deferred        ws2_32<elf>
  \-PE	7dfc0000-7dff0000	\               ws2_32
ELF	7dff0000-7e063000	Deferred        shlwapi<elf>
  \-PE	7e000000-7e063000	\               shlwapi
ELF	7e063000-7e286000	Deferred        shell32<elf>
  \-PE	7e070000-7e286000	\               shell32
ELF	7e286000-7e2b2000	Deferred        msvfw32<elf>
  \-PE	7e290000-7e2b2000	\               msvfw32
ELF	7e2b2000-7e330000	Deferred        rpcrt4<elf>
  \-PE	7e2c0000-7e330000	\               rpcrt4
ELF	7e330000-7e457000	Deferred        ole32<elf>
  \-PE	7e350000-7e457000	\               ole32
ELF	7e457000-7e508000	Deferred        winmm<elf>
  \-PE	7e460000-7e508000	\               winmm
ELF	7e508000-7e50e000	Deferred        libuuid.so.1
ELF	7e50e000-7e528000	Deferred        libice.so.6
ELF	7e528000-7e531000	Deferred        libsm.so.6
ELF	7e531000-7e60c000	Dwarf           opengl32<elf>
  \-PE	7e550000-7e60c000	\               opengl32
ELF	7e60c000-7e615000	Deferred        librt.so.1
ELF	7e615000-7e61c000	Deferred        libxdmcp.so.6
ELF	7e61c000-7e620000	Deferred        libxau.so.6
ELF	7e620000-7e62d000	Deferred        libdrm.so.2
ELF	7e62d000-7e633000	Deferred        libxxf86vm.so.1
ELF	7e633000-7e653000	Deferred        libxcb.so.1
ELF	7e653000-7e669000	Deferred        libxcb-glx.so.0
ELF	7e669000-7e7a1000	Deferred        libx11.so.6
ELF	7e7a1000-7e7a7000	Deferred        libxfixes.so.3
ELF	7e7a7000-7e7ba000	Deferred        libxext.so.6
ELF	7e7ba000-7e7d0000	Deferred        libglapi.so.0
ELF	7e7d0000-7e7eb000	Deferred        libgcc_s.so.1
ELF	7e8d4000-7e92e000	Dwarf           libgl.so.1
ELF	7e92e000-7e9a4000	Deferred        libglu.so.1
ELF	7e9a5000-7e9a9000	Deferred        libxinerama.so.1
ELF	7e9a9000-7e9cc000	Deferred        iphlpapi<elf>
  \-PE	7e9b0000-7e9cc000	\               iphlpapi
ELF	7e9cc000-7e9f6000	Deferred        msacm32<elf>
  \-PE	7e9d0000-7e9f6000	\               msacm32
ELF	7e9f6000-7eac2000	Dwarf           gdi32<elf>
  \-PE	7ea00000-7eac2000	\               gdi32
ELF	7eac2000-7ec14000	Deferred        user32<elf>
  \-PE	7ead0000-7ec14000	\               user32
ELF	7ec14000-7ed17000	Deferred        comctl32<elf>
  \-PE	7ec20000-7ed17000	\               comctl32
ELF	7ed17000-7ed80000	Deferred        advapi32<elf>
  \-PE	7ed20000-7ed80000	\               advapi32
ELF	7ef80000-7efae000	Deferred        libm.so.6
ELF	7efaf000-7efc7000	Deferred        glu32<elf>
  \-PE	7efc0000-7efc7000	\               glu32
ELF	7efe6000-7f000000	Deferred        version<elf>
  \-PE	7eff0000-7f000000	\               version
ELF	f7432000-f7436000	Deferred        libxdamage.so.1
ELF	f7438000-f743d000	Deferred        libdl.so.2
ELF	f743d000-f7440000	Deferred        libx11-xcb.so.1
ELF	f7482000-f748f000	Deferred        libnss_files.so.2
ELF	f748f000-f7631000	Dwarf           libc.so.6
ELF	f7631000-f764c000	Deferred        libpthread.so.0
ELF	f764c000-f7790000	Dwarf           libwine.so.1
ELF	f7791000-f77b3000	Deferred        ld-linux.so.2
ELF	f77b3000-f77b4000	Deferred        [vdso].so
Threads:
process  tid      prio (all id:s are in hex)
00000008 (D) C:\Programme\Geeks3D\Benchmarks\FurMark_1.9.2\FurMark.exe
	00000009    0 <==
0000000e services.exe
	0000001f    0
	0000001e    0
	00000019    0
	00000018    0
	00000017    0
	00000015    0
	00000010    0
	0000000f    0
00000012 winedevice.exe
	0000001a    0
	00000014    0
	00000013    0
0000001b plugplay.exe
	00000020    0
	0000001d    0
	0000001c    0
00000021 explorer.exe
	00000022    0
System information:
    Wine build: wine-1.4-rc5
    Platform: i386
    Host system: Linux
    Host version: 3.3.0-1-mainline

The curious thing is that furmark starts up fine when started with

WINEDEBUG=+all wine FurMark.exe &> furmarkdebug.txt

But veeery slow of course.
However starting the actual benchmark crashes again. Warcraft 3 on the other hand renders opengl fine with WINEDEBUG=+all, however it's too slow to be useful.

In the meantime I added those lines to my lib32 mesa PKGBUILD:

export CFLAGS=$(echo "$CFLAGS" | sed "s/O2/O1/")
export CXXFLAGS="$CFLAGS"

And everything works as expected. (and the actual benchmark in furmark works)

I find it really hard to believe that I am the only person experiencing those problem... Or is there something wrong with my PKGBUILD? Looks like this now: http://pastebin.com/9J73mHmz

It's also curious that the -O1 package of lib32 mesa is 0.83 MB smaller than the -O2 mesa... For 20.00 MB package size that's quite a bit.

Last edited by Cdh (2012-02-27 21:25:07)


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#2230 2012-02-29 08:20:17

Wilco
Member
Registered: 2008-11-09
Posts: 431

Re: Discussion: the ati/radeon open source drivers & radeon repository

Quick question: I'm torn between Catalyst and xf86-video-ati. The former runs like crap but at least I can watch full HD movies with GPU decoding while the latter runs perfectly stable but has nog GPU offloading. I read somewhere that xbmc supports vaapi even with the open source driver. Is that true?

Offline

#2231 2012-02-29 10:21:17

Perry3D
Member
Registered: 2008-03-20
Posts: 542

Re: Discussion: the ati/radeon open source drivers & radeon repository

Here are some news concerning the open source driver and video acceleration: http://www.phoronix.com/scan.php?page=n … px=MTA2MzY

And here you can find the current features of this driver: http://www.x.org/wiki/RadeonFeature
As you can see it is still work in progress.

Offline

#2232 2012-02-29 11:16:24

Wilco
Member
Registered: 2008-11-09
Posts: 431

Re: Discussion: the ati/radeon open source drivers & radeon repository

Thanks Perry3D, I already found the feature matrix but the git was very silent about the WIP on vaapi. The Phoronix article sounds promising though.

Offline

#2233 2012-03-02 22:38:32

kett
Member
Registered: 2008-04-21
Posts: 104

Re: Discussion: the ati/radeon open source drivers & radeon repository

@CDH
I'm having problems with wine and the ati driver with that same error message

Unhandled exception: page fault on read access to 0xffffffff in 32-bit code 

It sounds like you are just rebuilding lib32-mesa with -O1 optimization.  Can you repost your pkgbuild?  The pastebin link doesn't go anywhere.

Offline

#2234 2012-03-02 23:56:20

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,240

Re: Discussion: the ati/radeon open source drivers & radeon repository

@Cdh :

The can't find game.dll message from warcraft 3 Demo looks like it has to do with  a copy-protection check.
trackmania does indeed crash.

my system has an AMD opteron processor, what do you have ?


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#2235 2012-03-02 23:59:43

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: Discussion: the ati/radeon open source drivers & radeon repository

edit: I'm on a notebook with 1st generation intel i5 and HD 6550HD.

Indeed it vanished:

64 bit:

pkgname=mesa-full-r600g
pkgver=20120302
_realver=8.1
pkgrel=1
pkgdesc="Full Mesa 3D graphics library with all its components, built from the git master branch (mesa 7.12). Compiles mesa for r600g (gallium)."
arch=(i686 x86_64)
url="http://mesa3d.org/"
license=('LGPL')
depends=('libdrm-git' 'dri2proto>=2.1' 'glproto>=1.4.10' 'libxxf86vm' 'libxdamage' 'expat>=2.0.1' 'libxmu' 'talloc' 'llvm')
makedepends=('pkgconfig' 'imake' 'xorg-server-devel')
provides=("libgl=${_realver}" "mesa=${_realver}" "ati-dri=${_realver}" 'libglapi' 'libegl' 'libgles' 'khrplatform-devel')
replaces=('libgl' 'mesa' 'ati-dri' 'libglapi' 'libegl' 'khrplatform-devel' 'libgles') 
conflicts=('libgl' 'mesa' 'ati-dri' 'mesa-full' 'libglapi' 'libegl' 'khrplatform-devel' 'libgles')

_gitroot="git://anongit.freedesktop.org/git/mesa/mesa"
_gitname="mesa"

build() {
   msg "Connecting to git.freedesktop.org GIT server...."

#   if [ -d $startdir/src/$_gitname ] ; then
#      cd $_gitname && git pull origin
#      msg "The local files are updated."
#   else
#      git clone $_gitroot
#   fi

 #  msg "GIT checkout done or server timeout"
   msg "Starting make..."

   rm -rf $startdir/src/$_gitname-build
   cp -rH $startdir/src/$_gitname $startdir/src/$_gitname-build
   cd ${srcdir}/${_gitname}-build

   cd "${startdir}/src/mesa-build"
   ./autogen.sh --prefix=/usr \
   --with-dri-driverdir=/usr/lib/xorg/modules/dri \
   --with-gallium-drivers=r600 \
   --with-dri-drivers= \
   --with-egl-platforms=x11,drm \
   --enable-texture-float \
   --enable-gles1 \
   --enable-gles2 \
   --enable-osmesa \
   --enable-egl \
   --enable-xorg \
   --enable-xa \
   --enable-vdpau \
   --enable-gallium-g3dvl \
   --enable-glx-tls \
   --enable-glu \
   --enable-gbm \
   --enable-gallium-gbm \
   --enable-shared-glapi \
   --enable-xorg \
   --enable-gallium-llvm \
   --enable-openvg \
   --enable-gallium-egl || return 1

   make || return 1
   make DESTDIR="${pkgdir}" install || return 1

   install -m755 -d "${pkgdir}/usr/lib/xorg/modules/extensions"
   ln -sf libglx.xorg ${pkgdir}/usr/lib/xorg/modules/extensions/libglx.so || return 1

   install -d ${pkgdir}/etc/profile.d
   echo '#!/bin/bash' > ${pkgdir}/etc/profile.d/mesa.sh
   echo 'export LIBGL_DRIVERS_PATH=/usr/lib/xorg/modules/dri:$LIBGL_DRIVERS_PATH
export VDPAU_DRIVER=r600
export R600_ENABLE_S3TC=1
export force_s3tc_enable=true

#opengl3
export R600_GLSL130=1
export R600_STREAMOUT=1

#introduces graphics errors (at least for me)
#export R600_TILING=1
' >> ${pkgdir}/etc/profile.d/mesa.sh
  chmod +x ${pkgdir}/etc/profile.d/mesa.sh
}

And the kind of messy 32 bit PKGBUILD:

pkgname=lib32-mesa-full-r600g
pkgver=20120302
_realver=8.1
pkgrel=1
pkgdesc="Full Mesa 3D graphics library with all its components, built from the git master branch (mesa 7.12). Compiles mesa for r600g (gallium)."
arch=(x86_64)
url="http://mesa3d.org/"
license=('LGPL')
depends=('lib32-libdrm-git' 'dri2proto>=2.1' 'glproto>=1.4.10' 'libxxf86vm' 'libxdamage' 'expat>=2.0.1' 'libxmu' 'talloc' 'lib32-llvm')
makedepends=('pkgconfig' 'imake' 'xorg-server-devel')
provides=("lib32-libgl=${_realver}" "lib32-mesa=${_realver}" "lib32-ati-dri=${_realver}" 'lib32-libglapi' 'lib32-libegl' 'lib32-libgles')
replaces=('lib32-libgl' 'lib32-mesa' 'lib32-ati-dri' 'lib32-libglapi' 'lib32-libegl' 'lib32-libgles')
conflicts=('lib32-libgl' 'lib32-mesa' 'lib32-ati-dri' 'lib32-libglapi' 'lib32-libegl' 'lib32-libgles')

_gitroot="git://anongit.freedesktop.org/git/mesa/mesa"
_gitname="mesa"

build() {
   msg "Connecting to git.freedesktop.org GIT server...."

#   if [ -d $startdir/src/$_gitname ] ; then
#      cd $_gitname && git pull origin
#      msg "The local files are updated."
#   else
#      git clone $_gitroot
#   fi

   rm -rf $startdir/src/$_gitname-build
   cp -rH $startdir/src/$_gitname $startdir/src/$_gitname-build
   cd ${srcdir}/${_gitname}-build


  export CC="gcc -m32"
  export CXX="g++ -m32"
  export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
  # for our llvm-config for 32 bit
  export LLVM_CONFIG=/usr/lib32/llvm/llvm-config

# when -O2 doesn't work
export CFLAGS=$(echo "$CFLAGS" | sed "s/O2/O1/")
export CXXFLAGS="$CFLAGS"

    ./autogen.sh --prefix=/usr \
    --with-dri-driverdir=/usr/lib32/xorg/modules/dri \
    --with-gallium-drivers=r600 \
    --with-dri-drivers= \
   --enable-texture-float \
   --enable-gles1 \
   --enable-gles2 \
   --enable-osmesa \
   --enable-egl \
   --enable-xorg \
   --enable-xa \
   --enable-vdpau \
   --enable-gallium-g3dvl \
   --enable-glx-tls \
   --enable-glu \
   --enable-gbm \
   --enable-gallium-gbm \
   --enable-shared-glapi \
   --enable-xorg \
   --disable-gallium-llvm \
   --enable-openvg \
   --enable-gallium-egl \
   --enable-32-bit \
   --libdir=/usr/lib32 || return 1

   make || return 1
   make DESTDIR="${pkgdir}" install || return 1

   cd ${srcdir}/${_gitname}-build

  rm -rf "${pkgdir}"/usr/{include,share,bin}

   install -d ${pkgdir}/etc/profile.d
   echo '#!/bin/bash' > ${pkgdir}/etc/profile.d/lib32-mesa.sh
   echo 'export LIBGL_DRIVERS_PATH=$LIBGL_DRIVERS_PATH:/usr/lib32/xorg/modules/dri' >> ${pkgdir}/etc/profile.d/lib32-mesa.sh
   chmod +x ${pkgdir}/etc/profile.d/lib32-mesa.sh
}

Last edited by Cdh (2012-03-03 00:00:43)


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#2236 2012-03-03 00:08:05

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,240

Re: Discussion: the ati/radeon open source drivers & radeon repository

given that both intel and amd systems suffer from this problem, it might have to do with a change in how gcc 4.6 optimizes code.

I suggest building lib32-mesa with -O2 on an older gcc version, 4.3 is in the aur i think.

If that gives the same errors, the problem is likely in lib32-mesa code.

Last edited by Lone_Wolf (2012-03-03 00:09:10)


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#2237 2012-03-06 15:37:24

JoKo
Member
Registered: 2010-04-09
Posts: 37

Re: Discussion: the ati/radeon open source drivers & radeon repository

Hello, everyone,

I am using the mesa-full package from the radeon repository. During my latest update checks I get the following message:

error: failed to prepare transaction (could not satisfy dependencies)
:: jasper: requires freeglut

freeglut is in conflict with mesa-full, is there any workaround?

Offline

#2238 2012-03-06 16:20:46

spirit
Member
Registered: 2010-03-19
Posts: 11

Re: Discussion: the ati/radeon open source drivers & radeon repository

Hi,same problem here.

I check the last package mesa-full-20120305, it's missing "replaces = freeglut" in pkginfo.

do we need to install freeglut ?

Offline

#2239 2012-03-06 17:37:51

Perry3D
Member
Registered: 2008-03-20
Posts: 542

Re: Discussion: the ati/radeon open source drivers & radeon repository

Hi,

i ran in the same problem: mesa-full doesn't contain freeglut anymore. For a quick workaround i removed the provides and replaces line.
After that i installed freeglut from the repo.

That worked for me (used hugin).

Can you try it and report problems occurring?

Offline

#2240 2012-03-06 22:37:39

kett
Member
Registered: 2008-04-21
Posts: 104

Re: Discussion: the ati/radeon open source drivers & radeon repository

@CDH

Thanks for posting it.  My computer uses the r300 driver so I couldn't use your pkgbuilds outright.  Either way, the -O1 trick didn't work for me.  I found a couple bug reports that seem to be the same problem (Posted below).  According to the comments in the bug reports the issue is related to the update to llvm 3.0.

It looks like your lib32 PKGBUILD disables the llvm for gallium.  The r300 driver won't build with llvm disabled so I can't test it.  But you could probably confirm its the same bug on your end by enabling gallium-llvm, and seeing if the problem returns.  Though that still doesn't explain why the -O1 trick is needed.  But I thought I'd share what I found.

http://llvm.org/bugs/show_bug.cgi?id=12151

https://bugs.freedesktop.org/show_bug.cgi?id=41791

Offline

#2241 2012-03-06 23:19:19

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: Discussion: the ati/radeon open source drivers & radeon repository

kett wrote:

It looks like your lib32 PKGBUILD disables the llvm for gallium

Whoa, I have looked at that lines so many times and didn't see that. :)
(I had it enabled originally but I believe I disabled it for some testing when there was an issue when llvm 3.0 was new in the repos).

So it didn't like the lib32-llvm from testing... Something about version numbers... Whatever. lib32-llvm from stable repos work.

But with -O2 Warcraft3 still doesn't start.

With -O1 again: no Problem running Warcraft3. (Haven't tested more programs with wine but I believe it would be the same)

So it's probably not llvm related I guess.


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#2242 2012-03-07 06:23:13

spirit
Member
Registered: 2010-03-19
Posts: 11

Re: Discussion: the ati/radeon open source drivers & radeon repository

Perry3D wrote:

Hi,

i ran in the same problem: mesa-full doesn't contain freeglut anymore. For a quick workaround i removed the provides and replaces line.
After that i installed freeglut from the repo.

That worked for me (used hugin).

Can you try it and report problems occurring?

yaourt -Rdd mesa-full
pacman -S mesa-full
pacman -S freeglut


correct my problem

Offline

#2243 2012-03-07 06:32:03

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,975

Re: Discussion: the ati/radeon open source drivers & radeon repository

Moderator.

@spirit:  If you are wondering where your post went, You hit the report link, not the reply link.  It happens smile


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#2244 2012-03-09 06:26:31

Ejik
Member
From: Rybinsk
Registered: 2011-06-06
Posts: 24

Re: Discussion: the ati/radeon open source drivers & radeon repository

spirit wrote:
Perry3D wrote:

Hi,

i ran in the same problem: mesa-full doesn't contain freeglut anymore. For a quick workaround i removed the provides and replaces line.
After that i installed freeglut from the repo.

That worked for me (used hugin).

Can you try it and report problems occurring?

yaourt -Rdd mesa-full
pacman -S mesa-full
pacman -S freeglut


correct my problem

This work for me too! Thx!

Offline

#2245 2012-03-13 19:46:40

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: Discussion: the ati/radeon open source drivers & radeon repository

Can anybody build the xa state tracker in lib32 mesa? I wonder how it could ever work!?

It aborts in

/src/gallium/auxiliary/libgallium.a -lLLVMBitWriter -lLLVMX86Disassembler -lLLVMX86AsmParser -lLLVMX86CodeGen -lLLVMX86Desc -lLLVMSelectionDAG -lLLVMAsmPrinter -lLLVMMCParser -lLLVMX86AsmPrinter -lLLVMX86Utils -lLLVMX86Info -lLLVMJIT -lLLVMExecutionEngine -lLLVMCodeGen -lLLVMScalarOpts -lLLVMInstCombine -lLLVMTransformUtils -lLLVMipa -lLLVMAnalysis -lLLVMTarget -lLLVMMC -lLLVMCore -lLLVMSupport
mklib: Unknown option:  -m32

So I had a look where mklib gets called:
src/gallium/targets/libgl-xlib/Makefile

        $(TOP)/bin/mklib -o $(GL_LIB) \
                -linker "$(CXX)" -ldflags '$(LDFLAGS)' \
                -major $(GL_MAJOR) -minor $(GL_MINOR) -patch $(GL_TINY) \
                -cplusplus \
                -install $(TOP)/$(LIB_DIR)/gallium \
                $(MKLIB_OPTIONS) $(XLIB_TARGET_OBJECTS) \
                -Wl,--start-group $(LIBS) -Wl,--end-group $(GL_LIB_DEPS)

What? $(CXX) is always "g++ -m32" for the 32 bit build... The Makefile at this position hasn't changed since november.. What's the secret?


(Also I had a look at  LLVM_CONFIG=/usr/lib32/llbm/llvm-config and I don't know why it points there or why it worked earlier. llvmconfig is located at /usr/bin/llvmconfig32 for the repo version and the version in testing.... It should be LLVM_CONFIG=/usr/bin/llvm-config32)


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#2246 2012-03-14 14:58:29

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,240

Re: Discussion: the ati/radeon open source drivers & radeon repository

Cdh wrote:

(Also I had a look at  LLVM_CONFIG=/usr/lib32/llbm/llvm-config and I don't know why it points there or why it worked earlier. llvmconfig is located at /usr/bin/llvmconfig32 for the repo version and the version in testing.... It should be LLVM_CONFIG=/usr/bin/llvm-config32)

I've checked the PKGBUILDs and in lib32-llvm 3.0-2 a mv command was added, not sure why.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#2247 2012-03-14 18:23:14

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,240

Re: Discussion: the ati/radeon open source drivers & radeon repository

@ Cdh :
i've tested wine with my latest lib32-mesa package, and things have improved.

W3demo now installs and runs (i stopped at the main screen)
Trackmania still hangs, but gets  a lot further.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#2248 2012-03-15 07:29:54

Cdh
Member
Registered: 2009-02-03
Posts: 1,098

Re: Discussion: the ati/radeon open source drivers & radeon repository

They probably wanted the 32 bit llvm-config in $PATH.

mklib: Unknown option:  -m32

by the way only happens when trying to build r600g,svga gallium drivers, r600g only works.


฿ 18PRsqbZCrwPUrVnJe1BZvza7bwSDbpxZz

Offline

#2249 2012-03-15 08:22:21

trapanator
Member
From: Italy
Registered: 2009-08-10
Posts: 137

Re: Discussion: the ati/radeon open source drivers & radeon repository

have you tried the unigine-tropico benchmarking suite?

it doesn't recognize my ATI HD3200 with opensource drivers.

Last edited by trapanator (2012-03-15 08:22:47)

Offline

#2250 2012-03-15 11:29:49

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,240

Re: Discussion: the ati/radeon open source drivers & radeon repository

It does run with my HD4890 and my own mesa-git packages.

it's slow though, in demo mode :
1920x1080 5-6 FPS,
windowed 10 - 12 FPS

do you have lib32-mesa installed ?


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

Board footer

Powered by FluxBB