You are not logged in.

#26 2010-10-07 12:45:57

damdim
Member
Registered: 2010-03-13
Posts: 48

Re: pm-suspend after suspend just simple boot (no resume)

There is a workaround that worked for me in this thread: http://ubuntuforums.org/showthread.php?p=9934814
Edit menu.lst and add "acpi_sleep=nonvs" to your kernel line.
After reboot resume from suspend to ram works again.

Last edited by damdim (2010-10-07 19:42:23)

Offline

#27 2010-10-09 16:19:54

Basu
Member
From: Cornell University
Registered: 2006-12-15
Posts: 296
Website

Re: pm-suspend after suspend just simple boot (no resume)

There used to be a pm-resume executable that I could call from the /etc/acpi/handlers.sh but that seems to be gone. Any idea why that was removed?


The Bytebaker -- Computer science is not a science and it's not about computers
Check out my open source software at Github

Offline

#28 2010-10-21 08:38:03

korpenkraxar
Member
Registered: 2006-04-02
Posts: 123

Re: pm-suspend after suspend just simple boot (no resume)

thayer wrote:

For those experiencing this issue, make sure that you have followed the troubleshooting steps on the pm-utils wiki, specifically the sections dealing with the 'resume' and 'autodetect' hooks:

http://wiki.archlinux.org/index.php/Pm- … leshooting and
http://wiki.archlinux.org/index.php/Pm- … reen_issue

I have a feeling this may clear things up for at least some of you.

My HOOKS looks like this:

HOOKS="base udev keymap autodetect pata scsi sata usb pcmcia usbinput encrypt btrfs filesystems"

where should I add resume, in relation to for instance btrfs?

Offline

#29 2011-01-20 02:06:03

s8dtvt
Member
From: Vietnam
Registered: 2011-01-13
Posts: 15
Website

Re: pm-suspend after suspend just simple boot (no resume)

I had same problem with system include: kernel both 2.6.36  and 2.6.37 + kde4.5.5 + grub2.
Suspend to ram always works fine and computer seem hibernate done with power off perfect.  But it never ever resume success, event, I try to:
    - add resume=/dev/sdaX and acpi_sleep=nonvs to option in /boot/grub/grub.cfg
    - add resume and keep or remove autodetect to hook
    - use uswsusp as pm-utils backend

Last edited by s8dtvt (2011-01-20 02:07:24)

Offline

#30 2011-01-20 05:16:45

s8dtvt
Member
From: Vietnam
Registered: 2011-01-13
Posts: 15
Website

Re: pm-suspend after suspend just simple boot (no resume)

Oh, well I got it.
I'm wrong when use option resume=/dev/sdaX because grub2 disable it as default. So It's fixed to me by doing as:
- add resume=/dev/disk/by-uuid/<uuid of swap partition>
- add resume to hook in file: "/etc/mkinitcpio.conf"
Hope it's useful for others.

Offline

#31 2011-01-22 09:45:17

rubenvb
Member
Registered: 2011-01-14
Posts: 95

Re: pm-suspend after suspend just simple boot (no resume)

To get suspend (to disk) working on my laptop, I did three things at once:
1. Add a resume=/dev/somedisk to the kernel boot line in GRUB's menu.list.
2. Add the user trying to suspend to the "power" group
3. Add the resume hook to the kernel images.

Suspend to RAM "just works" here, even before these adaptations. Just my two cents...

Offline

Board footer

Powered by FluxBB