You are not logged in.

#26 2009-10-14 02:35:21

moose jaw
Member
From: Milwaukee
Registered: 2007-08-20
Posts: 99

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

A quick update for anyone having a problem with ath5k and 2.6.31 after suspend/resume: as I mentioned above, my problem before was that wireless with ath5k would work on first boot but not after a suspend/resume.  I've now found that I can reliably get wireless back up after resuming by removing and the reloading the ath5k module and then restarting the wicd daemon.  In simple script form:

modprobe -r ath5k && modprobe ath5k && /etc/rc.d/wicd restart

If I run that script as root after resuming, wireless comes back (it can take 10-15 seconds for wicd to reestablish the connection; this is with WPA2 and the wext driver).  This with an AR2425 chip on a Samsung netbook.  Not sure if this will work with ath9k or even with different hardware using ath5k.  But perhaps worth a shot if you haven't tried it.  Much better than madwifi in my opinion, which worked but which I found to be much slower than ath5k.

Update: same deal with the just-updated kernel 2.6.31.4-1

Last edited by moose jaw (2009-10-14 02:53:21)

Offline

#27 2009-10-14 06:04:31

cb474
Member
Registered: 2009-04-04
Posts: 469

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

moose jaw wrote:

Much better than madwifi in my opinion, which worked but which I found to be much slower than ath5k.

Update: same deal with the just-updated kernel 2.6.31.4-1

That's interesting. When ath5k was working for me in 2.6.30 (it doesn't work at all for me in 2.6.31) it was so slow it was maddening. That's why I switched back to madwifi. The only time I used ath5k was with one specific router that madwifi wouldn't connect to for some reason. Other than that, my experience with madwifi has been much better than with ath5k. It seems worth trying madwifi, since it sounds like people may have varying results.

This is very frustrating, this late in the game to have so many wifi issues in Linux. It reminds me of what it was like several years ago. I thought those days were over. I wonder if the intel drivers in 2.6.31 are having problems?

Last edited by cb474 (2009-10-14 06:05:39)

Offline

#28 2009-10-14 08:36:44

moljac024
Member
From: Serbia
Registered: 2008-01-29
Posts: 2,676

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

I'm having problems with my ralink card, the kernel doesn't recognize it anymore. Me, being an idiot, cleared the pacman cache after testing everything....anyone got the old kernel package ? Or is there a server where I could find it ?


The day Microsoft makes a product that doesn't suck, is the day they make a vacuum cleaner.
--------------------------------------------------------------------------------------------------------------
But if they tell you that I've lost my mind, maybe it's not gone just a little hard to find...

Offline

#29 2009-10-14 10:57:00

kjon
Member
From: Temuco, Chile
Registered: 2008-04-16
Posts: 398

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

pick the pkgbuild from an older revision of the kernel26. Then rebuild it at your needs.

http://repos.archlinux.org/viewvc.cgi/k … t=packages

Last edited by kjon (2009-10-14 10:58:19)


They say that if you play a Win cd backward you hear satanic messages. That's nothing! 'cause if you play it forwards, it installs windows.

Offline

#30 2009-10-14 12:02:47

cb474
Member
Registered: 2009-04-04
Posts: 469

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

moljac024 wrote:

I'm having problems with my ralink card, the kernel doesn't recognize it anymore. Me, being an idiot, cleared the pacman cache after testing everything....anyone got the old kernel package ? Or is there a server where I could find it ?

http://arm.kh.nu/

Offline

#31 2009-10-14 12:55:41

scio
Member
From: Buffalo, NY
Registered: 2008-08-05
Posts: 366

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

ath9k here, problems connecting to g and n routers.
I'm tracking:
http://bugzilla.kernel.org/show_bug.cgi?id=14267
http://bugzilla.kernel.org/show_bug.cgi?id=14402

Guess I'll have to downgrade kernel, was hoping it was just my n router that was the problem.

Offline

#32 2009-10-14 13:02:27

neoanima
Member
Registered: 2008-05-08
Posts: 40

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

same problem with my atheros AR5001, i blacklist the module ath5k in rc.conf file and get my wireless connection back.
 

hope this bug will be fix in new update. for some persons say that the connection is faster with new ath5k module.

Offline

#33 2009-10-15 07:46:25

Wilco
Member
Registered: 2008-11-09
Posts: 437

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

scio wrote:

ath9k here, problems connecting to g and n routers.
I'm tracking:
http://bugzilla.kernel.org/show_bug.cgi?id=14267
http://bugzilla.kernel.org/show_bug.cgi?id=14402

Guess I'll have to downgrade kernel, was hoping it was just my n router that was the problem.

For some mysterious reason Wi-Fi worked for 30 minutes last night. So I guess the problem is hard to tackle since this is one of these problems that does only appears some random times

Offline

#34 2009-10-15 10:44:29

scio
Member
From: Buffalo, NY
Registered: 2008-08-05
Posts: 366

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

I started replying to some of those issues, and they think it points to eee-laptop.  However, seeing as how not everyone with the problem is on an Eee, I guess I should start my own issue.

Edit:
Fewt (long time Eee hacker) has this to say: http://www.fewt.com/2009/10/i-give-up.html

He talks about Ubuntu, but some of it is kernel related.  Apparently with the rfkill rewrite we now get double the adapters AND they are not always the same number....
Hopefully I will have some time today or tomorrow to really look at this, been busy this week.

Last edited by scio (2009-10-15 16:36:34)

Offline

#35 2009-10-15 17:58:44

Wilco
Member
Registered: 2008-11-09
Posts: 437

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

It's possibly rfkill related as I have rfkill0 and rfkill1. One of them is for bluetooth and one is for Wi-Fi. It's possible the kernel is mixing these up.

Offline

#36 2009-10-17 10:52:25

Nicky726
Member
From: Czech Republic
Registered: 2008-02-15
Posts: 142
Website

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

Solved something similar on my EEE 1005 with atheros AR9285 using ath9k driver. So I wrote theese scripts (guess they are really badly written, but seems to work, as I can scan, but cannot test real connection, as I have now no acces to wifi's here):

[root@kawagiri /home/nik]# cat /usr/bin/start-wifi.sh
#!/bin/sh
#ublocks wifi

rfkill unblock all
modprobe ath9k
rfkill unblock all
ifconfig up wlan0
wpa_supplicant -B -Dwext -iwlan0 -c /etc/wpa_supplicant.conf
exit 0

and:

[root@kawagiri /home/nik]# cat /usr/bin/stop-wifi.sh
#!/bin/sh
#blocks wifi

killall wpa_supplicant
ifconfig down wlan0
rmmod ath9k
rfkill block all
exit 0

"Although the masters make the rules
For the wise men and the fools
I got nothing, Ma, to live up to."

Offline

#37 2009-10-17 12:46:34

scio
Member
From: Buffalo, NY
Registered: 2008-08-05
Posts: 366

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

Yea it seems like something in acpi is causing wlan0 to get softblocked, I'm still trying to figure out exactly what.

Offline

#38 2009-10-18 08:50:48

mechmg93
Member
From: Greece
Registered: 2007-05-23
Posts: 197

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

has any archlinux developer submitted any bug report to the linux kernel developers about these problems?


Mikes on AUR

Offline

#39 2009-10-18 12:42:53

Wilco
Member
Registered: 2008-11-09
Posts: 437

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

mechmg93 wrote:

has any archlinux developer submitted any bug report to the linux kernel developers about these problems?

See the post from Scio

Offline

#40 2009-10-18 16:38:49

ssl6
Member
From: Ottawa, ON, CA
Registered: 2007-08-30
Posts: 594

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

the only problem i'm having with the ath5k driver on my eee-pc is that i can't connect to WPA2 encrypted networks. i'm not sure about WEP encrypted, but non-encrypted work fine. i'm using wicd as well


this is a signature

Offline

#41 2009-10-18 21:05:42

thaldyron
Member
Registered: 2009-10-16
Posts: 9

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

Same problem here (Asus EEE 1005HA-M): wlan0 works for a random amount of seconds, then I get the "disassociating" error. So right now the only way for me to have wireless is by periodically running:

rmmod ath9k
modprobe ath9k
ifconfig wlan0 up
iwconfig ...

Offline

#42 2009-10-19 00:29:22

scio
Member
From: Buffalo, NY
Registered: 2008-08-05
Posts: 366

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

rfkill unblock all

usually does the trick for me, or simply

netcfg -a
netcfg <network>

depending on the error (I use some quirks so that might be why it works).

Offline

#43 2009-10-20 11:06:12

kick52
Member
Registered: 2009-10-19
Posts: 18

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

I don't think I'm having any problems, except on resume from suspending to RAM.
I fixed this with a "netcfg all-suspend; modprobe -r ath9k; s2ram (etc); modprobe ath9k; netcfg all-resume &" style script. It seems to work okay. (I also have this for my fn+f2/wifi toggle acpi handler script.)

EDIT: I've also noticed rfkill devices being swapped around between rfkill1/2/3 in /sys/devices/platform/eeepc/rfkill/ randomly on reboot/etc, maybe check rfkill*/name to make sure you're turning off the correct device.

Last edited by kick52 (2009-10-20 11:13:46)

Offline

#44 2009-10-20 17:18:20

scio
Member
From: Buffalo, NY
Registered: 2008-08-05
Posts: 366

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

http://aur.archlinux.org/packages.php?ID=23318 acpi-eeepc-generic does the name checking for you if you use those scripts.  (http://code.google.com/p/acpi-eeepc-gen … ons.sh#359)

Edit: I've seen the swapping as well, are we approaching rfkill/by-uuid >_<
I believe this is party due to the duplication of rfkill targets however.

Last edited by scio (2009-10-20 17:19:41)

Offline

#45 2009-10-22 10:49:35

kick52
Member
Registered: 2009-10-19
Posts: 18

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

Slight update/possible solution:

I've also been having problems with "disassociating from AP" etc. disconnects, although solvable with my FN+F2 turn off/on wlan acpi script, I've switched to using ndiswrapper.
So far it seems to work perfectly.. if not faster. I also haven't seen any problems with suspend.

I followed the instructions here: http://wiki.archlinux.org/index.php/Wir … diswrapper
(make sure to blacklist the old kernel module and unload it when using ndiswrapper)
Using the AR9285 driver I found on the web (for XP 32-bit.

I hope this helps! It took me a while to find a decent download, so here's a link here for people using the same card as me: http://www.nodevice.com/driver/AR9285/get64221.html

It shouldn't take too long to find one for ath5k, etc.

Good luck big_smile

Offline

#46 2009-10-22 10:54:46

pyther
Member
Registered: 2008-01-21
Posts: 1,395
Website

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

That is so dirty, it is not funny! :X


Website - Blog - arch-home
Arch User since March 2005

Offline

#47 2009-10-22 14:32:34

scio
Member
From: Buffalo, NY
Registered: 2008-08-05
Posts: 366

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

pyther wrote:

That is so dirty, it is not funny! :X

True, but that further proves the fact that it's wireless driver not rfkill, acpi, etc...
You might want to tack on one of the kernel issues that ndiswrapper doesn't have the problem.  More information is always better, can be sorted out later if needed.

Offline

#48 2009-10-23 09:59:17

kick52
Member
Registered: 2009-10-19
Posts: 18

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

pyther wrote:

That is so dirty, it is not funny! :X

Dirty?
Well I don't mind if it's working well smile

And yeah, I found the ndiswrapper solution on a few kernel bug threads.

Offline

#49 2009-10-23 12:53:19

drandre
Member
Registered: 2009-04-16
Posts: 35

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

FWIW I have not had any problems (so far) with wireless when running 2.6.31 (kernel26 2.6.31.4-1).  This is on an acer aspire laptop with ath5k wicd connected using WPA2; and on a second machine with ralink wireless.  Perhaps I'm just lucky?

That said I'm still struggling to keep the acer from overheating.... that's a different thread however.

Offline

#50 2009-10-23 13:38:30

scio
Member
From: Buffalo, NY
Registered: 2008-08-05
Posts: 366

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

drandre wrote:

FWIW I have not had any problems (so far) with wireless when running 2.6.31 (kernel26 2.6.31.4-1).  This is on an acer aspire laptop with ath5k wicd connected using WPA2; and on a second machine with ralink wireless.  Perhaps I'm just lucky?

Do you connect to different routers or just one?

I have only had problems connecting to an unsecured 802.11g rotuer, my WPA2 802.11n router gives me no problems.

Offline

Board footer

Powered by FluxBB