You are not logged in.

#51 2009-10-27 12:29:03

kick52
Member
Registered: 2009-10-19
Posts: 18

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

Hrmm.
Anyone else with ath9k getting a freeze on resume if the wlan is disabled? (Eee 1005ha here.)
sad

I'm going to have to write a rfkill unblock wlan; sleep; rfkill block; script, ugh!
I can't figure out what is causing it. It doesn't seem to be ndiswrapper because I can rmmod that and the same thing happens. It seems the system still responds slightly.. disk/log activity if I press the power button (although it never fully shuts down and doesn't respond to any other keys.)

If I disabled the wlan using echo -n 0> /sys/bus/pci/-----/enable, etc, I could get a prompt back up, but the keyboard didn't respond, and again it couldn't shutdown fully.

Offline

#52 2009-10-28 18:31:40

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,942

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

Sorry everyone. This is the better thread to leave open.

Offline

#53 2009-11-02 06:14:49

thetrivialstuff
Member
Registered: 2006-05-10
Posts: 191

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

Just thought I'd chime in -- I also appear to be having problems connecting to certain routers.

The campus-wide WPA/PEAP/MSCHAP secured network at the university is fine; I can connect to it with wpa_supplicant, and I seem able to connect to most unsecured access points. However, I cannot connect to the WEP (128-bit) router at work (which is an apple airport from 10 years ago or so), nor the 40-bit WEP router at a church near campus (I have no idea what kind of router it is).

Offline

#54 2009-11-02 11:19:22

Wilco
Member
Registered: 2008-11-09
Posts: 437

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

Has anyone fixed this? If not, I'm going to use Windows 7 on my netbook cause I really need Wi-Fi

Offline

#55 2009-11-02 11:58:58

hokasch
Member
Registered: 2007-09-23
Posts: 1,461

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

Well, it is pretty vague what kind of errors you can expect, seems to differ from exact card model, routers, security, solar altitude, and what not.
For me, it goes from frequent, automatic reconnects (the most convenient) over having to reconnect manually, over having to reload the module, to reboot required. Compat-wireless improves the situation slightly, but also gives me hard freezes. Since a lot of people have this problem, and the cards are quite new, I strongly hope it will get fixed in the near future. So, I would say try it for yourself (with dual boot maybe).

Offline

#56 2009-11-02 22:49:33

scio
Member
From: Buffalo, NY
Registered: 2008-08-05
Posts: 366

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

Linux bugtracker currently has this in it: http://bugzilla.kernel.org/show_bug.cgi?id=14402#c64

Looks like this could be why its various problems on different cards.

Either roll back your kernel, or use one of the work arounds mentioned in this thread until it gets sorted out.

Offline

#57 2009-11-03 15:34:19

Wilco
Member
Registered: 2008-11-09
Posts: 437

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

scio wrote:

Linux bugtracker currently has this in it: http://bugzilla.kernel.org/show_bug.cgi?id=14402#c64

Looks like this could be why its various problems on different cards.

Either roll back your kernel, or use one of the work arounds mentioned in this thread until it gets sorted out.

Are there good workarounds? The ndiswrapper solution doesn't work for me since my ath9k (eee 1000he) windows drivers don't work with ndiswrapper.

Offline

#58 2009-11-03 16:40:34

hokasch
Member
Registered: 2007-09-23
Posts: 1,461

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

For your netbook, look at thisand this bug. The other one about the interface not getting created seems to be a problem on specific laptops only.

Someone (Frank) posted a small patch on the bug tracker, which seems to have fixed the problem for some.

Offline

#59 2009-11-03 16:45:58

pyther
Member
Registered: 2008-01-21
Posts: 1,395
Website

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

You might want to try 2.6.32-rc5 as someone reported the issue was resolved in said kernel.


Website - Blog - arch-home
Arch User since March 2005

Offline

#60 2009-11-03 18:31:29

pyther
Member
Registered: 2008-01-21
Posts: 1,395
Website

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

I just compiled 2.6.31-rc5 and it seems that the problem as gone away.
*Signal Strenght: 80% -> 98%
*I can manually load/unload the wireless modules

Fn+F2 key will cause my eee to freeze, but the toggle script works fine. :-l

I will report back once I go to the university where the problem was most noticeable (ap disassociation)


Website - Blog - arch-home
Arch User since March 2005

Offline

#61 2009-11-03 19:08:48

scio
Member
From: Buffalo, NY
Registered: 2008-08-05
Posts: 366

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

Wilco wrote:
scio wrote:

Linux bugtracker currently has this in it: http://bugzilla.kernel.org/show_bug.cgi?id=14402#c64

Looks like this could be why its various problems on different cards.

Either roll back your kernel, or use one of the work arounds mentioned in this thread until it gets sorted out.

Are there good workarounds? The ndiswrapper solution doesn't work for me since my ath9k (eee 1000he) windows drivers don't work with ndiswrapper.

This works for me, but as others have said, possibly a newer kernel will help as well.

Offline

#62 2009-11-04 01:11:11

cb474
Member
Registered: 2009-04-04
Posts: 469

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

I also think just sticking with kernel 2.6.30 works fine. Although it's good to hear the problem has probably been fixed in 2.6.32.

Offline

#63 2009-11-04 12:06:04

Wilco
Member
Registered: 2008-11-09
Posts: 437

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

Reverting to 2.6.30 seems to have fixed it. Last night I didn't have any problems for 1.5 hours.

A good test is using scp to copy some 100+ MB to another machine. That usually fails after 50 MB and gives disconnects.

Offline

#64 2009-11-14 22:39:12

march
Member
Registered: 2009-11-14
Posts: 1

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

Posting in case this helps someone else...

hw        macbook1,1 --- ath5k --- atheros AR5414
sw        fully up-to-date arch --- kernel 2.6.31* --- wicd / wpa_supplicant / wext
config   wpa2 psk aes
issue    upgrading to any 2.6.31 series kernel caused my wifi to no longer associate with AP.
fix        revert to 2.6.30 series kernel

better fix

After messing around with kernels I discovered the issue was that wicd was failing to set 'scan_ssid' to 1, despite 'Hidden' being set to 'True'.  The AP is owned by my company, and they choose not to broadcast the ESSID.  Roll your eyes, but it is a legitimate, and common, configuration.  The man page to wpa_supplicant states that scan_ssid should be set to technique '1' (direct probe) in such cases.

The wicd/wireless-settings man page doesn't cover $_SCAN, but explicitly setting 'scan_ssid' to '1' (and setting 'bssid' just to be sure) appears to have solved all my connection issues with ath5k and 2.6.31 kernels.

Offline

#65 2009-11-15 04:06:50

phoenix89
Member
Registered: 2009-08-07
Posts: 24

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

What do you have to do in order to revert back to 2.6.30, I keep hoping that the latest update to 2.6.31 will help but my system keeps locking up when using wireless

Offline

#66 2009-11-15 04:25:05

brenix
Member
From: California
Registered: 2008-03-05
Posts: 185

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

Hrm, I must be lucky.. No problems here with my Atheros card on a Thinkpad T61p. Don't know if this could help, but here's the details of mine

ath5k --- atheros AR5212
netcfg2 wpa2/aes network
full up to date system. Card has been working on all revisions of kernel 2.6.31 vanilla and bfs

edit: my card has worked with multiple routers (netgear, linksys, dlink..)
modinfo..

$ modinfo ath5k
filename:       /lib/modules/2.6.31-bfs/kernel/drivers/net/wireless/ath/ath5k/ath5k.ko
version:        0.6.0 (EXPERIMENTAL)
license:        Dual BSD/GPL
description:    Support for 5xxx series of Atheros 802.11 wireless LAN cards.
author:         Nick Kossifidis
author:         Jiri Slaby
srcversion:     4CC5921A00F32232A640E9F
alias:          pci:v0000168Cd0000001Dsv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000001Csv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000001Bsv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000001Asv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000019sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000018sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000017sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000016sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000015sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000014sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00001014sv*sd*bc*sc*i*
alias:          pci:v000010B7d00000013sv*sd*bc*sc*i*
alias:          pci:v0000A727d00000013sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000013sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000012sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000011sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000007sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000207sv*sd*bc*sc*i*
depends:        mac80211,led-class,cfg80211,ath
vermagic:       2.6.31-bfs SMP preempt mod_unload 
parm:           nohwcrypt:Disable hardware encryption. (bool)
parm:           all_channels:Expose all channels the device can use. (bool)

Last edited by brenix (2009-11-15 04:29:47)

Offline

#67 2009-11-16 02:01:40

1LordAnubis
Member
Registered: 2008-10-10
Posts: 252
Website

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

brenix wrote:

Hrm, I must be lucky.. No problems here with my Atheros card on a Thinkpad T61p. Don't know if this could help, but here's the details of mine

ath5k --- atheros AR5212
netcfg2 wpa2/aes network
full up to date system. Card has been working on all revisions of kernel 2.6.31 vanilla and bfs

edit: my card has worked with multiple routers (netgear, linksys, dlink..)
modinfo..

Likewise;

ath5k - Atheros AR5001X+ Wireless Network Adapter (rev 01)
wicd   - WPA Network
Up to date system, madwifi began working horribly with recent kernels so I tried switching to ath5k with 2.6.31, and its working quite well. The only problem is if I suspend to ram, the module often won't work correctly, and sometimes won't even reload... But I don't suspend to ram on this system anyway since there are other problems....
--Alienware 7700 Laptop w/ external Atheros card--


Any society that would give up a little liberty to gain a little security will deserve neither and lose both.
-Benjamin Franklin
The reasonable man adapts himself to the world; the unreasonable one persists in trying to adapt the world to himself. Therefore all progress depends on the unreasonable man.
-George Bernard Shaw

Offline

#68 2009-11-23 21:07:25

Wilco
Member
Registered: 2008-11-09
Posts: 437

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

Reading all these messages again it seems ath9k only works with 2.6.30, and ath5k works fine with 2.6.31

Offline

#69 2009-11-24 08:26:31

hokasch
Member
Registered: 2007-09-23
Posts: 1,461

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

ath9k works again with kernel26-rc from (rc8 from aur).

Offline

#70 2009-11-26 19:51:48

jocheem67
Member
Registered: 2009-11-09
Posts: 223

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

I can confirm that ndiswrapper works for an asus 1005HA-H, replacing the ath9k driver

http://www.nodevice.com/driver/AR9285/get64221.html

As a "collegue" on page 2 confirmed, this is the right windows-driver for a

"Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)"

Offline

#71 2009-12-05 09:35:15

mechmg93
Member
From: Greece
Registered: 2007-05-23
Posts: 197

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

has anyone tried kernel 2.6.32 and has any news refering to this topics problem?


Mikes on AUR

Offline

#72 2009-12-05 15:25:04

hokasch
Member
Registered: 2007-09-23
Posts: 1,461

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

As with the release candidates, 2.6.32 from testing has better performance and no stability issues on my system (speaking of ath9k).

DAMMN! I shall stop making this statements. Worked for hours, sure enough it took 10 minutes after this post and the connection dropped, and did not go up again with the methods that worked in .31, had to reboot. Now wireless ceased operation altogether. This did not happen with self-compiled rc. No idea what goes wrong here, but I am fed up diving into this atm. Since self-compiled .32 rc fixed wireless but also introduced hard locks, I am back to .31

Last edited by hokasch (2009-12-05 15:58:44)

Offline

#73 2009-12-05 19:46:12

mechmg93
Member
From: Greece
Registered: 2007-05-23
Posts: 197

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

i tested kernel 2.6.32 from testing. with ath5k wireless is still broken. even if i unblock everything with rfkill my laptop is unable to connect.

back to 2.6.30.6..

EDIT

In order to have the latest kernel available installed i decided to blacklist ath5k and use madwifi. With madwifi wireless is functional but it is too slow(did some tests with countrycodes).

So i suppose that linux and wireless are enemies.

Last edited by mechmg93 (2009-12-06 08:57:36)


Mikes on AUR

Offline

#74 2009-12-06 18:53:56

Wilco
Member
Registered: 2008-11-09
Posts: 437

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

What a mess, I wonder what's so hard to fix. Well, guess I'll stick with 2.6.30 and wait for 2.6.33

Offline

#75 2009-12-22 05:43:51

mechmg93
Member
From: Greece
Registered: 2007-05-23
Posts: 197

Re: am i the onlyone having problem with ath5k(etc) and kernel 2.6.3X??

has anyone tested 2.6.32.2-1 from testing?


Mikes on AUR

Offline

Board footer

Powered by FluxBB