You are not logged in.

#26 2009-12-08 09:15:25

zodmaner
Member
Registered: 2007-07-11
Posts: 653

Re: kernel 2.6.32: How to enable ATI KMS?

Thanks guys! smile KMS early start is working perfectly using radeon hook placed before udev just like ras0ir & tomk suggested.

Last edited by zodmaner (2009-12-08 11:22:38)


Memento mori

Offline

#27 2009-12-08 14:03:14

cpuesser
Member
Registered: 2009-12-08
Posts: 4

Re: kernel 2.6.32: How to enable ATI KMS?

zodmaner wrote:

Thanks guys! smile KMS early start is working perfectly using radeon hook placed before udev just like ras0ir & tomk suggested.

this works for me too.

cpuesser

Offline

#28 2009-12-08 14:45:41

Tapan
Member
Registered: 2009-12-07
Posts: 9

Re: kernel 2.6.32: How to enable ATI KMS?

zodmaner wrote:

Thanks guys! smile KMS early start is working perfectly using radeon hook placed before udev just like ras0ir & tomk suggested.

For me works fine too, thanx.
________
Edit:
When i'm using early start, system 2times freeze in X (KDE4). I'm back in late start, works fine.

Last edited by Tapan (2009-12-08 17:01:05)

Offline

#29 2009-12-08 15:13:24

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: kernel 2.6.32: How to enable ATI KMS?

i'm still puzzled tongue should 'early' mean that kms starts right after grub, or am i supposed to see a few big ugly lines of text scroll by first (even with 'quiet')?


ᶘ ᵒᴥᵒᶅ

Offline

#30 2009-12-08 15:53:49

riivo
Member
Registered: 2008-08-25
Posts: 112

Re: kernel 2.6.32: How to enable ATI KMS?

litemotiv wrote:

i'm still puzzled tongue should 'early' mean that kms starts right after grub, or am i supposed to see a few big ugly lines of text scroll by first (even with 'quiet')?

A few big ugly lines first is early.

Offline

#31 2009-12-08 19:49:37

zodmaner
Member
Registered: 2007-07-11
Posts: 653

Re: kernel 2.6.32: How to enable ATI KMS?

riivo wrote:
litemotiv wrote:

i'm still puzzled tongue should 'early' mean that kms starts right after grub, or am i supposed to see a few big ugly lines of text scroll by first (even with 'quiet')?

A few big ugly lines first is early.

Yeah, that's as early as it get (same case as on the intel card, even if you built the module into the kernel itself). smile


Memento mori

Offline

#32 2009-12-08 20:11:35

linuxgod
Member
Registered: 2009-05-06
Posts: 50

Re: kernel 2.6.32: How to enable ATI KMS?

guys, help me please!
I've managed to enable KMS, but there are some problems:

1) Black screen during boot-up (init scripts), see practically nothing until Xorg
2) No acceleration in Xorg and "white cube" in compiz with painfully  slow 3D..

Here is my dmesg

[drm] Initialized drm 1.1.0 20060810
[drm] radeon defaulting to kernel modesetting.
[drm] radeon kernel modesetting enabled.
radeon 0000:01:05.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[drm] radeon: Initializing kernel modesetting.
[drm] register mmio base: 0xD0000000
[drm] register mmio size: 65536
ATOM BIOS: ATI
[drm] GPU reset succeed (RBBM_STATUS=0x10000140)
[drm] radeon: VRAM 0M
[drm] radeon: VRAM from 0x00000000 to 0xFFFFFFFF
[drm] radeon: GTT 512M
[drm] radeon: GTT from 0x00000000 to 0x1FFFFFFF
radeon 0000:01:05.0: irq 27 for MSI/MSI-X
[drm] radeon: irq initialized.
mtrr: zero sized request
[drm] Detected VRAM RAM=0M, BAR=0M
[drm] RAM width 128bits DDR
[TTM] Zone  kernel: Available graphics memory: 444328 kiB.
[TTM] Zone highmem: Available graphics memory: 906444 kiB.
[TTM] Zero size memory manager type 2
[TTM] Failed moving buffer. Proposed placement 0x00060004
[drm:radeon_object_create] *ERROR* Failed to allocate TTM object (262144, 0x00060004, 0)
[drm:radeon_driver_load_kms] *ERROR* Fatal error while trying to initialize radeon.
radeon: probe of 0000:01:05.0 failed with error -22

Last edited by linuxgod (2009-12-08 20:12:54)

Offline

#33 2009-12-08 20:23:15

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,637

Re: kernel 2.6.32: How to enable ATI KMS?

http://bugs.archlinux.org/task/17357 - so this is a known issue you should discuss in the bugtracker.

Offline

#34 2009-12-08 22:14:13

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,117

Re: kernel 2.6.32: How to enable ATI KMS?

I think it is worse than that for linuxgod.

These seem to suggest that it's better to disable kms for now:
[drm] radeon: VRAM 0M
[drm] Detected VRAM RAM=0M, BAR=0M

It seems it can't detect the amount of vram properly.

Here I get:
[drm] Detected VRAM RAM=128M, BAR=128M
[drm] RAM width 64bits DDR
[drm] radeon: 128M of VRAM memory ready
[drm] radeon: 512M of GTT memory ready.
[drm] Loading RV610 CP Microcode


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#35 2009-12-09 07:39:26

ap_
Member
From: Finland
Registered: 2008-10-14
Posts: 47

Re: kernel 2.6.32: How to enable ATI KMS?

Yey! Thanks for the instructions guys. Both of my machines now have working KMS.

Offline

#36 2009-12-09 08:20:55

kinski
Member
Registered: 2009-03-25
Posts: 9

Re: kernel 2.6.32: How to enable ATI KMS?

hi guys, got kms starting (RV610, late start), but i get a gpu lockup after a few minutes (after lockup, the only thing i can do is: ssh + reboot).
without kms i get screen corruptions

By the way: i am using kernel26 2.6.32 from testing, libdrm-git, mesa-git, glproto-git, dri2proto-git, xf86-video-ati-git, libgl-git, ati-dri-git, all checked out yesterday

Do you have any suggestions?

Offline

#37 2009-12-09 09:22:36

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: kernel 2.6.32: How to enable ATI KMS?

kinski wrote:

hi guys, got kms starting (RV610, late start), but i get a gpu lockup after a few minutes (after lockup, the only thing i can do is: ssh + reboot).
without kms i get screen corruptions

By the way: i am using kernel26 2.6.32 from testing, libdrm-git, mesa-git, glproto-git, dri2proto-git, xf86-video-ati-git, libgl-git, ati-dri-git, all checked out yesterday

Do you have any suggestions?

do you still have an old vga= or video= parameter in your grub line?


ᶘ ᵒᴥᵒᶅ

Offline

#38 2009-12-09 09:23:10

zodmaner
Member
Registered: 2007-07-11
Posts: 653

Re: kernel 2.6.32: How to enable ATI KMS?

kinski wrote:

hi guys, got kms starting (RV610, late start), but i get a gpu lockup after a few minutes (after lockup, the only thing i can do is: ssh + reboot).
without kms i get screen corruptions

By the way: i am using kernel26 2.6.32 from testing, libdrm-git, mesa-git, glproto-git, dri2proto-git, xf86-video-ati-git, libgl-git, ati-dri-git, all checked out yesterday

Do you have any suggestions?

Have you try using ati driver and the associated dependencies from the extra/testing repositories? If not, try to install xf86-video-ati package from official repo and see if the problem still persisted.

Newest driver from git repo have been known to introduced regression from time to time.


Memento mori

Offline

#39 2009-12-09 12:07:58

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,117

Re: kernel 2.6.32: How to enable ATI KMS?

kinski wrote:

hi guys, got kms starting (RV610, late start), but i get a gpu lockup after a few minutes (after lockup, the only thing i can do is: ssh + reboot).
without kms i get screen corruptions

By the way: i am using kernel26 2.6.32 from testing, libdrm-git, mesa-git, glproto-git, dri2proto-git, xf86-video-ati-git, libgl-git, ati-dri-git, all checked out yesterday

Do you have any suggestions?

I'm using an RV610 too and It works fine, try to use only stuff from the repos (some of the stuff needs to come from [testing]).


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#40 2009-12-09 12:55:44

hungerfish
Member
Registered: 2009-09-13
Posts: 242

Re: kernel 2.6.32: How to enable ATI KMS?

I use mesa-full from aur, instead of all these idividual packages;  libdrm-git, mesa-git,libgl-git, ati-dri-git
With that, and glproto-git, dri2proto-git, xf86-video-ati-git dri + kms is working like a charm.

I did this because I was getting screen-corruption with apps like abiword or the gimp, making them unusable with the packages from repos.

Regarding early start, I was wrong, its working for me again now,using the radeon hook.

Last edited by hungerfish (2009-12-09 12:56:19)


Beetles and bacteria are vastly more successful than humans in terms of survival.

Offline

#41 2009-12-09 12:56:01

linuxgod
Member
Registered: 2009-05-06
Posts: 50

Re: kernel 2.6.32: How to enable ATI KMS?

it looks like we don't need to insert a radeon module at all..its already built-in and works fine

Last edited by linuxgod (2009-12-09 12:57:45)

Offline

#42 2009-12-09 13:01:44

linuxgod
Member
Registered: 2009-05-06
Posts: 50

Re: kernel 2.6.32: How to enable ATI KMS?

as i see drm loads radeon firmware successfully when KMS disabled (strange, coz its unuseful i think)
when enabled it crashes as described above

Last edited by linuxgod (2009-12-09 13:02:31)

Offline

#43 2009-12-09 13:13:01

kinski
Member
Registered: 2009-03-25
Posts: 9

Re: kernel 2.6.32: How to enable ATI KMS?

to litemotiv: no i have removed all vga= and video= entries

to zodmaner: i know about the risk of going git and i have tried using packages of the extra/testing repos.
                    but to play safe, i'll try it again.

Offline

#44 2009-12-09 14:27:52

kinski
Member
Registered: 2009-03-25
Posts: 9

Re: kernel 2.6.32: How to enable ATI KMS?

ok now i am using: libdrm, xf86-video-ati from testing and mesa, libgl ... from extra

with xorg.conf it hangs before kdm (blackscreen and white cursor) when kms enabled
without xorg.conf kms works, but there is wrong resolution + dual-screen does not work (randr)

Offline

#45 2009-12-09 14:40:32

kinski
Member
Registered: 2009-03-25
Posts: 9

Re: kernel 2.6.32: How to enable ATI KMS?

next try: now i use xf86-video-ati from extra (not from testing as before)
+ now kms is working (switching terminals) the resolution is right and dual head setup (randr) works
again
- but glxgears doesn't work anymore because:
        drmRadeonCmdBuffer: -22. Kernel failed to parse or rejected command stream.
   is back again
+ the screen corruptions are gone

Last edited by kinski (2009-12-09 14:42:19)

Offline

#46 2009-12-09 14:44:25

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,117

Re: kernel 2.6.32: How to enable ATI KMS?

drmRadeonCmdBuffer: -22. Kernel failed to parse or rejected command stream.

This is a known problem, something to do with mesa I think.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#47 2009-12-09 14:46:44

kinski
Member
Registered: 2009-03-25
Posts: 9

Re: kernel 2.6.32: How to enable ATI KMS?

but it has to do something with xf86-video-ati too, because using it from testing instead of extra, this error is gone ( well some others are introduced - at least for me)

Offline

#48 2009-12-09 16:32:36

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: kernel 2.6.32: How to enable ATI KMS?

kinski - you're using the testing repo incorrectly. Enable it at top of the pacman.conf list, and run pacman -Syu. Remember that this forum is for the discussion of issues arising from the testing repo.

linuxgod - you don't need radeon in the MODULES line, if that's what you mean, You do need radeon in the HOOKS line, as detailed above. I don't know what you mean by "it's already built-in".

Offline

#49 2009-12-09 21:28:24

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 3,117

Re: kernel 2.6.32: How to enable ATI KMS?

Speaking of KMS, did anyone notice that when KMS is enabled it seems there is no power saving for the graphics card?

In my case if I boot _without_ KMS then I get this:
1) Only in the console, before starting X my notebook while idle uses around 25W of power (reported by the battery ... I think ... /proc/acpi/battery/BAT0/state)
2) After starting X the notebook idles using around 21W or power (I have: Option "ForceLowPowerMode" "TRUE" in my xorg.conf)

If I use KMS (early start) then the notebook uses always around 25W of power while idle.

This difference represents about 30min of autonomy in my case.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#50 2009-12-09 22:50:23

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: kernel 2.6.32: How to enable ATI KMS?

R00KIE wrote:

Speaking of KMS, did anyone notice that when KMS is enabled it seems there is no power saving for the graphics card?

yes, ATI power saving with KMS might supposedly be added in 2.6.33 hmm


ᶘ ᵒᴥᵒᶅ

Offline

Board footer

Powered by FluxBB