You are not logged in.

#201 2010-01-27 17:07:09

sHyLoCk
Member
From: /dev/null
Registered: 2009-06-19
Posts: 1,197

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

barzam wrote:

I get the terminal too wide error when editing the pkgbuild, I guess this is a system wide error in Vi that I haven't bothered to fix. Any wey to make packer use something else (vim for example) or a solution to the Vi thingy?

Great package btw, with the separate pacdiffviewer package I can dump yaourt for now. Thanks!

Maybe change the vi to nano in these lines:

eval ${EDITOR:-vi} PKGBUILD
eval ${EDITOR:-vi} "$install"

dirty hack..

Btw, I vote for nano being the default editor. It comes with the Arch core install anyway and is easier than vi.


~ Regards,
sHy
ArchBang: Yet another Distro for Allan to break.
Blog | GIT | Forum (。◕‿◕。)

Offline

#202 2010-01-27 17:23:23

drcouzelis
Member
From: Connecticut, USA
Registered: 2009-11-09
Posts: 3,497
Website

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

Packer uses the standard "EDITOR" variable. You can set it globally in "/etc/profile" or in "~/.bashrc". (or wherever you want)

export EDITOR="nano"

I personally use vim, which doesn't have a "screen too wide" limit like vi does.

Offline

#203 2010-01-27 17:26:10

bruenig
Member
Registered: 2007-05-20
Posts: 175

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

barzam wrote:

I get the terminal too wide error when editing the pkgbuild, I guess this is a system wide error in Vi that I haven't bothered to fix. Any wey to make packer use something else (vim for example) or a solution to the Vi thingy?

Great package btw, with the separate pacdiffviewer package I can dump yaourt for now. Thanks!

Like it says, packer used $EDITOR. This is a standard unix convention whereby you are supposed to set an environmental variable for your preferred editor.

So in short add a line to your /etc/profile or other relevant places that says

export EDITOR=nano

and it will work.

vi has always seemed to be standard on *nix systems, but if enough people complain I can change the default to nano. However, the real answer ought to be to change your environment variables.

Edit: *shakes fist at drcouzelis*

Last edited by bruenig (2010-01-27 17:27:27)

Offline

#204 2010-01-27 17:26:18

barzam
Member
From: Sweden
Registered: 2009-01-27
Posts: 277

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

Thanks for the very quick help guys! I'll set it up to use Vim instead of Vi like drcouzelis suggested.

I also think that nano should be the default editor (due to being easy and straight forward), or maybe make it like yaourt  does ("edit pkgbuild with:").

Offline

#205 2010-01-27 18:08:41

davidm
Member
Registered: 2009-04-25
Posts: 338

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

Nice work!  Thank you.

Offline

#206 2010-01-28 02:21:20

handy
Member
From: Oz
Registered: 2008-03-26
Posts: 719

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

I also use export EDITOR=nano

If I were a scripter/programmer I would probably be using vim, but I'm not so I don't need to learn how to use vi, vim or emacs for that matter. smile

Last edited by handy (2010-01-28 02:22:07)


I used to be surprised that I was still surprised by my own stupidity, finding it strangely refreshing.
Well, now I don't find it refreshing.
I'm over it!

Offline

#207 2010-01-28 02:22:23

tvale
Member
From: Palmela, Portugal
Registered: 2008-12-11
Posts: 169

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

From what I've used so far it seems like a very nice work.
Thanks!


archlinux x86_64 @ Asus UL30A

dwm and patches
conky-dzen

Offline

#208 2010-01-28 10:20:32

r6
Member
From: Melbourne
Registered: 2008-07-02
Posts: 155

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

Found a possible bug when I typed "packer epiphany". It doesn't show the version number of the extra/epiphany package for some reason.

Offline

#209 2010-01-28 13:35:29

tvale
Member
From: Palmela, Portugal
Registered: 2008-12-11
Posts: 169

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

Yes, after quick quick test I think running the interactive mode doesn't show the version of packages that belong to a meta-package.
For example, epiphany or xf86-input-evdev.


archlinux x86_64 @ Asus UL30A

dwm and patches
conky-dzen

Offline

#210 2010-01-28 14:14:55

fgr
Member
From: Italy
Registered: 2009-02-12
Posts: 20

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

seems 'packer' doesn't work well here. Take a look at the following:

fgr@ao ~ % packer -Si localepurge
Repository     : aur
Name           : localepurge
Version        : 0.6.2-4
URL            : http://packages.qa.debian.org/l/localepurge.html
[...]

fgr@ao ~ % packer -S localepurge
warning: localepurge-0.6.2-3 is up to date -- reinstalling

Aur Targets    (1): localepurge

Proceed with installation? [Y/n]

fgr@ao ~ % packer -Su
:: Aggiornamento del sistema in corso...
Il database locale è aggiornato
:: Synchronizing aur database...
aur                                         12  12 [#####################] 100%
:: Starting full aur upgrade...
local database is up to date

Offline

#211 2010-01-28 14:48:56

MajorTom
Member
From: Canada, GTA
Registered: 2008-09-12
Posts: 58

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

packer -S pkgname will always install/reinstall
packer -Su will do a system upgrade but since that package is up to date, there is nothing to do.

Also, since recently, packer -Su will only upgrade AUR packages. If there is a new package version, you will need to do packer -Syu to refresh the master package list.
Finally, if the package in question comes, for example, from git (like packer itself), you will need to do packer -Syu --devel.

Last edited by MajorTom (2010-01-28 14:56:41)

Offline

#212 2010-01-28 17:57:28

bruenig
Member
Registered: 2007-05-20
Posts: 175

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

fgr wrote:

seems 'packer' doesn't work well here. Take a look at the following:

fgr@ao ~ % packer -Si localepurge
Repository     : aur
Name           : localepurge
Version        : 0.6.2-4
URL            : http://packages.qa.debian.org/l/localepurge.html
[...]

fgr@ao ~ % packer -S localepurge
warning: localepurge-0.6.2-3 is up to date -- reinstalling

Aur Targets    (1): localepurge

Proceed with installation? [Y/n]

fgr@ao ~ % packer -Su
:: Aggiornamento del sistema in corso...
Il database locale è aggiornato
:: Synchronizing aur database...
aur                                         12  12 [#####################] 100%
:: Starting full aur upgrade...
local database is up to date

Here is what happens when I do it here.

[bruenig localepurge]$ pacman -Qi localepurge
Name           : localepurge
Version        : 0.6.2-3

______________________________

[bruenig localepurge]$ packer -Si localepurge
Repository     : aur
Name           : localepurge
Version        : 0.6.2-4

______________________________

[bruenig localepurge]$ packer -S localepurge

Aur Targets    (1): localepurge

Proceed with installation? [Y/n]

_____________________________

[bruenig localepurge]$ packer --auronly -Syu localepurge
:: Synchronizing aur database...
 aur                                         26  26 [-------------------------------------------------] 100%
:: Starting full aur upgrade...

Aur Targets    (1): localepurge

Proceed with installation? [Y/n]

So I don't know what the problem is on your end.

Last edited by bruenig (2010-01-28 17:58:32)

Offline

#213 2010-01-28 18:38:56

bruenig
Member
Registered: 2007-05-20
Posts: 175

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

r6 wrote:

Found a possible bug when I typed "packer epiphany". It doesn't show the version number of the extra/epiphany package for some reason.

You are right. What I was doing was stripping off everything before the last space in pacman output.

extra/epiphany-extensions 2.28.1-1

See this worked very well here because everything before the last space is everything except the version!

extra/epiphany 2.28.2-1 (gnome)

But it failed here because everything before the last space was everything except the group name!

Anyways, I fixed it by stripping off everything before the FIRST space. This allows you to see the version and as luck would have it, also shows the group it belongs too if it in fact does belong to one.

packer -S packer to get change

Offline

#214 2010-01-28 18:53:23

tvale
Member
From: Palmela, Portugal
Registered: 2008-12-11
Posts: 169

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

Confirmed fix. wink


archlinux x86_64 @ Asus UL30A

dwm and patches
conky-dzen

Offline

#215 2010-01-28 20:44:58

fgr
Member
From: Italy
Registered: 2009-02-12
Posts: 20

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

bruenig wrote:

[...]
So I don't know what the problem is on your end.

Neither do I. smile I'm looking for a solution anyway.

Offline

#216 2010-01-28 21:25:57

bruenig
Member
Registered: 2007-05-20
Posts: 175

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

fgr wrote:
bruenig wrote:

[...]
So I don't know what the problem is on your end.

Neither do I. smile I'm looking for a solution anyway.

packer -S packer and try again. I changed the version comparison code to use LC_ALL=C as the only thing that seems to be plausible as a problem is the locale.

Offline

#217 2010-01-29 03:28:02

MajorTom
Member
From: Canada, GTA
Registered: 2008-09-12
Posts: 58

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

Here's what happens if the supplied string doesn't match any packages/descriptions:

$ packer nomatch


Type numbers to install. Separate each number with a space.
Numbers: 
$

Offline

#218 2010-01-29 04:04:09

bruenig
Member
Registered: 2007-05-20
Posts: 175

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

MajorTom wrote:

Here's what happens if the supplied string doesn't match any packages/descriptions:

$ packer nomatch


Type numbers to install. Separate each number with a space.
Numbers: 
$

I noticed this the other day, but did not bother with trying to clean it up. I cleaned it up now though.

Offline

#219 2010-01-29 06:25:23

MajorTom
Member
From: Canada, GTA
Registered: 2008-09-12
Posts: 58

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

Confirmed. Works nicely now.

Any progress on the -q(uiet) search output or did you decide not to implement it?
Thanks.

Offline

#220 2010-01-29 06:29:21

kalpik
Member
From: India
Registered: 2007-05-08
Posts: 163
Website

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

What about the -U flag? Useful for installing/upgrading already downloaded/built packages.

Offline

#221 2010-01-29 07:43:54

bruenig
Member
Registered: 2007-05-20
Posts: 175

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

kalpik wrote:

What about the -U flag? Useful for installing/upgrading already downloaded/built packages.

use pacman

Offline

#222 2010-01-29 07:46:31

bruenig
Member
Registered: 2007-05-20
Posts: 175

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

MajorTom wrote:

Confirmed. Works nicely now.

Any progress on the -q(uiet) search output or did you decide not to implement it?
Thanks.

I put it off for a bit as I try to get everything solidly where I like it. I am toying with how to implement it. Like obviously -Ss, but what about interactive mode?

Offline

#223 2010-01-29 11:17:47

JayJay
Member
Registered: 2008-09-25
Posts: 6

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

Package group oder provider package as dependency

If i try to install fcron, i get this:

% packer -S fcron
Dependency `smtp-server' of `fcron' does not exist.

Then I...

 % packer -S smtp-server
Package `smtp-server' does not exist.

Search for it...

 % packer -Ss smtp-server
extra/courier-mta 0.62.1-4 [5.58 MB]
    IMAP(s)/POP3(s) and SMTP Server with ML-manager, webmail and webconfig
extra/exim 4.69-2 [0.45 MB]
    A Message Transfer Agent
extra/postfix 2.6.5-3 [3.35 MB]
    Secure, fast, easy to administer drop in replacement for Sendmail (MTA)
community/esmtp 1.2-1 [0.02 MB]
    An easy smtp forwarder

If i install esmtp and then fcron it works.
Is this a bug of packer, or is the PKGBUILD of fcron wrong/bad?

JJ

Offline

#224 2010-01-29 12:01:42

sHyLoCk
Member
From: /dev/null
Registered: 2009-06-19
Posts: 1,197

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

@JayJay

I think it's a packer issue. Manually compiling fcron using makepkg -s checks for smtp-server and then askss to install courier-mta group which provides smtp-server. However using packer it shows that error you mentioned!


~ Regards,
sHy
ArchBang: Yet another Distro for Allan to break.
Blog | GIT | Forum (。◕‿◕。)

Offline

#225 2010-01-29 16:52:21

fgr
Member
From: Italy
Registered: 2009-02-12
Posts: 20

Re: packer - New bash aur+pacman wrapper (replaces poorly written yaourt)

bruenig wrote:
fgr wrote:
bruenig wrote:

[...]
So I don't know what the problem is on your end.

Neither do I. smile I'm looking for a solution anyway.

packer -S packer and try again. I changed the version comparison code to use LC_ALL=C as the only thing that seems to be plausible as a problem is the locale.

yeah, now it works. From my «pacman.log»:

[2010-01-29 17:32] upgraded fontconfig-ubuntu (2.6.0-8 -> 2.8.0-1)

fontconfig-ubuntu [typo: has been updated -- sorry] was updated on Wed, 20 Jan 2010 21:37:20 +0000.

Last edited by fgr (2010-02-03 19:07:02)

Offline

Board footer

Powered by FluxBB