You are not logged in.

#26 2010-02-04 01:08:22

12o
Member
Registered: 2009-05-19
Posts: 79

Re: Replace kernel-headers with core/linux-api-headers?

:-|  Very funny, dhave...

Actually, that was kind of funny. The last time I tried something like this, my refrigerator settings went all out of whack.

Thanks for the info.

UPDATE:

I pressed 'Y' and did the upgrade. I shut off my computer and restarted it without any problems whatsoever. Thank you very much for the help.

Best regards.

Last edited by 12o (2010-02-04 18:35:52)


Silence is golden.... duct tape is silver.

Time flies like the wind,
Fruit flies like bananas.

Offline

#27 2010-02-09 22:14:26

Dr.Paneas
Member
From: Thessaloniki,GR
Registered: 2010-01-19
Posts: 13
Website

Re: Replace kernel-headers with core/linux-api-headers?

dhave wrote:
12o wrote:

Did anyone have any problems with pressing 'Y' on this? Did it work? Did it tank?

When I pressed "Y", my credit card was immediately charged $5,000 US. I'm working with the credit card company right now to try to recover at least some of the cash. cool

Same bug here lol

Offline

#28 2010-02-10 21:14:57

oGRE2080
Member
From: UKRAINE-NY
Registered: 2009-10-09
Posts: 63

Re: Replace kernel-headers with core/linux-api-headers?

've got clean arch x64, and was installing openbox stuff...

pacman -Syu
pacman -S openbox obconf
resolving dependecies...
warning: provider package was selected (linux-api-headers provides kernel-headers) 
looking for inter-conflicts..
:: linux-api-headers conflicts with kernel-headers. Remove kernel-headers? [b]YES[/b]
:: util-linux-ng conflicts with e2fsprogs. remove e2sprogs ? yes/no

if I press yes

error: failed to prepare transaction (could not satisfy dependencies)
:: cryptsetup requieres e2fsprogs
:: gcc
:: jfsutils
:: nfs utils
:: xfsprogs

all thoose tools requieres e2fsprogs
if I press no
error: unresolvable package conflicts detected
error: failed to prepare transaction

so what should I do if I have linux from the box and want to install openbox ?? o_O

Offline

#29 2010-02-10 23:21:56

sand_man
Member
From: Australia
Registered: 2008-06-10
Posts: 2,164

Re: Replace kernel-headers with core/linux-api-headers?

Someone may need to confirm this with someone, but you might need to skip the dependancy check when removing kernel-headers then install linux-api-headers.

pacman -Rd kernel-headers
pacman -S linux-api-headers

Last edited by sand_man (2010-02-10 23:26:21)


neutral

Offline

#30 2010-02-10 23:32:08

Allan
Pacman
From: Brisbane, AU
Registered: 2007-06-09
Posts: 11,425
Website

Re: Replace kernel-headers with core/linux-api-headers?

Nope.  It looks like a case of a badly outdated mirror.  e2fsprogs does not conflict with util-linux-ng.   Try changing mirrors and updating again.

Offline

#31 2010-03-07 15:05:59

Dave Cohen
Member
Registered: 2008-09-27
Posts: 126

Re: Replace kernel-headers with core/linux-api-headers?

linux-api-headers has nothing to do with the kernel.  It is part of the toolchain.

I'm glad to see this explicitly stated.  I had problems with a kernel upgrade, so I added

IgnorePkg = kernel26

to my /etc/pacman.conf.  Ever since I've had concerns when I see kernel-headers package version change, fearing a mismatch.  And because of that I've said no to the replace with linux-api-headers.

Now that I've seen this, I'll accept the upgrade.

Offline

Board footer

Powered by FluxBB