You are not logged in.

#651 2011-05-20 08:54:05

zodmaner
Member
Registered: 2007-07-11
Posts: 653

Re: systemd: Yet Another Init Replacement

sand_man wrote:
falconindy wrote:

Separate /var is fine. It will never support separate /usr.

Does anyone have /usr on a separate partition? I don't think I ever have.
I do in FreeBSD but that's different.

I used separate /usr on my netbook, which have two SSD with very limited storage space, one 4GB and another 16GB.

Offline

#652 2011-05-20 09:29:48

hauzer
Member
From: Belgrade, Serbia
Registered: 2010-11-17
Posts: 279
Website

Re: systemd: Yet Another Init Replacement

sand_man wrote:

Does anyone have /usr on a separate partition? I don't think I ever have.
I do in FreeBSD but that's different.

I had it untill a day ago for about two months, just for the kicks. But I've merged it with / to try out systemd.


Vanity of vanities, saith the Preacher, vanity of vanities; all is vanity.
What profit hath a man of all his labour which he taketh under the sun?
All the rivers run into the sea; yet the sea is not full; unto the place from whence the rivers come, thither they return again.
For in much wisdom is much grief: and he that increaseth knowledge increaseth sorrow.

Offline

#653 2011-05-20 10:13:36

XZS
Member
Registered: 2011-05-11
Posts: 29

Re: systemd: Yet Another Init Replacement

falconindy wrote:

findmnt [...] lsblk [...] (util-linux 2.19) tool for looking at actual block devices.

Now that is a nice tool. And in such a basic package.


falconindy wrote:

Feel free to mangle the package as you see fit.

sed -i '/^\(initscripts\|sysvinit\)$/d' /var/lib/pacman/local/systemd-26-1/desc

Farwell, old sysvinit.


falconindy wrote:

Create a symlink to /dev/null for the mount unit you want obliterated

I tried this at first. Though these units kept listed as failed in systemctl list-units. Seemingly, meanwhile an update fixed that. Now they are gone.


falconindy wrote:
XZS wrote:

/etc/locale.conf: LANG=de_DE.utf8

I'd say you failed to set your locale in /etc/locale.conf. See 'man locale.conf'.

The locale.conf worked fine ever since. As WorMzy pointed out, /etc/profile.d/locale.sh was the culprit.


So everything is fixed now. Thanks for the quick solutions.

Offline

#654 2011-05-21 18:38:50

reflexing
Member
Registered: 2009-03-25
Posts: 58
Website

Re: systemd: Yet Another Init Replacement

Systemd fails booting with latest kernel26 from testing (maybe it is because of udev or other new packages, dunno).

It brings in emergency shell and freeze if I try to continue.

Here is dmesg:

[   96.473512] systemd[1]: Job dev-mapper-arch\x2dboot.device/start timed out.
[   96.473570] systemd[1]: Job local-fs.target/start failed with result 'dependency'.
[   96.473578] systemd[1]: Triggering OnFailure= dependencies of local-fs.target.
[   96.473787] systemd[1]: Job var-lock.mount/start failed with result 'dependency'.
[   96.473835] systemd[1]: Job dbus.service/start failed with result 'dependency'.
[   96.473866] systemd[1]: Job console-kit-daemon.service/start failed with result 'dependency'.
[   96.473875] systemd[1]: Job dbus.socket/start failed with result 'dependency'.
[   96.473883] systemd[1]: Job var-run.mount/start failed with result 'dependency'.
[   96.473892] systemd[1]: Job var.mount/start failed with result 'dependency'.
[   96.473919] systemd[1]: Job fsck@dev-mapper-arch\x2dvar.service/start failed with result 'dependency'.
[   96.473940] systemd[1]: Job mnt-media.mount/start failed with result 'dependency'.
[   96.473971] systemd[1]: Job fsck@dev-mapper-arch\x2dmedia.service/start failed with result 'dependency'.
[   96.473992] systemd[1]: Job home.mount/start failed with result 'dependency'.
[   96.474023] systemd[1]: Job fsck@dev-mapper-arch\x2dhome.service/start failed with result 'dependency'.
[   96.474303] systemd[1]: Job boot.mount/start failed with result 'dependency'.
[   96.474312] systemd[1]: Job dev-mapper-arch\x2dboot.device/start failed with result 'timeout'.
[   97.096838] systemd[1]: Startup finished in 6s 154ms 716us (kernel) + 1min 30s 942ms 50us (userspace) = 1min 37s 96ms 766us.

Obviously it fails on mounting filesystems. I have my partitions on LVM. I don't know how to get more verbose details...

Offline

#655 2011-05-21 19:50:05

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: systemd: Yet Another Init Replacement

reflexing wrote:

Systemd fails booting with latest kernel26 from testing (maybe it is because of udev or other new packages, dunno).

Obviously it fails on mounting filesystems. I have my partitions on LVM. I don't know how to get more verbose details...

And the normal init works okay?


ᶘ ᵒᴥᵒᶅ

Offline

#656 2011-05-21 20:04:03

reflexing
Member
Registered: 2009-03-25
Posts: 58
Website

Re: systemd: Yet Another Init Replacement

litemotiv wrote:
reflexing wrote:

Systemd fails booting with latest kernel26 from testing (maybe it is because of udev or other new packages, dunno).

Obviously it fails on mounting filesystems. I have my partitions on LVM. I don't know how to get more verbose details...

And the normal init works okay?

Yep, normal init boots fine. Forgot to mention that i'm using systemd-git and systemd-arch-units-git form AUR.

Offline

#657 2011-05-21 20:48:50

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,111
Website

Re: systemd: Yet Another Init Replacement

I can reproduce this. it's udev/mkinitcpio related. You'll need to modify the LVM udev rule as mentioned in FS#24272:

https://bugs.archlinux.org/task/24272

Make sure to generate your initramfs after making the change. My non-root LVM volumes work just fine with the modified rule.

Offline

#658 2011-05-21 21:08:44

reflexing
Member
Registered: 2009-03-25
Posts: 58
Website

Re: systemd: Yet Another Init Replacement

falconindy wrote:

I can reproduce this. it's udev/mkinitcpio related. You'll need to modify the LVM udev rule as mentioned in FS#24272:

https://bugs.archlinux.org/task/24272

Make sure to generate your initramfs after making the change. My non-root LVM volumes work just fine with the modified rule.

Thanks, boots like a charm now.

Offline

#659 2011-05-23 19:15:28

BasT
Member
Registered: 2010-08-28
Posts: 94

Re: systemd: Yet Another Init Replacement

I just set systemd (27-2 from [community]) up and the one thing that doesn't work is rebooting:

shutdown[23134]: shutting down for system reboot
systemd-initctl[23140]: Received environment initctl request. This is not implemented in systemd.

I found this thread on the [systemd-devel] mailinglist regarding this problem but haven't figured out how to correctly fix it:
http://lists.freedesktop.org/archives/s … 00434.html
(setting an environment variable?)

The other solution I found here (http://lists.freedesktop.org/archives/s … 00072.html) fixes the problem by creating certain symlinks but that would break the use of sysvinit, right? I'd prefer keeping that fallback option for now.

Last edited by BasT (2011-05-23 19:16:36)

Offline

#660 2011-05-23 19:23:17

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,111
Website

Re: systemd: Yet Another Init Replacement

Great, but how did you try to reboot to get that error?

Rebooting here via 'reboot', 'init 6', or 'systemctl reboot' all work just fine.

Offline

#661 2011-05-23 19:45:14

BasT
Member
Registered: 2010-08-28
Posts: 94

Re: systemd: Yet Another Init Replacement

It happens when I use the Reboot button from the KDE menu.

Rebooting from console seems to work fine.

Offline

#662 2011-05-23 20:47:19

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,111
Website

Re: systemd: Yet Another Init Replacement

So the question then becomes: how are you starting KDE? Are you using KDM? Have you enabled pam_systemd.so in /etc/pam.d/kdm? Do you have a proper consolekit session?

Offline

#663 2011-05-23 21:12:26

BasT
Member
Registered: 2010-08-28
Posts: 94

Re: systemd: Yet Another Init Replacement

falconindy wrote:

So the question then becomes: how are you starting KDE? Are you using KDM?

Yes.

Have you enabled pam_systemd.so in /etc/pam.d/kdm?

No. Should I? Currently there is no /etc/pam.d/kdm.

Do you have a proper consolekit session?

console-kit-daemon.service is running. I followed the wiki on that issue:

archwiki wrote:

On KDE start an error message will appear saying "console-kit-daemon.unit" could not be found. To solve this problem install systemd-arch-units.

Offline

#664 2011-05-24 09:18:06

reflexing
Member
Registered: 2009-03-25
Posts: 58
Website

Re: systemd: Yet Another Init Replacement

BasT wrote:
falconindy wrote:

So the question then becomes: how are you starting KDE? Are you using KDM?

Yes.

Have you enabled pam_systemd.so in /etc/pam.d/kdm?

No. Should I? Currently there is no /etc/pam.d/kdm.

Do you have a proper consolekit session?

console-kit-daemon.service is running. I followed the wiki on that issue:

archwiki wrote:

On KDE start an error message will appear saying "console-kit-daemon.unit" could not be found. To solve this problem install systemd-arch-units.

Try this (from Gentoo wiki):

Note: KDM will fail to reboot/halt because /sbin/halt and /sbin/reboot are no longer in the system, so as a workaround you can create a wrapper to the systemd equivalents:
File: /usr/local/sbin/reboot

#!/bin/sh
/bin/systemctl reboot

File: /usr/local/bin/halt

#!/bin/sh
/bin/systemctl halt

Then add/edit this section to the file at /usr/share/config/kdm/kdmrc (or changing it via systemsettings)

File: /usr/share/config/kdm/kdmrc

[Shutdown]
HaltCmd=/usr/local/sbin/halt
RebootCmd=/usr/local/sbin/reboot

I think we should add this to the wiki too, yes, Falconindy?

Offline

#665 2011-05-24 10:12:28

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,111
Website

Re: systemd: Yet Another Init Replacement

No, it shouldn't be added, because the community package requires sysvinit, meaning /sbin/reboot and /sbin/halt still exist.

No. Should I? Currently there is no /etc/pam.d/kdm.

Ah, it's called kde, not kdm. and yes.

Last edited by falconindy (2011-05-24 10:15:29)

Offline

#666 2011-05-24 10:13:31

Zom
Member
From: Sweden
Registered: 2007-10-27
Posts: 430

Re: systemd: Yet Another Init Replacement

reflexing wrote:

Try this (from Gentoo wiki):

Note: KDM will fail to reboot/halt because /sbin/halt and /sbin/reboot are no longer in the system, so as a workaround you can create a wrapper to the systemd equivalents:
File: /usr/local/sbin/reboot

#!/bin/sh
/bin/systemctl reboot

File: /usr/local/bin/halt

#!/bin/sh
/bin/systemctl halt

Then add/edit this section to the file at /usr/share/config/kdm/kdmrc (or changing it via systemsettings)

File: /usr/share/config/kdm/kdmrc

[Shutdown]
HaltCmd=/usr/local/sbin/halt
RebootCmd=/usr/local/sbin/reboot

I think we should add this to the wiki too, yes, Falconindy?

This is only needed if you remove sysvinit, IIRC.

E: That's what I get for not refreshing before posting, I suppose.

Last edited by Zom (2011-05-24 10:15:03)

Offline

#667 2011-05-24 12:00:24

Zom
Member
From: Sweden
Registered: 2007-10-27
Posts: 430

Re: systemd: Yet Another Init Replacement

falconindy wrote:

Have you enabled pam_systemd.so in /etc/pam.d/kdm?

This seems like a good idea to be honest. I had no idea about this.

So, reading man pam_systemd, and as far as I understand it, the example section basically had it nailed down pretty well:

session    required     pam_systemd.so kill-user=1

This will ensure anything started in the kde session is killed when you log out/reboot/halt the computer, right?

I should probably add this to the wiki... smile

E: Oh. Perhaps I should start reading the wiki a bit more closely then.

Last edited by Zom (2011-05-24 12:35:28)

Offline

#668 2011-05-24 12:11:58

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,111
Website

Re: systemd: Yet Another Init Replacement

The wiki already mentions this.  If anything, the wiki should merely refer people to the man page to let them figure out what options make sense for their setup. I personally prefer the default behavior, as the man page also mentions:

Note that setting kill-user=1 or even kill-session=1 will break tools like screen(1)

Offline

#669 2011-05-25 10:57:55

franz1789
Member
Registered: 2008-04-22
Posts: 56

Re: systemd: Yet Another Init Replacement

I have a problem with systemd: everytime my system halt "improprerly" (and this happens sometimes, since I am on a notebook) when I boot into archlinux systemd says emergency mode, ask me for ctrl-d or root pass. Well, there's no way to make it boot, if I press ctrl-d it simply repeat those line, if I give my root pass it brings me in a root console, I do a fsck and all is ok. systemctl default just fails, saying that's destructive (or stuff like that).. what to do?

Offline

#670 2011-05-25 15:24:41

sidneyk
Member
From: Bonner Springs, KS. USA
Registered: 2011-04-22
Posts: 129

Re: systemd: Yet Another Init Replacement

franz1789 wrote:

I have a problem with systemd: everytime my system halt "improprerly" (and this happens sometimes, since I am on a notebook) when I boot into archlinux systemd says emergency mode, ask me for ctrl-d or root pass. Well, there's no way to make it boot, if I press ctrl-d it simply repeat those line, if I give my root pass it brings me in a root console, I do a fsck and all is ok. systemctl default just fails, saying that's destructive (or stuff like that).. what to do?

Not trying to come across as unhelpful, but did you follow the wiki on systemd? Are you trying to boot up to a graphical environment, like Gnome or KDE, or such? Did you include the kernel command line option in your grub config.? Someone here can probably get you pointed in the right direction, but we need a little more info.

Offline

#671 2011-05-25 15:38:20

reflexing
Member
Registered: 2009-03-25
Posts: 58
Website

Re: systemd: Yet Another Init Replacement

franz1789 wrote:

I have a problem with systemd: everytime my system halt "improprerly" (and this happens sometimes, since I am on a notebook) when I boot into archlinux systemd says emergency mode, ask me for ctrl-d or root pass. Well, there's no way to make it boot, if I press ctrl-d it simply repeat those line, if I give my root pass it brings me in a root console, I do a fsck and all is ok. systemctl default just fails, saying that's destructive (or stuff like that).. what to do?

I am also experiencing this bug.

Offline

#672 2011-05-25 17:21:27

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,111
Website

Re: systemd: Yet Another Init Replacement

Sounds like /etc/mtab isn't a symlink to /proc/self/mounts. If that isn't the case, you'll need to post your /etc/fstab.

Last edited by falconindy (2011-05-25 17:21:46)

Offline

#673 2011-05-25 20:50:39

reflexing
Member
Registered: 2009-03-25
Posts: 58
Website

Re: systemd: Yet Another Init Replacement

falconindy wrote:

Sounds like /etc/mtab isn't a symlink to /proc/self/mounts. If that isn't the case, you'll need to post your /etc/fstab.

Of course it is a symlink. Here is my /etc/fstab:

# 
# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
devpts                 /dev/pts      devpts    defaults            0      0
shm                    /dev/shm      tmpfs     nodev,nosuid        0      0
/dev/mapper/arch-home /home ext4 defaults,user_xattr 0 1
/dev/mapper/arch-media /mnt/media xfs defaults 0 1
/dev/mapper/arch-root / ext4 defaults 0 1
/dev/mapper/arch-swap swap swap defaults 0 0
/dev/mapper/arch-var /var reiserfs defaults 0 1
/dev/mapper/arch-boot /boot ext2 defaults 0 1
none /proc/bus/usb usbfs devgid=108,devmode=664 0 0

Offline

#674 2011-05-25 21:03:14

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,111
Website

Re: systemd: Yet Another Init Replacement

groan. right. you're using LVM.

@franz1789: also on LVM?

This isn't something I've seen myself under  these conditions. There's always been accompanying dependencies which failed to start as well. Booting with systemd.log_level=debug will be useful here.

Offline

#675 2011-05-25 22:40:26

franz1789
Member
Registered: 2008-04-22
Posts: 56

Re: systemd: Yet Another Init Replacement

since I never followed the lvm archwiki (and since I didn't even know what was it) I think that no, I'm not using it big_smile

should I add systemd.log_level=debug to kernel line in grub or which file should I edit otherwise?

Offline

Board footer

Powered by FluxBB