You are not logged in.

#776 2011-06-20 21:15:42

Lothium
Member
Registered: 2009-10-10
Posts: 192

Re: systemd: Yet Another Init Replacement

Mmh... very strange. Today I tried to uninstall and reinstall systemd to give it a second try, but when I try to start my system it do a filesystemcheck on root and than it stops working completely. No idea why. This is so frustrating. Why systemd isn't working on my system? This gonna be a long night hmm

@Zom: Yes sorry, last time I entered the wrong letters. Now it says at boot it uses hwclock, but now my system doesn't start anyway.


Edit: Mmmh... after the filesystemcheck it says "Starting remount root fs" and here it stops. When I wait or press "Ctrl+Alt+del" it can't restart, because it says there are dependency errors. Anyone an idea? As I already said, I reinstalled systemd with all dependencys, cause last time suddenly it doesnt  restart anymore, everytime I want to shutdown or restart.

Last edited by Lothium (2011-06-20 22:01:28)

Offline

#777 2011-06-21 10:36:28

Viper_Scull
Member
From: London, UK
Registered: 2011-01-15
Posts: 153

Re: systemd: Yet Another Init Replacement

Viper_Scull wrote:

Console System Startup Loggin status is failed:

console-kit-log-system-start.service - Console System Startup Logging
      Loaded: loaded (/lib/systemd/system/console-kit-log-system-start.service)
      Active: failed since Mon, 20 Jun 2011 15:19:11 +0200; 7min ago
     Process: 302 ExecStart=/usr/sbin/ck-log-system-start (code=exited, status=1/FAILURE)
      CGroup: name=systemd:/system/console-kit-log-system-start.service

However if i restart the service:

console-kit-log-system-start.service - Console System Startup Logging
      Loaded: loaded (/lib/systemd/system/console-kit-log-system-start.service)
      Active: active (exited) since Mon, 20 Jun 2011 15:27:57 +0200; 1s ago
     Process: 1173 ExecStart=/usr/sbin/ck-log-system-start (code=exited, status=0/SUCCESS)
      CGroup: name=systemd:/system/console-kit-log-system-start.service

Could it be anything related to the dependencies?

[Unit]
Description=Console System Startup Logging
DefaultDependencies=no
After=sysinit.target
Before=shutdown.target

[Service]
Type=oneshot
ExecStart=/usr/sbin/ck-log-system-start
RemainAfterExit=yes

Any comments someone?

I think this could be the problem but i'm not sure. I have /var/log to be mounted as tmpfs. Maybe the service is called before that happens. What can i add to the field After in the service unit to make it wait for /var/log to be mounted in RAM?


Athlon II X4 620 + Gigabyte 785GPM-UD2H + 4GB DDR3 + SSD OCZ Vertex2 60GB

Archlinux x86_64 + Openbox

Offline

#778 2011-06-21 12:40:51

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,111
Website

Re: systemd: Yet Another Init Replacement

I suggest you test your theory (and perhaps rethink your mount strategy). I can only add a 'works for me'.

Last edited by falconindy (2011-06-21 12:41:04)

Offline

#779 2011-06-21 14:05:16

sidneyk
Member
From: Bonner Springs, KS. USA
Registered: 2011-04-22
Posts: 129

Re: systemd: Yet Another Init Replacement

bwat47 wrote:
falconindy wrote:
bwat47 wrote:

I am also running it with an rc.conf almost totally commented out and it works fine. Only reason I still need initscripts is because I need to run a shutdown script due to a poweroff bug in the kernel (had to out rmmod ehci_hcd in rc.local.shutdown)

Is there no way to due this natively with systemd?

scripts in /lib/systemd/system-shutdown/ will be run during shutdown. I don't recall exactly when this happens.

Thanks, I'll give that a shot.

EDIT: worked perfectly, thanks smile Now the only thing I seem to need the initscripts package for is the timezone setting. If I remove initscripts there seems to be no way to set the time zone, setting it in gnome 3 date and time resets immediately. I guess its not a big deal though, as the only unit from the initscripts package I have enabled is persistent settings and it only runs on shutdown.

I am not using the arch-persistent-settings.service, but have created a file: /etc/adjtime with 1 line that reads: hwclock --systohc --utc. I have my CMOS clock set to UTC time. I can then set the time in Gnome 3 to my local time and everything works fine with time. I dual boot Win 7 and have made the appropriate registry changes to get Win 7 to use UTC also, no problems. I've been doing this for a couple of months or better. I have nothing being used in /etc/rc.conf and have created the native .conf files in /etc for systemd's use. I picked this up from the wiki and other posts / forums somewhere. I don't know if there are any other scripts or config files that affect the time settings. At this point I'm not able to find any.

Offline

#780 2011-06-21 14:48:10

bwat47
Member
Registered: 2009-10-07
Posts: 638

Re: systemd: Yet Another Init Replacement

sidneyk wrote:
bwat47 wrote:
falconindy wrote:

scripts in /lib/systemd/system-shutdown/ will be run during shutdown. I don't recall exactly when this happens.

Thanks, I'll give that a shot.

EDIT: worked perfectly, thanks smile Now the only thing I seem to need the initscripts package for is the timezone setting. If I remove initscripts there seems to be no way to set the time zone, setting it in gnome 3 date and time resets immediately. I guess its not a big deal though, as the only unit from the initscripts package I have enabled is persistent settings and it only runs on shutdown.

I am not using the arch-persistent-settings.service, but have created a file: /etc/adjtime with 1 line that reads: hwclock --systohc --utc. I have my CMOS clock set to UTC time. I can then set the time in Gnome 3 to my local time and everything works fine with time. I dual boot Win 7 and have made the appropriate registry changes to get Win 7 to use UTC also, no problems. I've been doing this for a couple of months or better. I have nothing being used in /etc/rc.conf and have created the native .conf files in /etc for systemd's use. I picked this up from the wiki and other posts / forums somewhere. I don't know if there are any other scripts or config files that affect the time settings. At this point I'm not able to find any.

Hmm, does this set the timezone though? When I remove persistent settings my timezone gets set to london with no way to change it (gnome date and time simply would not save settings)

Offline

#781 2011-06-21 14:56:59

bwat47
Member
Registered: 2009-10-07
Posts: 638

Re: systemd: Yet Another Init Replacement

falconindy wrote:
bwat47 wrote:

I am also running it with an rc.conf almost totally commented out and it works fine. Only reason I still need initscripts is because I need to run a shutdown script due to a poweroff bug in the kernel (had to out rmmod ehci_hcd in rc.local.shutdown)

Is there no way to due this natively with systemd?

scripts in /lib/systemd/system-shutdown/ will be run during shutdown. I don't recall exactly when this happens.

Is there a similar dir for startup scripts?

Offline

#782 2011-06-21 15:19:53

sidneyk
Member
From: Bonner Springs, KS. USA
Registered: 2011-04-22
Posts: 129

Re: systemd: Yet Another Init Replacement

bwat47 wrote:
sidneyk wrote:
bwat47 wrote:

Thanks, I'll give that a shot.

EDIT: worked perfectly, thanks smile Now the only thing I seem to need the initscripts package for is the timezone setting. If I remove initscripts there seems to be no way to set the time zone, setting it in gnome 3 date and time resets immediately. I guess its not a big deal though, as the only unit from the initscripts package I have enabled is persistent settings and it only runs on shutdown.

I am not using the arch-persistent-settings.service, but have created a file: /etc/adjtime with 1 line that reads: hwclock --systohc --utc. I have my CMOS clock set to UTC time. I can then set the time in Gnome 3 to my local time and everything works fine with time. I dual boot Win 7 and have made the appropriate registry changes to get Win 7 to use UTC also, no problems. I've been doing this for a couple of months or better. I have nothing being used in /etc/rc.conf and have created the native .conf files in /etc for systemd's use. I picked this up from the wiki and other posts / forums somewhere. I don't know if there are any other scripts or config files that affect the time settings. At this point I'm not able to find any.

Hmm, does this set the timezone though? When I remove persistent settings my timezone gets set to london with no way to change it (gnome date and time simply would not save settings)

Just tested it. There may be a little bugginess in the Gnome time settings. After insuring that my CMOS clock is set to UTC, I boot and at this point my clock should come up with the correct time and then click on the time at the top and go to "Date and Time Settings". The time still shows correct (I have already set the settings under the map to 'America' and 'Chicago' for my local time zone. If I click on 'Unlock' and authenticate, for some reason the time setting reverts back to UTC, if I make my correction also in UTC and then hit 'Lock', my time is still displayed in the expected local time. If I go back to 'Date and Time Settings', it also reads out in local time. A reboot doesn't change anything.

[EDIT] Actually the displayed time in the 'Date and Time Settings' dialog goes to UTC after a few seconds whether I've clicked on 'Unlock' or authenticated or not. They should tell you that you need to set this to UTC. The settings on the left under the map set your time zone i.e. the UTC offset. Kind of clunky but it works.

Last edited by sidneyk (2011-06-21 15:52:33)

Offline

#783 2011-06-21 16:32:45

bwat47
Member
Registered: 2009-10-07
Posts: 638

Re: systemd: Yet Another Init Replacement

sidneyk wrote:
bwat47 wrote:
sidneyk wrote:

I am not using the arch-persistent-settings.service, but have created a file: /etc/adjtime with 1 line that reads: hwclock --systohc --utc. I have my CMOS clock set to UTC time. I can then set the time in Gnome 3 to my local time and everything works fine with time. I dual boot Win 7 and have made the appropriate registry changes to get Win 7 to use UTC also, no problems. I've been doing this for a couple of months or better. I have nothing being used in /etc/rc.conf and have created the native .conf files in /etc for systemd's use. I picked this up from the wiki and other posts / forums somewhere. I don't know if there are any other scripts or config files that affect the time settings. At this point I'm not able to find any.

Hmm, does this set the timezone though? When I remove persistent settings my timezone gets set to london with no way to change it (gnome date and time simply would not save settings)

Just tested it. There may be a little bugginess in the Gnome time settings. After insuring that my CMOS clock is set to UTC, I boot and at this point my clock should come up with the correct time and then click on the time at the top and go to "Date and Time Settings". The time still shows correct (I have already set the settings under the map to 'America' and 'Chicago' for my local time zone. If I click on 'Unlock' and authenticate, for some reason the time setting reverts back to UTC, if I make my correction also in UTC and then hit 'Lock', my time is still displayed in the expected local time. If I go back to 'Date and Time Settings', it also reads out in local time. A reboot doesn't change anything.

[EDIT] Actually the displayed time in the 'Date and Time Settings' dialog goes to UTC after a few seconds whether I've clicked on 'Unlock' or authenticated or not. They should tell you that you need to set this to UTC. The settings on the left under the map set your time zone i.e. the UTC offset. Kind of clunky but it works.

It seems as long as I leave timezone uncommented in rc.conf I can remove the initscripts fine and gnome 3 shows the correct timezone. I am using ntpd for my hwclock and the time seems to stay correct. I guess the gnome 3 date and time is just hardcoded to read the timezone from rc.conf.

Removing initscripts-systemd shaved 2-3 seconds from my boot, even though the only unit I was using was persistant settings. I now get ~14-15 second boot time  on my laptop smile

Last edited by bwat47 (2011-06-21 16:34:17)

Offline

#784 2011-06-22 04:51:07

sidneyk
Member
From: Bonner Springs, KS. USA
Registered: 2011-04-22
Posts: 129

Re: systemd: Yet Another Init Replacement

bwat47 wrote:
sidneyk wrote:
bwat47 wrote:

Hmm, does this set the timezone though? When I remove persistent settings my timezone gets set to london with no way to change it (gnome date and time simply would not save settings)

Just tested it. There may be a little bugginess in the Gnome time settings. After insuring that my CMOS clock is set to UTC, I boot and at this point my clock should come up with the correct time and then click on the time at the top and go to "Date and Time Settings". The time still shows correct (I have already set the settings under the map to 'America' and 'Chicago' for my local time zone. If I click on 'Unlock' and authenticate, for some reason the time setting reverts back to UTC, if I make my correction also in UTC and then hit 'Lock', my time is still displayed in the expected local time. If I go back to 'Date and Time Settings', it also reads out in local time. A reboot doesn't change anything.

[EDIT] Actually the displayed time in the 'Date and Time Settings' dialog goes to UTC after a few seconds whether I've clicked on 'Unlock' or authenticated or not. They should tell you that you need to set this to UTC. The settings on the left under the map set your time zone i.e. the UTC offset. Kind of clunky but it works.

It seems as long as I leave timezone uncommented in rc.conf I can remove the initscripts fine and gnome 3 shows the correct timezone. I am using ntpd for my hwclock and the time seems to stay correct. I guess the gnome 3 date and time is just hardcoded to read the timezone from rc.conf.

Removing initscripts-systemd shaved 2-3 seconds from my boot, even though the only unit I was using was persistant settings. I now get ~14-15 second boot time  on my laptop smile

I decided to experiment a little bit tonight. I had already removed initscripts-systemd awhile back and removed initscripts tonight, which removes rc.conf (mine was already empty) and some other rc.* files and presumably, anything that was part of the initscripts package. I had to remove plymouth-git first as it has a dependency on initscripts. I tried this in a VM first. Then I rebooted and all seemed fine. I was at a 14.3 second boot and my time was showing correct. I then decided to remove the previously mentioned /etc/adjtime file just to see what would happen. I rebooted and my time is still showing my correct local time within Gnome3. I think this is what is happening. From reading systemd background info, i.e. blogs, forums, man pages, etc., etc. the kernel reads the RTC at boot and assumes that it will be in UTC. The Date and Time Setting dialog in Gnome3 allows to set the time zone (UTC offset) and, apparently, UTC time for the RTC. When this is saved the UTC offset or time zone is applied to RTC which is (or should be) already set to UTC time in order to display the correct local time within Gnome3. I can assure you that Gnome3 is not hard coded to get anything from rc.conf that I can see. I'm not using rc.conf and Gnome3-GnomeShell runs fine. Also, something has changed and the adjtime file doesn't have any effect either. My conclusion is that, at least in the case of using Gnome3, that Gnome3 is setting the time zone (UTC offset) and may be storing that TZ info in a standard place where the base Arch system can also use it. Anyway, just my observations, in case it may help.

Offline

#785 2011-06-22 04:52:55

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,111
Website

Re: systemd: Yet Another Init Replacement

Your 'observations' are a bit strange. We modify our util-linux package to write the adjustment file to /var/lib/hwclock/adjtime, and timezone is "stored" as /etc/localtime.

For all those curious, you might find yourself not being able to save changes to time/timezone/ntpd in gnome because it requires modifications to consolekit which aren't provided by default in arch.

Last edited by falconindy (2011-06-22 04:55:31)

Offline

#786 2011-06-22 05:38:31

sidneyk
Member
From: Bonner Springs, KS. USA
Registered: 2011-04-22
Posts: 129

Re: systemd: Yet Another Init Replacement

falconindy wrote:

Your 'observations' are a bit strange. We modify our util-linux package to write the adjustment file to /var/lib/hwclock/adjtime, and timezone is "stored" as /etc/localtime.

For all those curious, you might find yourself not being able to save changes to time/timezone/ntpd in gnome because it requires modifications to consolekit which aren't provided by default in arch.

Thanks for the clarification. I just looked at that file, /var/lib/hwclock/adjtime, and indeed the 3rd line says UTC. I had seen the presence of the /etc/localtime file and figured that that was where the 'localtime' setting was stored. Again, I was observing that creating a file /etc/adjtime and using the setting intitially presented in the wiki wasn't doing anything like I initially thought it was. I'll have to take a closer look at the util-linux package to further my understanding. But this would confirm, as I believe this 'adjtime' is written back to the RTC at shutdown, at least I read that somewhere, and in my case, UTC is being written back. I am definitely seeing the time in the Gnome3 "Date and Time Setting' dialog switch back to displaying UTC time when I unlock the dialog to make changes and without making any change to the local time settings there, which are set to my correct time zone. Part of what I was expressing was that that seems to be a bug, at least in design, or like you said, an inability, perhaps, to do it correctly. Gnome3 should either say that the displayed time setting is actually UTC or keep it displaying the time with the offset applied to make it transparent to the end user, instead of having to figure that out. I know Gnome3 is not your concern. I was just trying to be helpful as I knew that rc.conf wasn't necessary when using systemd in order to get a correct time setting. I appreciate when those like yourself who have the knowledge share some of it with the rest of us so that we also learn more. Thanks for your work on the systemd package.

Offline

#787 2011-06-22 11:50:38

Viper_Scull
Member
From: London, UK
Registered: 2011-01-15
Posts: 153

Re: systemd: Yet Another Init Replacement

falconindy wrote:

I suggest you test your theory (and perhaps rethink your mount strategy). I can only add a 'works for me'.

Well. my mount strategy is the one recommended for SSD disks. AFAIK you also have one, and to preserve the disk live, one has to avoid as many writes as possible.

What i wanted to add is a .service or a .target in the field "After" so it waits till the tmp fs are mounted. Of course this could have nothing to do with it. but it's strange that it doesnt work at the boot, but it works if i restart it later.


Athlon II X4 620 + Gigabyte 785GPM-UD2H + 4GB DDR3 + SSD OCZ Vertex2 60GB

Archlinux x86_64 + Openbox

Offline

#788 2011-06-23 08:54:40

Revelation60
Member
From: The Netherlands
Registered: 2009-03-19
Posts: 155
Website

Re: systemd: Yet Another Init Replacement

I am getting a bunch of errors, maybe related to systemd:

[    6.345705] udevd[854]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.346592] udevd[856]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.346733] udevd[855]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.346940] udevd[858]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.347126] udevd[859]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.347267] udevd[860]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.347667] udevd[861]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.348065] udevd[862]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.348211] udevd[857]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.348431] udevd[865]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.348512] udevd[864]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.348669] udevd[863]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.348905] udevd[866]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.349816] udevd[867]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.349904] udevd[868]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.381692] udevd[870]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.392199] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
[    6.392272] HDA Intel 0000:00:1b.0: irq 45 for MSI/MSI-X
[    6.392297] HDA Intel 0000:00:1b.0: setting latency timer to 64
[    6.392703] udevd[871]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.458781] nvidia: module license 'NVIDIA' taints kernel.
[    6.458786] Disabling lock debugging due to kernel taint
[    6.486020] udevd[882]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.499972] hda_codec: ALC883: BIOS auto-probing.
[    6.500154] udevd[883]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.501292] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1b.0/input/input2
[    6.504683] input: HDA Intel Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input3
[    6.505336] udevd[885]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.505346] udevd[884]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.506496] udevd[887]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.509222] udevd[888]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.510346] udevd[889]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.513488] udevd[890]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.514303] udevd[891]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.516111] udevd[894]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.516836] udevd[895]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.519301] udevd[897]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.519842] udevd[899]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.522609] udevd[903]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.523177] udevd[904]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.602694] mtp-probe[881]: checking bus 1, device 3: "/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-3"
[    6.613361] usb 2-5: new high speed USB device number 2 using ehci_hcd
[    6.741284] mtp-probe[906]: checking bus 2, device 2: "/sys/devices/pci0000:00/0000:00:1d.7/usb2/2-5"
[    6.780105] firewire_core: created device fw0: GUID 001e8c000139f2c1, S400
[    6.781643] udevd[907]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.856062] udevd[908]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.863836] udevd[911]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.907283] udevd[913]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.908132] udevd[914]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.944490] udevd[915]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.945332] udevd[916]: failed to execute '/lib/udev/vol_id' 'vol_id --export /dev/sda6': No such file or directory
[    6.945841] udevd[917]: failed to execute '/lib/udev/vol_id' 'vol_id --export /dev/sda7': No such file or directory
[    6.947155] udevd[922]: failed to execute '/lib/udev/vol_id' 'vol_id --export /dev/sda4': No such file or directory
[    6.947323] udevd[921]: failed to execute '/lib/udev/vol_id' 'vol_id --export /dev/sda5': No such file or directory
[    6.947867] udevd[919]: failed to execute '/lib/udev/vol_id' 'vol_id --export /dev/sda2': No such file or directory
[    6.950207] udevd[920]: failed to execute '/lib/udev/vol_id' 'vol_id --export /dev/sda1': No such file or directory
[    6.960441] udevd[928]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.960519] udevd[929]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.961170] udevd[930]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.962336] udevd[932]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.962881] udevd[931]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    6.963405] usb 3-2: new low speed USB device number 2 using uhci_hcd
[    6.963659] udevd[933]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    7.052658] fuse init (API version 7.16)
[    7.053419] udevd[939]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    7.053738] udevd[940]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    7.055844] udevd[938]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    7.056937] udevd[942]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    7.074057] Adding 2554296k swap on /dev/sda5.  Priority:0 extents:1 across:2554296k 
[    7.141907] mtp-probe[945]: checking bus 3, device 2: "/sys/devices/pci0000:00/0000:00:1a.0/usb3/3-2"
[    7.158154] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[    7.158164] nvidia 0000:01:00.0: setting latency timer to 64
[    7.158169] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
[    7.158335] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  275.09.07  Wed Jun  8 14:16:46 PDT 2011
[    7.158826] udevd[946]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    7.160009] udevd[947]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    7.370110] usb 4-2: new low speed USB device number 2 using uhci_hcd
[    7.482651] udevd[949]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    7.484320] ntfs-3g[951]: Version 2011.4.12 external FUSE 28
[    7.484331] ntfs-3g[951]: Mounted /dev/sda2 (Read-Write, label "DATA", NTFS 3.1)
[    7.484338] ntfs-3g[951]: Cmdline options: rw
[    7.484346] ntfs-3g[951]: Mount options: rw,allow_other,nonempty,atime,fsname=/dev/sda2,blkdev,blksize=4096
[    7.484353] ntfs-3g[951]: Ownership and permissions disabled, configuration type 1
[    7.544385] mtp-probe[906]: bus: 2, device: 2 was not an MTP device
[    7.545897] mtp-probe[881]: bus: 1, device: 3 was not an MTP device
[    7.545956] mtp-probe[953]: checking bus 2, device 2: "/sys/devices/pci0000:00/0000:00:1d.7/usb2/2-5"
[    7.546056] mtp-probe[954]: checking bus 4, device 2: "/sys/devices/pci0000:00/0000:00:1a.1/usb4/4-2"
[    7.548689] mtp-probe[955]: checking bus 1, device 3: "/sys/devices/pci0000:00/0000:00:1a.7/usb1/1-3"
[    7.560011] mtp-probe[945]: bus: 3, device: 2 was not an MTP device
[    7.561916] mtp-probe[953]: bus: 2, device: 2 was not an MTP device
[    7.561937] mtp-probe[957]: checking bus 3, device 2: "/sys/devices/pci0000:00/0000:00:1a.0/usb3/3-2"
[    7.566040] mtp-probe[955]: bus: 1, device: 3 was not an MTP device
[    7.573215] mtp-probe[954]: bus: 4, device: 2 was not an MTP device
[    7.574563] mtp-probe[968]: checking bus 4, device 2: "/sys/devices/pci0000:00/0000:00:1a.1/usb4/4-2"
[    7.580923] mtp-probe[957]: bus: 3, device: 2 was not an MTP device
[    7.586190] mtp-probe[968]: bus: 4, device: 2 was not an MTP device
[    7.694521] udevd[1005]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    7.694795] udevd[1006]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    7.695886] udevd[1008]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    7.696190] udevd[1010]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    7.766839] udevd[1014]: failed to execute '/usr/local/bin/unlock' '/usr/local/bin/unlock': Permission denied
[    7.818261] rt2870sta: module is from the staging directory, the quality is unknown, you have been warned.

And this goes on for a very long time.

Offline

#789 2011-06-23 21:08:13

framas
Member
Registered: 2009-07-24
Posts: 50

Re: systemd: Yet Another Init Replacement

I'm running systemd since a few days and I run into some troubles whith fstab entries pointing to /media/

During startup systemd creates only directories for mount points in /media which are mounted during startup.
Directories which have the fstab option noauto set are not created. It doesn't help to create them manually. The folders are gone during next reboot (systemd seems to delete them).
So I wrote a little script  and a unit to handle this.

ls -l /lib/systemd/system/local-fs.target.wants/media-create.service 
lrwxrwxrwx 1 root root 32 23. Jun 19:42 /lib/systemd/system/local-fs.target.wants/media-create.service -> /lib/systemd/system/media.create
cat /lib/systemd/system/media.create
[Unit]
Description=Creates direcotrys in media which mount is not set to auto
After=media.mount

[Service]
Type=oneshot
StandardOutput=syslog+console
ExecStart=/sbin/createMountpoints
cat /sbin/createMountpoints
#!/bin/sh
fstab=( $(grep "^[^#].*noauto"  /etc/fstab   | awk '{ print $2 }') )
echo "lenth  ${#fstab[@]}"
for i in $(seq 0 $(expr ${#fstab[@]} - 1))
do
        if [ ! -d ${fstab[$i]}  ]
        then
                logger  "mkdir ${fstab[$i]}"
                mkdir -p ${fstab[$i]}
                if [ $? -ne 0 ]
                then
                        logger "Failed to create  ${fstab[$i]}"
                fi
        fi
done

This should help for fstab entrys like nfs, smb or  cd drive  entrys which should not be mount during startup.

The reason I post this is, that I want to know if systemd does not provide a built in function to solve such a kind of problem.
If not maybe I could help other users.

Offline

#790 2011-06-23 21:09:29

framas
Member
Registered: 2009-07-24
Posts: 50

Re: systemd: Yet Another Init Replacement

I'm running systemd since a few days and I run into some troubles whith fstab entries pointing to /media/

During startup systemd creates only directories for mount points in /media which are mounted during startup.
Directories which have the fstab option noauto set are not created. It doesn't help to create them manually. The folders are gone during next reboot (systemd seems to delete them).
So I wrote a little script  and a unit to handle this.

ls -l /lib/systemd/system/local-fs.target.wants/media-create.service 
lrwxrwxrwx 1 root root 32 23. Jun 19:42 /lib/systemd/system/local-fs.target.wants/media-create.service -> /lib/systemd/system/media.create
cat /lib/systemd/system/media.create
[Unit]
Description=Creates direcotrys in media which mount is not set to auto
After=media.mount

[Service]
Type=oneshot
StandardOutput=syslog+console
ExecStart=/sbin/createMountpoints
cat /sbin/createMountpoints
#!/bin/sh
fstab=( $(grep "^[^#].*noauto"  /etc/fstab   | awk '{ print $2 }') )
echo "lenth  ${#fstab[@]}"
for i in $(seq 0 $(expr ${#fstab[@]} - 1))
do
        if [ ! -d ${fstab[$i]}  ]
        then
                logger  "mkdir ${fstab[$i]}"
                mkdir -p ${fstab[$i]}
                if [ $? -ne 0 ]
                then
                        logger "Failed to create  ${fstab[$i]}"
                fi
        fi
done

This should help for fstab entrys like nfs, smb or  cd drive  entrys which should not be mount during startup.

The reason I post this is, that I want to know if systemd does not provide a built in function to solve such a kind of problem.
If not maybe I could help other users.

Offline

#791 2011-06-24 01:03:55

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,111
Website

Re: systemd: Yet Another Init Replacement

A page or two ago in this thread I pointed out that /media gets mounted with a tmpfs over it. If you want your directories to stop "disappearing", mask the /lib/systemd/systemd/media.mount unit.

Offline

#792 2011-06-24 12:13:21

Maki
Member
From: Skopje, Macedonia
Registered: 2007-10-16
Posts: 353
Website

Re: systemd: Yet Another Init Replacement

when i try to shutdown/poweroff systemd sometimes prints "Error: Connection refused" or "Error: Connection reset by peer" then hangs for a minute or two and then reboot, i use nfs for remote partitions so that may be the reason but i couldn't find anything usefull.


If it ain't broke, broke it then fix it.

Offline

#793 2011-06-24 23:57:12

EpocSquadron
Member
Registered: 2011-06-24
Posts: 5

Re: systemd: Yet Another Init Replacement

Like many others, I am trying to replace init entirely with systemd (as much as is currently possible).  I have disables the arch-daemons.target and have most of the service files I need to replicate the DAEMONS array.  The only one I have yet to find is ufw.service.

I have tried to create my own:

[Unit]
Description=Uncomplicated Firewall
After=syslog.target
Requires=iptables.service

[Service]
Type=forking
ExecStart=/usr/bin/ufw enable
ExecReload=/usr/bin/ufw reload
ExecStop=/usr/bin/ufw disable
StandardOutput=syslog

[Install]
WantedBy=multi-user.target

But I run into the following issues:
-With Type=simple or anything else, running systemctl start/stop ufw.service raises no error, but also has no effect when inspecting via "ufw status"
-Using Exec*=/etc/rc.d/ufw start/stop/reload did not help.
-With Type=forking, running systemctl start/stop ufw.service raises error:

A dependency job failed.

Looking into it I find that iptables.service is failing.

It may be that the above service file actually works and that my own system's iptables is somehow broken. I'm also really not sure if I should eb using Requires or Wants for the iptables dependency, neither setting affects my "error".  I'd appreciate testing/feedback.

[Edit] Forgot to add that simple using ufw enable does not, as the output suggests, make ufw active at startup with systemd.

Last edited by EpocSquadron (2011-06-24 23:59:34)

Offline

#794 2011-06-25 02:03:55

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,111
Website

Re: systemd: Yet Another Init Replacement

I've put syslog-ng-systemd back in the AUR.

http://aur.archlinux.org/packages.php?ID=50168

It includes a patch from upstream that should resolve the hangups that were previously seen on shutdown. If folks want to give it a shot and report any explosions (or not), I'll see about opening a feature request for core/syslog-ng.

Offline

#795 2011-06-25 09:15:17

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: systemd: Yet Another Init Replacement

falconindy wrote:

I've put syslog-ng-systemd back in the AUR.

Works as advertised here, no problems so far.


ᶘ ᵒᴥᵒᶅ

Offline

#796 2011-06-25 12:38:29

snack
Member
From: Italy
Registered: 2009-01-13
Posts: 816

Re: systemd: Yet Another Init Replacement

I'm still trying to make systemd work but I cannot resolve the swap partition problem. From this log:

2011-06-19T14:34:23.861558+02:00 localhost kernel: [    3.258831] systemd[1]: systemd 29 running in system mode. (+PAM -LIBWRAP -AUDIT -SELINUX +SYSVINIT +LIBCRYPTSETUP; arch)
2011-06-19T14:34:23.861559+02:00 localhost kernel: [    3.472555] NET: Registered protocol family 10
2011-06-19T14:34:23.861563+02:00 localhost kernel: [    3.480428] systemd[1]: Set hostname to <conan>.
2011-06-19T14:34:23.861566+02:00 localhost kernel: [    4.814494] systemd-fsck[284]: /dev/sda2: clean, 178994/1250928 files, 3492883/5000231 blocks
2011-06-19T14:34:23.861567+02:00 localhost kernel: [    4.877878] EXT4-fs (sda2): re-mounted. Opts: (null)
2011-06-19T14:34:23.861569+02:00 localhost kernel: [   94.111843] systemd[1]: Job dev-sda3.device/start timed out.
2011-06-19T14:34:23.861571+02:00 localhost kernel: [   94.123079] systemd[1]: Job dev-sda3.swap/start failed with result 'dependency'.
2011-06-19T14:34:23.861572+02:00 localhost kernel: [   94.128668] systemd[1]: Job dev-sda3.device/start failed with result 'timeout'.
2011-06-19T14:34:23.861574+02:00 localhost kernel: [   94.386994] systemd[1]: Job dev-tty6.device/start timed out.
2011-06-19T14:34:23.861578+02:00 localhost kernel: [   94.392230] systemd[1]: Job getty@tty6.service/start failed with result 'dependency'.
2011-06-19T14:34:23.861579+02:00 localhost kernel: [   94.397529] systemd[1]: Job dev-tty6.device/start failed with result 'timeout'.
2011-06-19T14:34:23.861581+02:00 localhost kernel: [   94.402876] systemd[1]: Job dev-tty2.device/start timed out.
2011-06-19T14:34:23.861582+02:00 localhost kernel: [   94.408262] systemd[1]: Job getty@tty2.service/start failed with result 'dependency'.
2011-06-19T14:34:23.861584+02:00 localhost kernel: [   94.413710] systemd[1]: Job dev-tty2.device/start failed with result 'timeout'.
2011-06-19T14:34:23.861586+02:00 localhost kernel: [   94.419223] systemd[1]: Job dev-tty3.device/start timed out.
2011-06-19T14:34:23.861587+02:00 localhost kernel: [   94.424737] systemd[1]: Job getty@tty3.service/start failed with result 'dependency'.
2011-06-19T14:34:23.861591+02:00 localhost kernel: [   94.430328] systemd[1]: Job dev-tty3.device/start failed with result 'timeout'.
2011-06-19T14:34:23.861593+02:00 localhost kernel: [   94.435975] systemd[1]: Job dev-tty5.device/start timed out.
2011-06-19T14:34:23.861594+02:00 localhost kernel: [   94.441666] systemd[1]: Job getty@tty5.service/start failed with result 'dependency'.
2011-06-19T14:34:23.861596+02:00 localhost kernel: [   94.447482] systemd[1]: Job dev-tty5.device/start failed with result 'timeout'.
2011-06-19T14:34:23.861597+02:00 localhost kernel: [   94.453377] systemd[1]: Job dev-tty1.device/start timed out.
2011-06-19T14:34:23.861599+02:00 localhost kernel: [   94.459372] systemd[1]: Job getty@tty1.service/start failed with result 'dependency'.
2011-06-19T14:34:23.861601+02:00 localhost kernel: [   94.465515] systemd[1]: Job dev-tty1.device/start failed with result 'timeout'.
2011-06-19T14:34:23.861602+02:00 localhost kernel: [   94.471646] systemd[1]: Job dev-tty4.device/start timed out.
2011-06-19T14:34:23.861606+02:00 localhost kernel: [   94.477807] systemd[1]: Job getty@tty4.service/start failed with result 'dependency'.
2011-06-19T14:34:23.861608+02:00 localhost kernel: [   94.484125] systemd[1]: Job dev-tty4.device/start failed with result 'timeout'.
2011-06-19T14:34:23.861609+02:00 localhost kernel: [   94.490557] systemd[1]: Job dev-tty7.device/start timed out.
2011-06-19T14:34:23.861611+02:00 localhost kernel: [   94.496974] systemd[1]: Job kdm.service/start failed with result 'dependency'.
2011-06-19T14:34:23.861612+02:00 localhost kernel: [   94.503494] systemd[1]: Job dev-tty7.device/start failed with result 'timeout'.
2011-06-19T14:34:24.746896+02:00 localhost kernel: [   95.968447] systemd[1]: Startup finished in 3s 496ms 822us (kernel) + 1min 32s 471ms 459us (userspace) = 1min 35s 968ms 281us.

I understand that the problem is timeout for dev-sda3.device/start (/dev/sda3 is my swap partition), but I don't understand why it comes up or how to narrow down the problem, nor if this is what causes getty@tty#.service to fail because of missing dependency.
Currently I have systemd 29-1 and initscripts-systemd v25-1 (no systemd-arch-units) installed. I didn't change anything in configuration, only set the default target to multi-user with systemctl -f enable multi-user.target and added init=/bin/systemd to my kernel line in grub.cfg.
I really need some help to fix this...

Offline

#797 2011-06-26 00:16:29

relgueta
Member
Registered: 2010-04-26
Posts: 31

Re: systemd: Yet Another Init Replacement

im using a quiet bootup process, there's some way to put some kind of message like "booting" in the left bottom of the screen?.

Offline

#798 2011-06-26 16:07:46

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,497
Website

Re: systemd: Yet Another Init Replacement

falconindy wrote:

I've put syslog-ng-systemd back in the AUR.

Alas, it seems to be intermittently causing hangups here. It's proving a bit difficult to reproduce -- it doesn't seem to happen if I shutdown immediately after booting up, but it's happened twice so far after running a normal session (e.g. several hours of web browsing, text editing, video watching, etc.)

The symptoms are a little different too. Before, with the official Arch package, shutdown would continue after issuing SysRq E and I; it'd print out some message about syslog-ng, then continue on it's merry way. Now E and I don't cause this behaviour, and I need to S-U-{B|O} too.

However, my shutdowns are called via dbus and ConsoleKit, and not systemctl. I'm not sure if this matters. I'll update my post once I've tried the systemctl way several times.


Sakura:-
Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#799 2011-06-26 16:51:41

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,111
Website

Re: systemd: Yet Another Init Replacement

WorMzy wrote:
falconindy wrote:

I've put syslog-ng-systemd back in the AUR.

Alas, it seems to be intermittently causing hangups here. It's proving a bit difficult to reproduce -- it doesn't seem to happen if I shutdown immediately after booting up, but it's happened twice so far after running a normal session (e.g. several hours of web browsing, text editing, video watching, etc.)

The symptoms are a little different too. Before, with the official Arch package, shutdown would continue after issuing SysRq E and I; it'd print out some message about syslog-ng, then continue on it's merry way. Now E and I don't cause this behaviour, and I need to S-U-{B|O} too.

However, my shutdowns are called via dbus and ConsoleKit, and not systemctl. I'm not sure if this matters. I'll update my post once I've tried the systemctl way several times.

You don't need to shut down to exhibit the hangup. Boot and run 'systemctl stop syslog-ng.service'. What I discovered in writing up my  bug report is that syslog-ng isn't actually hanging, it's just not responding to the systemctl call because it's not fully online with regard to systemd. It continues to log messages until the dbus call from systemctl expires and systemd sends the deathtouch. After that, if you start up syslog-ng (now no longer socket activated), it works as intended.

Based on the fix I applied, I'd be surprised if syslog-ng is still the culprit.

Last edited by falconindy (2011-06-26 16:53:50)

Offline

#800 2011-06-26 18:06:14

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,497
Website

Re: systemd: Yet Another Init Replacement

No problems exiting via systemctl during the middle of a session (two hours uptime):

Process: 565 ExecStart=/usr/sbin/syslog-ng -F (code=exited, status=0/SUCCESS)

I haven't had any hangups with rsyslog acting as a replacement, so I can't see how anything else could be the culprit.

Just to make sure we're talking about the same type of hangups: I click shutdown, X closes down, I get dumped into tty1 with a login prompt but am unable to type anything. Alt+F2 switches to tty2 with the same symptoms. Alt+SysRq+REISUB is seemingly the only way out. Are these the same symptoms of the bug you've been addressing, or is this a different one?


Sakura:-
Mobo: MSI MEG B550 UNIFY // Processor: AMD Ryzen 9 5950X @4.9GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB