You are not logged in.

#1276 2012-03-15 14:48:27

Avant-texte
Member
Registered: 2012-02-13
Posts: 136

Re: systemd: Yet Another Init Replacement

falconindy wrote:
tomegun wrote:
Avant-texte wrote:

How do I switch agetty with qingy? Obviously, custom unit(s) need to be made, but what else needs to be done.

Copy getty@.service to /etc/systemd/system and adjust ExecStart.

...and disable/enable getty@tty1.service to force it to relink to the new qingy unit.

Didn't work. After Grub loading the kernel and initramfs, nothing else was printed to the screen. I waited for a bit to be sure but, nothing came up. hmm

What I did:
  1.   Copied /lib/systemd/system/getty@.service to /etc/systemd/system/qingy@.service
  2a. Changed Description from "Getty on %I" to "Qingy on %I"
  2b. Commented out "Before=getty.target" as I won't be having other Gettys spawned durring boot
  2c. Changed ExecStart from "-/sbin/agetty %I 38400"  to "-/sbin/qingy %I"
  2d. Commented out the install section as I have no need to alias  "getty.target.wants/getty@tty1.service" and qingy@.service is already in /etc/systemd/system/
  3.   I removed getty.target.wants from /etc/systemd/system/ to disable as `systemctl disable getty@tty1.service` and anything else I could think up just turned a file not found error

Offline

#1277 2012-03-15 18:17:43

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,094
Website

Re: systemd: Yet Another Init Replacement

Avant-texte wrote:

What I did:
  1.   Copied /lib/systemd/system/getty@.service to /etc/systemd/system/qingy@.service
  2a. Changed Description from "Getty on %I" to "Qingy on %I"
  2b. Commented out "Before=getty.target" as I won't be having other Gettys spawned durring boot
  2c. Changed ExecStart from "-/sbin/agetty %I 38400"  to "-/sbin/qingy %I"
  2d. Commented out the install section as I have no need to alias  "getty.target.wants/getty@tty1.service" and qingy@.service is already in /etc/systemd/system/
  3.   I removed getty.target.wants from /etc/systemd/system/ to disable as `systemctl disable getty@tty1.service` and anything else I could think up just turned a file not found error

What you didn't do: enable the service. Without the symlink, it's not enabled. You need the ordering and the wants.

Offline

#1278 2012-03-15 22:03:41

Avant-texte
Member
Registered: 2012-02-13
Posts: 136

Re: systemd: Yet Another Init Replacement

falconindy wrote:
Avant-texte wrote:

What I did:
  1.   Copied /lib/systemd/system/getty@.service to /etc/systemd/system/qingy@.service
  2a. Changed Description from "Getty on %I" to "Qingy on %I"
  2b. Commented out "Before=getty.target" as I won't be having other Gettys spawned durring boot
  2c. Changed ExecStart from "-/sbin/agetty %I 38400"  to "-/sbin/qingy %I"
  2d. Commented out the install section as I have no need to alias  "getty.target.wants/getty@tty1.service" and qingy@.service is already in /etc/systemd/system/
  3.   I removed getty.target.wants from /etc/systemd/system/ to disable as `systemctl disable getty@tty1.service` and anything else I could think up just turned a file not found error

What you didn't do: enable the service. Without the symlink, it's not enabled. You need the ordering and the wants.

I think a couple of my steps could have been wrong. While Qingy "is not getty", it pretty much is to systemd. So, I renamed qingy@.service back to getty@.service, uncommented it's install instructions again (figuring it may need the symlinks named the exact same thing as agetty), and then disabling & enabling getty (allowing my custom unit tp overide the installed).

Unfortunately, no dice. I still get nothing. Maybe I have another problem? hmm
Aside from the custom getty unit, I have a default install.

Offline

#1279 2012-03-15 23:24:54

ron9
Member
From: Norway
Registered: 2011-02-02
Posts: 105

Re: systemd: Yet Another Init Replacement

Maybe something like this:

1. Copy /lib/systemd/system/getty@.service to /etc/systemd/system/getty@.service
2. Change ExecStart from agetty to qingy
3. Systemctl disable getty@.service / systemctl enable getty@.service
4. Systemctl reboot

lenovo w500 | ssd 850 evo | openbox | urxvt | qupzilla

Offline

#1280 2012-03-16 00:24:56

Avant-texte
Member
Registered: 2012-02-13
Posts: 136

Re: systemd: Yet Another Init Replacement

ron9 wrote:

Maybe something like this:

1. Copy /lib/systemd/system/getty@.service to /etc/systemd/system/getty@.service
2. Change ExecStart from agetty to qingy
3. Systemctl disable getty@.service / systemctl enable getty@.service
4. Systemctl reboot

Yea, that's what I did the second time around, but it still hangs. There's a moment when the harddrive makes noise, like something is happening, but then it just goes quiet.

I'm pretty sure I have all the right services enabled, so I don't know.

Offline

#1281 2012-03-18 22:32:47

Hspasta
Member
Registered: 2011-12-24
Posts: 187
Website

Re: systemd: Yet Another Init Replacement

What's the status of a transmission-daemon service on systemd? I found this, but it that was 6 months ago. Does that mean we still won't see it for a while? I tried both scripts from the link, but both failed to load.

Offline

#1282 2012-03-20 14:47:21

Arm-the-Homeless
Member
Registered: 2008-12-22
Posts: 273

Re: systemd: Yet Another Init Replacement

So. I'd like to switch over to systemd. And... I think I kinda need help. I'm not really sure how to configure it to make sure everything's working.
In my /etc/inittab, it goes to runlevel 3 which runs xinit and launches Openbox normally, if this is relevant.

This is my /etc/rc.conf:

#
# /etc/rc.conf - Main Configuration for Arch Linux
#
# See 'man 5 rc.conf' for more details
#

# LOCALIZATION
# ------------
HARDWARECLOCK="UTC"
TIMEZONE="America/New_York"
KEYMAP="us"
CONSOLEFONT=
CONSOLEMAP=
LOCALE="en_US.utf8"
DAEMON_LOCALE="yes"
USECOLOR="yes"

# HARDWARE
# --------
MODULES=()
UDEV_TIMEOUT=30
USEDMRAID="no"
USEBTRFS="no"
USELVM="no"

# NETWORKING
# ----------
HOSTNAME="vithon"

interface=eth0
address=
netmask=
broadcast=
gateway=

NETWORK_PERSIST="no"

# DAEMONS
# -------
#
DAEMONS=(!hwclock syslog-ng iptables dbus network oss @crond @ntpd)

Basically, I'm just not sure if I'm just good-to-go.

Offline

#1283 2012-03-20 15:38:49

eworm
Trusted User (TU)
From: Oberhausen, Germany
Registered: 2010-01-30
Posts: 99
Website

Re: systemd: Yet Another Init Replacement

The only way to make pstree, tmux and friends happy in console is to change getty@.service:

--- getty@.service 2012-03-20 16:28:57.831383824 +0100
+++ getty@.service 2012-03-20 16:35:44.531336593 +0100
@@ -18,7 +18,7 @@ Before=getty.target
 
 [Service]
 Environment=TERM=linux
-ExecStart=-/sbin/agetty %I 38400
+ExecStart=-/sbin/agetty %I 38400 linux
 Restart=always
 RestartSec=0
 UtmpIdentifier=%I

Anything wrong with that?


ArchLinux - make it simple & lightweight

Offline

#1284 2012-03-20 16:18:13

Avant-texte
Member
Registered: 2012-02-13
Posts: 136

Re: systemd: Yet Another Init Replacement

To be sure I cleared out systemd, reinstalled it, touched nothing in preperation of getting any service I want running, and simply tried running it with all defaults (getty and such). It won't boot [period]. I guess, systemd doesn't work out of the box for me.

It seems to start. Udev starts, the drive getts mounted, and I even get that little Welcom to Arch Linux, but nothing after that point.

Does anyone see anything wrong with the following?

$ ls -l /etc/systemd/system/*
lrwxrwxrwx 1 root root   37 Mar 14 00:23 /etc/systemd/system/default.target -> /lib/systemd/system/multi-user.target

/etc/systemd/system/getty.target.wants:
total 0
lrwxrwxrwx 1 root root 34 Mar 16 21:58 getty@tty1.service -> /lib/systemd/system/getty@.service

/etc/systemd/system/local-fs.target.wants:
total 0

/etc/systemd/system/sysinit.target.wants:
total 0

I only have systemd and systemd-arch-units and no configs have been edited.

Offline

#1285 2012-03-20 17:41:32

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,094
Website

Re: systemd: Yet Another Init Replacement

eworm wrote:

The only way to make pstree, tmux and friends happy in console is to change getty@.service:

--- getty@.service 2012-03-20 16:28:57.831383824 +0100
+++ getty@.service 2012-03-20 16:35:44.531336593 +0100
@@ -18,7 +18,7 @@ Before=getty.target
 
 [Service]
 Environment=TERM=linux
-ExecStart=-/sbin/agetty %I 38400
+ExecStart=-/sbin/agetty %I 38400 linux
 Restart=always
 RestartSec=0
 UtmpIdentifier=%I

Anything wrong with that?

Huh? Solved what problem? I haven't seen any issues here...

Offline

#1286 2012-03-20 17:54:12

eworm
Trusted User (TU)
From: Oberhausen, Germany
Registered: 2010-01-30
Posts: 99
Website

Re: systemd: Yet Another Init Replacement

falconindy wrote:
eworm wrote:

The only way to make pstree, tmux and friends happy in console is to change getty@.service:

--- getty@.service 2012-03-20 16:28:57.831383824 +0100
+++ getty@.service 2012-03-20 16:35:44.531336593 +0100
@@ -18,7 +18,7 @@ Before=getty.target
 
 [Service]
 Environment=TERM=linux
-ExecStart=-/sbin/agetty %I 38400
+ExecStart=-/sbin/agetty %I 38400 linux
 Restart=always
 RestartSec=0
 UtmpIdentifier=%I

Anything wrong with that?

Huh? Solved what problem? I haven't seen any issues here...

I had some. big_smile

Logging in to console (tty[1-6]) any kind of special character did not work, including German umlaut (ä, ö, ü & ß) and pseudo graphical stuff spoduced by pstree, tmux & Co. Looked like utf8 character being displayed on a terminal that does not support it. Pane borders in tmux expanded to three lines of weired characters for example.

I'm setting LANG and LC_* via pam_env in /etc/pam.d/login, so that should be fine. TERM is "linux".

Only adding "linux" to the agetty command fixes this for me.


ArchLinux - make it simple & lightweight

Offline

#1287 2012-03-20 19:28:18

eworm
Trusted User (TU)
From: Oberhausen, Germany
Registered: 2010-01-30
Posts: 99
Website

Re: systemd: Yet Another Init Replacement

eworm wrote:
falconindy wrote:
eworm wrote:

The only way to make pstree, tmux and friends happy in console is to change getty@.service:

--- getty@.service 2012-03-20 16:28:57.831383824 +0100
+++ getty@.service 2012-03-20 16:35:44.531336593 +0100
@@ -18,7 +18,7 @@ Before=getty.target
 
 [Service]
 Environment=TERM=linux
-ExecStart=-/sbin/agetty %I 38400
+ExecStart=-/sbin/agetty %I 38400 linux
 Restart=always
 RestartSec=0
 UtmpIdentifier=%I

Anything wrong with that?

Huh? Solved what problem? I haven't seen any issues here...

I had some. big_smile

Logging in to console (tty[1-6]) any kind of special character did not work, including German umlaut (ä, ö, ü & ß) and pseudo graphical stuff spoduced by pstree, tmux & Co. Looked like utf8 character being displayed on a terminal that does not support it. Pane borders in tmux expanded to three lines of weired characters for example.

I'm setting LANG and LC_* via pam_env in /etc/pam.d/login, so that should be fine. TERM is "linux".

Only adding "linux" to the agetty command fixes this for me.

Ok, forget about it... Was confused by my habits.

It's independent from whether or not I give agetty a terminal via argument.
(Anything else should be very wired as "linux" is the default for linux
systemd. wink )

The problem occurs on tty1. tty2 to tty6 are ok. So what is different with
tty1?


ArchLinux - make it simple & lightweight

Offline

#1288 2012-03-20 21:05:35

eworm
Trusted User (TU)
From: Oberhausen, Germany
Registered: 2010-01-30
Posts: 99
Website

Re: systemd: Yet Another Init Replacement

eworm wrote:

Ok, forget about it... Was confused by my habits.

It's independent from whether or not I give agetty a terminal via argument.
(Anything else should be very wired as "linux" is the default for linux
systemd. wink )

The problem occurs on tty1. tty2 to tty6 are ok. So what is different with
tty1?

Ok, found the problem... Kind of.
This time for real I think. big_smile

It's the keymap hook from Arch's mkinitcpio.

Setting the console font is not a problem, I have the correct font on all
ttys. Also setting consolefont in initrd via consolefont hook is not a
problem.


ArchLinux - make it simple & lightweight

Offline

#1289 2012-03-20 22:13:27

Viper_Scull
Member
From: London, UK
Registered: 2011-01-15
Posts: 152

Re: systemd: Yet Another Init Replacement

Hiya.

I've set up systemd on a laptop. I'm using net-auto-wireless.service to set the wifi connection but it won't work (no ESSID associated, status of the service dead). If I restart the service once logged in then it connects with no problems whatsoever.

I've tried changing the requirements in the unit making it similar to net-auto-wired.service. Before network.target, WantedBy multi-user.target...Same behaviour.

I've created a profile to use with net-profiles and a systemd unit to test it. Still the same. It does nothing at boot, but it works if I restart it manually.

Both daemons (net-auto-wireless and net-profiles) work flawlessly if I boot with normal init.

Last edited by Viper_Scull (2012-03-20 22:14:27)


Athlon II X4 620 + Gigabyte 785GPM-UD2H + 4GB DDR3 + SSD OCZ Vertex2 60GB

Archlinux x86_64 + Openbox

Offline

#1290 2012-03-24 12:33:28

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: systemd: Yet Another Init Replacement

This could be something simple i'm missing, but in combination with comment=systemd.automount in fstab, pacman wants to check each mount on operations:

# pacman -Syu
(8/8) checking for file conflicts   [########################################################] 100%
warning: could not get filesystem information for /home/user/media/remotemount1: No such device
warning: could not get filesystem information for /home/user/media/remotemount2: No such device
warning: could not get filesystem information for /home/user/media/remotemount3: No such device
(8/8) checking available disk space 
$ cat /etc/fstab
sshfs#user@host:/ /home/user/media/remotemount1 fuse comment=systemd.automount,defaults,noauto,intr,allow_other 0 0

I have a lot of remote mounts so this is not ideal, any advice on how to prevent this?


ᶘ ᵒᴥᵒᶅ

Offline

#1291 2012-03-26 13:24:04

aya
Member
From: Japan
Registered: 2011-06-12
Posts: 51

Re: systemd: Yet Another Init Replacement

Hello

I am trying to do one simple thing.
eth0 is dhcp
eth1 is static

eth0 enables fine on boot with

[root@arch1 system]# cat /etc/systemd/system/multi-user.target.wants/dhcpcd@eth0.service
[Unit]
Description=dhcpcd on %I
Wants=network.target
Before=network.target

[Service]
Type=forking
PIDFile=/var/run/dhcpcd-%I.pid
ExecStart=/sbin/dhcpcd -A -q -w %I
ExecStop=/sbin/dhcpcd -k %I

[Install]
Alias=multi-user.target.wants/dhcpcd@eth0.service

------------------------------------------------------------------
eth1 has the following according to wiki guide

[root@arch1 system]# cat /etc/systemd/system/multi-user.target.wants/network@eth1.service
[Unit]
Description=Network Connectivity
Wants=network.target
Before=network.target

[Service]
Type=oneshot
RemainAfterExit=yes
EnvironmentFile=/etc/conf.d/network
ExecStart=/sbin/ip link set dev %I up
ExecStart=/sbin/ip addr add ${address}/${netmask} broadcast ${broadcast} dev %I
ExecStart=/sbin/ip route add default via ${gateway}
ExecStop=/sbin/ip addr flush dev %I
ExecStop=/sbin/ip link set dev %I down

[Install]
Alias=multi-user.target.wants/network@%I.service

[root@arch1 ~]# cat /etc/conf.d/network
address=192.168.56.2
netmask=255.255.255.0
broadcast=192.168.56.255
gateway=192.168.56.1

------------------------------------------------------------------
but an error occurs every time on boot

[root@arch1 ~]# systemctl status network@eth1.service
network@eth1.service - Network Connectivity
          Loaded: loaded (/etc/systemd/system/network@.service; enabled)
          Active: failed (Result: exit-code) since Mon, 26 Mar 2012 21:38:46 +0900; 4min 4s ago
         Process: 195 ExecStart=/sbin/ip link set dev %I up (code=exited, status=1/FAILURE)
          CGroup: name=systemd:/system/network@.service/eth1

Mar 26 21:38:46 arch1 ip[195]: Cannot find device "eth1

However when after login I do

systemctl start network@eth1.service
it works fine and eth1 is being brought up

I suspect there is some race condition(?) occurs here during boot...
Any advice is appreciated. Thanks

Offline

#1292 2012-03-27 05:47:23

ying
Member
From: Austria
Registered: 2010-03-02
Posts: 110

Re: systemd: Yet Another Init Replacement

My /tmp folder has not been cleared after a reboot. I fixed this by editing /usr/lib/tmpfiles.d/tmp.conf:

d /tmp 1777 root root 10d
d /var/tmp 1777 root root 30d

to

D /tmp 1777 root root 10d
D /var/tmp 1777 root root 30d

wink

Last edited by ying (2012-03-27 05:47:48)

Offline

#1293 2012-03-27 21:55:06

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,094
Website

Re: systemd: Yet Another Init Replacement

ying wrote:

My /tmp folder has not been cleared after a reboot. I fixed this by editing /usr/lib/tmpfiles.d/tmp.conf:

d /tmp 1777 root root 10d
d /var/tmp 1777 root root 30d

to

D /tmp 1777 root root 10d
D /var/tmp 1777 root root 30d

wink

Or do the right thing and mount /tmp on tmpfs... this is the default next release anyways.

http://cgit.freedesktop.org/systemd/sys … 3ac9d2fce3

Offline

#1294 2012-03-27 21:58:04

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,094
Website

Re: systemd: Yet Another Init Replacement

aya wrote:

I suspect there is some race condition(?) occurs here during boot...
Any advice is appreciated. Thanks

Seems unlikely. You can add BindTo as a device dependency for the unit. Unfortunately, you can't use the symlink in /sys/class/net, it needs to be the resolved path, so for example...

$ systemctl status sys-devices-pci0000:00-0000:00:1c.2-0000:05:00.0-net-eth0.device
sys-devices-pci0000:00-0000:00:1c.2-0000:05:00.0-net-eth0.device - 88E8056 PCI-E Gigabit Ethernet Controller
          Loaded: loaded
          Active: active (plugged)
          Device: /sys/devices/pci0000:00/0000:00:1c.2/0000:05:00.0/net/eth0

..means you can add "BindTo=sys-devices-pci0000:00-0000:00:1c.2-0000:05:00.0-net-eth0.device" in your unit file if you want to depend on eth0.

Offline

#1295 2012-03-28 06:32:16

gulafaran
Member
Registered: 2011-02-09
Posts: 14

Re: systemd: Yet Another Init Replacement

just installed systemd, and enabled my few services i need ntpd,bitlbee,lxdm,cronie,syslog-ng,NetworkManager and now upon boot i get that console-kit-log-system-start.service failed to start, output of systemctl status console-kit-log-system-start.service , http://sprunge.us/DMWa. everything seems to work fine otherwise. little help would be appreciated


Nvm seems to fixed itself after i started using systemctl's journal instead of syslog-ng

Last edited by gulafaran (2012-03-28 08:17:42)

Offline

#1296 2012-03-28 15:34:33

aya
Member
From: Japan
Registered: 2011-06-12
Posts: 51

Re: systemd: Yet Another Init Replacement

Thanks Dave,

falconindy wrote:

..means you can add "BindTo=sys-devices-pci0000:00-0000:00:1c.2-0000:05:00.0-net-eth0.device" in your unit file if you want to depend on eth0.

Did not work unfortunately.

 [root@arch1 ~]# systemctl 
......
sys-devices-pci0000:00-0000:00:08.0-net-eth1.device    loaded active plugged       82540EM Gigabit Ethernet Controller
......
[root@arch1 ~]# systemctl status sys-devices-pci0000:00-0000:00:08.0-net-eth1.device
sys-devices-pci0000:00-0000:00:08.0-net-eth1.device - 82540EM Gigabit Ethernet Controller
          Loaded: loaded
          Active: active (plugged) since Wed, 28 Mar 2012 22:51:21 +0900; 2min 54s ago
          Device: /sys/devices/pci0000:00/0000:00:08.0/net/eth1
[root@arch1 ~]# cat /etc/systemd/system/multi-user.target.wants/network@eth1.service 
[Unit]
Description=Network Connectivity
Wants=network.target
Before=network.target
BindTo=sys-devices-pci0000:00-0000:00:08.0-net-eth1.device

[Service]
Type=oneshot
RemainAfterExit=yes
EnvironmentFile=/etc/conf.d/network
ExecStart=/sbin/ip link set dev %I up
ExecStart=/sbin/ip addr add ${address}/${netmask} broadcast ${broadcast} dev %I
ExecStart=/sbin/ip route add default via ${gateway}
ExecStop=/sbin/ip addr flush dev %I
ExecStop=/sbin/ip link set dev %I down

[Install]
Alias=multi-user.target.wants/network@%I.service
[root@arch1 ~]# systemctl status network@eth1.service
network@eth1.service - Network Connectivity
          Loaded: loaded (/etc/systemd/system/network@.service; enabled)
          Active: failed (Result: exit-code) since Wed, 28 Mar 2012 23:02:22 +0900; 31s ago
         Process: 193 ExecStart=/sbin/ip link set dev %I up (code=exited, status=1/FAILURE)
          CGroup: name=systemd:/system/network@.service/eth1

From systemd-journalctl

......
Mar 29 00:06:30 arch1 kernel: e1000 0000:00:03.0: eth0: (PCI:33MHz:32-bit) 08:00:27:8e:04:a4
Mar 29 00:06:30 arch1 kernel: e1000 0000:00:03.0: eth0: Intel(R) PRO/1000 Network Connection
Mar 29 00:06:30 arch1 kernel: piix4_smbus 0000:00:07.0: SMBus base address uninitialized - upgrade BIOS or use force_addr=0xaddr
Mar 29 00:06:30 arch1 kernel: snd_intel8x0 0000:00:05.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
Mar 29 00:06:30 arch1 /usr/sbin/crond[189]: (CRON) INFO (Syslog will be used instead of sendmail.): No such file or directory
Mar 29 00:06:30 arch1 /usr/sbin/crond[189]: (CRON) INFO (running with inotify support)
Mar 29 00:06:30 arch1 kernel: intel8x0_measure_ac97_clock: measured 51605 usecs (10170 samples)
Mar 29 00:06:30 arch1 kernel: intel8x0: measured clock 197073 rejected
Mar 29 00:06:30 arch1 ip[190]: Cannot find device "eth1"
Mar 29 00:06:30 arch1 systemd[1]: network@eth1.service: main process exited, code=exited, status=1
Mar 29 00:06:30 arch1 systemd[1]: Unit network@eth1.service entered failed state.
Mar 29 00:06:30 arch1 dhcpcd[191]: version 5.5.4 starting
Mar 29 00:06:30 arch1 kernel: e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Mar 29 00:06:30 arch1 kernel: ADDRCONF(NETDEV_UP): eth0: link is not ready
Mar 29 00:06:30 arch1 kernel: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Mar 29 00:06:31 arch1 systemd-logind[193]: New seat seat0.
Mar 29 00:06:31 arch1 kernel: intel8x0_measure_ac97_clock: measured 52615 usecs (10023 samples)
Mar 29 00:06:31 arch1 kernel: intel8x0: measured clock 190497 rejected
Mar 29 00:06:31 arch1 dhcpcd[191]: eth0: carrier lost
Mar 29 00:06:31 arch1 dhcpcd[191]: eth0: carrier acquired
Mar 29 00:06:31 arch1 dhcpcd[191]: eth0: sending IPv6 Router Solicitation
Mar 29 00:06:31 arch1 dhcpcd[191]: eth0: sendmsg: Cannot assign requested address
Mar 29 00:06:31 arch1 dhcpcd[191]: eth0: broadcasting for a lease
Mar 29 00:06:31 arch1 dhcpcd[191]: eth0: offered 10.0.2.15 from 10.0.2.2
Mar 29 00:06:31 arch1 dhcpcd[191]: eth0: acknowledged 10.0.2.15 from 10.0.2.2
Mar 29 00:06:31 arch1 dhcpcd[191]: eth0: leased 10.0.2.15 for 86400 seconds
Mar 29 00:06:31 arch1 dhcpcd[191]: forked to background, child pid 245
Mar 29 00:06:31 arch1 kernel: intel8x0_measure_ac97_clock: measured 54155 usecs (10292 samples)
Mar 29 00:06:31 arch1 kernel: intel8x0: measured clock 190047 rejected
Mar 29 00:06:31 arch1 kernel: intel8x0: clocking to 48000
Mar 29 00:06:31 arch1 kernel: e1000 0000:00:08.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Mar 29 00:06:31 arch1 kernel: e1000 0000:00:08.0: eth1: (PCI:33MHz:32-bit) 08:00:27:8b:26:92
Mar 29 00:06:31 arch1 kernel: e1000 0000:00:08.0: eth1: Intel(R) PRO/1000 Network Connection
Mar 29 00:06:31 arch1 systemd[1]: Startup finished in 2s 235ms 357us (kernel) + 3s 563ms 98us (userspace) = 5s 798ms 455us.

Looks like e1000 0000:00:08.0: eth1 is being initialized only after network@eth1.service executes?

And the interesting thing is that eth1 did work for me correctly in this setup about 1 time out of 20.

Offline

#1297 2012-03-28 15:50:39

aya
Member
From: Japan
Registered: 2011-06-12
Posts: 51

Re: systemd: Yet Another Init Replacement

Given the above the following works for me every time:

[root@arch1 ~]# cat /etc/systemd/system/multi-user.target.wants/dhcpcd\@eth0.service 
[Unit]
Description=dhcpcd on %I
Wants=network.target
After=sys-devices-pci0000:00-0000:00:03.0-net-eth0.device
BindTo=sys-devices-pci0000:00-0000:00:03.0-net-eth0.device
......
[root@arch1 ~]# cat /etc/systemd/system/multi-user.target.wants/network\@eth1.service 
[Unit]
Description=Network Connectivity
Wants=network.target
After=sys-devices-pci0000:00-0000:00:08.0-net-eth1.device
BindTo=sys-devices-pci0000:00-0000:00:08.0-net-eth1.device
......

Offline

#1298 2012-03-28 19:34:22

broken pipe
Member
Registered: 2010-12-10
Posts: 216

Re: systemd: Yet Another Init Replacement

is it just me or is there any bug with kde/kdm? when i try to reboot/shutdown from kde, it just logs me out and throws me back to the kdm login. at the login prompt i'm able to shutdown/reboot. when i boot my system using the initscripts everything works as expected.

best regards!

Offline

#1299 2012-03-28 22:13:19

adrianx
Member
From: South Africa
Registered: 2010-03-22
Posts: 67

Re: systemd: Yet Another Init Replacement

broken pipe wrote:

is it just me or is there any bug with kde/kdm? when i try to reboot/shutdown from kde, it just logs me out and throws me back to the kdm login. at the login prompt i'm able to shutdown/reboot. when i boot my system using the initscripts everything works as expected.

best regards!

No, it's not just you - https://bugs.kde.org/show_bug.cgi?id=293978

Offline

#1300 2012-03-28 22:22:17

bobwya
Member
Registered: 2012-01-09
Posts: 36

Re: systemd: Yet Another Init Replacement

broken pipe wrote:

is it just me or is there any bug with kde/kdm? when i try to reboot/shutdown from kde, it just logs me out and throws me back to the kdm login. at the login prompt i'm able to shutdown/reboot. when i boot my system using the initscripts everything works as expected.

best regards!

Yeh I am seeing the same behaviour! I only get bounced to the KDM login screen when I try to shutdown / reboot. I can shutdown / reboot from the login screen.

KDE 4.8.1 (only KDM Desktop Manager is installed).

I've read through this thread and altered:
System Settings GUI - Login Settings - Shutdown :
Halt = /bin/systemctl poweroff
Reboot = /bin/systemctl reboot
Allow (Local) Shutdown = Everybody

Running these systemctl commands directly from the commandline gives the error:
Failed to issue method call: Access denied

So I guess I have missed adding my user to a group with privileges needed to power down in a KDE session??

Main problem I'm seeing (that's related to SystemD anyway wink )

Thanks
Bob

Offline

Board footer

Powered by FluxBB