You are not logged in.

#176 2011-11-05 17:06:46

kabbalah
Banned
Registered: 2011-08-23
Posts: 150

Re: KDEMod3 Rebuild

Ok, it have pag web and already was release 3.5.13:

http://www.trinitydesktop.org/

See for yourself.

It is a serious proyect.

Thank

Offline

#177 2011-11-07 05:18:02

MutantTurkey
Member
Registered: 2010-02-07
Posts: 17

Re: KDEMod3 Rebuild

Hello,

I've made PKGBUILDs for trinity 3.5.13! they're in the AUR. installing trinity-kdebase should pull in everything in the trinity-base group.

Let me know how it goes! email to the ML or to me privately or here or whatever, any testing would be jolly!


Thanks.

Calvin Morrison
Trinity Desktop Team

Offline

#178 2011-11-08 01:46:16

superchango
Member
From: Tenochtitlan
Registered: 2009-01-22
Posts: 133

Re: KDEMod3 Rebuild

MutantTurkey wrote:

Let me know how it goes! email to the ML or to me privately or here or whatever, any testing would be jolly!


Thanks.

Calvin Morrison
Trinity Desktop Team


Hi. Thank you these packages.

I'm in the step to compile kdelibs, but i have problems. In the 19% of the compilation cmake stop with an error building kshortcutdialog, but i don't know why:

[ 19%] Building CXX object kdeui/CMakeFiles/kdeui-shared.dir/kshortcutdialog_simple.cpp.o
/home/mono/abs/kdelibs/src/build/kdeui/kshortcutdialog_simple.cpp: En el constructor ‘KShortcutDialogSimple::KShortcutDialogSimple(QWidget*, const char*)’:
/home/mono/abs/kdelibs/src/build/kdeui/kshortcutdialog_simple.cpp:31:50: error: uso inválido del tipo incompleto ‘struct QLabel’
/home/mono/abs/kdelibs/src/kdelibs/kdeui/kdialog.h:236:7: error: declaración adelantada de ‘struct QLabel’
/home/mono/abs/kdelibs/src/build/kdeui/kshortcutdialog_simple.cpp:33:62: error: no se encontró una función coincidente para la llamada a ‘QGridLayout::addWidget(QLabel*&, int, int)’
/home/mono/abs/kdelibs/src/build/kdeui/kshortcutdialog_simple.cpp:33:62: nota: el candidato es:
/opt/qt/include/qlayout.h:334:10: nota: void QGridLayout::addWidget(QWidget*, int, int, int)
/opt/qt/include/qlayout.h:334:10: nota:   no hay una conversión conocida para el argumento 1 de ‘QLabel*’ a ‘QWidget*’
/home/mono/abs/kdelibs/src/build/kdeui/kshortcutdialog_simple.cpp: En la función miembro ‘virtual void KShortcutDialogSimple::languageChange()’:
/home/mono/abs/kdelibs/src/build/kdeui/kshortcutdialog_simple.cpp:71:15: error: uso inválido del tipo incompleto ‘struct QLabel’
/home/mono/abs/kdelibs/src/kdelibs/kdeui/kdialog.h:236:7: error: declaración adelantada de ‘struct QLabel’
make[2]: *** [kdeui/CMakeFiles/kdeui-shared.dir/kshortcutdialog_simple.cpp.o] Error 1
make[1]: *** [kdeui/CMakeFiles/kdeui-shared.dir/all] Error 2
make: *** [all] Error 2
==> ERROR: Se produjo un error en build().
    Cancelando...

Does anybody else have problems compiling trinity-kdelibs? (i have installed all dependences correctly).

Thanks in advance.

Last edited by superchango (2011-11-08 01:47:10)


"Yo creo que los muertos son tiernos. ¿Nos besamos?"

Offline

#179 2011-11-08 17:20:08

MutantTurkey
Member
Registered: 2010-02-07
Posts: 17

Re: KDEMod3 Rebuild

Do you have

Offline

#180 2011-11-11 10:07:07

djskolman
Member
Registered: 2011-10-31
Posts: 4

Re: KDEMod3 Rebuild

After I upgraded to my trinity kmplayer stopped working. The only show videos in full screen. Is there a reason?

Offline

#181 2011-11-11 17:27:10

MutantTurkey
Member
Registered: 2010-02-07
Posts: 17

Re: KDEMod3 Rebuild

If you are speaking of kmplayer from kdemod3 or wherever you had it (I think you are), you'll need to recompile the application with the latest trinity libs, AFAIK.

I'll see about making up a PKGBUILD for this .

Offline

#182 2011-11-17 12:56:28

djskolman
Member
Registered: 2011-10-31
Posts: 4

Re: KDEMod3 Rebuild

how to do it?

Offline

#183 2011-11-18 09:52:49

saleem
Member
Registered: 2011-09-21
Posts: 81

Re: KDEMod3 Rebuild

Hi,

facing same error as above faced by @ superchango

trinity-kdelibs fails to build leading to failure of build of trinity-kdebase 3513-1

http://pastie.org/2882365

fix would be appreciated,

regards

Offline

#184 2011-11-18 14:30:24

saleem
Member
Registered: 2011-09-21
Posts: 81

Re: KDEMod3 Rebuild

hi,

just wondering are we going to get the Binary Packages for Trinity Current Stable V. 3.5.13 on

[kdemod3]
Server = http://vgafib.upc.es/kdemod3/$arch

in near future than the AUR packages ?

Offline

#185 2011-11-18 17:41:18

elvaka
Member
Registered: 2010-05-02
Posts: 28

Re: KDEMod3 Rebuild

Since the build system has changed from autotools to cmake, I cannot use the PKGBUILDs from the original KDEmod3 to build Trinity 3.5.13.

Since some people has already done the job of writing new PKGBUILDs for 3.5.13, I'm trying to contact them instead of writing my own ones.

If you are reading this and have a working set of PKGBUILDs for 3.5.13, please contact me so we can host and provide binary packages!

Even thought, I think that there are not PKGBUILDs for every single package available on the 3.5.12, so we will have to wait for some of them.

Offline

#186 2011-11-27 19:49:50

MutantTurkey
Member
Registered: 2010-02-07
Posts: 17

Re: KDEMod3 Rebuild

Hey.

That's me smile

I'd love to get binary packages going. The pkgbuilds are so far in the AUR and on our git tree at trinity-desktop.org

can you email me for more details? my username at gmail dot com.

Calvin

Offline

#187 2011-12-18 18:19:15

kwd
Member
From: Panamá
Registered: 2011-04-09
Posts: 15

Re: KDEMod3 Rebuild

elvaka

How are things going with the PKBUILDs for 4.5.13

Is there any way a non programmer could help?  I have a lot of linux sysadmin experience but I only program in bash.

Keith


"A newspaper is not just for reporting news,
it's to get people mad enough to do something about it."

--Mark Twain

Offline

#188 2012-02-04 21:29:44

thetrivialstuff
Member
Registered: 2006-05-10
Posts: 191

Re: KDEMod3 Rebuild

I'm always running into the hal dependency whenever I install kdemod3 on a new machine. Does anyone know what actually depends on hal? As others have said, it's not a "true" dependency, as everything seems to work just fine without it. Maybe it should be removed as a dependency entirely, or at least made an optional one? (Mind you, I only use konqueror, kwrite, and a few others -- I don't use the full desktop environment by any means; DE's are too slow for my tastes.)

Lately my workaround has been "mkdir /var/lib/pacman/local/hal-1-1" , which fools pacman into thinking hal is already installed. Faster than going through the AUR smile

~Felix.

Offline

#189 2012-02-04 21:49:44

kwd
Member
From: Panamá
Registered: 2011-04-09
Posts: 15

Re: KDEMod3 Rebuild

For Trinity 3.5.13, I have  a patched version of hal -- i.e.: hal-0.5.14-6-x86_64.pkg.tar.xz 

If you install it first you will not have the dependency problem.

Whether it would work for any other flavor of KDE3, I have no idea.

I got it from Calvin on the Trinity site.

If you want it, and if there is somewhere on this forum to post it, just point me to the info on "how and where" and I will post it there.

If not, I could put it up on MediaFire.com and you could download it from there and I would post the link here.

kwd


"A newspaper is not just for reporting news,
it's to get people mad enough to do something about it."

--Mark Twain

Offline

#190 2012-02-05 21:17:25

l0ner
Member
Registered: 2011-09-25
Posts: 13
Website

Re: KDEMod3 Rebuild

There are hal and hal-info PKGBUILDS in aur.

Offline

#191 2012-02-07 20:59:53

drankinatty
Member
From: Nacogdoches, Texas
Registered: 2009-04-24
Posts: 43
Website

Re: KDEMod3 Rebuild

The February 2012 updates to Arch break just about everything in the Trinity 3.5.12 builds (pkg.eth-os.org). I have managed to get everything running again. You will need the following:

(1) install libpng14 from AUR (this was the big culprit)
(2) downgrade audiofile from 3.3 -> 3.2 (breaks sound and basket notepads)

you will have to find the audiofile-3.2 binary, it will not rebuild from the 3.2 PKGBUILD without modifying the Makefile to add -lm. Hopefully I will have time this summer to jump back into 3.5.13.


David C. Rankin, J.D.,P.E.

Offline

#192 2012-02-09 05:22:25

Barthalion
Forum Fellow
From: Poland
Registered: 2010-02-26
Posts: 111

Re: KDEMod3 Rebuild

drankinatty wrote:

I have managed to get everything running again. You will need the following:
(1) install libpng14 from AUR (this was the big culprit)

Or just recompile against new libpng. I wouldn't say, that Arch broke anything.

Offline

#193 2012-02-10 18:47:06

kwd
Member
From: Panamá
Registered: 2011-04-09
Posts: 15

Re: KDEMod3 Rebuild

l0ner

I just tried to finish a previous installation of trinity-kdebase.  This was because that installation terminated in the middle of the install--when Trinity's server died in December.

When I tried it a couple of days ago, I got a lot of "mirror not found" messages for:

libraw1394
cifs-utils
smbclient

and then the AUR install shuts down.

To save me a lot of time testing things over a slow internet connection, could you tell me if:

1 - I need to remove the previously atemped install files and start all over?

2 - If you can still install all of Trinity by installing trinity-kdebase?

3 - If the trinity-kdebase install works "as is" or if you need to do anything special to make it work?

4 - If I need to install the Arch Febuary updates before I install the current version of Trinity?

Keith


"A newspaper is not just for reporting news,
it's to get people mad enough to do something about it."

--Mark Twain

Offline

#194 2012-02-11 22:38:50

l0ner
Member
Registered: 2011-09-25
Posts: 13
Website

Re: KDEMod3 Rebuild

kwd wrote:

l0ner

I just tried to finish a previous installation of trinity-kdebase.  This was because that installation terminated in the middle of the install--when Trinity's server died in December.

When I tried it a couple of days ago, I got a lot of "mirror not found" messages for:

libraw1394
cifs-utils
smbclient

and then the AUR install shuts down.

Did you do pacman -Sy before trying to resume building trinity? Packages you listed come from the arch repos and are not part of trinity (but they are trinity dependencies). When they got updated the version change, and thus change the filename of package  in arch repo. If you have outdated local package list, pacman will search for package versions that don't exist anymore.

kwd wrote:

1 - I need to remove the previously atemped install files and start all over?

Theoretically no, since no changes were made to the package groups and names. But you should update them. That means rebuilding them. Removal, unless you want to be really sure everything goes fine, shouldn't be necessary.
Please note that the trinity internal dependencies were changed so some of previously installed packages will become useless. The current dependency chain up to trinity-kdebase is: trinity-qt3, trinity-tqtinterface, trinity-arts, trinity-dbus-tqt, trinity-kdelibs, trinity-kdebase.

kwd wrote:

2 - If you can still install all of Trinity by installing trinity-kdebase?

Yes, unless you use our split-pkgbuild available in trinity git. You won't get though the applications provided by trinity-extras packages (again, look at trinity git repository tde-packaging) [http://git.trinitydesktop.org/cgit/tde- … rch/3.5.13].

kwd wrote:

3 - If the trinity-kdebase install works "as is" or if you need to do anything special to make it work?

You will need hal, hal-info and libutempter from aur. First one is needed for trinity-kdebase, last one is needed for trinity-kdelibs.

kwd wrote:

4 - If I need to install the Arch Febuary updates before I install the current version of Trinity?

Honestly, dunno, since I test the pkgbuilds on up-to-date system. I know that you need to recompile trinity after updating (problems with libpng) but otherwise everything should work.

Offline

#195 2012-02-12 04:21:15

kwd
Member
From: Panamá
Registered: 2011-04-09
Posts: 15

Re: KDEMod3 Rebuild

Thanks l0ner

That was a fantastic job of answering all my questions.

Tomorrow I will do the pacman -Sy thing and then update to the most recent version of Arch.

After that i will check for libutempter and install it if it is not already installed.  Hal is already installed and should not be a problem.

Then I will restart the kdebase install.

I would like to make a local repository in my external usb hard drive, that would contain everything needed to do a full install of Arch, Trinity and other programs. I don't need any details on how to do it right now but would you know if setting something up like that is difficult?

The reason I want to do this is so I can go to areas in Panama that do not  have "high speed" internet but do have low speed internet and install the software on local computers there.  Then the locals could use the 128 kb wireless links to get email, and do a little surfing of the web.

Thanks for the help

Keith


"A newspaper is not just for reporting news,
it's to get people mad enough to do something about it."

--Mark Twain

Offline

#196 2012-02-12 07:52:52

thetrivialstuff
Member
Registered: 2006-05-10
Posts: 191

Re: KDEMod3 Rebuild

Just in case anyone else finds this annoying and has searched high and low for a setting to turn it off:

In konqueror, when you double-click an icon, there is a brief "zooming" animation before it responds. The setting for this is in kcontrol (not konqueror), and it's not under any of the usual places you'd look for animations or effects settings. It's under Peripherals(?!) > Mouse > General > "Visual feedback on activation"

Now folders open instantly instead of having to wait for that stupid animation smile

Offline

#197 2012-02-13 05:14:58

thetrivialstuff
Member
Registered: 2006-05-10
Posts: 191

Re: KDEMod3 Rebuild

Just did pacman -Syu again, and some more things are broken -- kwrite won't start and konqueror complains it can't find libpcre.so.0 when opening a new tab (but works otherwise).

Symlinking (ln -s /usr/lib/libpcre.so /opt/kde3/lib/libpcre.so.0) appears to fix both problems, so a temporary fix would be to just add that symlink to the packages.

Offline

#198 2012-02-13 19:56:37

l0ner
Member
Registered: 2011-09-25
Posts: 13
Website

Re: KDEMod3 Rebuild

kwd wrote:

Thanks l0ner

That was a fantastic job of answering all my questions.

Tomorrow I will do the pacman -Sy thing and then update to the most recent version of Arch.

After that i will check for libutempter and install it if it is not already installed.  Hal is already installed and should not be a problem.

Then I will restart the kdebase install.

I would like to make a local repository in my external usb hard drive, that would contain everything needed to do a full install of Arch, Trinity and other programs. I don't need any details on how to do it right now but would you know if setting something up like that is difficult?

The reason I want to do this is so I can go to areas in Panama that do not  have "high speed" internet but do have low speed internet and install the software on local computers there.  Then the locals could use the 128 kb wireless links to get email, and do a little surfing of the web.

Thanks for the help

Keith

I don't know how difficult it is, since I never had necessity to do so.

thetrivialstuff wrote:

Just did pacman -Syu again, and some more things are broken -- kwrite won't start and konqueror complains it can't find libpcre.so.0 when opening a new tab (but works otherwise).

Symlinking (ln -s /usr/lib/libpcre.so /opt/kde3/lib/libpcre.so.0) appears to fix both problems, so a temporary fix would be to just add that symlink to the packages.

Strange, but noted. When I find some time I'll try to reproduce this. Yet I have 3 different installations of trinity, 1 on my laptop, 2 on virtual machines. On virtual machines trinity was installed from scratch, on a fresh arch install, pulling only dependencies required by trinity, and this did not happened to me.
Anyway, why are you linking to /opt/kde3 when trinity (at least form the latest PKGBUILDS) is installed to /opt/trinity ?
I assume you are trying this on trinity, and not on kdemod3?

Offline

#199 2012-02-13 20:26:49

thetrivialstuff
Member
Registered: 2006-05-10
Posts: 191

Re: KDEMod3 Rebuild

l0ner wrote:

Yet I have 3 different installations of trinity, 1 on my laptop, 2 on virtual machines. On virtual machines trinity was installed from scratch, on a fresh arch install, pulling only dependencies required by trinity, and this did not happened to me.
Anyway, why are you linking to /opt/kde3 when trinity (at least form the latest PKGBUILDS) is installed to /opt/trinity ?
I assume you are trying this on trinity, and not on kdemod3?

No this is on kdemod3, with packages pulled from http://vgafib.upc.es/kdemod3/$arch -- hmm. I just reread some of this thread, and it seems I may be out of date, eh?

Sorry about that; I'll try to switch to trinity and see if the pcre thing is true of the latest version.

I admit I haven't been reading every message in this thread; I was using that vgafib URL from before, and whenever something stops working for me I come here and skim for updated URL's. Last time I did that I think I saw this message: https://bbs.archlinux.org/viewtopic.php … 3#p1018333 and assumed that vgafib was still the most current URL.

Maybe the first post in this thread should be changed to a frequently-updated brief summary of "Here's what you do if you want KDE 3" -- and it'd be nice if it were stickied too, perhaps.

Or are we an unpopular bunch because the KDE 4 crowd thinks of us as counter-revolutionary reactionaries? wink

~Felix.

Offline

#200 2012-02-13 20:43:32

l0ner
Member
Registered: 2011-09-25
Posts: 13
Website

Re: KDEMod3 Rebuild

thetrivialstuff wrote:
l0ner wrote:

Yet I have 3 different installations of trinity, 1 on my laptop, 2 on virtual machines. On virtual machines trinity was installed from scratch, on a fresh arch install, pulling only dependencies required by trinity, and this did not happened to me.
Anyway, why are you linking to /opt/kde3 when trinity (at least form the latest PKGBUILDS) is installed to /opt/trinity ?
I assume you are trying this on trinity, and not on kdemod3?

No this is on kdemod3, with packages pulled from http://vgafib.upc.es/kdemod3/$arch -- hmm. I just reread some of this thread, and it seems I may be out of date, eh?

Well, the thread is about kdemod3, so technically you are not really outdated. The best way to get everything staright would be either create new topic covering only problems with trinity, or state in every post about which wersion one is talking about.

thetrivialstuff wrote:

Sorry about that; I'll try to switch to trinity and see if the pcre thing is true of the latest version.

Well, the pkgbuilds for trinity provide only the kdebase at the moment. I'm still working on the pkgbuilds for other things that come from kdegames, kdegraphics and so on... So if you need applications that come from those, I advise you not to update unless I've finished them. When I do so, I'll upload them to aur.

Offline

Board footer

Powered by FluxBB