You are not logged in.

#1 2021-10-12 17:04:51

jokoko
Member
Registered: 2021-10-12
Posts: 2

Lost in the UEFI...

Hi,

I just received my new assembled computer with a ASrock Z490 motherboard and a 500G NVMe SSD.
I followed the steps of installation, and when arrived the time to setup GRUB (maybe this isn't bootloader for my situation but i don't know any other), I encounter issues:

I'm pretty sure my computer is UEFI compatible (as my BIOS offer me to setup UEFI or legacy mode). But when I type

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=arch_grub --recheck

It tells me EFI variables aren't supported... I finally succed to get my grub install with this command:

grub-install --target=x86_64-efi --efi-directory=/boot/efi --removable

But after the installation complete, the boot doesn't work.
In the boot option I have 2 entries :
UEFI OS (M2_2....)
or
M2_2

the "UEFI OS" option only give me a black screen and the "M2_2" ask me to "reboot and select a proper Boot device or insert a boot boot media...."

Well, this make me doubting on the fact I have EFI available on my computer, as i kind of force grub install in this mode, and I'm now quite lost about the right way to make it work...

Thank you very much for your answers!
(Also thx to take time to be precise, at least with links, I'm still newbie with Arch ;-) )

Offline

#2 2021-10-12 17:27:36

Scimmia
Fellow
Registered: 2012-09-01
Posts: 8,685

Re: Lost in the UEFI...

You have to actually boot the ISO with legacy (bios) turned off.

Offline

#3 2021-10-12 17:28:39

pebcak
Member
Registered: 2020-08-11
Posts: 9

Re: Lost in the UEFI...

jokoko wrote:

I'm pretty sure my computer is UEFI compatible (as my BIOS offer me to setup UEFI or legacy mode).

Did you check the boot mode while booted in the installation medium?

https://wiki.archlinux.org/title/Instal … _boot_mode

You could also perhaps disable Legacy boot mode in your firmware settings and try to install again.

Offline

#4 2021-10-14 08:29:40

jokoko
Member
Registered: 2021-10-12
Posts: 2

Re: Lost in the UEFI...

Ok,
The thing is I disabled fastboot, and unlocked CSM because I was unable to boot on my USB stick in UEFI :
it offers me to boot on "UEFI: wilk GOODRAM 8GB PMAP" in the boot menu, but it turn only to blackscreen, whereas, with the CSM (and so Legacy I guess) turned on, it offer me a choose between "UEFI:  wilk....." ->that doesn't work, and "USB: wilk GOODRAM..." that work, and from which I made my installation (but with the efivars test, telling me I hadn't the UEFI ...

Reading your suggestions, I though it was probably about the format of my stick (I first made with USBcreator from ubuntustudio distro I had before). So I reformated my USB stick in FAT32, flash it with pp as described here : https://wiki.archlinux.org/title/USB_fl … tiliser_dd
But didn't get any better result...

So... I'm still lost... ^^.

Offline

Board footer

Powered by FluxBB