You are not logged in.

#1 2023-10-06 20:35:25

hexdump
Member
Registered: 2023-10-04
Posts: 8

[Solved] Home folder shortcut opens VSCode instead of File Manager

Hi,

The problem is that I have setup a shortcut to open the home folder in GNOME and everytime I call it Visual Studio code loads up and opens the home folder as a workspace instead of being opened by Files. I have checked the default apps and VS code is not there.

P.D. I have noticed that if I search for something (when pressing the super key) and a folder is shown in the list, if I click on it, vscode gets opened too instead of Files.

Any tip would be appreciated.

Thanks!

Last edited by hexdump (2023-10-08 14:17:38)

Offline

#2 2023-10-07 21:34:34

jonno2002
Member
Registered: 2016-11-21
Posts: 683

Re: [Solved] Home folder shortcut opens VSCode instead of File Manager

Offline

#3 2023-10-08 14:17:05

hexdump
Member
Registered: 2023-10-04
Posts: 8

Re: [Solved] Home folder shortcut opens VSCode instead of File Manager

Thanks you put me on the right track.

If I use the open with option when rightclicking the folder and then select files it just works for that time. To make it permanent one can use:

gio mime inode/directory org.gnome.Nautilus.desktop

Thanks!

Offline

#4 2024-02-12 20:01:58

iruoy
Member
Registered: 2019-12-06
Posts: 1

Re: [Solved] Home folder shortcut opens VSCode instead of File Manager

This worked fine for me. I haven't tried gio.

xdg-mime default org.gnome.Nautilus.desktop inode/directory

Offline

Board footer

Powered by FluxBB