You are not logged in.

#1 2005-02-14 23:39:10

ExcessiveForce
Member
Registered: 2003-12-13
Posts: 15

Can't play audio CDs

I can mount my DVD drive and my CD/CD-RW drives, play DVDs, open data disks... but I get file system errors when trying to mount audio cds. My cdrom drive is set as iso9660.  sad


Her mouth tastes like a loaded gun.

Offline

#2 2005-02-14 23:53:35

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Can't play audio CDs

Audio CD's can't be mounted.  Just configure your player so it reads from the right device and it should work.

Offline

#3 2005-02-15 00:02:06

ExcessiveForce
Member
Registered: 2003-12-13
Posts: 15

Re: Can't play audio CDs

I feel like such a newbie. sad

I'm pretty sure I tried it last night, but I'll try it as soon as I get a chance. Thanks!


Her mouth tastes like a loaded gun.

Offline

#4 2005-02-15 03:39:29

ExcessiveForce
Member
Registered: 2003-12-13
Posts: 15

Re: Can't play audio CDs

No luck... I start xmms and I go to either directory (both have audio CDs in there that I know work) but it doesn't see anything in there.


Her mouth tastes like a loaded gun.

Offline

#5 2005-02-15 04:21:52

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: Can't play audio CDs

You need a plugin:

pacman -S xmms-cdparanoia

EDIT: You don't need the xmms-cdparanoia plugin.  There is an audio cd plugin with xmms.  In the preferences (Audio I/O plugins), enable the CD Audio Player plugin.  Then configure it such that it reads from the right device.

Offline

#6 2005-02-15 18:58:00

ExcessiveForce
Member
Registered: 2003-12-13
Posts: 15

Re: Can't play audio CDs

Ah yes, I was about to say that I got that plugin last night but had no luck (which was the case), and I also tried the KDE CD player, as well as Apolos. Apolos gave me 300+ popup error messages about having trouble while getting input/output errors when I tried to start it.

I'll try enabling the audio CD option in XMMS and see what it does. Thanks so far!


Her mouth tastes like a loaded gun.

Offline

#7 2005-02-15 19:46:31

lucke
Member
From: Poland
Registered: 2004-11-30
Posts: 4,018

Re: Can't play audio CDs

Yhm, did you try to enable direct digital playback in kscd (I believe that's the KDE player you're referring to)?

Offline

#8 2005-02-15 20:51:02

IceRAM
Member
From: Bucharest, Romania
Registered: 2004-03-04
Posts: 772
Website

Re: Can't play audio CDs

Maybe you should add yourself to the optical group... or change the permissions of your device.

Don't know for sure since I've never listened an AudioCD in Linux... hmm.. pretty weird...

Offline

#9 2005-02-15 21:22:01

ExcessiveForce
Member
Registered: 2003-12-13
Posts: 15

Re: Can't play audio CDs

I added myself to the optical group last night as well with no luck.


Her mouth tastes like a loaded gun.

Offline

#10 2005-02-16 04:01:14

skoal
Member
From: Frequent Flyer Underworld
Registered: 2004-03-23
Posts: 612
Website

Re: Can't play audio CDs

ExcessiveForce wrote:

I added myself to the optical group last night as well with no luck.

It probably works now and you just don't know it.  I had to do the same thing, and I forgot to restart my "devfs" daemon.  By accident, I rebooted and I suddenly had audio CD's working again.

Outside of that, if you're using "udev", I don't have a clue.  Everything else everyone else here mentioned is all you need to get it working in XMMS.  Just make sure you have the right "/dev" and "/mnt" entries configured like they mentioned above.

Offline

#11 2005-02-16 21:03:56

ExcessiveForce
Member
Registered: 2003-12-13
Posts: 15

Re: Can't play audio CDs

I rebooted and still no luck. I'm not using udev (thought it could be that, too). I tried changing my Audio I/O options in xmms, but it still does not see the CD in the drive. I've used multiple CDs to verify it isn't the CD itself.

Ah well. I'm not as interested in playing CDs as I am ripping them so I can put them on my iPod without booting into windows instead. hmm


Her mouth tastes like a loaded gun.

Offline

#12 2005-02-17 04:13:50

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: Can't play audio CDs

you should make sure that if you are using devfs that you have the proper permissions set in your conf file as well. I assume it must be right though since you can do everything but listen to music.

The only other thing tha tI can think of is that if thhe music on your drive is being recognized then you may not have your audio cable that runs from the drive to the soundcard connected.

It would help if you posted some of your errors and conf files though.


AKA uknowme

I am not your friend

Offline

#13 2005-02-17 04:17:48

SleepyDog
Member
Registered: 2004-10-15
Posts: 114

Re: Can't play audio CDs

Now, when you configured the xmms cd plugin, did you put "/mnt/cdrom"(or whatever) in the device field, or did you put "/dev/hdc" in there? You want to put the /dev path there. It's a base question, I know, but someone's gotta ask, right?

Offline

#14 2005-02-17 12:35:27

Cotton
Member
From: Cornwall, UK
Registered: 2004-09-17
Posts: 549

Re: Can't play audio CDs

Does xmms or kscd work for the root user?

Offline

#15 2005-02-19 05:35:36

skoal
Member
From: Frequent Flyer Underworld
Registered: 2004-03-23
Posts: 612
Website

Re: Can't play audio CDs

sarah31 wrote:

The only other thing tha tI can think of is that if thhe music on your drive is being recognized then you may not have your audio cable that runs from the drive to the soundcard connected.

Funny you should suggest that.  I had my computer ripped apart the last week or so and I had this exact same problem with sound, since I had accidentally unplugged my cable from drive to sound card.

The other thing to look for is the alsa mixer settings for "CD" or "music".  Depending on various soundcard drivers, these settings may or may not be used.

Oops, I forgot he's not having a sound issue, just can't see his songs show up in the XMMS playlist.  The only to check for when you add CD's to the playlist, is that you use "add directory".  I don't think CD wav files will show up by using "add files" and browsing that mount point.  I may be wrong.

Offline

#16 2005-04-09 16:49:38

Riklaunim
Member
Registered: 2005-04-09
Posts: 106
Website

Re: Can't play audio CDs

Did you added yoursefl to users group? (:shock:)
1. nano /etc/group as root
2. add your login to "users" if not present (and optical/audio etc...)
3. logout / login

Offline

Board footer

Powered by FluxBB