You are not logged in.

#1 2010-07-01 21:05:04

kanonmat
Member
From: Linköping, Sweden
Registered: 2008-10-30
Posts: 31

[SOLVED] Cannot startx with intel driver on intel 965

I can't startx with the intel driver on a hp 6910p laptop. It has a core2duo processor, so I installed x86_64 arch. The laptop has intel 965GM graphics and there is  X with vesa (and with the grml.org live cd). The screen is 1280x800. I followed the wiki page on intel and put MODULES="intel_agp i915" and FILE="/etc/modprobe.d/modprobe.conf" in /etc/mkinitcpio.conf . I put "options i915 modeset=1" in /etc/modprobe.d/modprobe.conf

"cat /proc/fb" and "dmesg | grep drm" gives no output. There is no /dev/fb0

I boot with acpi=off modeset.i915=1 (as it wouldn't boot with acpi).
xf86-video-intel and xf86-video-vesa are installed.

root[~]# modprobe i915
WARNING: Error inserting i2c_algo_bit (/lib/modules/2.6.34-ARCH/kernel/drivers/i2c/algos/i2c-algo-bit.ko): No such device
WARNING: Error inserting drm (/lib/modules/2.6.34-ARCH/kernel/drivers/gpu/drm/drm.ko): No such device
WARNING: Error inserting drm_kms_helper (/lib/modules/2.6.34-ARCH/kernel/drivers/gpu/drm/drm_kms_helper.ko): No such device
WARNING: Error inserting intel_agp (/lib/modules/2.6.34-ARCH/kernel/drivers/char/agp/intel-agp.ko): No such device
FATAL: Error inserting i915 (/lib/modules/2.6.34-ARCH/kernel/drivers/gpu/drm/i915/i915.ko): No such device

I have tried with an empty xorg.conf, one from an older laptop with the 915 chip and with the xorg.conf from "Xorg -configure"
I tried with and without hal running.
error output from startx:

This is a pre-release version of the X server from The X.Org Foundation.
It is not supported in any way.
Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
Select the "xorg" product for bugs you find in this release.
Before reporting bugs in pre-release versions please check the
latest version in the X.Org Foundation git repository.
See http://wiki.x.org/wiki/GitPage for git access instructions.

X.Org X Server 1.8.1.902 (1.8.2 RC 2)
Release Date: 2010-06-21
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.34-ARCH x86_64 
Current Operating System: Linux zeratul 2.6.34-ARCH #1 SMP PREEMPT Sat Jun 19 00:07:49 CEST 2010 x86_64
Kernel command line: root=/dev/sda2 ro acpi=off i915.modeset=1
Build Date: 21 June 2010  12:01:49PM
 
Current version of pixman: 0.18.2
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jul  1 05:52:43 2010
(==) Using config directory: "/etc/X11/xorg.conf.d"
(EE) Failed to load module "fbdev" (module does not exist, 0)
WARNING: Error inserting i2c_algo_bit (/lib/modules/2.6.34-ARCH/kernel/drivers/i2c/algos/i2c-algo-bit.ko): No such device
WARNING: Error inserting drm (/lib/modules/2.6.34-ARCH/kernel/drivers/gpu/drm/drm.ko): No such device
WARNING: Error inserting drm_kms_helper (/lib/modules/2.6.34-ARCH/kernel/drivers/gpu/drm/drm_kms_helper.ko): No such device
WARNING: Error inserting intel_agp (/lib/modules/2.6.34-ARCH/kernel/drivers/char/agp/intel-agp.ko): No such device
FATAL: Error inserting i915 (/lib/modules/2.6.34-ARCH/kernel/drivers/gpu/drm/i915/i915.ko): No such device
(EE) intel(0): No kernel modesetting driver detected.
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

giving up.
xinit:  No such file or directory (errno 2):  unable to connect to X server
xinit:  No such process (errno 3):  Server error.

Last edited by kanonmat (2010-07-02 10:23:27)


hp 6910p laptop // phenomII965, gigabyte GA-MA790XT-UD4P mobo, 8600gt desktop.
Sometimes I play xonotic, sometimes I sleep.

Offline

#2 2010-07-01 21:44:12

tjwoosta
Member
Registered: 2008-12-18
Posts: 453

Re: [SOLVED] Cannot startx with intel driver on intel 965

Im using intel gm965 and have no issues whatsoever. My screen is also 1280x800 but I didn't modify anything like you did. I dont have an xorg.conf, I didn't add anything to modules array in rc.conf, I didnt modify mkinitcpio.conf, and I didn't modify modprobe.conf, and I dont boot with acpi=off modeset.i915=1, or any vga= settings for that matter. Absolutely nothing except install xf86-video-intel. Also I dont have hal since xorg 1.8 doesn't use it anymore.

Everything just worked without any configuration at all, resolution was automatically detected, and kms automatically kicks in about a quarter way through the boot process.

Offline

#3 2010-07-02 05:27:07

cantabile
Member
Registered: 2010-06-29
Posts: 19

Re: [SOLVED] Cannot startx with intel driver on intel 965

You can't start x because you don't have kms (the intel driver must have kms in order to work...)

What exactly do you mean by "it wouldn't boot with acpi"? I'm guessing acpi=off might be the reason why you get those "No such device" errors.

By the way, there is no need to include /etc/modprobe.d/modprobe.conf in the initrd, and there is no need to put "options i915 modeset=1" in /etc/modprobe.d/modprobe.conf. That option used to be useful when kms wasn't enabled by default.

Last edited by cantabile (2010-07-02 05:29:48)

Offline

#4 2010-07-02 06:19:11

tjwoosta
Member
Registered: 2008-12-18
Posts: 453

Re: [SOLVED] Cannot startx with intel driver on intel 965

You can't start x because you don't have kms (the intel driver must have kms in order to work...)

Theres no special package for kms if thats what your trying to say. Its part of the default arch kernel and it automatically loads up during boot if you have intel. Also thats what the (MODULES="intel_agp i915") part that he speaks of is supposed to do although its technically not required, its just supposed to make kms start earlier in the boot process.


Im wondering if maybe he didn't regenerate the initramfs properly. I noticed that on the intel page in the wiki it says

Now, regenerate the initramfs:
# mkinitcpio -p kernel26

What it doesnt tell you is that you have to run the command as root. If you run it without root privelages it fails. Im not sure if that would cause this problem he speaks of or not but I figured it was worth mentioning.

Offline

#5 2010-07-02 06:27:32

cantabile
Member
Registered: 2010-06-29
Posts: 19

Re: [SOLVED] Cannot startx with intel driver on intel 965

tjwoosta wrote:

You can't start x because you don't have kms (the intel driver must have kms in order to work...)

Theres no special package for kms if thats what your trying to say. Its part of the default arch kernel and it automatically loads up during boot if you have intel. Also thats what the (MODULES="intel_agp i915") part that he speaks of is supposed to do although its technically not required, its just supposed to make kms start earlier in the boot process.


Im wondering if maybe he didn't regenerate the initramfs properly. I noticed that on the intel page in the wiki it says

Now, regenerate the initramfs:
# mkinitcpio -p kernel26

What it doesnt tell you is that you have to run the command as root. If you run it without root privelages it fails. Im not sure if that would cause this problem he speaks of or not but I figured it was worth mentioning.

It does actually tell you to run it as root big_smile notice the #

As for kms: it's the i915 module which does the magic, and as you can see, he cannot insert it:

kanonmat wrote:
root[~]# modprobe i915
WARNING: Error inserting i2c_algo_bit (/lib/modules/2.6.34-ARCH/kernel/drivers/i2c/algos/i2c-algo-bit.ko): No such device
WARNING: Error inserting drm (/lib/modules/2.6.34-ARCH/kernel/drivers/gpu/drm/drm.ko): No such device
WARNING: Error inserting drm_kms_helper (/lib/modules/2.6.34-ARCH/kernel/drivers/gpu/drm/drm_kms_helper.ko): No such device
WARNING: Error inserting intel_agp (/lib/modules/2.6.34-ARCH/kernel/drivers/char/agp/intel-agp.ko): No such device
FATAL: Error inserting i915 (/lib/modules/2.6.34-ARCH/kernel/drivers/gpu/drm/i915/i915.ko): No such device

Thus, no kms.

Offline

#6 2010-07-02 07:21:26

tjwoosta
Member
Registered: 2008-12-18
Posts: 453

Re: [SOLVED] Cannot startx with intel driver on intel 965

cantabile wrote:

It does actually tell you to run it as root big_smile notice the #

hmm, never realized a # meant run as root, I guess that makes since. Is there a key somewhere that tells you this?

cantabile wrote:

As for kms: it's the i915 module which does the magic, and as you can see, he cannot insert it:

kanonmat wrote:
root[~]# modprobe i915
WARNING: Error inserting i2c_algo_bit (/lib/modules/2.6.34-ARCH/kernel/drivers/i2c/algos/i2c-algo-bit.ko): No such device
WARNING: Error inserting drm (/lib/modules/2.6.34-ARCH/kernel/drivers/gpu/drm/drm.ko): No such device
WARNING: Error inserting drm_kms_helper (/lib/modules/2.6.34-ARCH/kernel/drivers/gpu/drm/drm_kms_helper.ko): No such device
WARNING: Error inserting intel_agp (/lib/modules/2.6.34-ARCH/kernel/drivers/char/agp/intel-agp.ko): No such device
FATAL: Error inserting i915 (/lib/modules/2.6.34-ARCH/kernel/drivers/gpu/drm/i915/i915.ko): No such device

Thus, no kms.

ahh I see what you mean now, sry for misunderstanding

Offline

#7 2010-07-02 10:03:03

kanonmat
Member
From: Linköping, Sweden
Registered: 2008-10-30
Posts: 31

Re: [SOLVED] Cannot startx with intel driver on intel 965

I tried the "natural" unconfed way too --same result. (On my older 915 laptop I needed to those extra things to get kms with kernel 2.6.29 .) For some reason I couldn't boot without "acpi=off" the first time I tried, that part works now. I'm guessing the "device" in the "No such device" message is /dev/fb0 , but I don't know. The i2c_algo_bit drm drm_kms_helper and intel_agp modules can be loaded without fuzz, but i915 gives errors. Is this the new xorgs fault? How do I generate a proper /dev/fb0 ?


hp 6910p laptop // phenomII965, gigabyte GA-MA790XT-UD4P mobo, 8600gt desktop.
Sometimes I play xonotic, sometimes I sleep.

Offline

#8 2010-07-02 10:17:12

cantabile
Member
Registered: 2010-06-29
Posts: 19

Re: [SOLVED] Cannot startx with intel driver on intel 965

Post the errors please.

kanonmat wrote:

Is this the new xorgs fault?

No.

Offline

#9 2010-07-02 10:23:00

kanonmat
Member
From: Linköping, Sweden
Registered: 2008-10-30
Posts: 31

Re: [SOLVED] Cannot startx with intel driver on intel 965

[SOLVED] It works, I just had to install xf86-video-fbdev. Initially I installed a list of pkgs from the other laptop and I missed this one. Thanks for the support.


hp 6910p laptop // phenomII965, gigabyte GA-MA790XT-UD4P mobo, 8600gt desktop.
Sometimes I play xonotic, sometimes I sleep.

Offline

#10 2010-07-02 10:24:52

cantabile
Member
Registered: 2010-06-29
Posts: 19

Re: [SOLVED] Cannot startx with intel driver on intel 965

That's not really solved, x is probably using fbdev now, not the intel driver.

But, whatever floats your boat.

Offline

#11 2011-08-08 00:23:04

capoeira
Member
From: Vila Velha - Brasil
Registered: 2010-05-25
Posts: 462

Re: [SOLVED] Cannot startx with intel driver on intel 965

setting up Arch on my girlfriends laptop I have the same problem. did you find any solution to get the driver to work? it has GMA 4500M chip

Offline

Board footer

Powered by FluxBB