You are not logged in.

#1 2010-07-07 23:13:06

zero_one
Member
Registered: 2010-07-07
Posts: 104

[Solved] removable media read only?

Hey all. I just made the switch to Arch from Slackware. Its still too early to get a solid opinion.  The Only problem that I have is that All removable media is seen as read only. All usb flash drives, sd cards, external harddrives are read only and were fine on slackware and windows boxes. after connecting them to Arch the all act as read only devices not only in Arch but in windows. I cannot format the flash drives or sd cards on windows at the moment either, no permission.  there are now fstab entrys for these devices when they are plugged in, although i dont know if there should be. Any one have any ideas?

Last edited by zero_one (2010-07-08 02:23:29)

Offline

#2 2010-07-07 23:15:47

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,941
Website

Re: [Solved] removable media read only?

1) your media have ntfs filesystem and you didn't installed ntfs-3g
2) consolekit. use gdm or kdm as graphical login manager or  launch your WM as 'exec ck-launch-session wm' in .xinitrc


Give what you have. To someone, it may be better than you dare to think.

Offline

#3 2010-07-07 23:23:09

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: [Solved] removable media read only?

That's all a bit general, so here's some general points to start with:

- your Arch user has to be in the storage group to access removable devices correctly
- /etc/fstab should be created/amended by system admins only i.e you and/or other users of the system, and not by any application

and some general questions:

- how are you mounting these devices?
- if you're automounting them, with which automount tool(s)?

FYI - I know of only one automount tool that edits /etc/fstab (skvm) and its author accepts that it should not be doing that.

Offline

#4 2010-07-07 23:57:30

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [Solved] removable media read only?

If you log in as root, can you read / write or still are the devices read-only?

> act as read only devices not only in Arch but in windows
What kind of filesystem are you using on those devices?

Offline

#5 2010-07-08 01:58:03

zero_one
Member
Registered: 2010-07-07
Posts: 104

Re: [Solved] removable media read only?

thanks for the fast replies guys. im not that advanced but i will try my best to answer all questions. im still in the linux learning stages.

wonder; i totally missed the install of ntfs-3g= external drives now read and write. both are ntfs. thanks. as for windows, i think i forgot to unmount before disconnecting from linux. duh! my bad.

I Just plugged the flash drive in and works fine, linux and windows. however the sd card does not. df -T returns;

$ df -T 
/dev/mmcblk0p1
              vfat     3859968     20788   3839180   1% /media/disk (sd card)
/dev/sdb      vfat     2002752        16   2002736   1% /media/disk-1 (flash drive)

tomk; the devices automout, but i dont know how to tell which tool is used.

so really the only problem still persisting at the moment is the sd card is still read only in windows and linux.

thanks guys!

Offline

#6 2010-07-08 02:06:28

cesura
Trusted User (TU)
From: Tallinn, Estonia
Registered: 2010-01-23
Posts: 1,867

Re: [Solved] removable media read only?

Can you do (making sure it isn't already automounted):

# mount /dev/mmcblk0p1 /mnt -t vfat

Then see if you can copy something into /mnt, etc.

Offline

#7 2010-07-08 02:23:05

zero_one
Member
Registered: 2010-07-07
Posts: 104

Re: [Solved] removable media read only?

as root   

mount: block device /dev/mmcblk0p1 is write-protected, mounting read-only

it may be that the card has finally taken a sh**, not too sure though. so i will make as solved. thanks again.

Offline

#8 2021-11-27 12:15:00

Industrial-Refrigerator
Member
Registered: 2021-11-27
Posts: 1

Re: [Solved] removable media read only?

Well, i had this problem and today i found the answer. It was not by using the terminal, but it's the only way i found that works and do not delete any data you already have on your removable media

By using GParted, use the option to Resize/move on the partition you need (the size does not matter as long as the partition isn't totally full)

Then do the same on the original partition to include what you just resized.

To finish, go to Partition>Verify

Then apply and it should start working as read/write

Last edited by Industrial-Refrigerator (2021-11-27 12:17:07)

Offline

#9 2021-11-27 20:34:54

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,648

Re: [Solved] removable media read only?

Thanks for the input and welcome to the forums.

Be aware of the age of threads though -- they are probably still not chasing the problem after a decade wink
Using this opportunity to close this old thread.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

Board footer

Powered by FluxBB