You are not logged in.

#1 2010-07-14 19:10:45

Dr.X
Member
From: Daugavpils, Latvia
Registered: 2009-08-30
Posts: 58

[SOLVED] Downgrade to nvidia-173xx

Hi! I know what for old videocards not yet supported in xorg 1.8 nvidia-173xx driver. I want to downgrade to it from nouveau because suspend-to-ram isn't working and slow video performance. How to make it?

After installing nvidia-173xx drivers from nvidia site and "startx" I have error:

(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!

Maybe I can solve this problem with other way? Please help sad

Last edited by Dr.X (2010-07-15 14:28:44)

Offline

#2 2010-07-14 19:13:40

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] Downgrade to nvidia-173xx

I think you need to downgrade - not merely install an old package.
Try using old xorg-server and friends. KMS may also be an issue.

Edit: you can get old packages from here http://arm.kh.nu/search/index.php?a=32& … ommunity=1

Last edited by karol (2010-07-14 19:15:02)

Offline

#3 2010-07-14 19:35:32

Dr.X
Member
From: Daugavpils, Latvia
Registered: 2009-08-30
Posts: 58

Re: [SOLVED] Downgrade to nvidia-173xx

karol, thanks for ARM, from there I dowloaded nvidia-173xx-173.14.25-1-i686.pkg.tar.gz and nvidia-173xx-utils-173.14.25-1-i686.pkg.tar.gz (because 25-1 is same). Then I tried to install nvidia-173xx with -d key and successfully installed, but 173xx-utils is conflicting with libgl. How to solve it?

Offline

#4 2010-07-14 19:45:10

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] Downgrade to nvidia-173xx

Remove libgl. IIRC nvidia has it's own gl implementation in their drivers.

Offline

#5 2010-07-14 21:52:27

Dr.X
Member
From: Daugavpils, Latvia
Registered: 2009-08-30
Posts: 58

Re: [SOLVED] Downgrade to nvidia-173xx

My steps:
1) I successfully installed nvidia-173xx-utils-glselect 173.14.25-1 from AUR instead nvidia-173xx-utils-173.14.25-1 (Can I do it?).
2) nouveau is fully removed
3) glselect nvidia
4) reboot
5) I have error:

This server has a video driver ABI version of 7.0 that is not supported by this NVIDIA driver. Please check nvidia.com for driver updates or downgrade to an X server with a supported driver ABI.

5) startx -ignoreABI doesn't solve problem
6)xorg-server dependencies are fully downgraded to may 15, 2010
7) I have error:

Failed to initialize the GLX module; please check in your X log file that the GLX module has been loaded in your X server, and that the module is the NVIDIA GLX module. ...

(my Xorg.0.log

Offline

#6 2010-07-14 21:55:03

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] Downgrade to nvidia-173xx

> xorg-server dependencies are fully downgraded to may 15, 2010
Double check it and don't use the packages form AUR but the standard ones.
http://arm.konnichi.com/2010/05/
http://arm.konnichi.com/2010/05/05/extra/os/i686/ (May 5th, for 32-bit)

Last edited by karol (2010-07-14 21:57:21)

Offline

#7 2010-07-15 07:35:18

Dr.X
Member
From: Daugavpils, Latvia
Registered: 2009-08-30
Posts: 58

Re: [SOLVED] Downgrade to nvidia-173xx

Failed to initialize the GLX module; please check in your X log file that the GLX module has been loaded in your X server, and that the module is the NVIDIA GLX module. ...

That error I solved by glselect nvidia, but now I have other error:

(EE)NVIDIA(0): This video driver ABI is not supported
(EE) NVIDIA(0): Use the -ignoreABI option to override this check.
Fatal server error:
AddScreen/ScreenInit failed for driver 0

I used -ignoreABI but I have same error.

Offline

#8 2010-07-15 07:43:41

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] Downgrade to nvidia-173xx

Did you downgrade xorg?
pacman -Q xorg-server

Offline

#9 2010-07-15 08:06:28

Dr.X
Member
From: Daugavpils, Latvia
Registered: 2009-08-30
Posts: 58

Re: [SOLVED] Downgrade to nvidia-173xx

Yes, I downgraded xorg-server to 1.7.6-1 and it dependencies to may 5, 2010, and now I have:

Fatal: module nvidia not found
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) Screen(s) found, but none have a usable configuration.
Fatal server error:
no screens found.

How to add this module?

Offline

#10 2010-07-15 08:13:23

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] Downgrade to nvidia-173xx

How did you configure the system? Are you using xorg.conf? If so, post it here. Are you using KMS, any kernel line options?

Edit: did you rebuild the kernel modules?

Last edited by karol (2010-07-15 08:33:04)

Offline

#11 2010-07-15 08:32:47

Dr.X
Member
From: Daugavpils, Latvia
Registered: 2009-08-30
Posts: 58

Re: [SOLVED] Downgrade to nvidia-173xx

My xorg.conf: http://pastebin.org/397313 , it's made by sudo X -configure . After removing nouveau, KMS is disabled. Now I have kernel26-2.6.33-1, mkinicpio -p kernel26 is successfully executed.
Also my Xorg.0.log: http://pastebin.org/397316

Offline

#12 2010-07-15 08:33:28

Dr.X
Member
From: Daugavpils, Latvia
Registered: 2009-08-30
Posts: 58

Re: [SOLVED] Downgrade to nvidia-173xx

Yes, I downgrade kernel from 34 to 32 and now to 33.

Offline

#13 2010-07-15 08:40:09

Dr.X
Member
From: Daugavpils, Latvia
Registered: 2009-08-30
Posts: 58

Re: [SOLVED] Downgrade to nvidia-173xx

Edit: did you rebuild the kernel modules?

hmm, I think mkinicpio -p kernel26 do that, then yes))

Offline

#14 2010-07-15 08:41:20

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] Downgrade to nvidia-173xx

Add

Section "ServerFlags"
     Option "AllowEmptyInput" "no"
EndSection

How did you get this xorg.conf? Did you run nvidia-xconfig?

Offline

#15 2010-07-15 09:11:32

Dr.X
Member
From: Daugavpils, Latvia
Registered: 2009-08-30
Posts: 58

Re: [SOLVED] Downgrade to nvidia-173xx

I added this to conf and runned nvidia-xconfig, but nothing changes((

Offline

#16 2010-07-15 09:44:38

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] Downgrade to nvidia-173xx

Did you restart after rebuilding kernel modules?

Offline

#17 2010-07-15 09:47:49

Dr.X
Member
From: Daugavpils, Latvia
Registered: 2009-08-30
Posts: 58

Re: [SOLVED] Downgrade to nvidia-173xx

yes, I always reboot after work with kernel

Offline

#18 2010-07-15 09:50:08

Dr.X
Member
From: Daugavpils, Latvia
Registered: 2009-08-30
Posts: 58

Re: [SOLVED] Downgrade to nvidia-173xx

Maybe helps custom kernel compiling?

Offline

#19 2010-07-15 09:52:15

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] Downgrade to nvidia-173xx

Run

modprobe nvidia
lsmod | grep -i nvidia

Offline

#20 2010-07-15 10:06:37

Dr.X
Member
From: Daugavpils, Latvia
Registered: 2009-08-30
Posts: 58

Re: [SOLVED] Downgrade to nvidia-173xx

# modprobe nvidia
Fatal: Module nvidia not found.
# lsmod | grep -i nvidia
<nothing>

Offline

#21 2010-07-15 10:07:47

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] Downgrade to nvidia-173xx

So where the f*ck did this driver go?

Again, form the beginning:
You downloaded the drivers from ARM.
Install them pacman -U nvidia-173xx-173.14.25-1-i686.pkg.tar.gz and the nvidia-utils and all the rest

Is it correct?

Last edited by karol (2010-07-15 10:09:57)

Offline

#22 2010-07-15 10:14:10

Dr.X
Member
From: Daugavpils, Latvia
Registered: 2009-08-30
Posts: 58

Re: [SOLVED] Downgrade to nvidia-173xx

yes, it's true, first of all I installed that version of drivers from ARM. Maybe  I should first of all downgrade kernel, and then install drivers?

Last edited by Dr.X (2010-07-15 10:14:26)

Offline

#23 2010-07-15 10:23:53

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] Downgrade to nvidia-173xx

> Maybe  I should first of all downgrade kernel, and then install drivers?
You can rebuild the modules at any time so I don't think it matters.

Run

pacman -Qs nvidia

Offline

#24 2010-07-15 11:04:20

Dr.X
Member
From: Daugavpils, Latvia
Registered: 2009-08-30
Posts: 58

Re: [SOLVED] Downgrade to nvidia-173xx

$ pacman -Qs nvidia
local/libvdpau
local/nvidia-173xx
local/nvidia-173xx-utls

Offline

#25 2010-07-15 11:09:10

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] Downgrade to nvidia-173xx

Post your rc.conf

Offline

Board footer

Powered by FluxBB