You are not logged in.

#1 2010-07-30 21:30:36

alleyoopster
Member
From: Cape Town
Registered: 2006-11-19
Posts: 92

Unable to un-mute PCM in alsa

Hi, recently audio stopped working. It maybe after the upgrade of alsa [2010-07-23 07:19] installed alsa-utils (1.0.23-2), but not sure. It is a SiS SI7012 Chip: C-Media Electronics CMI9739 and has been working for a while without problems.

I checked in xfce4-mixer and found PCM muted. Tried to unmute, but it just muted itself again. Tried the same in alsamixer and could not unmute. Also tried as root. I am member of audio

I have tried restarting alsa as root /etc/rc.d/alsa restart and got this

/usr/sbin/alsactl: set_control:1388: Cannot write control '2:0:0:PCM Playback Volume:0' : Operation not permitted

Also as root amixer sset PCM 90% unmute -d

amixer: Invalid command!

Tried on the IRC with a few suggestions, tried setting card options again, but still dead. Hoping someone here may have some clues.

Dan

Last edited by alleyoopster (2010-07-30 21:31:56)

Offline

#2 2010-08-02 14:38:08

lagagnon
Member
From: an Island in the Pacific...
Registered: 2009-12-10
Posts: 1,073
Website

Re: Unable to un-mute PCM in alsa

Did you try re-running "alsaconf" (as root) ?
Also, read through this and try anything there that seems reasonable to your situation: http://wiki.archlinux.org/index.php/Alsa .


Philosophy is looking for a black cat in a dark room. Metaphysics is looking for a black cat in a dark room that isn't there. Religion is looking for a black cat in a dark room that isn't there and shouting "I found it!". Science is looking for a black cat in a dark room with a flashlight.

Offline

#3 2010-08-02 15:03:31

alleyoopster
Member
From: Cape Town
Registered: 2006-11-19
Posts: 92

Re: Unable to un-mute PCM in alsa

I tried running alsaconf (root) and that does not change things, but I have made some progress. It seems that stopping X and running alsamixer from a tty and  un-muting PCM fixes the problem. It is still fixed going back into a desktop. After rebooting and then going into XFCE once again PCM is muted an cannot un-mute. Weird!

Offline

#4 2010-08-02 15:38:27

lagagnon
Member
From: an Island in the Pacific...
Registered: 2009-12-10
Posts: 1,073
Website

Re: Unable to un-mute PCM in alsa

Try running "amixer" from the command line:

amixer -q set PCM mute
amixer -q set PCM unmute

You could bind those commands to a keystroke also, if they work for you...


Philosophy is looking for a black cat in a dark room. Metaphysics is looking for a black cat in a dark room that isn't there. Religion is looking for a black cat in a dark room that isn't there and shouting "I found it!". Science is looking for a black cat in a dark room with a flashlight.

Offline

#5 2010-08-02 19:08:48

alleyoopster
Member
From: Cape Town
Registered: 2006-11-19
Posts: 92

Re: Unable to un-mute PCM in alsa

Yeah, I tried that as per the first post and it gives an error amixer: Invalid command!.

Still it works outside of XFCE. It works at tty and I just tried going into openbox. so it must be something XFCE specific. I'll look at what I have starting up and try and figure it out.

Offline

#6 2010-08-02 19:19:27

Stebalien
Member
Registered: 2010-04-27
Posts: 1,218
Website

Re: Unable to un-mute PCM in alsa

amixer set PCM 85% unmute


Steven [ web : git ]
GPG:  327B 20CE 21EA 68CF A7748675 7C92 3221 5899 410C
Do not email: honeypot@stebalien.com

Offline

#7 2010-08-02 20:56:04

alleyoopster
Member
From: Cape Town
Registered: 2006-11-19
Posts: 92

Re: Unable to un-mute PCM in alsa

Either command

amixer -q set PCM mute

or

amixer set PCM 85% unmute

give error "amixer: Invalid command!", but only in XFCE. It works at tty or even in openbox. Must be something with XFCE.

Offline

Board footer

Powered by FluxBB