You are not logged in.

#1 2010-07-30 22:00:20

apcorn
Member
Registered: 2010-02-15
Posts: 2

VMware Server 2.0.2 Modules on kernel >= 2.6.34

I recently got a new laptop that required kernel 2.6.35 for the ethernet controller. I was able to get it compiled and installed, and then tried to install VMware Server 2.0.2 from the AUR. Unfortunately, something changed in kernel 2.6.34 and the vmware-server-modules package would not build. I found a patch for VMware Worstation 7.1 at http://www.debuntu.org/how-wmware-works … rkat-10.10. However, it wasn't compatible with the source code from VMware Server 2.0.2. I managed to port the patch over manually. Here is how:

  1. Download the file VMware-server-2.0.2-203138.i386.tar.gz from the vmware.com website.

  2. Untar the file in a temporary directory.

  3. cd vmware-server-distrib/lib/modules/source/

  4. Untar vsock.tar and vmnet.tar

  5. cd vsock-only/linux/

  6. vim af_vsock.c

  7. Issue this command within vim: :%s/sk->compat_sk_sleep/compat_sk_sleep(sk)/g (there should be ten substitutions)

  8. The file is probably read-only, so issue :w! to save it. Then quit.

  9. cd ../include/

  10. vim compat_sock.h

  11. Change line 46 from:

    # define compat_sk_sleep                sleep

    to:

    # define compat_sk_sleep(sk)            sk->sleep
  12. Delete line 64:

    # define compat_sk_sleep                sk_sleep

    and replace it with:

    #if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 34)
    # define compat_sk_sleep(sk)            sk->sk_sleep
    #else
    # define compat_sk_sleep(sk)            sk_sleep(sk)
    #endif
  13. cd ../../

  14. cp vsock-only/include/compat_sock.h vmnet-only/compat_sock.h

  15. rm vmnet.tar vsock.tar

  16. tar -cf vmnet.tar vmnet-only/

  17. tar -cf vsock.tar vsock-only/

  18. cd ../../../../

  19. rm VMware-server-2.0.2-203138.i386.tar.gz

  20. tar -cf VMware-server-2.0.2-203138.i386.tar.gz vmware-server-distrib/

  21. Last, you need to md5sum VMware-server-2.0.2-203138.i386.tar.gz and then open PKGBUILD and change the existing VMware-server-2.0.2-203138.i386.tar.gz md5sum to the new one. If you don't do this step, the build will fail because the checksums won't match.

After making the above changes, run makepkg -s as normal. It should work fine.

This process would be much smoother if someone more knowlegeable than I could make a .patch file and modify the AUR build scripts. I have the updated files and would be willing to provide those to anyone who wants to undertake that task. Please also note that I HAVE NOT tested this on any kernel except 2.6.35-rc6. The patch I found in the link at the top of this post is for kernel 2.6.34, so I assume it fixes the vmware-server-modules compilation for both 2.6.34 and 2.6.35. I hope this post can be of help to somebody.

Offline

#2 2010-10-06 09:25:09

MAC!EK
Member
Registered: 2005-09-27
Posts: 265

Re: VMware Server 2.0.2 Modules on kernel >= 2.6.34

I this patch is exactly what you describe here:
http://pastie.org/1202649

Offline

#3 2010-10-14 15:01:44

emory
Member
From: ~
Registered: 2010-10-09
Posts: 17

Re: VMware Server 2.0.2 Modules on kernel >= 2.6.34

MAC!EK wrote:

I this patch is exactly what you describe here:
http://pastie.org/1202649

How does one implement that patch?

Offline

#4 2010-10-20 17:00:45

gdane195
Member
From: Canada
Registered: 2009-10-11
Posts: 6

Re: VMware Server 2.0.2 Modules on kernel >= 2.6.34

I would like to run VMWare server on my ArchLinux, could you share the package??

gdane195

Offline

Board footer

Powered by FluxBB