You are not logged in.

#1 2010-08-15 09:42:25

chris_debian
Member
From: Wiltshire, UK
Registered: 2009-02-24
Posts: 284

[SOLVED]Can't Print- PPD version not compatible with Gutenprint 5.2.6.

Hi, all.

I have printing problems with CUPS. I have searched for an existing mention of this, but without any luck.

I have an Epson Stylus DX7400. I tried to print a test page and received an 'input/ output' error. I then realised that for some reason the printed appeared to be 'paused'. From the CUPS administration page. I 'Resumed' the printer. The print dialogue box in my browser then said 'Printer on-line'. Thinking the problem was solved, I tried to to a new print job. Unfortunately I got "The PPD version (39516747) is not compatible with Gutenprint 5.2.6.". Looking through my administration page, I seem to have a few of these messages, but just with a different reference number, such as:

stopped
"The PPD version (14162507) is not compatible with Gutenprint 5.2.6."

Printing has been fine and I last printed successfully, a couple of days ago. I don't recall seeing any print related pacman updates.

Any ideas?

Many thanks,

Chris.

"The PPD version nnn is not compatible with Gutenprint 5.2.6."

Last edited by chris_debian (2010-08-15 11:09:54)


Reasons why you may want to try GNU/Linux:

www.whylinuxisbetter.net/

Offline

#2 2010-08-15 11:09:09

chris_debian
Member
From: Wiltshire, UK
Registered: 2009-02-24
Posts: 284

Re: [SOLVED]Can't Print- PPD version not compatible with Gutenprint 5.2.6.

Problem solved. I went into the CUPS admin page and modified my printer so it used Gutenprint 5.2, instead of 5.2.6.  :-)

Chris.


Reasons why you may want to try GNU/Linux:

www.whylinuxisbetter.net/

Offline

#3 2010-08-15 15:09:04

chris_debian
Member
From: Wiltshire, UK
Registered: 2009-02-24
Posts: 284

Re: [SOLVED]Can't Print- PPD version not compatible with Gutenprint 5.2.6.

Having a look at updates over the last couple of days, I think this update may have caused the problem:

x86_64      Extra      cups      1.4.4-3      The CUPS Printing System - deamon package      2010-08-14

Bug STR #3644 reported to CUPS.

Chris.

Last edited by chris_debian (2010-08-15 15:22:53)


Reasons why you may want to try GNU/Linux:

www.whylinuxisbetter.net/

Offline

#4 2010-08-16 08:30:59

shetland_breeder
Member
From: England
Registered: 2010-05-17
Posts: 57
Website

Re: [SOLVED]Can't Print- PPD version not compatible with Gutenprint 5.2.6.

Just had the same problem.

I think the real answer is here:

http://wiki.archlinux.org/index.php/CUP … gutenprint

Run /usr/sbin/cups-genppdupdate - after installing the new cupsd.conf file too.

Pete

Last edited by shetland_breeder (2010-08-16 08:31:23)

Offline

#5 2010-08-24 22:18:47

trev311
Member
From: Planet Pumpkin
Registered: 2010-08-24
Posts: 2
Website

Re: [SOLVED]Can't Print- PPD version not compatible with Gutenprint 5.2.6.

I had the same problem with an Stylus NX515... The command /usr/sbin/cups-genppdupdate just said that no PPD files were updated. Apparently there is a foomatic+gutenprint and a CUPS+gutenprint PPD for a few of the Stylus modesl (I didn't mess around too much in the CUPS admin section) and switching to the CUPS+gutenprint PPD fixed the issue for me. So in all, I too don't think that the CUPS update messed things up as much as the last gutenprint update especially since a roll back of the last gutenprint update fixed my issues.

Offline

#6 2010-10-03 21:02:23

amj
Member
Registered: 2008-06-13
Posts: 4

Re: [SOLVED]Can't Print- PPD version not compatible with Gutenprint 5.2.6.

shetland_breeder wrote:

Just had the same problem.

I think the real answer is here:

http://wiki.archlinux.org/index.php/CUP … gutenprint

Run /usr/sbin/cups-genppdupdate - after installing the new cupsd.conf file too.

Pete


This solved my problem too. Of course, you have to restart cupsd after running cups-genppdupdate. Thanks a lot.

Offline

#7 2011-05-26 19:53:06

brazzmonkey
Member
From: between keyboard and chair
Registered: 2006-03-16
Posts: 818
Website

Re: [SOLVED]Can't Print- PPD version not compatible with Gutenprint 5.2.6.

/usr/sbin/cups-genppdupdate worked for me. Thanks shetland_breeder.


what goes up must come down

Offline

Board footer

Powered by FluxBB