You are not logged in.

#1 2005-02-27 01:08:57


[SOLVED] HELP Samsung ML-1710 (printer)

I tried using the printing howto via the arch wiki but couldn't get the printer setup for some reason. Checked out, read that the drivers provided from samsung work best so I downloaded and unzipped them (via KDE....still havent figured out how to unzip something via commandline.... :? ) and there is a file in there. How do i run this I tried cd'ing to the directory and just typing but that didn't work also clicking on it via graphical kde doesnt work.  What do I need to do?

#2 2005-02-27 09:12:09

From: Lithuania/Klaipeda-Vilnius
Registered: 2005-02-08
Posts: 101

Re: [SOLVED] HELP Samsung ML-1710 (printer)

1) unzip via console:


2) to run do the following things:
login as root:

$ su

Then type your root password. Don't be scared - no stars are showed.
Then cd to the directory where is your and:

# sh


# ./ 

If you get some errors make sure that you have x flag on your

# chmod +x


#3 2005-02-27 17:56:22


Re: [SOLVED] HELP Samsung ML-1710 (printer)

nothing happens...

[xxx@xxx ~]$ su
[root@xxx xxx]# cd /temp/downloads/image
[root@xxx image]# sh
[root@xxx image]# ./
[root@xxx image]# chmod +x
[root@xxx image]# sh
[root@xxx image]# ./
[root@xxx image]# ls
README.txt  bin   help      locale  ppd
autorun     data  icon.xpm  misc    scripts
[root@xxx image]#

I just threw in the ls to show you that I'm in the correct directory. I wonder if it's broken or if i'm doing something wrong or....?

#4 2005-02-28 18:44:05


Re: [SOLVED] HELP Samsung ML-1710 (printer)

no other takers?

#5 2005-03-08 23:39:06

Registered: 2005-03-01
Posts: 442

Re: [SOLVED] HELP Samsung ML-1710 (printer)

Generally, I like to use "sh", that way I don't have to worry about whether the file is executable or not.  For variations on each  theme, however...

Using 'sh':
# sh /some/path/
# cd /some/path; sh

Using './' (executable files only):
# /some/path/
# cd /some/path; ./

Thoroughly confused, yet? :?

If the file isn't too large, could you post it?  Just curious if it contains *anything* at all, or if it might be missing the all important "#!/bin/bash" header.  To dump (print) to the console, type:
# cd /some path
# cat

Then, using your mouse, highlight the dumped out text and paste it into the phpBB form (Ctrl-V works to paste text).


#6 2005-03-10 07:54:03


Re: [SOLVED] HELP Samsung ML-1710 (printer)

After much ... tweaking (as best as I know how) ... still nothing worked. Until

pacman -Syu

then automagically, after changing 0 settings the printer works. How very odd.

Very large Thank You(s) to all those who took the time to try and help.

Board footer

Powered by FluxBB