You are not logged in.

#1 2010-09-09 00:11:22

Registered: 2009-09-04
Posts: 28

Wassup with from AUR...?


I downloaded a demo version of a CAD package called BricsCAD.

This is a clone of CAD based on IntelliCAD code ( compatible with autocad dwg/dxf formats from R10 till 2007 )

There is a demo version available for Download,

Anyway, I downloaded the deb, converted it with deb2targz, unpacked the thing into ~/Build/pkg, ( this creates an /opt/Bricsys/.... and an /usr/bin/bricscad which is a symlink to the app ) wrote a PKGBUILD,, packed it with makepkg -Rd PKGBUILD. and installed the created package.

This is a 32 bits app, and I have lib32 packages installed.

Tried to run bricscad, and it reported an error about a missing, so here i go, and fetch lib32-libjpeg6 from AUR, created the package, and installed it... this landed in /usr/lib32.

:crossing fingers: ...ran bricscad again, and again it reported the missing but the link and the library proprer both live in /usr/lib32...

so I ran ldconfig -v as root, as user ran

ln -s /usr/lib32/ .

tried to run bricscad, and still it complains about the same missing lib...

What is the problem here...?

Shouldn´t this run against a 32 bits that I created from AUR...?




#2 2010-09-12 02:07:54

From: Portland, Oregon
Registered: 2004-01-06
Posts: 15

Re: Wassup with from AUR...?

I was able to get the current version (V10.6.4) to work using the lib32-libjpeg package from the "multilib" repo (and after manually making the link.)

pacman -S lib32-libjpeg
cd /usr/lib32
ln -s

But then I needed the lib32-libpng12 (which I built & installed from the AUR)

But then I needed the lib32-nvidia-utils from the "multilib" repo (I'm using the Nvidia drivers)

So now the program runs, but I get " wrong ELF class: ELFCLASS64" errors.  The AUR package for lib32-gtk-engines does not seem to fix the error.  I suspect that the package needs to be reworked for the recent multilib change.

I have done a recent update (pacman -Syu), so I'm as current as I can be.

Please try again, we want to encourge the Bricsys folks to keep developing a better cad program


Last edited by cmhood (2010-09-12 02:09:27)


#3 2010-09-13 00:35:44

Registered: 2009-09-04
Posts: 28

Re: Wassup with from AUR...?

Hi cmhood

Thanks for yur reply, and for your work...

I will try again this week...  in the mean time, I have posted in Bricsys forum, stating my difficulties and suggested them to release a native 64 bits port...

In the mean time, BricsCad for windows demo runs allright in wine....

would be awesome to have a full 64 bits port for linux...




Personally i think that if they do not release the code, they should at least ship it with the libraries it uses ( at least the less basic of them ) so that it would be a more "universal" package, IMHO

Last edited by Alexvader (2010-09-13 00:38:54)


Board footer

Powered by FluxBB