You are not logged in.

#1 2010-09-10 00:03:36

jwhendy
Member
Registered: 2010-04-01
Posts: 548

[SOLVED]txlive-localmgr: Can't get object for collection langukenglish

Hi,


I just had issues today with tllocalmgr not working at all. Every command hangs with:

-----
[jwhendy]$ tllocalmgr
Initializing ...
Can't get object for collection-langukenglish at /usr/bin/tllocalmgr line 103
-----

Line 103 in /usr/bin/tllocalmgr is:

-----
my %tlpackages = $tlpdb->archpackages;
-----

And $tlpdb seems to refer to this line:

-----
my $tlpdb = new TeXLive::Arch (root => $ROOT) || die "cannot read $ROOT/tlpkg/texlive.tlpdb"
-----

I tried removing ~/.texlive/texmf-var/arch/tlpkg/texlive.tlpdb to see what it would do and it just regenerated one and produced the same issue.

The only google results for collection-langukenglish refer to /usr/share/texmf[-config]/tex/generic/config/language.dat. I checked that file out and commented out all languages except english seeing if that would help. No luck.

Any other thoughts? I'm truly puzzled. I just installed some texlive packages from CTAN within the last week... two at the most. Is this on my end or perhaps with some momentary glitch in CTAN, like being out of sync somehow?


John

Last edited by jwhendy (2010-09-10 02:26:19)

Offline

#2 2010-09-10 02:25:44

jwhendy
Member
Registered: 2010-04-01
Posts: 548

Re: [SOLVED]txlive-localmgr: Can't get object for collection langukenglish

Hmmm. Wonder if it really was the mirror. After a few 'yaourt -R texlive-localmanager' and 'yaourt -S texlive-localmanager' iterations... the problem is gone!

John

Offline

Board footer

Powered by FluxBB