You are not logged in.

#1 2005-03-04 23:44:59

sud_crow
Member
From: Argentina
Registered: 2003-06-30
Posts: 545

AMD Cool 'n Quiet (powernow-k8 module)

Hi,

Im having a little problem on getting CnQ to work, here is whats going on>

[root@archcrow crow]# modprobe powernow_k8
FATAL: Error inserting powernow_k8 (/lib/modules/2.6.10-ARCH/kernel/arch/i386/kernel/cpu/cpufreq/powernow-k8.ko): No such device
[root@archcrow crow]#


Im using the stock arch scsi kernel26.

Im missing something here? or the stock kernel has a problem with cool and quiet?

Just in case: I do have an Athlon64 and a motherboard supporting the feature, also its activated in the BIOS smile


Leonardo Andrés Gallego
www.archlinux-es.org || Comunidad Hispana de Arch Linux

Offline

#2 2005-03-06 00:15:59

sud_crow
Member
From: Argentina
Registered: 2003-06-30
Posts: 545

Re: AMD Cool 'n Quiet (powernow-k8 module)

Now one has a AMD64 with Cool and quiet running on Arch??

I found out that this package is requeried (or at least, thats what a lot of people say):
http://www.deater.net/john/powernowd.html

Its a deamon incharge of stepping the FSB.

I will be looking for more info later and post any updates. If i succesfully make this thing work i will post it to the wiki i guess.


Leonardo Andrés Gallego
www.archlinux-es.org || Comunidad Hispana de Arch Linux

Offline

#3 2005-03-06 02:33:56

Algol
Member
Registered: 2005-01-05
Posts: 37

Re: AMD Cool 'n Quiet (powernow-k8 module)

There are a few ways of running cool-n-quiet... either with daemons, or just setting ondemand as governor in '/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor'
The stock arch kernel worked for me (kernel26-scsi 2.6.10-3), I don't remember that I had to install any extra packages., just loading the module worked.. (I don't have powernowd installed) what does 'dmesg | grep powernow' give you?

Check out:
http://gentoo-wiki.com/HOWTO_PowerNow!

Offline

#4 2005-03-08 04:38:34

sud_crow
Member
From: Argentina
Registered: 2003-06-30
Posts: 545

Re: AMD Cool 'n Quiet (powernow-k8 module)

the grep command is throwing zip (nothing) !.

here is:

[root@archcrow ~]# dmesg | grep powernow
[root@archcrow ~]#

Whats going on here?
according to the howto at Gentoo wiki, i should get a description of my processor powernow levels... heck.

Im using

[root@archcrow ~]# pacman -Qi kernel26-scsi
Name           : kernel26-scsi
Version        : 2.6.10-3
Groups         : None
Packager       : Arch Linux (http://www.archlinux.org)
URL            : http://www.kernel.org
License        :
Architecture   : i686
Size           : 47744789
Build Date     : Tue Jan 18 17:52:01 2005 UTC
Install Date   : Tue Feb 22 19:16:30 2005 UTC
Install Script : No
Reason:        : explicitly installed
Provides       : None
Depends On     : module-init-tools
Required By    : None
Conflicts With : kernel26
Description    : The Linux Kernel and modules (SCSI support)


Also, i found out this:

[root@archcrow cpu0]# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq
cat: /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq: No such file or directory

The deepest i got is this:
/sys/devices/system/cpu/cpu0

There is no cpufreq dir, and ofcourse there is no scaling_cur_freq file.

Some tips?


Leonardo Andrés Gallego
www.archlinux-es.org || Comunidad Hispana de Arch Linux

Offline

#5 2005-03-08 06:51:54

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: AMD Cool 'n Quiet (powernow-k8 module)

You need to load these modules:
acpi_cpufreq and freq_table  as well as powernow-k8

Offline

#6 2005-03-08 11:28:11

Algol
Member
Registered: 2005-01-05
Posts: 37

Re: AMD Cool 'n Quiet (powernow-k8 module)

Im sorry that I cannot assist better, but are you *sure* that cool and quiet is activated in the BIOS? This all seems very familiar to me, but I've only set it up once, and then even in a very ad hoc manner.

I personally have cpufreq_ondemand loaded by rc.conf and freq_table is pulled in by auto (not in rc.conf), they shouldn't impact on your dmesg though... my dmesg | grep powernow gives:

powernow-k8: Found 1 AMD Athlon 64 / Opteron processors (version 1.00.09e)
powernow-k8:    0 : fid 0xc (2000 MHz), vid 0x2 (1500 mV)
powernow-k8:    1 : fid 0xa (1800 MHz), vid 0x6 (1400 mV)
powernow-k8:    2 : fid 0x2 (1000 MHz), vid 0x12 (1100 mV)
powernow-k8: ph2 null fid transition 0xc

As a final resort, try updating your BIOS?
If I have time later I might experiment some to remember better.

Offline

#7 2005-03-09 04:36:08

sud_crow
Member
From: Argentina
Registered: 2003-06-30
Posts: 545

Re: AMD Cool 'n Quiet (powernow-k8 module)

Hi,
This were my modules before doing anything:

[root@archcrow crow]# lsmod
Module                  Size  Used by
eth1394                21640  0
uhci_hcd               34576  0
parport_pc             28996  0
parport                38600  1 parport_pc
irtty_sir               7424  0
sir_dev                18492  1 irtty_sir
irda                  144188  1 sir_dev
crc_ccitt               2432  1 irda
pcspkr                  4044  0
ohci1394               35716  0
ieee1394              111416  2 eth1394,ohci1394
nvidia               3465660  12
pci_hotplug            34748  0
joydev                 10560  0
usbhid                 45824  0
snd_intel8x0           34336  1
snd_ac97_codec         78176  1 snd_intel8x0
snd_pcm_oss            56612  0
snd_mixer_oss          21120  2 snd_pcm_oss
snd_pcm               101252  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              27140  1 snd_pcm
snd                    59108  6 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              10848  2 snd
snd_page_alloc         10244  2 snd_intel8x0,snd_pcm
forcedeth              18560  0
ehci_hcd               35332  0
ohci_hcd               23560  0
usbcore               125560  5 uhci_hcd,usbhid,ehci_hcd,ohci_hcd
tsdev                   8128  0
evdev                   9984  0
rtc                    13128  0
nls_cp437               6144  2
vfat                   14976  2
fat                    42912  1 vfat

I could load the "freq_table" module, but the "acpi_cpufreq" answered with the following error:

[root@archcrow crow]# modprobe acpi_cpufreq
FATAL: Error inserting acpi_cpufreq (/lib/modules/2.6.10-ARCH/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko): No such device

Its the same as powernow-k8.

Dont understand whats wrong with this:
Yes the CnQ is enabled in BIOS, and YES, ACPI is also enabled (also tryed disabling it).


Leonardo Andrés Gallego
www.archlinux-es.org || Comunidad Hispana de Arch Linux

Offline

#8 2005-03-10 02:42:55

sud_crow
Member
From: Argentina
Registered: 2003-06-30
Posts: 545

Re: AMD Cool 'n Quiet (powernow-k8 module)

When i disable ACPI in the BIOS i get:

"BIOS error: No PSB was found"

or something like that...
I searched and its also related to the cool and quiet being disabled in the BIOS, but mine is enabled.

By the way, my motherboard is a Lanparty UT nforce3 250gb, im _not_ overclocking the CPU.

Regards.


Leonardo Andrés Gallego
www.archlinux-es.org || Comunidad Hispana de Arch Linux

Offline

#9 2005-03-20 12:54:36

swim
Member
Registered: 2005-01-09
Posts: 25

Re: AMD Cool 'n Quiet (powernow-k8 module)

Hi, I'm not sure if you've gotten this to work yet.
I have, and I though I'd post what I do.
I install cpufreqd package, and install powernowd from deaters site.
Then I add powernowd to the daemons line in rc.conf,  powernow-k8 and cpufreq-userspace to the modules line. and check /proc/cpuinfo for results.
I also have an athlon64 btw...

let me know how it goes...

Offline

#10 2005-03-24 04:26:20

sud_crow
Member
From: Argentina
Registered: 2003-06-30
Posts: 545

Re: AMD Cool 'n Quiet (powernow-k8 module)

Hi,
thanks for the information, i havent gotten this to work, at least until now.

Im going to try your steps, and post the results at a later time (have to wait till end of month to buy my new HD and reinstall the system).

Thanks again!


Leonardo Andrés Gallego
www.archlinux-es.org || Comunidad Hispana de Arch Linux

Offline

#11 2006-08-22 03:18:43

sud_crow
Member
From: Argentina
Registered: 2003-06-30
Posts: 545

Re: AMD Cool 'n Quiet (powernow-k8 module)

I was looking for the governor file, to set the default mode, and i found this post, where i had this problem with cool and quiet and wanted to post the answer:

Bios Update... after a couple of months, DFI released a BIOS update where they fixed an incompatibility between certain memory brands and cool n quiet.

That's it... i lost so much time over this that i was quite angry they didn't at least post something about it before updating the bios.


Leonardo Andrés Gallego
www.archlinux-es.org || Comunidad Hispana de Arch Linux

Offline

Board footer

Powered by FluxBB