You are not logged in.

#1 2010-09-19 21:06:41

thibdb13
Member
From: Mechelen - Belgium
Registered: 2005-10-11
Posts: 113

Network daemon

I have a Intel 10 GB network card which module is "e1000e".
When starting my system the network daemon does not work correctly and I have to correct this after loging in with the following command:
ifconfig eth0 mtu 576

After this I have to enter /etc/rc.d/network restart and /etc/rc.d/openntpd restart to get my network and openntpd working.

Is there a way to correct the network daemon or to make a new daemon so that I will not have to correct this situation manually after each boot?

Offline

#2 2010-09-19 21:31:44

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: Network daemon

Maybe this will help: http://wiki.archlinux.org/index.php/Jum … ration_.3D
Set MTU to 576 manually and disable the MTU hook.

Last edited by karol (2010-09-19 21:33:24)

Offline

#3 2010-09-19 21:33:26

codycarey
Member
Registered: 2009-08-21
Posts: 154

Re: Network daemon

Can you post the output of your 'lspci -vvnn' related to your network card?

Last edited by codycarey (2010-09-19 21:34:16)

Offline

#4 2010-09-20 19:58:09

thibdb13
Member
From: Mechelen - Belgium
Registered: 2005-10-11
Posts: 113

Re: Network daemon

codycarey wrote:

Can you post the output of your 'lspci -vvnn' related to your network card?

This is what I get:

00:19.0 Ethernet controller [0200]: Intel Corporation 82578DC Gigabit Network Connection [8086:10f0] (rev 06)
        Subsystem: Acer Incorporated [ALI] Device [1025:8000]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 54
        Region 0: Memory at f9fc0000 (32-bit, non-prefetchable) [size=128K]
        Region 1: Memory at f9ffc000 (32-bit, non-prefetchable) [size=4K]
        Region 2: I/O ports at bc00 [size=32]
        Capabilities: [c8] Power Management version 2
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=1 PME-
        Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
                Address: 00000000fee0f00c  Data: 412a
        Capabilities: [e0] PCI Advanced Features
                AFCap: TP+ FLR+
                AFCtrl: FLR-
                AFStatus: TP-
        Kernel driver in use: e1000e
        Kernel modules: e1000e

Offline

#5 2010-09-21 07:11:00

thibdb13
Member
From: Mechelen - Belgium
Registered: 2005-10-11
Posts: 113

Re: Network daemon

So, the problem is solved. Thanks to Karol for the links.
The solution was quite simple, I just had to add a line in my /etc/rc.local:
/sbin/ifconfig eth0 mtu 576

Offline

Board footer

Powered by FluxBB