You are not logged in.

#1 2010-09-22 16:32:25

markz79
Member
Registered: 2009-05-17
Posts: 72

[BUG SUBMITTED]Metacity 2.30.2-1 damaged title bars

After upgrading Metacity (from 2.30.1-1) the title bars of windows don't render correctly (most pixels are missing or improperly colored). This is only when the Arch system is accessed remotely via NX Client for Windows. Using NX Client on another Arch system doesn't result in damaged title bars. Before the upgrade I didn't have these issues. I've restarted X, rebooted, cleared out cached files, and still no go. Any ideas?

[Edit] I should mention if I replace Metacity with Fluxbox the title bars are OK.

Last edited by markz79 (2010-09-29 04:01:46)

Offline

#2 2010-09-22 21:49:55

markz79
Member
Registered: 2009-05-17
Posts: 72

Re: [BUG SUBMITTED]Metacity 2.30.2-1 damaged title bars

Reverting to the previous version of Metacity results in properly rendered windows, so it seems to be an issue with the latest version.

Offline

#3 2010-09-22 21:53:09

eldragon
Member
From: Buenos Aires
Registered: 2008-11-18
Posts: 1,028

Re: [BUG SUBMITTED]Metacity 2.30.2-1 damaged title bars

file a bug report

Offline

#4 2010-09-26 18:24:55

markz79
Member
Registered: 2009-05-17
Posts: 72

Re: [BUG SUBMITTED]Metacity 2.30.2-1 damaged title bars

Where?

Offline

#5 2010-09-26 18:26:34

wonder
Developer
From: Bucharest, Romania
Registered: 2006-07-05
Posts: 5,939
Website

Re: [BUG SUBMITTED]Metacity 2.30.2-1 damaged title bars

is already submitted upstream.

http://bugzilla.gnome.org/show_bug.cgi?id=630426


Give what you have. To someone, it may be better than you dare to think.

Offline

#6 2010-09-29 04:00:08

markz79
Member
Registered: 2009-05-17
Posts: 72

Re: [BUG SUBMITTED]Metacity 2.30.2-1 damaged title bars

OK, good. Thanks.

Offline

#7 2010-10-08 11:44:50

prometej
Member
From: Zagreb, Croatia
Registered: 2008-10-10
Posts: 19

Re: [BUG SUBMITTED]Metacity 2.30.2-1 damaged title bars

@Mark79
Thanx for posting your solution.

I have/had the same problem with NX Client and metacity.
Downgrading metacity and gnome-control-center (metacity dependency) from current version (2.30.3-1) to version 2.30.1-1 worked for me.
If somone else needs packages to downgrade - I found them on http://schlunix.org/archlinux/extra/ (link found on Downgrading Packages - Arch Wiki).
Hope it will work fine until this metacity bug is resolved.


UTERE SED NE ABUTERE !!

Offline

Board footer

Powered by FluxBB