You are not logged in.

#1 2010-10-07 04:40:04

PreparationH67
Member
From: Chicago IL
Registered: 2010-07-28
Posts: 40

Arch PPC - Display not outputting anything

I've been working with an Apple G4, 1.4(?)Ghz PPC with one of the Apple Display Port monitors, and I've been trying to get arch on it using the install image from the Arch PPC site. So I finally got it to boot correctly, dear god that was more work than it should have been, and it loads the kernel, starts the daemons, but then, when the screen refreshes at the end, nothing. The display appears active, but there is no visible output. No login no nothing. I used the install disk to chroot into the root partition and installed some more packages including: dbus, hal, fam, abs, and openssh. So I added a user configured sshd and rebooted and I can shell into the machine fine. Everything appears to be there, I have no idea why it is doing this. I really have not had the time to do an extensive search in the system for possible errors, but does anyone have any ideas on what it could be and how to fix it?

Thanks

Offline

#2 2010-10-07 10:55:13

mianka
Member
From: BE LEUVEN
Registered: 2006-05-30
Posts: 209

Re: Arch PPC - Display not outputting anything

There is a mailing list for ppc problems on http://groups.google.it/group/archlinuxppc-user. The archppc devs follow it.

Offline

#3 2010-10-07 15:31:46

PreparationH67
Member
From: Chicago IL
Registered: 2010-07-28
Posts: 40

Re: Arch PPC - Display not outputting anything

Cool, thanks. I'll try asking them.

Offline

#4 2010-10-13 15:13:30

klaatu
Member
Registered: 2010-10-13
Posts: 1

Re: Arch PPC - Display not outputting anything

try booting, but after your kernel selection enter  "nomodeset"

so it would be something like...
arch64 nomodeset

or

kernel26_64 nomodeset

Offline

#5 2010-12-24 09:26:27

DaNiMoTh
Member
Registered: 2006-06-10
Posts: 253

Re: Arch PPC - Display not outputting anything

also add

!yenta_socket

to rc.conf, in modules array.

Offline

Board footer

Powered by FluxBB