You are not logged in.

#1 2003-08-22 18:46:35

Guest
Guest

kde control center sound i/o method

I just installed arch 0.5, and had some problems getting ALSA set up.  After reading through this forum and several others, I managed to get it set up properly (I think). 

However, when I go to the KDE control center>>sound>>sound i/o, I don't see an option for ALSA.  When I had Mandrake 9.1 installed, it was there.

Do I have to do something special to get the ALSA option to show up?  Do others out there running Arch have that option?  I added the alsa drivers to modules.conf and do see them when I run lsmod.  Is there something else I need to do to use alsa in KDE?

Thanks!

#2 2003-08-22 18:49:45

Jagged
Member
From: Blacksburg, VA
Registered: 2003-07-18
Posts: 153

Re: kde control center sound i/o method

are you getting any sound?


in /etc/modules.devfs is there an: alias /dev/sound/   nameofalsaaliashere?


Nkawtg...n!

Offline

#3 2003-08-22 19:07:12

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: kde control center sound i/o method

as i know, aRTs, the soundserver in kde, can connect only to the old stable ALSA-versions ... but it should work when you select OSS in the menu you meant, when you use the "alsa-oss"-package in archlinux


The impossible missions are the only ones which succeed.

Offline

#4 2003-08-22 19:12:48

Guest
Guest

Re: kde control center sound i/o method

Do you mean modules.conf?  I am getting sound.  Here's the contents of modules.conf having to do with ALSA:

     # ALSA portion
     alias char-major-116 snd
     alias snd-card-0 snd-emu10k1
     # module options should go here

     # OSS/Free portion
     alias char-major-14 soundcore
     alias sound-slot-0 snd-card-0
    
     # card #1
     alias sound-service-0-0 snd-mixer-oss
     alias sound-service-0-1 snd-seq-oss
     alias sound-service-0-3 snd-pcm-oss
     alias sound-service-0-8 snd-seq-oss
     alias sound-service-0-12 snd-pcm-oss

Looks like I am missing an "alias /dev/sound/ nameofalsaaliashere" here entry.  Could that be it?

#5 2003-08-22 20:20:56

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: kde control center sound i/o method

no i dont think so ... my modules.conf-sound-part looks like this:

#### SOUND #####
# the specific part:
 snd_index=0
options snd snd_cards_limit=1 snd_major=116
alias snd-card-0 i810_audio
# and some things for the general sound support:
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-11 snd-mixer-oss
alias sound-service-0-12 snd-pcm-oss

i'm using the "i810_audio" module, as oyu can see ... and with this OSS works for me --- adapt this for you --- and in the KDE-aRTs-dialog(the one in the control center) just select "Autodetect"

-> one more thing: be sure you have access to /dev/dsp (either chmod in /eth/rc.local or make a usergroup sound that owns it)


The impossible missions are the only ones which succeed.

Offline

#6 2003-08-23 03:48:41

Jagged
Member
From: Blacksburg, VA
Registered: 2003-07-18
Posts: 153

Re: kde control center sound i/o method

no... i meant modules.devfs

# Soundcard
alias     /dev/sound            sound-slot-0
alias     /dev/audio            /dev/sound
alias     /dev/mixer            /dev/sound
alias     /dev/dsp              /dev/sound
alias     /dev/dspW             /dev/sound
alias     /dev/midi             /dev/sound

edit it arrocdingly per your sound system


Nkawtg...n!

Offline

#7 2003-08-23 15:59:31

Arielext
Member
From: Amersfoort, the Netherlands
Registered: 2002-08-12
Posts: 362
Website

Re: kde control center sound i/o method

recompile arts for use with alsa, don't have to do anything else and arts works perfectly with alsa 0.9.


apt-get install arch

Offline

#8 2003-08-24 18:55:14

mb
Member
Registered: 2003-08-22
Posts: 14

Re: kde control center sound i/o method

Recompiling the arts package did the trick!

Here's what I did:

1. Open the PKGBUILD file in /usr/abs/kde/arts.  There should be a line that reads:

   

 ./configure --prefix=/opt/kde --without-alsa 

2. Change the "without-alsa" to "with-alsa". 
3. Run makepkg
4. Install the package with pacman

Now when I open the KDE Control Center and go to Sound & Multimedia>>Sound System and look on the Sound I/O tab, there is an option under "Sound I/O Method" for ALSA.

Thanks for all the help!  I just installed ARCH after having run Mandrake for a few months, and I'm impressed with the simplicity, not to mention the community support.  Thanks again!

Offline

#9 2003-08-24 19:01:00

Arielext
Member
From: Amersfoort, the Netherlands
Registered: 2002-08-12
Posts: 362
Website

Re: kde control center sound i/o method

No problem smile
If you want mplayer with alsa/arts support just do the same "trick" and remove the --disable-alsa --disable-arts lines from the makepkg file


apt-get install arch

Offline

Board footer

Powered by FluxBB