You are not logged in.

#1 2010-10-16 19:30:43

goodboy
Member
Registered: 2007-02-23
Posts: 21

Problem related to acpi

I've been living with this problem since I installed archlinux on my not so up to date pc based on a  Pentium 4 mobo with HT.

The problem is w/o putting acpi=ht in the kernel boot line the PC won't start up and freezes shortly after passing grub.
Especially in combination with apm=power off (enabling auto power off after system shutdown) I can happily live with that.


But after a complete system upgrade in late September which apparently includes a kernel upgrade the pc won't fire up again, even
with acpi=ht and apm=power off in the kernel line... it freezes shortly after grub. It seems acpi=ht has lost its magic.

http://www.mediafire.com/imageview.php? … gx&thumb=5


Now I need your kind help to find out what's going on. Has there been a change to the kernel parameters? Should I re-install the kernel? How?

You can find the pacman install log here in case you need it -> http://pastebin.com/24ThBjZG

Many thanks!

Offline

#2 2010-10-18 11:41:15

goodboy
Member
Registered: 2007-02-23
Posts: 21

Re: Problem related to acpi

I really need my linux system by the end of this week, because I've to return my current pc back to the university dep.
Any idea how and where to start looking?

Many thanks!

Offline

#3 2010-10-18 14:29:16

hidefromkgb
Member
Registered: 2009-08-03
Posts: 146

Re: Problem related to acpi

goodboy, you can try to downgrade to kernel26-LTS (2.6.32), it's in the official repo.
It's older than your previous .34, so it probably supports the acpi trick.

Last edited by hidefromkgb (2010-10-18 15:03:33)

Offline

#4 2010-10-18 17:07:28

eldragon
Member
From: Buenos Aires
Registered: 2008-11-18
Posts: 1,026

Re: Problem related to acpi

there is something odd at your kernel boot parameters.

it seems you want to enable some kind of acpi, and then provide an apm mode. both are mutually exclussive.

and from the linux documentation, acpi=ht does not exist. did you try any of the following?

147         acpi=           [HW,ACPI,X86]
 148                         Advanced Configuration and Power Interface
 149                         Format: { force | off | strict | noirq | rsdt }
 150                         force -- enable ACPI if default was off
 151                         off -- disable ACPI if default was on
 152                         noirq -- do not use ACPI for IRQ routing
 153                         strict -- Be less tolerant of platforms that are no     t
 154                                 strictly ACPI specification compliant.
 155                         rsdt -- prefer RSDT over (default) XSDT
 156                         copy_dsdt -- copy DSDT to memory
 157 
 158                         See also Documentation/power/pm.txt, pci=noacpi

this was taken from linux-2.6/Documentation/kernel-parameters.txt

EDIT
and some more digging: i got to the patch that removed the ht parameter: http://kerneltrap.org/mailarchive/git-c … 5/28/40705

you could try to revert that patch on a custom kernel, but i dont think this to be a long term solution. i guess the best you can do is file a bug report upstream requesting for a revert or a fix for your situation.

EDIT2: seems that your only viable solution would be acpi=off if you dont want to compile your own kernel (you will apparently lose hyperthreading too)

Last edited by eldragon (2010-10-18 17:14:32)

Offline

#5 2010-10-19 14:17:07

goodboy
Member
Registered: 2007-02-23
Posts: 21

Re: Problem related to acpi

I always believed one of the strengths of Linux was to support older systems, I don't understand why they just cancelled the acpi=ht option w/o an alternative, the majority doesn't even know that option exists. I'm going to ask them to revert the patch. For now I've to live with no ht enabled.

Again many thanks you really helped me a great deal.

Offline

#6 2010-10-21 20:38:57

Leonid.I
Member
From: Aethyr
Registered: 2009-03-22
Posts: 994

Re: Problem related to acpi

goodboy wrote:

I always believed one of the strengths of Linux was to support older systems, I don't understand why they just cancelled the acpi=ht option w/o an alternative, the majority doesn't even know that option exists. I'm going to ask them to revert the patch. For now I've to live with no ht enabled.

Again many thanks you really helped me a great deal.

Are you sure, it's a kernel problem? I have P4HT machine, which has been running arch for 15 months already, with the default config. Before, there was RHEL5 with 2.6.18


Arch Linux is more than just GNU/Linux -- it's an adventure
pkill -9 systemd

Offline

Board footer

Powered by FluxBB