You are not logged in.

#1 2010-10-17 23:08:42

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,942

On new hardware USB keyboard occasionally is not recognized

New system, new problem.

On occasion my keyboard isn't seen once the Linux kernel gets to user login. I can use the keyboard to get into BIOS and use GRUB, but fails at the login prompt. There's nothing in the logs. I'm guessing that modules are getting ahead of themselves while loading, but that's only a guess. There's no problem once in X.

(Probably related. If not, B will have to super-jujusu-kick me in the...)

The same thing is happening to eth0. dhcpcd will not get a connection and rebooting does eventually help. I haven't tried dhclient yet (no way to install it when the problem arose), but it's installed now. I'm sure that it's related to the above. Of course I'm wrong 50% of the time, so hedge your bets now...

Last edited by skottish (2010-10-17 23:09:13)

Offline

#2 2010-10-18 07:48:09

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: On new hardware USB keyboard occasionally is not recognized

Moving to Kernel & Hardware Issues. smile

Do you see anything in dmesg? What happens when you detach and reinsert the keyboard?


ᶘ ᵒᴥᵒᶅ

Offline

#3 2010-10-19 00:23:18

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,942

Re: On new hardware USB keyboard occasionally is not recognized

Where are you moving this to?

There's nothing in dmesg out of the ordinary. As well, unplugging and replugging the keyboard changes nothing. It's strange because all of this is just so quiet. I'll wait until the next incidence and see if I can SSH into the machine. I'll report back them.

Offline

#4 2010-10-19 00:54:22

cesura
Trusted User (TU)
From: Chicago, USA
Registered: 2010-01-23
Posts: 1,864

Re: On new hardware USB keyboard occasionally is not recognized

skottish wrote:

Where are you moving this to?

Had to lol at that one. tongue

I've heard strange things from somewhere relating to your problem. Someone's keyboard wasn't functioning if KMS was enabled. neutral That seems illogical, but I guess it may be worth something...

Offline

#5 2010-10-19 01:35:09

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,942

Re: On new hardware USB keyboard occasionally is not recognized

itsbrad212 wrote:
skottish wrote:

Where are you moving this to?

Had to lol at that one. tongue

I've heard strange things from somewhere relating to your problem. Someone's keyboard wasn't functioning if KMS was enabled. neutral That seems illogical, but I guess it may be worth something...

No KMS here. I blacklisted the nouveau module to prevent conflicts with nVidia.

itsbrad212 wrote:

Had to lol at that one. tongue

He learned his super mod powers from me. Unfortunately, I never made the 'top 10 greatest active mods list' even though I invented it.

Last edited by skottish (2010-10-19 01:36:58)

Offline

#6 2010-10-19 09:20:33

litemotiv
Forum Fellow
Registered: 2008-08-01
Posts: 5,026

Re: On new hardware USB keyboard occasionally is not recognized

skottish wrote:

Where are you moving this to?

Darn.. Ok moving to Workstation User instead.


ᶘ ᵒᴥᵒᶅ

Offline

#7 2010-10-22 22:05:11

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,713

Re: On new hardware USB keyboard occasionally is not recognized

Might it be by some odd reason or nasty gremlin be related to this https://bbs.archlinux.org/viewtopic.php?id=106715 ?

Does that keyboard have any fancy extras that might on occasion be picked up as the main function instead of working as a keyboard?


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#8 2010-10-23 01:20:33

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,942

Re: On new hardware USB keyboard occasionally is not recognized

Thanks ROOKIE. That's not quite it.

I know for a fact that some modules aren't being loaded at start up on occasion. I've seen the keyboard not work a few times, the network not work at least four times, and ALSA not work once. I'm trying to collect log files, but it hasn't happened in a few days.

Offline

#9 2010-10-23 12:31:45

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,713

Re: On new hardware USB keyboard occasionally is not recognized

Thats really really strange, I haven't seen that behavior yet, even when booting arch from a usb drive in several different machines.

I'd say it might be a defective motherboard but if things work right after (and during) post (the keyboard at least) that is not very likely.

Without a reliable way to trigger the problem it isn't possible to try to track the source of it ... hopefully things will keep working smoothly. If it happens again and if you can login through ssh and if manually loading the modules works then I guess putting all the needed modules in the MODULES line in rc.conf might help to make things work as intended (I guess I didn't need to say it because you know this better than I do tongue ).

It might have been some strange corner case that cannot be triggered anymore after some update (it is likely if you are dealing with brand new, shinny, state of the art hardware).


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

Board footer

Powered by FluxBB