You are not logged in.

#1 2010-10-26 23:15:10

castlevaniahellraiser
Member
Registered: 2010-08-31
Posts: 54
Website

zd1211 disconnects , until unplugged and replugged.

lsusb:
Bus 001 Device 003: ID 0ace:1215 ZyDAS ZD1211B 802.11g

dmesg (showing the error)
    cfg80211: Calling CRDA to update world regulatory domain
    zd1211rw 1-4:1.0: error ioread32(CR_REG1): -71

Once I unplug and replug the adaptor and hit refresh in wicd, it can connect again.

Now, this happens randomly, sometimes it will be fine, on the occasions that the adaptor connects successfully upon bootup, dmesg shows:
wlan0: authenticated
wlan0: associated
and in my DAEMONS in rc.conf, wicd is the only wireless connection program, no scripts or anything else.

So my question to you, what would cause this to happen?

Last edited by castlevaniahellraiser (2010-10-26 23:16:18)


17:44 < fryguy> TheBilgeRat: they don't tell retards in special ed classes to rtfm either.

Offline

#2 2010-10-27 01:28:18

itsbrad212
Member
From: Chicago, USA
Registered: 2010-01-23
Posts: 1,855

Re: zd1211 disconnects , until unplugged and replugged.

Does dmesg show anything of interest right after your connection is dropped?

Offline

#3 2010-10-27 02:19:12

castlevaniahellraiser
Member
Registered: 2010-08-31
Posts: 54
Website

Re: zd1211 disconnects , until unplugged and replugged.

I will check next time it drops, but the
"cfg80211: Calling CRDA to update world regulatory domain
    zd1211rw 1-4:1.0: error ioread32(CR_REG1): -71"
that I posted above showed up in dmesg last time it dropped.

Last edited by castlevaniahellraiser (2010-10-27 02:19:28)


17:44 < fryguy> TheBilgeRat: they don't tell retards in special ed classes to rtfm either.

Offline

#4 2010-10-27 02:55:50

itsbrad212
Member
From: Chicago, USA
Registered: 2010-01-23
Posts: 1,855

Re: zd1211 disconnects , until unplugged and replugged.

Offline

#5 2010-10-27 22:53:16

castlevaniahellraiser
Member
Registered: 2010-08-31
Posts: 54
Website

Re: zd1211 disconnects , until unplugged and replugged.

It happened again but I restarted wicd, and dmesg spat out this error.


ACPI: resource it87 [io  0x0295-0x0296] conflicts with ACPI region IP__ [??? 0x00000295-0x00000296 flags 0x5f]
ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
zd1211rw 2-1:1.0: error ioread32(CR_REG1): -110
eth0: link down
usb 2-1: USB control request for firmware upload failed. Error number -110
usb 2-1: Could not upload firmware code uph. Error number -110
zd1211rw 2-1:1.0: couldn't load firmware. Error number -110
usb 2-1: USB control request for firmware upload failed. Error number -110
usb 2-1: Could not upload firmware code uph. Error number -110
zd1211rw 2-1:1.0: couldn't load firmware. Error number -110
usb 2-1: USB control request for firmware upload failed. Error number -110
usb 2-1: Could not upload firmware code uph. Error number -110
zd1211rw 2-1:1.0: couldn't load firmware. Error number -110
usb 2-1: USB control request for firmware upload failed. Error number -110
usb 2-1: Could not upload firmware code uph. Error number -110
zd1211rw 2-1:1.0: couldn't load firmware. Error number -110

Last edited by castlevaniahellraiser (2010-10-27 22:53:28)


17:44 < fryguy> TheBilgeRat: they don't tell retards in special ed classes to rtfm either.

Offline

Board footer

Powered by FluxBB