You are not logged in.

#1 2010-10-27 17:13:06

Registered: 2008-06-11
Posts: 91

MPD Permissions [Solved very quickly]


I moved my Music collection to a new PC; now trying to get mpd running. I'm using the mpd.conf from my old machine, with which I never had any problems, so this is pretty weired.


music_directory       "/home/sleepy/Music"
playlist_directory    "/var/lib/mpd/playlists"
db_file               "/var/lib/mpd/db"
log_file              "/var/log/mpd/mpd.log"
error_file            "/var/log/mpd/mpd.error"
pid_file              "/var/run/mpd/"
state_file            "/var/lib/mpd/mpdstate"


Starting mpd gives me

failed to stat music directory "/home/sleepy/Music": Permission denied

Decided to use the sledgehammer method,, so I did a "chmod 777 /home/sleepy/Music"

ls -la | grep Music
--> drwxrwxrwx 958 sleepy users       36864 27. Okt 18:53 Music

... but mpd still bitches about the permissions. It starts, but no client can find any files (obviously...)

Any ideas?

Last edited by SleepyFloyd (2010-10-27 17:30:48)


#2 2010-10-27 17:23:16

From: boston, ma
Registered: 2008-07-24
Posts: 1,796

Re: MPD Permissions [Solved very quickly]

everyone always forgets....

to access any folder you need +x on all its parents

/home/sleepy is likely mod 700 meaning you can't access anything under it (regardless of the perms on the directory itself).

you can: run mpd as you, 755 /home/sleepy, move your music, or use a mount --bind to a directory the mpd user can read.

also, this.

Last edited by brisbin33 (2010-10-27 17:27:11)


#3 2010-10-27 17:30:20

Registered: 2008-06-11
Posts: 91

Re: MPD Permissions [Solved very quickly]

Hey, thanks alot.

Works now. Didn't think about the permissions of /home.


Board footer

Powered by FluxBB