You are not logged in.

#1 2010-10-28 17:59:35

From: London
Registered: 2009-01-13
Posts: 18

Arch Linux PPC installation failure


I tried to install the Arch Port (2010-07-23_archppc-ftp.iso) on a Power Mac G4 and got the following result:

:: scanning for boot cdrom device
Failed to mount /dev/cd/*
Failed to mount /dev/cdrom
Failed to mount /dev/hd*
Failed to mount /dev/sda
Failed to mount /dev/sv*

Cannot find booted cdrom device
Cannot continue

followed by:

kernal panic - not syncing: attempted to kill init!

I've tried the same CD in a MacBook G5, with the same results.

Is there a kernel parameter I could pass to get around this?


My new username is now Aerion in order to match my username on the AUR, Wiki and Bug Reports.


#2 2010-11-02 21:12:01

Registered: 2010-09-22
Posts: 3

Re: Arch Linux PPC installation failure

Check this out: … &task_id=4

The hack/work-around worked for me (sometimes). You could also try the image linked to below.


#3 2010-11-06 00:21:46

From: Connecticut
Registered: 2010-11-05
Posts: 2

Re: Arch Linux PPC installation failure

I'm having a very similar problem that I think fits better under this topic than as its own post...

I started off with this exact same error using 2010-07-23_archppc-ftp.iso, following the little hack/workaround posted above I was able to successfully boot into the installer. So far so good.

However, when I go to partition the drive and assign the mountpoints, /arch/setup can't seem to find my hard disk.

I was able to partition the drive manually with mac-fdisc, but I still can't see it to set the mountpoints. I think the drive isn't mounting during the boot process.

I tried to use that new build, 2010-09-21_archppc-ftp.iso and so far that one hasn't booted hanging at "Waiting for UDev uevents to be processed". I've since siwtched back to the previous build 2010-07-23.

I'm getting the following error in both boots and I think this is the cause of the issue:

Failed to mount /dev/sda
attempt to access beyond end of device
sda1: rw=0, want=66, limit=63
isofs_fill_super: bread failed, dev=sda1, iso_blknum=16, block=32
Failed to mount /dev/sda1
Failed to mount /dev/sda2
Failed to mount /dev/sda3
Failed to mount /dev/sda4
Failed to mount /dev/sda5
Failed to mount /dev/sda6

Am I right in assuming that the drive isn't mounting so the installer can't target where to put the files?

If yes, what can I do to fix it? Or, am I able to just manually mount the drives? And if so, where do I mount them for a correct install?

Just before posting this I did try deleting all my partitions and mounting the remaining chunk (after formatting as ext3) in the /media directory (as /media/sda) but that did not fix my issue.

Any thoughts?

"Your reality, sir, is lies and balderdash and I'm delighted to say that I have no grasp of it whatsoever"
     ~Baron Munchausen, "The Adventures of Baron Munchausen"


#4 2010-11-09 00:58:43

Registered: 2008-10-30
Posts: 120

Re: Arch Linux PPC installation failure

I tried using kth5's 2010-09-21_archppc-ftp.iso which does mount the CD correctly, but then goes to a black screen sortly after on my G4 iBook. I'm not sure where to go from here.


#5 2010-12-24 09:25:36

Registered: 2006-06-10
Posts: 259

Re: Arch Linux PPC installation failure


if you have problems, previous iso is working (I tested it yesterday with a full installation)


Board footer

Powered by FluxBB